+ Responder ao Tópico



  1. #1

    Padrão Dificuldade para acessar outra RB depois do load balance PCC

    ola a todo!
    estou com um enorme problema para conseguir acessar meu servidor hotspot que esta tras do meu load pcc.

    ja tentei varios redirecionamento em NAT mais ate agora não obtive resultados

    essa printe mostra como esta montado minha estrutura atual
    Anexo 29109
    Desde pc que esta conectado ao hub eu consigo acessar pelo inbox o load balance pelo ip de 192.168.1.2 (cujo qual foi o ip que atribui na eth1 para receber o link do 1° gateway, resumindo

    load balance

    eth1 "ISP1" 192.168.1.2
    eth2 "ISP2" 192.168.2.2
    eth3 "local" 192.168.88.1 (aqui eu configurei dhcp server)

    Na RB que roda o hotspot configurei assim

    eth1 "LINK" configurei um dhcp cliente e recebeu o ip de 192.168.88.10.

    fiz alguns testes, configurei uma bridge no load, e conectado diretamente na bridge do load consegui acessar o server hotspot com o ip de 192.168.88.10

    gostaria de saber se e possivel acessar desse pc (que esta na minha casa), passando pelas nanobridge que estam em ap/station wds, passando pelo load e entrando no hotspot,

  2. #2

    Padrão Re: Dificuldade para acessar outra RB depois do load balance PCC

    em arp do load balance me aparece esses ips

    [[email protected]] > ip arp print
    Flags: X - disabled, I - invalid, H - DHCP, D - dynamic
    # ADDRESS MAC-ADDRESS INTERFACE
    0 D 192.168.1.1 00:1F:XX:1E:96:FB ISP1 <==== GATEWAY 1
    1 D 192.168.1.4 00:25:XX:B9:2F:BF ISP1 <==== meu pc
    2 D 192.168.2.1 00:1D:XX:9E:82:06 ISP2 <==== gateway 2
    3 D 192.168.88.10 00:0C:XX:7D:74:1F Local <=== IP DE SAIDA PARA O HOTSPOT



  3. #3

    Padrão Re: Dificuldade para acessar outra RB depois do load balance PCC

    Gostaria muito de algumas dicas, procurei muito no forum assuntos relacionado a redireciomamentos de porta, tentei algumas regras mais ate agora nada. Sou bem leigo em routeros. Qq dica e valida

  4. #4

    Padrão Re: Dificuldade para acessar outra RB depois do load balance PCC

    No caso eu participo da rede do 1 gateway, acesso o LB pelo ip que atribui a entrada do gateway 1 que e 192.168.1.2, o ip de saida do load e de 192.168.88.1/24 ====> entra eth1 do hotspot que esta como cliente dhcp que pegou o ip de 192.168.88.10. O gateway do hotspot tem outra classe de ip 10.10.10.1.

    Sera q para eu conseguir acessar o server do hotspot eu teria que redirecionar o ip de entrada do LB q e 192.168.1.2 para o ip de entrada do hotspot que e 192.168.88.10 ?
    De dentro do meu hotspot eu pingo ate meu pc q esta com outra classe de ip, mais de fora para dentro sem chance.

    Ps. Desculpa se eu to sendo um pouco chato



  5. #5

    Padrão Re: Dificuldade para acessar outra RB depois do load balance PCC

    Meu irmão claro que é possível, desde que seus ptp esteja em bridge.

    Eu tenho aqui um load balance funcionando, e acesso normalmente o servidor mikrotik por trás dele, o que posso te falar é pra vc não usar dhcp para atribuir o ip para o seu servidor atrás do load balance, coloca ip fixo nele que é melhor..

    o q acontece é o seguinte..

    mikrotik 1 ( load balance) - porta da winbox 8291, desativa a porta 80(http)

    mikrotik 2 (servidor de clientes) - porta da winbox 8291, vc pode modificar a porta do serviço winbox para 8292

    então..

    no load balance em ip->firewall adicione o seguinte

    add action=dst-nat chain=dstnat comment="" disabled=no dst-port=8292 protocol=tcp to-addresses=192.168.88.10 \
    to-ports=8292

    baixe uma versão nova da winbox coloque no ip 192.168.88.10:8292 para winbox tá pronto, agora para o hotspot faça com a porta 80

    qualquer coisa me add no msn [email protected] ou me liga, 2288170094, uma coisa, sua conexão internet é adsl ?
    Última edição por xXNeoXx; 31-10-2011 às 10:43.

  6. #6

    Padrão Re: Dificuldade para acessar outra RB depois do load balance PCC

    caro colega, fiko agradecido por sua resposta, agora que vc me explicou direitinho consegui acessar meu servidor da minha estação, eu já tinha feito essa regra de redirecionamento que vc citou, porem em vez de digitar 192.168.1.2:8292 eu tentava pelo ip do meu servidor 192.168.88.10:8292, era ai onde eu tava errando.
    mais uma pergunta, seria possível eu conseguir acessar meu bullet que esta na mesma faixa de ip do hotspot (10.10.10.1) bullet (10.10.10.100) ?
    Ah e adsl sim, meus modem no momento estão roteados, sei que não e bom e pretendo fazer o balance discar em breve

    ficarei eternamente agradecido pela sua ajuda



  7. #7

    Padrão Re: Dificuldade para acessar outra RB depois do load balance PCC

    cara posta pra mim sua estrutura, pois te falar assim não dá, pois não conheço como estão interligados seus equipamentos.. se fizer isso te respondo com certeza. Quanto aos modens, coloca em bridge o mais rápido possível, roteados causam lentidão, quedas do msn, por que o poder de processamento da cpu e memória dos modens são pequenos e gera muito gargalo e lentidão, já em bridge, se você tiver uma RB boa ou uma cpu, fica muito melhor..

  8. #8

    Padrão Re: Dificuldade para acessar outra RB depois do load balance PCC

    Clique na imagem para uma versão maior

Nome:	         Projeto 1.jpg
Visualizações:	290
Tamanho: 	19,4 KB
ID:      	29568
    esta montado assim



  9. #9

    Padrão Re: Dificuldade para acessar outra RB depois do load balance PCC

    Você se conecta no hotspot para poder navegar na internet ? o ip da sua placa de rede vc configura ou pega através de dhcp ? no caso vc teria que ter mais um ip adicionado na sua placa de rede na mesma faixa do hotspot e dos bullets para poder acessá-los.

  10. #10

    Padrão Re: Dificuldade para acessar outra RB depois do load balance PCC

    Eu me conecto a internet atraves do dhcp do 1 gateway, ou seja eu faço parte da 1° rede. Como a maior parte do tempo essa banda fica disponivel resolvi inserir ela no balance com outro link, na segunda parte da rede (depois do load) ai sim ela entra no hotspot e distribuo com bullet em bridge para os usuarios se conectarem.
    Por isso que na primeira rede (antes das nanos) esta roteado, pq eu a utilizo para navegar. Sei q poderia fazer o balance disca esse modem tmb passando pelas nanos. Queria acesso no hotspot so para gerencia a rede, q graças a tua ajuda eu bullet em bridge para os usuarios se conectarem.
    Por isso que na primeira rede (antes das nanos) esta roteado, pq eu a utilizo para navegar. Sei q poderia fazer o balance disca esse modem tmb passando pelas nanos. Queria acesso no hotspot so para gerencia a rede, q graças a tua ajuda eu consegui. Agora se fosse possivel gostaria de acessar o bullet que esta com ip que pertence ao pool do hotspot.
    Hotspot 10.10.10.1
    Bullet 10.10.10.100
    Grato



  11. #11

    Padrão Re: Dificuldade para acessar outra RB depois do load balance PCC

    um tinha postado de um jeito mais acho que não vai dar porque vc usa hotspot então não pode desativar a porta 80 do hotspot e nem redirecionar senão dá problemas,

    o que tu poderia fazer é trocar as portas www dos bullets de 80, para 8080,8081,8082 e assim por diante, por quantos bullets tu tenhas..

    coloque essa regra depois das regras de nat do seu hotspot

    /ip firewall add chain=dstnat protocol=tcp dst-port=8081 action=dst-nat to-address=10.10.10.100 to-port=8081.

    então no browser vc teria de digitar o endereço
    http://10.10.10.1:8081 isso entraria no em um bullet e assim por diante.





    coloque essa regra depois das regras de nat do seu hotspot

    /ip firewall add chain=dstnat protocol=tcp dst-port=8082 action=dst-nat to-address=10.10.10.100 to-port=8082.

    então no browser vc teria de digitar o endereço
    http://10.10.10.1:8082 isso entraria em um segundo bullet e assim por diante.




    entendeu ?? acho q é isso..

  12. #12

    Padrão Re: Dificuldade para acessar outra RB depois do load balance PCC

    eu entendi mais essa regra só funciona se eu tiver logado dentro da rede, com um ip do hotspot 10.10.10.xx

    eu to com ip aqui no pc 192.168.1.4
    consigo chegar no load pelo ip de 192.168.1.2
    com sua ajuda fiz redirecionamento no load e acesso o hotspot pelo ip de 192.168.1.2:8292;

    dai que vem a problema que eu não consigo resolver, meu hotspot gera um range de ip de 10.10.10.2 a 10.10.10.250. Meu bullet esta com um ip dento da range do pool (10.10.10.100)

    resumindo, gostaria de meu pc 192.168.1.4 acessar o bullet 10.10.10.100 pela porta 80

    meu pc(192.168.1.4)>>> entrada do loadbalance (192.168.1.2)>>>> entrada para o server mk (192.168.88.10) >>>> hotspot (10.10.10.1)>>>>> bullet em bridge (10.10.10.100)

    eauhaehueuhas complicado p caramba
    mais valeu vc ja me ajudou muito