Página 2 de 8 PrimeiroPrimeiro 1234567 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. Citação Postado originalmente por cristianff Ver Post
    Vamos manter a troca de idéias aqui e não via mensagem privada, assim compartilhamos com toda a comunidade.
    Abraço
    desculpe amigo, é que eu nao sei como pedir uma ajuda direta para alguem pela enquete.
    mas valeu, vou tentar e posto a resposta aqui

  2. Sem problemas, se atente aos pontos que eu sitei nas postagens anteriores em relação ao caminho para o arquivo access.log e output_dir no sarg.conf e veja se onde você está gerando os relatórios é um document_root do apache.

    Abraço



  3. Citação Postado originalmente por cristianff Ver Post
    Essa configuração é importante, o seu Apache está configurado o DocumentRoot como?
    No meu caso conforme configuração que passei acima, o DocumentRoot do Apache está assim:
    Código :
    DocumentRoot /var/www
    Você tem que se atentar a esses pequenos detalhes da configuração.

    Abraço
    meu output_dir /var/www/squid-reports

    aquele monte de output que coloquei ali em cima sao de diferents posts que fui seguindo!! quando vo la 192.168.101/sarg mostra la o relatorio do primeiro dia que instalei ele, mostra o IP e uns sites. Mas depois disto coloquei na rede e tenho 10 maquinas fazendo o proxy no squid. hoje nao me mostra mais nada.
    se vo em 192.168.101/squid-reports ou 192.168.101/squid da erro do apache, diz nao encontrado. ja tentei o output para output_dir /var/lib/sarg
    nao sei mais o que fazer!!

    mais alguma coisa no apache2 que tenho que fazer? eu sou bem leigo, só sei que se aparecer It Works! é porque o Apache esta funcionando. e proxy esta funcionando no direcionamento para o squid.

  4. O problema está aí, se o seu output_dir está /var/www/squid-reports o sarg irá gerar os relatórios nesta pasta. Você já verificou se existe esta pasta no diretório /var/www.

    Dê um "ls" em /var/www confira se o diretório squid-reports está lá.
    Se sim, dentro deve conter os relatórios gerados.

    No apache você tem que verificar qual é o DocumentRoot, ou seja, qual pasta do sistema ele está usando como root para os documento, se você está usando o output_dir /var/www/squid-reports você terá que ter uma entrada na configuração do apache que diga que o DocumentRoot é /var/www. Senão ele não estará acessível.

    Não sei qual distro você está utilizando e qual versão do apache, mas no Debian e com Apache2, as configurações ficam em:
    Código :
    proxylon:/etc/apache2/sites-available/default

    conteúdo do arquivo:
    Código :
    proxylon:/etc/apache2/sites-available# cat default
    <VirtualHost *:80>
            ServerAdmin webmaster@localhost
     
     
            DocumentRoot /var/www
            <Directory />
                    Options FollowSymLinks
                    AllowOverride None
            </Directory>
            <Directory /var/www/>
                    Options Indexes FollowSymLinks MultiViews
                    AllowOverride None
                    Order allow,deny
                    allow from all
            </Directory>
     
     
            ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
            <Directory "/usr/lib/cgi-bin">
                    AllowOverride None
                    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                    Order allow,deny
                    Allow from all
            </Directory>
     
     
            ErrorLog ${APACHE_LOG_DIR}/error.log
     
     
            # Possible values include: debug, info, notice, warn, error, crit,
            # alert, emerg.
            LogLevel warn
     
     
            CustomLog ${APACHE_LOG_DIR}/access.log combined
     
     
        Alias /doc/ "/usr/share/doc/"
        <Directory "/usr/share/doc/">
            Options Indexes MultiViews FollowSymLinks
            AllowOverride None
            Order deny,allow
            Deny from all
            Allow from 127.0.0.0/255.0.0.0 ::1/128
        </Directory>
     
     
    </VirtualHost>

    Faça o que eu te falei, primeiro verifique se existe a pasta squid-report dentro de /var/www, se não tiver, crie a mesma.

    Depois veja qual é o DocumentRoot do Apache, uma boa dica é dar uma procurada aqui no forum como configurar o Apache, mas se você seguir o que eu te falei, vai dar certo.

    Abraço



  5. dei um cd /var/www e dentro tenho
    html(pasta)
    index.html(arquivo)
    sarg(pasta)
    wpad.dat (arquivo este que uso no proxy em cada PC da minha rede)

    dentro da pasta sarg tenho:
    2011Nov04-2011Nov04(este historico que aparece quando vo no http://ip/sarg);
    pasta 2011Nov04-2011Nov06(nao aparece);
    pasta Daily (aparece no http://ip/sarg);
    pasta 2011Nov04-2011Nov05 (nao aparece no http://ip/sarg);
    pasta 2011Nov06-2011Nov07 (nao aparece no http://ip/sarg);
    pasta images pasta Weekly (aparece no http://ip/sarg)
    vou seguir o resto que postasse ai. valeu por me ajudar






Tópicos Similares

  1. Configurar SARG para envio de email
    Por sartori no fórum Servidores de Rede
    Respostas: 0
    Último Post: 26-12-2005, 13:50
  2. como configurar o sarg
    Por rootmaster no fórum Servidores de Rede
    Respostas: 7
    Último Post: 06-12-2005, 22:02
  3. Respostas: 4
    Último Post: 16-06-2005, 10:27
  4. Como configurar o httpd.conf para rodar scripts cgi?
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 28-05-2003, 10:29
  5. Sarg, como configurar
    Por no fórum Servidores de Rede
    Respostas: 5
    Último Post: 29-11-2002, 17:16

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L