+ Responder ao Tópico



  1. #1

    Padrão Como Alocar Blocos IP /29 para Clientes?

    Boa noite

    Pessoal seguinte, tenho BGP com CIDR próprio e PPOE para clientes configurados na mesma RB a parte do PPPoE e BGP esta tudo ok funcionando blz só que preciso dar IP fixo para alguns clientes (pelo PPPoE consigo sem maiores problemas fazer isso) da mesma forma que a embratel faz com seus links dedicados por exemplo quero alocar para um cliente um bloco de IP /29 onde o cliente possa usar direto no servidor ou roteador dele os endereços validos cedido por min sem a necessidade de usar PPPoE.

    Como posso realizar tal empreitada ?

  2. #2

    Padrão re: Como Alocar Blocos IP /29 para Clientes?

    Amigo de detalhes de sua estrutura de rede, mas a principio ele usa um ip no pppoe dai voce seta a faixa de ip liberada para ele na interface que ele ira receber o link



  3. #3

    Padrão re: Como Alocar Blocos IP /29 para Clientes?

    Roteamento estático ou OSPF vc entrega IP Público para seu cliente, sem gastar IP Publico em rádios.

  4. #4

    Padrão re: Como Alocar Blocos IP /29 para Clientes?

    Estrutura.

    RB 1100 Rodando BGP - CIDR PROPRIO E PPPoE SERVER

    Restande da estrutura até o cliente é bridge no cliente o AP disca PPPoE para RB 1100.

    Cliente recebe IP valido pelo PPPoE caso necessario, mas no caso quero destinar blocos para uso direto na interface do cliente.

    Link Operadora entra pela WAN e vai para cliente pela LAN.

    CIDR /22

    OSPF já tentei configurar mas acho que estou fazendo algo errado pois quando ativo, na aba routes onde informa gateway dos clientes e as rotas o gateway fica em branco ou 0.0.0.0. Vi varios exemplos de configuração mas todos envolviam mais que uma RB para este caso, não sei ao certo se é possivel fazer com uma RB só, isso que estou falando aqui testei somente com PPPOE mas como consigo entregar IP valido nos clientes pelo PPPoE sem roteamento ou proxy-arp por causa do BGP até o momento estava de molho éssa idéia do OSPF.

    Roteamento estatico tentei fazer a configuração mas não funcinou creio que deva estar faltando alguma coisa ou fazendo errado.

    Se puderem colocar uns exemplos pra min me basear tanto em roteamento estatico como OSPF fico grato.

    Sei que o ideal seria usar RBs em cada torre mas como estamos comecando há outras prioridades como SCM que já esta liberada e outros custos pesados agora.



  5. #5

    Padrão re: Como Alocar Blocos IP /29 para Clientes?

    primeiramente, voce vai add um /30 em sua interface exemplo

    /ip address add address=179.36.32.1/30 interface=cliente-link-dedicado

    Agora em seu cliente você vai colocar:
    ip 179.36.32.2
    msk 255.255.255.252
    gw 179.36.32.1
    dns 179.36.32.1 ou se você tiver um servidor de dns seu ou se sua preferência


    Bom com isso o cliente já tem internet agora vamos supor que isso era o roteador dele e que voce configurou a WAN dele desta forma e vamos passar para ele um /29

    Você vai no mikrotik em:
    /ip route
    add gateway=179.36.32.2 dst-address=179.36.34.0/29

    sendo os ip que ele vai ter do /29 é 179.36.34.1-7

  6. #6

    Padrão re: Como Alocar Blocos IP /29 para Clientes?

    O que você quer dizer com "cliente-link-dedicado" isso seria LAN ou WAN ?

    Por OSPF não teria como fazer ?

    Citação Postado originalmente por leo_h3 Ver Post
    primeiramente, voce vai add um /30 em sua interface exemplo

    /ip address add address=179.36.32.1/30 interface=cliente-link-dedicado

    Agora em seu cliente você vai colocar:
    ip 179.36.32.2
    msk 255.255.255.252
    gw 179.36.32.1
    dns 179.36.32.1 ou se você tiver um servidor de dns seu ou se sua preferência


    Bom com isso o cliente já tem internet agora vamos supor que isso era o roteador dele e que voce configurou a WAN dele desta forma e vamos passar para ele um /29

    Você vai no mikrotik em:
    /ip route
    add gateway=179.36.32.2 dst-address=179.36.34.0/29

    sendo os ip que ele vai ter do /29 é 179.36.34.1-7



  7. #7

    Padrão Re: Como Alocar Blocos IP /29 para Clientes?

    Citação Postado originalmente por AlexTrevisol Ver Post
    O que você quer dizer com "cliente-link-dedicado" isso seria LAN ou WAN ?

    Por OSPF não teria como fazer ?
    Estou querendo dizer que é a interface que o cliente está conectado.

    se você que usar OSPF ok?! Sem problemas nada contra, estou apenas simplificando para você, pois como é seu primeiro cliente assim e com isso eu acredito que sua rede é pequena, não vejo porque usar um protocolo de roteamento, e ainda mais um protocolo baseado em link state routing protocol. Mais repito não tenho nada contra, o que você achar melhor estamos aqui para ajudar!

  8. #8

    Padrão Re: Como Alocar Blocos IP /29 para Clientes?

    E que como já entrou OSPF na questão queria já elucidar algumas duvidas ou até mesmo fazer um teste inicial aproveitar que a rede ainda é pequena para quem sabe usar em um futuro próximo realmente por em pratica.

    Com certeza roteamento estatico já resolve meu porblema, mas sabe como é sempre tentamos melhorar.

    Obrigado pela ajuda.

    Citação Postado originalmente por leo_h3 Ver Post
    Estou querendo dizer que é a interface que o cliente está conectado.

    se você que usar OSPF ok?! Sem problemas nada contra, estou apenas simplificando para você, pois como é seu primeiro cliente assim e com isso eu acredito que sua rede é pequena, não vejo porque usar um protocolo de roteamento, e ainda mais um protocolo baseado em link state routing protocol. Mais repito não tenho nada contra, o que você achar melhor estamos aqui para ajudar!



  9. #9

    Padrão Re: Como Alocar Blocos IP /29 para Clientes?

    Não tive mais tempo de ver isso, mas fiz um teste e fazendo desta forma não funcionou sem utilizar NAT.

  10. #10

    Padrão Re: Como Alocar Blocos IP /29 para Clientes?

    Ninguém ai pra me dar uma luz !?



  11. #11

    Padrão Re: Como Alocar Blocos IP /29 para Clientes?

    Leo,

    Fiz desta forma que você me indicou mas com meus ips piblicos não funciona somente se usar ips privados ai vai blz com os ips publicos nem consigo pingar pra interface como se não tivesse rota.

  12. #12

    Padrão Re: Como Alocar Blocos IP /29 para Clientes?

    Skype, leonardo.winet ai posso acessar e ver qual o problema!

    Citação Postado originalmente por AlexTrevisol Ver Post
    Leo,

    Fiz desta forma que você me indicou mas com meus ips piblicos não funciona somente se usar ips privados ai vai blz com os ips publicos nem consigo pingar pra interface como se não tivesse rota.



  13. #13
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.408
    Posts de Blog
    10

    Padrão Re: Como Alocar Blocos IP /29 para Clientes?

    Olá de uma olhada neste post talvez possa te ajudar:
    Repasse de IP Público com exemplo para PPPoE por: M4D3

  14. #14

    Padrão Re: Como Alocar Blocos IP /29 para Clientes?

    Amigo se você fizer Nat apenas para sua rede PPPoe ira funcionar.



  15. #15

    Padrão Re: Como Alocar Blocos IP /29 para Clientes?

    Obrigado leo_h3 estava a procura disso, entregar um bloco /30 para ser a WAN do cliente e um bloco vinculado a esse /30 um /28 por exemplo para o cliente utilizar bem como quiser sem precisar fazer uma bridge. Muito Obrigado !!

    Citação Postado originalmente por leo_h3 Ver Post
    primeiramente, voce vai add um /30 em sua interface exemplo

    /ip address add address=179.36.32.1/30 interface=cliente-link-dedicado

    Agora em seu cliente você vai colocar:
    ip 179.36.32.2
    msk 255.255.255.252
    gw 179.36.32.1
    dns 179.36.32.1 ou se você tiver um servidor de dns seu ou se sua preferência


    Bom com isso o cliente já tem internet agora vamos supor que isso era o roteador dele e que voce configurou a WAN dele desta forma e vamos passar para ele um /29

    Você vai no mikrotik em:
    /ip route
    add gateway=179.36.32.2 dst-address=179.36.34.0/29

    sendo os ip que ele vai ter do /29 é 179.36.34.1-7