+ Responder ao Tópico



  1. #1

    Padrão Camera IP Wanscam

    Boa tarde...

    Um condomínio aqui que tem a minha net pediu para fazer a configuração de algumas câmeras IP para que os moradores possam acessá-las de fora através de um ip válido.

    As câmeras são da marca Wanscam AJ-C0WA-B106

    Configurei o ip de rede dela, mas nem mesmo de outro cliente consigo acessá-la, criei esta regra no firewall, mas não deu certo

    MK versão 5.6

    /ip firewall nat add chain=dstnat dst-address=200.159.158.224 protocol=tcp dst-port=0-65535 action=dst-nat to-addresses=192.168.0.16 \
    to-ports=0-65535 comment="Acesso Cameras IP" disabled=no


    Obrigado
    Última edição por VNInfo; 21-12-2011 às 19:18.

  2. #2

    Padrão Re: Camera IP Wanscam

    amigo se vc colocou ip valido vc tem q acessar de onde tiver net.. alguma coisa na configuracao esta errada.



  3. #3

    Padrão Re: Camera IP Wanscam

    As cameras estão com default gateway configurado? Se ela estiver só com o IP mas sem Gateway, a camera não vai saber fazer o caminho de volta do pacote.

  4. #4

    Thumbs up Re: Camera IP Wanscam

    Citação Postado originalmente por VNInfo Ver Post
    Boa tarde...

    Um condomínio aqui que tem a minha net pediu para fazer a configuração de algumas câmeras IP para que os moradores possam acessá-las de fora através de um ip válido.

    As câmeras são da marca Wanscam AJ-C0WA-B106

    Configurei o ip de rede dela, mas nem mesmo de outro cliente consigo acessá-la, criei esta regra no firewall, mas não deu certo

    MK versão 5.6

    /ip firewall nat add chain=dstnat dst-address=200.159.158.224 protocol=tcp dst-port=0-65535 action=dst-nat to-addresses=192.168.0.16 \
    to-ports=0-65535 comment="Acesso Cameras IP" disabled=no


    Obrigado

    Uma pergunta este ip 200.159.158.224 e de onde ou de que?

    você tem que configurar manualmente os IP's das câmeras pelo que vi o Ip de uma delas é 192.168.0.16 (certo?), agora escolha uma porta para ela (ex: porta 1315 (pode ser qualquer na faixa de 0 a 65535)). com base nessa configuração o teu MK tem que ser configurado assim:

    - - - - - - >> coment: Acesso Cameras IP
    chain=dstnat action=dst-nat to-addresses=192.168.0.16 to-ports=8080
    protocol=tcp in-interface=Internet<--(entrada da sua internet) dst-port=1315

    e para ter acesso remoto externo sem configurar o ddns e só botar o ip da rede(internet) + porta da câmera (ex: 0.0.0.0:1315 )
    (a configuração do ddns e outra história)


    se ainda não entendeu posta aih! http://cdn03.under-linux.org/images/icons/icon14.png
    Última edição por Maydeck; 22-12-2011 às 16:08.



  5. #5

    Padrão Re: Camera IP Wanscam

    Então, vou tentar explicar melhor a miha situação:

    Clique na imagem para uma versão maior

Nome:	         camera.jpg
Visualizações:	254
Tamanho: 	41,2 KB
ID:      	31726

    Cada cliente tem a sua rede local que no meu caso é 192.168.2.0/24

    Onde na imagem a câmera utiliza o ip 192.168.2.10 e a porta 100.

    Cada cliente também tem o ip da minha rede que no caso deste cliente é o 192.168.0.16.

    E tenho um ip válido: 200.159.158.224

    Quero acessar esta câmera externamente através do ip: http://200.159.158.224:100

    Esta é minha regra no mk.

    /ip firewall nat add chain=dstnat dst-address=200.159.158.224 protocol=tcp dst-port=0-65535 action=dst-nat to-addresses=192.168.0.16 \
    to-ports=0-65535 comment="Acesso Cameras IP" disabled=no

  6. #6

    Padrão Re: Camera IP Wanscam

    Tá faltando parametros na sua regra. aí. A regra correta seria:

    /ip firewall nat add chain=dstnat dst-address=200.159.158.224 protocol=tcp dst-port=100 action=dst-nat to-addresses=192.168.0.16 \
    to-ports=100 comment="Acesso Cameras IP" disabled=no

    Você não pode fazer um redirecionamento de todas as portas. Tem que especificar a porta que você quer redirecionar.

    E se estiverem na mesma rede esse cliente e essa camera, não seria melhor rotear esse acesso do que fazer ele pelo IP Real? Ao rotear o acesso, o pacote não sairia da sua rede.



  7. #7

    Padrão Re: Camera IP Wanscam

    Citação Postado originalmente por uesleycorrea Ver Post
    Tá faltando parametros na sua regra. aí. A regra correta seria:

    /ip firewall nat add chain=dstnat dst-address=200.159.158.224 protocol=tcp dst-port=100 action=dst-nat to-addresses=192.168.0.16 \
    to-ports=100 comment="Acesso Cameras IP" disabled=no

    Você não pode fazer um redirecionamento de todas as portas. Tem que especificar a porta que você quer redirecionar.

    E se estiverem na mesma rede esse cliente e essa camera, não seria melhor rotear esse acesso do que fazer ele pelo IP Real? Ao rotear o acesso, o pacote não sairia da sua rede.
    Não farão sempre parte da mesma rede, minha intensão é implementar também para clientes de fora utilizando tal ip, será que dá?

    Quanto a regra tentei também com portas específicas, mas não deu certo
    Última edição por VNInfo; 25-12-2011 às 20:49.

  8. #8

    Padrão Re: Camera IP Wanscam

    A regra que eu postei pra você está correta. Eu uso a mesma para acesso remoto de equuipamentos, só que utilizando porta 8080. Seu firewall por acaso não está bloqueando portas baixas? Se for isso, é só liberar o bloqueio da porta que o redirecionamento vai funcionar.
    Se precisar, presto consultoria nessa área, e se não conseguir com a ajuda aqui do fórum posso fazer um acesso remoto pra você por um valor bem em conta. Se precisar, entre em contato.



  9. #9

    Padrão Re: Camera IP Wanscam

    Citação Postado originalmente por uesleycorrea Ver Post
    A regra que eu postei pra você está correta. Eu uso a mesma para acesso remoto de equuipamentos, só que utilizando porta 8080. Seu firewall por acaso não está bloqueando portas baixas? Se for isso, é só liberar o bloqueio da porta que o redirecionamento vai funcionar.
    Se precisar, presto consultoria nessa área, e se não conseguir com a ajuda aqui do fórum posso fazer um acesso remoto pra você por um valor bem em conta. Se precisar, entre em contato.

    Consegui amigo, meu problema não eram minhas regras e sim minha CPE que bloqueava a porta.

    Fiz roteamento dentro dela e aceitou.

  10. #10

    Padrão Re: Camera IP Wanscam

    Citação Postado originalmente por VNInfo Ver Post
    Então, vou tentar explicar melhor a miha situação:

    Clique na imagem para uma versão maior

Nome:	         camera.jpg
Visualizações:	254
Tamanho: 	41,2 KB
ID:      	31726

    Cada cliente tem a sua rede local que no meu caso é 192.168.2.0/24

    Onde na imagem a câmera utiliza o ip 192.168.2.10 e a porta 100.

    Cada cliente também tem o ip da minha rede que no caso deste cliente é o 192.168.0.16.

    E tenho um ip válido: 200.159.158.224

    Quero acessar esta câmera externamente através do ip: http://200.159.158.224:100

    Esta é minha regra no mk.

    /ip firewall nat add chain=dstnat dst-address=200.159.158.224 protocol=tcp dst-port=0-65535 action=dst-nat to-addresses=192.168.0.16 \
    to-ports=0-65535 comment="Acesso Cameras IP" disabled=no



    Ok tudo certo! agora so falta add in interface= entrada da sua internet!

    da uma olhada, aqui funciona perfeitamente, espero que resolva o seu problema!
    abraços!

    Clique na imagem para uma versão maior

Nome:	         Nat.jpg
Visualizações:	206
Tamanho: 	48,3 KB
ID:      	31728



  11. #11

    Padrão Re: Camera IP Wanscam

    Bom dia tenho um dvr que faz a gravação das câmeras aqui de casa e quero acessa-lo externamente... internamente é bem simples acesso o ip dela ex: 192.168.2.109 e cai nela... Agora externamente uso DDNS e coloquei a porta dela 1280... Teoricamente ficaria assim meuddns.us:1280. Mais não estou conseguindo... A regra de direcionamento que estou usando é esta:
    /ip firewall nat
    add action=dst-nat chain=dstnat comment="Direcionamento para DVR" disabled=no dst-port=1280 \ protocol=tcp to-addresses=192.168.2.109 to-ports=80

  12. #12

    Padrão Re: Camera IP Wanscam

    Estou com o mesmo problema, meu modem ADSL esta em bridge minha regra seria essa:


    /ip firewall nat add chain=dstnat dst-address=210.159.30.100 protocol=tcp dst-port=8085 action=dst-nat to-addresses=192.168.11.72 \
    to-ports=8085 comment="Acesso Cameras IP" disabled=no

    Obs: o ip: 192.168.11.72 ele pegou conforme se conectou no hotspot e setei como type: Bypassed o ip de configuração é: 192.168.1.207 q seria o Adress...

    Alguém para me ajudar?



  13. #13

    Padrão Re: Camera IP Wanscam

    Citação Postado originalmente por SandroDiniz Ver Post
    Estou com o mesmo problema, meu modem ADSL esta em bridge minha regra seria essa:


    /ip firewall nat add chain=dstnat dst-address=210.159.30.100 protocol=tcp dst-port=8085 action=dst-nat to-addresses=192.168.11.72 \
    to-ports=8085 comment="Acesso Cameras IP" disabled=no

    Obs: o ip: 192.168.11.72 ele pegou conforme se conectou no hotspot e setei como type: Bypassed o ip de configuração é: 192.168.1.207 q seria o Adress...

    Alguém para me ajudar?


    blza já consegui resolver o problema: minha MK ja tinha um ddns setado para eu acessar de fora o MK portando eu so acresentei a porta da camera com esses ddns e deu certo... nesta mesma regra.