Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. #21

    Padrão Re: Problema com DNS no Mikrotik ROS

    Citação Postado originalmente por marcos0513 Ver Post
    Amigo você por a caso leu a minha solução? nos meus tests configurando o DNS no próprio DHCP resolve o problema e sem efeitos colaterais.

    /ip dhcp-server network set "id" dns-server=8.8.4.4,8.8.8.8

    id servidor dhcp usado no hotspot

    Fechem esse topico plmds
    Não e o caso, acho que você não leu o post completamente e os anteriores, não tenho problemas com clientes DHCP, meu problema é com alguns roteadores e nem setando os IPs do google diretamente no reteador resolve não amigo, só volta a funcionar se setar diretamente no PC do Cliente, se ele continuar usando o DNS fornecido pelo roteador o problema continua. Não utilizo PPPOE, como citei acima, o problema está relacionado com a captura da porta 53 pelo Hotspot. E nem posso fazer Downgrande para versões 5.xx porque a CCR1016 não aceita, pelo fato dela ser 64 bits.

    E não vejo porque fechar o tópico.

  2. #22

    Padrão Re: Problema com DNS no Mikrotik ROS

    Citação Postado originalmente por ricardowz Ver Post
    Já passei por este problema.

    Mas, desde que estou usando a versão 6.9 não aconteceu mais.

    Quando atualizei para a 6.10, aconteceu de novo. Desde então, não pretendo atualizar, até que tenha uma versão realmente estável da 6.x
    Obrigado pela dica Ricardo, vou ver a possibilidade de fazer o Downgrade durante a madrugada para testar.

    Só uma pergunta, você usa qual Routerboard atualmente? Porque tive esse mesmo problema na Versão 5.xx com a RB1100AH-X2.



  3. #23

    Padrão Re: Problema com DNS no Mikrotik ROS

    Esse tópico é de 2012 você tah mudando o assunto dele só isso é um bom motivo pra fechar. quando a gente quer perguntar alguma coisa a gente vai lá e cria nosso próprio tópico não fica desenterrando outro que já esta solucionado.

    E sobre a minha solução se você prestar atenção vai ver que a minha explicação resolve o problema de DNS enviando o IP do DNS diretamente para a placa do cliente através do DHCP. mas quer saber se vc acha que tah certo nao sou eu quem decido só quero descobrir como dar unfollow pra parar de receber e-mails sobre este assunto.

  4. #24

    Padrão Re: Problema com DNS no Mikrotik ROS

    Não estou mudando de assunto, nem tampouco fugindo do tópico, o problema aqui é DNS!

    Outra coisa, já citei acima, o problema é com algumas marcas de roteadores que utilizam IP estático, não tem como resolver isso no DHCP.

    No próprio e-mail, no final tem o Link para unfollow:

    https://under-linux.org/subscription...458270b6738cad

    Agradeço a sua atenção, mas peço que não responda mais meus posts e quem vai julgar se fecha ou não os tópicos são os moderadores. Se o tópico não serviu ou serve pra você, mas para outros está servindo ainda.



  5. #25

    Padrão Re: Problema com DNS no Mikrotik ROS

    Fiz uma modificação e aparentemente está dando certo, alterei algumas configurações do DNS do Mikrotik via Terminal, porque uma delas não é aceita pela Interface:

    /ip dns
    set allow-remote-requests=yes cache-max-ttl=5s cache-size=64KiB max-udp-packet-size=512 servers=8.8.8.8

    O que fiz ai, a grosso modo, foi diminuir ao extremo o cache de DNS do Mikrotik e ainda reduzir radicalmente o tempo de permanência dos dominios no cache. Até agora tem dado certo. Vou acompanhar mais e posto os resultados.

  6. #26

    Padrão Re: Problema com DNS no Mikrotik ROS

    problema de nat... se usar ppoe cria regra de nat pro ppoe... resolvi criando regra de nat... acha q era dns mais no fim era so problema de nat.
    exemplo no caso uso ppoe.
    cria pool remot e local
    se criar local 10.174.30.2-10.174.03.254
    remote 10.174.31.2-174.31.254

    cria uma regra de nat saida
    chain srcnat
    src address poem nat 10.174.0.0/16

    so exemplos seus ip n precisa ser iguais

    em profile do ppoe
    marca change tcp mss
    yes

    coloca dns server manual tbm.

    esse exemplo no caso de uso ppoe



  7. #27

    Padrão Re: Problema com DNS no Mikrotik ROS

    O tópico é antigo mais estou com um problema parecido com o inicial!

    Meu cenário é o seguinte:

    Ao tentar abrir sites como do paginas do Uol, Globo, Yahoo sempre da erro de pagina, mais se clicar em atualizar elas abrem normalmente!

    Fiz um redirect direto pra alguns DNS externo de todas as solicitações da porta 53 e funciona normal com a regra.

    Quando deixo o Mk resolver o DNS sempre da esses erros.

    Nada foi mudado nas config desse server e funcionava normalmente até uns 30 dias atrás.

    Além de não carregar algumas imagens de redes sociais e com a regra acima funciona normalmente!

    Detalhes:
    Server PC com versão: 5.26
    Todos cliente no Hotspot
    Todas as config nos clientes são estaticas e apontam o server como DNS

  8. #28

    Padrão Re: Problema com DNS no Mikrotik ROS

    Arraste sua regra de NAT para acima das regras do Hotspot e marque a opção allow remote requests no DNS do seu mikrotik.



  9. #29

    Padrão Re: Problema com DNS no Mikrotik ROS

    vc so precisa criar regra de nat saida tbm... ja tive esse problema... so vai resolver assim. não adianta encher seu servidor de regra não vai resolver... ta com problema nat