Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Vejo um problema... Esse cliente está participando do PCC? provavelmente sim, pois ele esta atrás do hotspot, que é um host do PCC. Você está usando nas regras do nat apenas se chegar por um interface X (pppou-out1). Se a conexão estiver por outro link não funcionará. Deixe as regras sem mencionar as interfaces de entrada e testa.

  2. Mesmo assim ainda não funcionou



  3. E ai amigo você conseguiu estou com o mesmo problema que você e nada ainda
    Tenho load e mk para autenticação com hotspot e não consigo abri porta de jeito nem um

  4. Olá edykl e mestre sergio,

    Deixa eu dar um modesto pitaco aki no assunto, sem querer contraria o grande sergio :P
    Seguinte, nas suas regras do firewall, se retirar a interface de entrada você pode ter futuros problemas, pois sem especificar por que interface de entrada você vai destinar o tráfego, o ROS também vai redirecionar o trafego de saída, então se alguém de dentro da sua rede tentar acessar algum serviço nessas portas externas não vai conseguir, porque o ROS vai redirecionar para o seu servidor interno.
    No caso do PCC, você pode resolver isso colocando uma negativa (!) na interface de entrada, então ficaria mais ou menos assim as suas regras de redirecionamento do balance:

    Código :
    add action=dst-nat chain=dstnat comment=cameras disabled=no dst-port=1001 in-interface=!interface_local protocol=tcp to-addresses=10.3.3.2 to-ports=1001
    add action=dst-nat chain=dstnat disabled=no dst-port=10001 in-interface=!interface_local protocol=tcp to-addresses=10.3.3.2 to-ports=10001
    add action=dst-nat chain=dstnat disabled=no dst-port=1000 in-interface=!interface_local protocol=tcp to-addresses=10.3.3.2 to-ports=1000
    add action=dst-nat chain=dstnat disabled=no dst-port=10000 in-interface=!interface_local protocol=tcp to-addresses=10.3.3.2 to-ports=10000

    Com isso, essas regras iriam valer para todo o tráfego que não tivesse como origem a interface_local (!interface_local), sendo que esse nome "interface_local" você tem que substituir pelo nome da sua interface que atende os seus usuários.

    Beleza, agora quanto ao problema principal, onde você está dizendo que as suas regras não estão funcionando, muito provavelmente é por causa do seu PCC, porque o pacote TCP entra por uma conexão, e na hora de sair vai pela outra conexão do PCC, e é por isso que uma regra funciona e a outra não, ou uma hora funciona uma e outra hora funciona a outra, vira uma salada completa.
    Para resolver esse problema você terá que adicionar algumas regras, com a finalidade de marcar a conexão na entrada, para que a mesma sempre saia pelo mesmo link.
    Caso, vou tomar como exemplo, você tenha 2 links de saída, se você tiver mais é só adaptar as regras, faça o seguinte:

    1º - Crie duas rotas estáticas no ROS:

    Código :
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out1 routing-mark=rota1 scope=30 target-scope=10
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out2 routing-mark=rota2 scope=30 target-scope=10

    2º - Marque as conexões de entrada, e faça ele sair pelo mesmo link que entrou, no Firewall --> Mangle:

    Código :
    /ip firewall mangle add action=mark-connection chain=input disabled=no protocol=tcp dst-port=1000,1001,10000,10001 in-interface=pppoe-out1 new-connection-mark=rota1_conn passthrough=yes
    /ip firewall mangle add action=mark-connection chain=input disabled=no protocol=tcp dst-port=1000,1001,10000,10001 in-interface=pppoe-out2 new-connection-mark=rota2_conn passthrough=yes
     
     
    /ip firewall mangle add action=mark-routing chain=output connection-mark=rota1_conn disabled=no new-routing-mark=rota1 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=rota2_conn disabled=no new-routing-mark=rota2 passthrough=yes

    Pronto, agora toda a conexão solicitada de fora da sua rede interna que tenha como destino as portas 1000, 1001, 10000 e 10001 vão entrar e retornar pelo mesmo link, resolvendo assim o seu problema de conexão.

    Um grande abraço a todos



  5. Que nada Michael, estamos aqui para somar. Sem contar que eu não sei tudo né, e às vezes, a memória falha...

    PCC é uma praia que estou dando uns pitacos agora, pois estou prestando serviços para uma empresa que utiliza, mas fora isso, usei muito pouco.

    Valeu pela contribuição!!






Tópicos Similares

  1. Redirecionamento de IP/PORTA
    Por rodolfoabcconnect no fórum Servidores de Rede
    Respostas: 3
    Último Post: 03-02-2009, 06:38
  2. Redirecionamento de ip e porta iptables.
    Por MAJOR no fórum Servidores de Rede
    Respostas: 35
    Último Post: 07-04-2005, 07:23
  3. Redirecionamento de Ip
    Por Thon no fórum Servidores de Rede
    Respostas: 1
    Último Post: 05-06-2004, 21:13
  4. Redirecionamento de todas as portas!!
    Por Perdigao no fórum Servidores de Rede
    Respostas: 2
    Último Post: 23-04-2004, 09:41
  5. DESAFIO - REDIRECIONAMENTO DE IP´S
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 11-02-2003, 07:52

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L