+ Responder ao Tópico



  1. Dê um comando "export" no terminal ai e posta suas regras pra agente poder dar uma olhada melhor.

  2. Ok! assim que eu exportar as regras posto aqui. valew cara, abraço!



  3. segue as configurações do meu rb, se tiver algo do tipo "disabled=yes" é porq no momento que dei o "export" não estava usando as configurações, estava tudo desativado, mas sai mudando para "no", pode ser que eu tenha esquecido alguma. valew!

    /interface ethernet
    set 0 arp=enabled auto-negotiation=yes disabled=no full-duplex=yes l2mtu=1600 mac-address=00:00:00:00:00:00 mtu=1500 name=Link1 speed=100Mbps
    set 1 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no full-duplex=yes l2mtu=1598 mac-address=00:00:00:00:00:00 \
    master-port=none mtu=1500 name=Link2 speed=100Mbps
    set 4 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no full-duplex=yes l2mtu=1598 mac-address=00:00:00:00:00:00 \
    master-port=none mtu=1500 name=Local speed=100Mbps
    set 0 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no full-duplex=yes l2mtu=1598 mac-address=00:00:00:00:00:00 \
    master-port=none mtu=1500 name=Link3 speed=100Mbps
    set 1 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=no full-duplex=yes l2mtu=1598 mac-address=00:00:00:00:00:00 \
    master-port=none mtu=1500 name=Link4 speed=100Mbps


    /interface pppoe-client
    add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface=Link1 max-mru=1480 max-mtu=1480 \
    mrru=disabled name=pppoe1 password=xxxx profile=default service-name="" use-peer-dns=no user=user1
    add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface=Link2 max-mru=1480 max-mtu=1480 \
    mrru=disabled name=pppoe2 password=xxxx profile=default service-name="" use-peer-dns=no user=user2
    add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface=Link3 max-mru=1480 max-mtu=1480 \
    mrru=disabled name=pppoe3 password=xxxx profile=default service-name="" use-peer-dns=no user=user3
    add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface=Link4 max-mru=1480 max-mtu=1480 \
    mrru=disabled name=pppoe4 password=xxxx profile=default service-name="" use-peer-dns=no user=user4


    /ip address
    add address=192.168.1.1/24 disabled=no interface=Local network=192.168.1.0


    /ip dns
    set allow-remote-requests=yes cache-max-ttl=1w cache-size=2048KiB max-udp-packet-size=512 servers=8.8.8.8,8.8.4.4


    /ip firewall mangle
    add action=accept chain=prerouting comment="====================================================================" disabled=no dst-address=\
    192.168.1.0/24 src-address=192.168.1.0/24


    add action=mark-connection chain=prerouting comment="===================================================================" connection-mark=\
    no-mark disabled=no in-interface=pppoe1 new-connection-mark=Link1_con passthrough=yes


    add action=mark-connection chain=prerouting connection-mark=no-mark disabled=no in-interface=pppoe2 new-connection-mark=Link2_con \
    passthrough=yes
    add action=mark-connection chain=prerouting connection-mark=no-mark disabled=no in-interface=pppoe3 new-connection-mark=Link3_con \
    passthrough=yes
    add action=mark-connection chain=prerouting connection-mark=no-mark disabled=no in-interface=pppoe4 new-connection-mark=Link4_con \
    passthrough=yes


    add action=jump chain=prerouting comment="====================================================================" connection-mark=no-mark \
    disabled=no in-interface=Local jump-target=policy_router


    add action=mark-routing chain=prerouting comment="====================================================================" connection-mark=\
    Link1_con disabled=no new-routing-mark=Link1_trafic passthrough=yes src-address=192.168.1.0/24


    add action=mark-routing chain=prerouting connection-mark=Link2_con disabled=no new-routing-mark=Link2_trafic passthrough=yes src-address=\
    192.168.1.0/24
    add action=mark-routing chain=prerouting connection-mark=Link3_con disabled=no new-routing-mark=Link3_trafic passthrough=yes src-address=\
    192.168.1.0/24
    add action=mark-routing chain=prerouting connection-mark=Link4_con disabled=no new-routing-mark=Link4_trafic passthrough=yes src-address=\
    192.168.1.0/24


    add action=mark-routing chain=output comment="====================================================================" connection-mark=Link1_con \
    disabled=no new-routing-mark=Link1_trafic passthrough=yes
    add action=mark-routing chain=output connection-mark=Link2_con disabled=no new-routing-mark=Link2_trafic passthrough=yes
    add action=mark-routing chain=output connection-mark=Link3_con disabled=no new-routing-mark=Link3_trafic passthrough=yes
    add action=mark-routing chain=output connection-mark=Link4_con disabled=no new-routing-mark=Link4_trafic passthrough=yes


    add action=mark-connection chain=policy_router comment="====================================================================" disabled=no \
    dst-address-type=!local new-connection-mark=Link1_con passthrough=yes per-connection-classifier=both-addresses:4/0
    add action=mark-connection chain=policy_router disabled=no dst-address-type=!local new-connection-mark=Link2_con passthrough=yes \
    per-connection-classifier=both-addresses:4/1
    add action=mark-connection chain=policy_router disabled=no dst-address-type=!local new-connection-mark=Link3_con passthrough=yes \
    per-connection-classifier=both-addresses:4/2
    add action=mark-connection chain=policy_router disabled=no dst-address-type=!local new-connection-mark=Link4_con passthrough=yes \
    per-connection-classifier=both-addresses:4/3


    /ip firewall nat
    add action=masquerade chain=srcnat disabled=no out-interface=pppoe1
    add action=masquerade chain=srcnat disabled=no out-interface=pppoe2
    add action=masquerade chain=srcnat disabled=no out-interface=pppoe3
    add action=masquerade chain=srcnat disabled=no out-interface=pppoe4


    /ip route
    add disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=pppoe1 routing-mark=Link1_trafic scope=30 target-scope=10
    add disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=pppoe2 routing-mark=Link2_trafic scope=30 target-scope=10
    add disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=pppoe3 routing-mark=Link3_trafic scope=30 target-scope=10
    add disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=pppoe4 routing-mark=Link4_trafic scope=30 target-scope=10
    add disabled=yes distance=2 dst-address=0.0.0.0/0 gateway=pppoe1 scope=30 target-scope=10
    add disabled=yes distance=3 dst-address=0.0.0.0/0 gateway=pppoe2 scope=30 target-scope=10
    add disabled=yes distance=4 dst-address=0.0.0.0/0 gateway=pppoe3 scope=30 target-scope=10
    add disabled=yes distance=5 dst-address=0.0.0.0/0 gateway=pppoe4 scope=30 target-scope=10

  4. Velho pelo que eu pude perceber suas rotas e as suas configurações de equilibrio de carga estão bem estranhas, vou postar as minhas regras de IP Address, Routes, e Firewall para que você possa dar uma analisada





    /ip firewall mangle
    add action=accept chain=prerouting comment=\
    "Aceita todo trafego das redes conectadas" disabled=no dst-address=\
    192.168.1.0/24 src-address=192.168.1.0/24
    add action=accept chain=prerouting disabled=no dst-address=192.168.10.0/24 \
    src-address=192.168.1.0/24
    add action=accept chain=prerouting disabled=no dst-address=192.168.11.0/24 \
    src-address=192.168.1.0/24
    add action=mark-connection chain=prerouting comment=\
    "Marca todas as conex\F5es externas iniciadas" connection-mark=no-mark \
    disabled=no in-interface=1-Link-9023 new-connection-mark=9023_conn \
    passthrough=yes
    add action=mark-connection chain=prerouting connection-mark=no-mark disabled=no \
    in-interface=2-Link-1111 new-connection-mark=1111_conn passthrough=yes
    add action=jump chain=prerouting comment="Encaminhamento personalizado" \
    connection-mark=no-mark disabled=no in-interface=5-Local jump-target=\
    policy_router
    add action=mark-routing chain=prerouting comment=Rotemento connection-mark=\
    9023_conn disabled=no new-routing-mark=9023_trafic passthrough=yes \
    src-address=192.168.1.0/24
    add action=mark-routing chain=prerouting connection-mark=1111_conn disabled=no \
    new-routing-mark=1111_trafic passthrough=yes src-address=192.168.1.0/24
    add action=mark-routing chain=output comment="Roteamento de sa\EDda" \
    connection-mark=9023_conn disabled=no new-routing-mark=9023_trafic \
    passthrough=yes
    add action=mark-routing chain=output connection-mark=1111_conn disabled=no \
    new-routing-mark=1111_trafic passthrough=yes
    add action=mark-connection chain=policy_router comment="Equil\EDbrio de carga" \
    disabled=no dst-address-type=!local new-connection-mark=9023_conn \
    passthrough=yes per-connection-classifier=both-addresses:4/0
    add action=mark-connection chain=policy_router disabled=no dst-address-type=\
    !local new-connection-mark=1111_conn passthrough=yes \
    per-connection-classifier=both-addresses:4/1
    add action=mark-connection chain=policy_router disabled=no dst-address-type=\
    !local new-connection-mark=1111_conn passthrough=yes \
    per-connection-classifier=both-addresses:4/2
    add action=mark-connection chain=policy_router disabled=no dst-address-type=\
    !local new-connection-mark=1111_conn passthrough=yes \
    per-connection-classifier=both-addresses:4/3

    /ip firewall nat
    add action=masquerade chain=srcnat comment=\
    "====================================================================" \
    disabled=no out-interface=1-Link-9023
    add action=masquerade chain=srcnat disabled=no out-interface=2-Link-1111
    /ip firewall service-port
    set ftp disabled=no ports=21
    set tftp disabled=no ports=69
    set irc disabled=no ports=6667
    set h323 disabled=no
    set sip disabled=no ports=5060,5061 sip-direct-media=yes
    set pptp disabled=no




    /ip address
    add address=192.168.88.1/24 disabled=no interface=ether3 network=192.168.88.0
    add address=192.168.10.2/24 comment="Link 1 MB" disabled=no interface=\
    1-Link-9023 network=192.168.10.0
    add address=192.168.11.2/24 comment="Link 2 MB" disabled=no interface=\
    2-Link-1111 network=192.168.11.0
    add address=192.168.1.1/24 comment="Sa\EDda" disabled=no interface=5-Local \
    network=192.168.1.0

    /ip route
    add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.10.1 \
    routing-mark=9023_trafic scope=30 target-scope=10
    add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.11.1 \
    routing-mark=1111_trafic scope=30 target-scope=10
    add disabled=no distance=2 dst-address=0.0.0.0/0 gateway=192.168.10.1 scope=30 \
    target-scope=10
    add disabled=no distance=3 dst-address=0.0.0.0/0 gateway=192.168.11.1 scope=30 \
    target-scope=10


    A diferença que uso apenas dois links e são de cargas deferentes e o segundo link por ser de maior capacidade está com 3 boots para ou seja, a cada 4 requisições 1 sai pelo link 1 e 3 pelo link 2.



  5. vou testar tuas configurações aqui, depois te dou uma resposta. valew cara, brigadão!






Tópicos Similares

  1. Respostas: 4
    Último Post: 17-07-2007, 18:12
  2. Controlando a banda do proprio gateway
    Por pinkfloydlsd no fórum Servidores de Rede
    Respostas: 2
    Último Post: 03-05-2007, 21:22
  3. Banda do Cache
    Por notgle no fórum Redes
    Respostas: 9
    Último Post: 04-02-2007, 09:55
  4. Balanceamente de banda. Como NÂO gastar toda a banda do servidor?
    Por stormrider no fórum Servidores de Rede
    Respostas: 2
    Último Post: 20-04-2006, 13:54
  5. Uso de banda do Skype!
    Por alslinux no fórum Servidores de Rede
    Respostas: 5
    Último Post: 14-11-2005, 05:43

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L