Página 3 de 4 PrimeiroPrimeiro 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. Bom dia

    Favor teste esta regra abaixo...

    /ip firewall nat
    add action=dst-nat chain=dstnat disabled=no dst-address=201.201.201.201 \
    dst-port=8080 protocol=tcp to-addresses=192.168.0.80 to-ports=8080


    Você esta usando Mikrotik em seu firewall?

  2. Citação Postado originalmente por gamineiro Ver Post
    Rede interna: 192.168.0.0/24
    GW: 192.168.0.254
    WEB SERVER: 192.168.0.80/24
    IP VÁLIDO GW: 201.201.201.201
    Código :
    /ip firewall nat \
    add action=dst-nat chain=dstnat disabled=no \
    dst-address=201.201.201.201 dst-port=8080 \
    protocol=tcp src-address=192.168.0.0/24 \
    to-addresses=192.168.0.80 to-ports=80
    Interpretação em linguagem mais próxima possível da natural (o que é impossível com iptables), do código acima.

    Redireciona para o host 192.168.0.80:80 as requisições originadas na redes 192.168.0.0/24, que tenham como destino o endereço 201.201.201.201:8080 TCP. Ao host alvo (192.168.0.80), assume-se a porta de destino em mesmo protocolo, portanto, TCP.

    Acredito que seu problema será sanado.

    Testa aí e nos avisa

    Saudações,

    Trober
    -
    -
    -
    -
    -



  3. Citação Postado originalmente por gamineiro Ver Post
    Olá,

    Não tenho como fazer assim por vários motivos. Não tenho servidor DNS rodando no firewall, uso AD e o DNS é nele. As conexões são feitas por IP e não por nome. Mesmo que não seja por nome, se eu tivesse outro serviço rodando no mesmo endereço, mas que ficasse fora da empresa (email por exemplo), não iria funcionar também.

    O cenário é exatamente o que você descreveu como Parte 2.

    Rede interna: 192.168.0.0/24
    GW: 192.168.0.254
    WEB SERVER: 192.168.0.80/24
    IP VÁLIDO GW: 201.201.201.201

    Quanto estou fora da empresa, acesso pelo browser o endereço http://201.201.201.201:8080 e sou redicionado para o IP do Web Server normalmente, essa regra é bem simples.

    Quando estou dentro da empresa, quero acessar pelo browser o mesmo endereço http://201.201.201.201:8080 e também ser direcionado para o Web Server.

    A regra correta para o Linux é exatamente essa. Ja tentei copiar mas não consigo.

    $IPT -t nat -A POSTROUTING -o $LOCAL_IFACE -s $LOCAL_NET -d 192.168.0.80/32 -j MASQUERADE
    Deixa ver se entendi!!
    Tu esta dentro da rede, e tem um ip valico xyz e que acessar pela porta externa 8080 pela rede interna.

    Se tu digitar o ip xyz sem a porta vai cair direto? Se sim tu vai fazer o seguinte:
    Troca a porta 80 do seu webserver pela porta 8080 e na regra do firewall tu troca a porta 80 do ip interno pela 8080.
    Ai é so tu coloca o ip xyz:8080 tanto internamente como externamente.

  4. Citação Postado originalmente por leonardolinux Ver Post
    Bom dia

    Favor teste esta regra abaixo...

    /ip firewall nat
    add action=dst-nat chain=dstnat disabled=no dst-address=201.201.201.201 \
    dst-port=8080 protocol=tcp to-addresses=192.168.0.80 to-ports=8080


    Você esta usando Mikrotik em seu firewall?
    Não funcionou também.



  5. Citação Postado originalmente por emanochio Ver Post
    Deixa ver se entendi!!
    Tu esta dentro da rede, e tem um ip valico xyz e que acessar pela porta externa 8080 pela rede interna.

    Se tu digitar o ip xyz sem a porta vai cair direto? Se sim tu vai fazer o seguinte:
    Troca a porta 80 do seu webserver pela porta 8080 e na regra do firewall tu troca a porta 80 do ip interno pela 8080.
    Ai é so tu coloca o ip xyz:8080 tanto internamente como externamente.
    Amigo, não entendi o "vai car direto". Mas se colocar sem a porta, vai abrir o webserver do firewall.

    Obrigado






Tópicos Similares

  1. Respostas: 2
    Último Post: 26-12-2012, 09:37
  2. Direcionar tráfego de entrada externo para um ip interno
    Por eume5mo no fórum Servidores de Rede
    Respostas: 1
    Último Post: 25-06-2008, 08:52
  3. Respostas: 5
    Último Post: 12-04-2007, 13:35
  4. rotear ip para outro ip
    Por marcelotanaka no fórum Servidores de Rede
    Respostas: 0
    Último Post: 20-05-2004, 15:07
  5. Liberando acesso apenas para um ip.
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 09-06-2003, 10:04

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L