+ Responder ao Tópico



  1. #1

    Padrão script MONITOR falta de energia

    Bom dia, estou com um script aqui, quase pronto e não consigo faze-lo funcionar, basicamente, ele monitora uma interface da qual eu tenho um modem conectado nela.
    quando falta energia, o status desta interface muda e então o script envia um email para mim, até ai tudo certo.

    Porem não estou conseguindo ajustar este script, alguém mode ver o que esta de errado com o script?

    segue:

    /interface ethernet monitor HUB do {
    :if ($status != "link-ok") do {
    /tool e-mail send to="[email protected]" subject="faltou_enegia $data as $hora" body="faltou_enegia $hora de $data."
    :log info "EMAIL ENVIADO COM SUSSESSO!"

    Lembrando que ja tenho outros scripts que enviam email, de backup automáticos, tudo funcionando certo.

    Se alguém me ajudar fico muito grato.

  2. #2

    Padrão Re: script MONITOR falta de energia

    vamos la pessoal. me ajudem por favor.



  3. #3

    Padrão Re: script MONITOR falta de energia

    Consegui fazer funcionar lembrando que este script é para MK 3.x
    testado e aprovado.

    segue script completo, qualquer duvida é só perguntar.




    Em System > NTP Cliente:


    Mode: unicast
    Primary NTP Server: 200.160.0.8
    Secondary NTP Server: 200.160.0.8
    Marque o: enable


    Depois em System > Clock:


    Time Zone Name: Coloque America/são paulo para fazer o devido ajuste sobre a hora obtida no NTP, que no caso é mundial.




    Configure o email em: tool > email:


    Server: smtp.bol.com.br
    Port: 25
    From: [email protected]
    User: [email protected]
    Password: minha senha do email






    MONITORAMENTO DE ENERGIA.


    EM UMA ETHERNET VC COLOCA UMA MODEM OU UM HUB, QUALQUER COISA, PARA QUE FIQUE
    CONECTADO COM UMA INTERFACE DO MIKROTIK.


    ESTE TEM QEU ESTAR LIGADO DIRETO NA ENERGIA, POIS QUANDO FALTAR ENERGIA,
    O MK VAI EXECUTAR O SCRIPT E VAI VER QEU A INTERFACE DO MODEM ESTA DESCONECTADO, E ENVIARA O EMAIL AUTOMATICAMENTE.








    SEGUE O SCRIPT.




    /interface ethernet monitor NOME_DA_ETHERNET once do {
    :if ($status != "link-ok") do {
    :delay 2s
    :global data [/system clock get date]
    :global hora [/system clock get time]
    /tool e-mail send to="[email protected]" subject="sem_energia" body="sem_energia AS: $hora de $data."
    /tool e-mail send to="[email protected]" subject="sem_energia AS: $hora de $data." body="sem_energia AS: $hora de $data."
    :log info "EMAIL ENVIADO COM SUSSESSO!"
    }
    }









    CRIE UM EMAIL NA CLARO, POIS A CLARO TEM A OPÇÃO DE ENVIAR UM AVISO SMS PARA O CELULAR QUE CHEGOU UM EMAIL.
    DESTA FORMA VC PODE MONITORAR TODA SUA REDE.






    AVISO por assunto da claro.


    site da claro: https://www.iclaro.com.br/


    EM ASSUNTO VAI NOTIFICAR:


    sem_energia

  4. #4

    Padrão Re: script MONITOR falta de energia

    Boa amigo.. Estrelinha pra vc..
    Alguem conhece alguma forma transformar 24v pra 12v...
    Desde ja agradeço...



  5. #5

    Padrão Re: script MONITOR falta de energia

    Use um circuito integrado 7812,
    é um regulador de voltagem para 12v 1A.

  6. #6

    Padrão Re: script MONITOR falta de energia

    Estrelinha pra vc....
    Metire uma duvida qual é o ip e a porta que o serv smtp da claro usa?
    agradeço



  7. #7
    técnico em Telecom Avatar de laurence669
    Ingresso
    Oct 2009
    Localização
    minas gerais
    Posts
    1.000
    Posts de Blog
    1

    Padrão Re: script MONITOR falta de energia


  8. #8

    Padrão Re: script MONITOR falta de energia

    Citação Postado originalmente por maxibelo Ver Post
    Boa amigo.. Estrelinha pra vc..
    Alguem conhece alguma forma transformar 24v pra 12v...
    Desde ja agradeço...
    se voce utlizar duas Baterias... só puxa negativo do meio.. assim voce terá 12v entre Polo Positivo da mesma bateria com Polo Negativo... ai voce pergunta.. Puxa Cabo 3pernas de fio para sua torre.. assim voce tem 12V e 24V



  9. #9

    Padrão Re: script MONITOR falta de energia

    Amigos ... também monitoro meus pops a questão da energia, quando cai ou volta, mas de uma forma muito mais simples.

    Eu configuro qualquer equipamento velho que aceite um IP e instalo no local desejado para monitoramento.

    Habilito então seu IP no meu monitoramento do The Dude como se fosse um Device comum mas com o nome "Monitor de Energia de tal lugar".

    Pronto ... toda minha rede monitorada também a questão de energia sem precisar fazer Scripts.

    O Script ficou muito bom mas acho muito trabalho para um serviço que pode ser resolvido de forma muito mais simples.

    Saudações

  10. #10

    Padrão Re: script MONITOR falta de energia

    Existe uma maneira de adaptar um cabo de rede onde um lado vai ligado na fonte de alimentação e o outro lado vai na porta ethernet ?
    Daí não seria necessário ligar um switch a mais na torre, diminuindo o consumo de energia.



  11. #11

    Padrão Re: script MONITOR falta de energia

    Citação Postado originalmente por HenriqueB Ver Post
    Existe uma maneira de adaptar um cabo de rede onde um lado vai ligado na fonte de alimentação e o outro lado vai na porta ethernet ?
    Daí não seria necessário ligar um switch a mais na torre, diminuindo o consumo de energia.
    Amigo ... me perdoe mas não compreendi dua pergunta, poderia ser mais claro?

    Saudações

  12. #12

    Padrão Re: script MONITOR falta de energia

    Godoy,
    Neste caso, o nosso amigo teve que usar um modem para poder monitorar uma interface. Verificando se o cabo esta ou não conectado (cabo conectado = com energia).
    Porém isso acaba por gerar um consumo de energia maior, visto que ele terá de manter o modem ligado.
    E se ao invés de ligar o modem, nós criássemos um adaptador que seja alimentado direto nos 12v e no outro lado seja com um terminal RJ-45 para conectar numa interface ?



  13. #13

    Padrão Re: script MONITOR falta de energia

    a configuração da iclaro é smtp: 74.202.142.43, port:80, from: [email protected], user: [email protected], password: senha do email da claro, testado 100% em todas as versões....

  14. #14

    Lightbulb Re: script MONITOR falta de energia

    Acho que o que você quer fazer é algo parecido com isso aqui: http://gregsowell.com/?p=2093 Correto?

    Citação Postado originalmente por HenriqueB Ver Post
    Godoy,
    Neste caso, o nosso amigo teve que usar um modem para poder monitorar uma interface. Verificando se o cabo esta ou não conectado (cabo conectado = com energia).
    Porém isso acaba por gerar um consumo de energia maior, visto que ele terá de manter o modem ligado.
    E se ao invés de ligar o modem, nós criássemos um adaptador que seja alimentado direto nos 12v e no outro lado seja com um terminal RJ-45 para conectar numa interface ?



  15. #15

    Padrão Re: script MONITOR falta de energia

    Amigo o script executa sozinho?