+ Responder ao Tópico



  1. #1

    Post hotspot + voip + controle de banda dinâmico

    Buenas colegas..

    Estou com um probleminha no meu provedor e necessito da ajuda de alguém mais experiente.. meus clientes estão reclamando que a voz pipoca quando está usando a internet, isso devido ao controle automático que o Radius envia para a RB quando o user faz o login.. quando nao está logado o telefone funciona q é uma beleza mas qdo usa a internet pipoca..

    ví vários lugares sobre marcação de pacotes, oque não é meu forte e quero ver se fiz certo e se vai funcionar, pois ainda não tive como testar e as rbs novas chegam quarta feira para mim testar..

    ip o servidor asterisk: 172.29.255.2
    uso MK-Auth como servidor Radius.. o hotspot está mascarado na torre, minha rede está com roteamento estático..

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment=VOIP disabled=no dst-address=172.29.255.2 new-connection-mark=voip_conn passthrough=yes
    add action=mark-connection chain=prerouting disabled=no new-connection-mark=voip_conn passthrough=yes src-address=172.29.255.2
    add action=mark-packet chain=prerouting connection-mark=voip_conn disabled=no dst-address-list="" new-packet-mark=voip_pkt passthrough=no
    add action=mark-connection chain=postrouting comment=VOIP disabled=no dst-address=172.29.255.2 dst-address-list="" new-connection-mark=voip_conn passthrough=yes
    add action=mark-connection chain=postrouting disabled=no dst-address-list="" new-connection-mark=voip_conn passthrough=yes src-address=172.29.255.2
    add action=mark-packet chain=postrouting connection-mark=voip_conn disabled=no new-packet-mark=voip_pkt passthrough=no

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=queue1 packet-mark=voip_pkt parent=global-in priority=8 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=queue2 packet-mark=voip_pkt parent=global-out priority=8 queue=default



    isso ja é o suficiente para liberar o voip do controle de banda ou preciso fazer mais alguma coisa?
    preciso tirar o voip do controle e liberar full, ou devo limitar este queue? geralmente 4 simultâneos por hotspot, com codec g729a.

    Obrigado e fico no aguardo para quem puder ajudar!

    Att,
    Lenon Moreschi

  2. #2

    Padrão Re: hotspot + voip + controle de banda dinâmico

    Citação Postado originalmente por len0n16 Ver Post
    Buenas colegas..

    Estou com um probleminha no meu provedor e necessito da ajuda de alguém mais experiente.. meus clientes estão reclamando que a voz pipoca quando está usando a internet, isso devido ao controle automático que o Radius envia para a RB quando o user faz o login.. quando nao está logado o telefone funciona q é uma beleza mas qdo usa a internet pipoca..

    ví vários lugares sobre marcação de pacotes, oque não é meu forte e quero ver se fiz certo e se vai funcionar, pois ainda não tive como testar e as rbs novas chegam quarta feira para mim testar..

    ip o servidor asterisk: 172.29.255.2
    uso MK-Auth como servidor Radius.. o hotspot está mascarado na torre, minha rede está com roteamento estático..

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment=VOIP disabled=no dst-address=172.29.255.2 new-connection-mark=voip_conn passthrough=yes
    add action=mark-connection chain=prerouting disabled=no new-connection-mark=voip_conn passthrough=yes src-address=172.29.255.2
    add action=mark-packet chain=prerouting connection-mark=voip_conn disabled=no dst-address-list="" new-packet-mark=voip_pkt passthrough=no
    add action=mark-connection chain=postrouting comment=VOIP disabled=no dst-address=172.29.255.2 dst-address-list="" new-connection-mark=voip_conn passthrough=yes
    add action=mark-connection chain=postrouting disabled=no dst-address-list="" new-connection-mark=voip_conn passthrough=yes src-address=172.29.255.2
    add action=mark-packet chain=postrouting connection-mark=voip_conn disabled=no new-packet-mark=voip_pkt passthrough=no

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=queue1 packet-mark=voip_pkt parent=global-in priority=8 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=queue2 packet-mark=voip_pkt parent=global-out priority=8 queue=default



    isso ja é o suficiente para liberar o voip do controle de banda ou preciso fazer mais alguma coisa?
    preciso tirar o voip do controle e liberar full, ou devo limitar este queue? geralmente 4 simultâneos por hotspot, com codec g729a.

    Obrigado e fico no aguardo para quem puder ajudar!

    Att,
    Lenon Moreschi




    ninguém já esteve em algum empasse parecido?!

    obrigado



  3. #3

    Padrão Re: hotspot + voip + controle de banda dinâmico

    Eai como ficou a questao do voip?

    da uma olhada neste material vai te ajudar

  4. #4

    Padrão Re: hotspot + voip + controle de banda dinâmico

    Citação Postado originalmente por jailtonnetlink Ver Post
    Eai como ficou a questao do voip?

    da uma olhada neste material vai te ajudar

    Opa amigo blz? então estive olhando na bancada uma maneira, mas não estou conseguindo.. ainda não pude fazer um teste realístico em cima disto, mas preciso muito pois meus clientes estão se queixando a respeito das picoteadas quando estão usando a internet..

    não consegui identificar o link que você mandou, mas valeu por ter tentado ajudar! (y)

    obrigado amigão, abraço!



  5. #5

    Padrão Re: hotspot + voip + controle de banda dinâmico

    Me desculpe ..nao inseri o link no post anterior.. mais agora segue o link do video da palestra no mum,aonde explica exatamente o seu problema e como resolver okhttp://www.tiktube.com/video/FHfq3bC...znyKuqlDomEJq=



    Aqui esta o slide da palestra para poder visualizar as regras ok
    http://mum.mikrotik.com/presentation...11_Antonio.pdf

  6. #6

    Padrão Re: hotspot + voip + controle de banda dinâmico

    Citação Postado originalmente por jailtonnetlink Ver Post
    Me desculpe ..nao inseri o link no post anterior.. mais agora segue o link do video da palestra no mum,aonde explica exatamente o seu problema e como resolver okhttp://www.tiktube.com/video/FHfq3bC...znyKuqlDomEJq=



    Aqui esta o slide da palestra para poder visualizar as regras ok
    http://mum.mikrotik.com/presentation...11_Antonio.pdf
    Opa novamente, desculpe a demora pra responder..

    Dei uma olhada no material que vc me passou, muito bom mesmo!! eu agradeço muito, pude tirar algumas conclusões, mas nada ainda que me esclareça.

    Pelo que entendi ali explica como priorizar o pacote do roteador de borda até a ponta. Mas não à frente do hotspot.. eu queria algo que tirasse os pacotes do voip do controle após o hotspot, pq é ali que a RB está bloqueando e fazendo picotar.. antes não possui controle algum, pois a rede possui capacidade de sobra..

    Enfim muito obrigado pela ajuda!! Se alguem mais puder ajudar eu agradeço!

    Obrigado

    Att,
    Lenon Moreschi



  7. #7

    Padrão Re: hotspot + voip + controle de banda dinâmico

    Citação Postado originalmente por len0n16 Ver Post
    Opa novamente, desculpe a demora pra responder..

    Dei uma olhada no material que vc me passou, muito bom mesmo!! eu agradeço muito, pude tirar algumas conclusões, mas nada ainda que me esclareça.

    Pelo que entendi ali explica como priorizar o pacote do roteador de borda até a ponta. Mas não à frente do hotspot.. eu queria algo que tirasse os pacotes do voip do controle após o hotspot, pq é ali que a RB está bloqueando e fazendo picotar.. antes não possui controle algum, pois a rede possui capacidade de sobra..

    Enfim muito obrigado pela ajuda!! Se alguem mais puder ajudar eu agradeço!

    Obrigado

    Att,
    Lenon Moreschi
    tanto o router de borda como tbm as de dentro da rede( as dos pops ).

  8. #8

    Padrão Re: hotspot + voip + controle de banda dinâmico

    Citação Postado originalmente por jailtonnetlink Ver Post
    tanto o router de borda como tbm as de dentro da rede( as dos pops ).

    Certo amigão! estou fazendo os testes em bancada.. funciona sim, mas na verdade oque está acontecendo: essas regras estão priorizando o tráfego do voip. Vamos supor que tenho 350k liberado para o user, quando eu usar o telefone vai priorizar 64k e vai sobrar 286k para a internet.. a o telefone da umas picotadas de vem em quando usando a internet junto..

    Oque eu queria na verdade era tirar o voip desse controle, entende? o usuário pegar o telefone e ligar, não priorizar os pacotes voip, mas sim não incluir no controle para continuar os 350k de internet para o usuário, mantendo assim uma maior fidelidade no serviço prestado ao cliente..

    Muitos reclamam ainda que não está bom justamente por causa disto.. mas vou ficar no aguardo se alguém mais puder ajudar!

    Muito obrigado!



  9. #9

    Padrão Re: hotspot + voip + controle de banda dinâmico

    Neste caso indico protocolo MPLS OU OSPF para isso ...e a melhor soluçao sem duvidas

  10. #10

    Padrão Re: hotspot + voip + controle de banda dinâmico

    Citação Postado originalmente por jailtonnetlink Ver Post
    Neste caso indico protocolo MPLS OU OSPF para isso ...e a melhor soluçao sem duvidas
    Certo cara eu também estava pensando sobre isso... estou fazendo testes ainda mas acho que encontrei a solução, pelo menos me parece até agora. Fiz segundo o tutorial que voce me indicou, bem certinho, depois adicionei essas regras apenas na Rb que está o hotspot:

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment=VOIP disabled=no dst-address=172.29.255.2 new-connection-mark=voip_conn passthrough=yes
    add action=mark-connection chain=prerouting disabled=no new-connection-mark=voip_conn passthrough=yes src-address=172.29.255.2
    add action=mark-packet chain=prerouting connection-mark=voip_conn disabled=no dst-address-list="" new-packet-mark=voip_pkt passthrough=no
    add action=mark-connection chain=postrouting comment=VOIP disabled=no dst-address=172.29.255.2 dst-address-list="" new-connection-mark=voip_conn passthrough=yes
    add action=mark-connection chain=postrouting disabled=no dst-address-list="" new-connection-mark=voip_conn passthrough=yes src-address=172.29.255.2
    add action=mark-packet chain=postrouting connection-mark=voip_conn disabled=no new-packet-mark=voip_pkt passthrough=no


    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=Queue IN packet-mark=voip_pkt parent=global-in priority=8 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=Queue OUT packet-mark=voip_pkt parent=global-out priority=8 queue=default


    testei e deu certo.. pelo menos até agora. Aviso qualquer mudança.. obrigado pela ajuda amigo



  11. #11

    Padrão Re: hotspot + voip + controle de banda dinâmico

    adicionou regras no servidor de borda ou so esta na rb do hospot?

    blz fico no aguardo

  12. #12

    Padrão Re: hotspot + voip + controle de banda dinâmico

    Citação Postado originalmente por jailtonnetlink Ver Post
    adicionou regras no servidor de borda ou so esta na rb do hospot?

    blz fico no aguardo
    Só na do hotspot.. na verdade eu tenho uma 450G interligando os servidores e fazendo o papel roteador de borda, e pra frente vou seguindo meio quem em linha, todas com hotspots com radius, e é nelas que eu mando essas regras que postei acima. Tudo que é trafego do ip 172.29.255.2 é desviado para a queue tree, que está sem controle, tanto de up quanto de down, e assim o telefone sai fora do queue simple gerado automaticamente pela RB que foi enviado do servidor MK-Auth.

    Seria mais uma marcação de pacotes.. qualquer coisa avisa! valeu