+ Responder ao Tópico



  1. #1

    Padrão Rodar script de reboot se host externo parar de responder

    Ola a todos.
    recentemente ando enfrentando um problema em minha rede.

    possuo uma 750 que recebe o link do net virtua via dhcp cliente.
    ate ai tudo bem, so oque ocorre e que de vez em quando o virtua troca de ip, e o dhcp cliente do router não intende isso e não recebe o novo ip do virtua. Fica contando o tempo de expired time, so recebe o ip se eu der reboot na RB.

    Oque eu gostaria e de um script que monitorasse um host externo (tipo 8.8.8.8) e se não tivesse resposta, rodaria um reboot no sistema.

    tentei colocar esses

    /tool netwatch
    add disabled=no down-script=reboot host=8.8.8.8 interval=2m timeout=1s \
    up-script=""


    /system script
    add name=reboot policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="/system reboot"


    ate dar certo, se o host não responde ele reinicia, só que entra em um loop eterno de reboot na volta, (ele liga e em seguida ja reboot denovo, so para se resetar o equipamento.

    grato a todos pela atenção.

  2. #2

    Padrão Re: Rodar script de reboot se host externo parar de responder

    Coloca o script para ser executado de X em X tempo, de 5 em 5 minutos, por exemplo. Aí você não vai ter esse problema.

    Se ajudei, estrelinha pra mim!



  3. #3

    Padrão Re: Rodar script de reboot se host externo parar de responder

    Voce poderia me explicar qual script eu alteron o tempo?

    Já tentei alterar o tempo em /tool netwatch. O monitoramento funciona perfeitamente, se o hostil não responde ele roda o reboot. Só que quando reinicia ele volta a reboota a novamente num loop sem fim.
    tem que haver uma maneira de que quando reiniciar ele esperar os 5 min para monitorar o host novamente.

  4. #4

    Padrão Re: Rodar script de reboot se host externo parar de responder

    não vi \systen scheduler nas tuas regras ,á função do scheduler é essa .(marcar tempo para aplcar ás regras)



  5. #5

    Padrão Re: Rodar script de reboot se host externo parar de responder

    Citação Postado originalmente por tigreinformatica Ver Post
    não vi \systen scheduler nas tuas regras ,á função do sheduler é essa .(marcar tempo para aplcar ás regras)
    acho que e nisso que estou errando. Não sei como colocar o agendador para rodar o script. Teria como você mim dar uma forcinha para formular essas regras

  6. #6

    Padrão Re: Rodar script de reboot se host externo parar de responder

    /system scheduler
    add disabled=no interval=5m name=reboot on-event=reboot policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api start-date=apr/16/2001 start-time=04:10:44



  7. #7

    Padrão Re: Rodar script de reboot se host externo parar de responder

    só copiar e colar new terminal

  8. #8

    Padrão Re: Rodar script de reboot se host externo parar de responder

    Citação Postado originalmente por tigreinformatica Ver Post
    /system scheduler
    add disabled=no interval=5m name=reboot on-event=reboot policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api start-date=apr/16/2001 start-time=04:10:44
    Caro colega, essa regra agenda um reboot de 5 em 5 minutos, com ou sem link de internet no mk.
    A ideia é, só rebootar se o link cair.
    Ficoo grato por tentar me ajudar



  9. #9

    Padrão Re: Rodar script de reboot se host externo parar de responder

    mais facil ainda
    /system watchdog

  10. #10

    Padrão Re: Rodar script de reboot se host externo parar de responder

    Citação Postado originalmente por speedconnection Ver Post
    mais facil ainda
    /system watchdog

    Vou estudar um pouco a utilização dessa ferramenta.
    depois posto os resultados.



  11. #11

    Padrão Re: Rodar script de reboot se host externo parar de responder

    depois de monitorar por algum tempo meu servidor vi que quando o meu link da Net caia ou simplesmente o ip mudava, deixando sem conexão com a web. A ferramenta watchdog reiniciava a routeerboad, fazendo com que o dhcp cliente se renovasse.

    a regra utilizada foi esta

    /system watchdog
    set auto-send-supout=no automatic-supout=no no-ping-delay=5m watch-address=\
    8.8.8.8 watchdog-timer=yes

    grato pela ajuda, e adicionei * aos cooperadores

  12. #12

    Padrão Re: Rodar script de reboot se host externo parar de responder

    Citação Postado originalmente por Anderson28 Ver Post

    /system watchdog
    set auto-send-supout=no automatic-supout=no no-ping-delay=5m watch-address=\
    8.8.8.8 watchdog-timer=yes

    grato pela ajuda, e adicionei * aos cooperadores
    Amigo, a regra citada acima funcionou pra vc? a função "automatic-suport=no" não teria que ser "yes" ???

    estou ativando o watchdog em um ptp com netmetal5. se pararem de responder de um ponto ao outro por 5 minutos quero que seja rebootado.
    minha região é tensa, aconteceu dois travamentos em dias muito quentes. acredito que o watchdog me polpe de reboots manuais.

    att