+ Responder ao Tópico



  1. #1

    Cool Script Mikrotik copiar arquivo. Essa é Complicada

    Boa tarde, to com um projeto e preciso de ajuda dos dinossauros ai do mkt.

    tenho uma rb1100 (10.10.0.1) que gerencia o provedor, o restante das torres estao todas em bridge

    essa rb1100 faz bkp e manda por e-mail. As outras como nao tem net conf, nao pode mandar.

    Kero que a rb1100 (10.10.0.1) acesse a (10.10.0.2) e copie o bkp e salve na rb1100.

    Ai a rb1100 envia o bkp por e-mail,

    Ou seria melhor conf, net em todas as torres? tem como fazer isso em bridge??

    agradeco toda ajuda

  2. #2

    Padrão Re: Script Mikrotik copiar arquivo. Essa é Complicada

    amigo do jeito que voce quer acho qe é possivel, porem eu nao teria algo assim, mais tem qe ser apenas por e-mail mesmo? vc nao gostaria de fazer esses backups em um servidor, assim teria um controle melhor, usar uma maquina qql como um linux ou freebsd para isso, qql posso ajudar.



  3. #3

    Padrão Re: Script Mikrotik copiar arquivo. Essa é Complicada

    So colocar net nas outras rbs, é muito mais facil que oq vc quer!!!

  4. #4

    Padrão Re: Script Mikrotik copiar arquivo. Essa é Complicada

    Podemos desenvolver seu projeto contato leonardo[at]leonardocosta.com.br



  5. #5
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Script Mikrotik copiar arquivo. Essa é Complicada

    Bom dia,

    Crie um NAT na RB1100 apenas para o IP do servidor de email, assim fica mais restrito o acesso dessas RB à Internet.

    Abraço

  6. #6
    Suporte em Mikrotik Avatar de Genis
    Ingresso
    Nov 2006
    Localização
    INTERIOR-SP
    Posts
    1.591

    Padrão Re: Script Mikrotik copiar arquivo. Essa é Complicada

    instala o cobian no micro e configura ele pra entrar nas RB´s e baixar o backup para o seu micro, sem a necessidade de enviar por email.



  7. #7

    Padrão Re: Script Mikrotik copiar arquivo. Essa é Complicada

    Boa Noite amigos, muito obrigado pela ajuda, na rb110 ja tem nat, se eu mandar um ping ex globo.com pinga normal. Nela ja tenho configurado um script q cria bkp e manda por e-mail.
    Ja nas outras rb estao todas em bridge, sem nat. Tem como eu colocar elas na internet sem fazer nat????

    a forma que desejo fazer é, criar uma regra para copiar o arquivo de um rb para outra, só isso.. Porem nao tenho conhecimento tao avancado pra isso..

    Mais uma ves obrigado pela ajuda e disposicao de todos, segue meu msn se alguem quiser add pra ajudar: [email protected]

    Obs todos vao ganhar estrelinha, penso se estao me ajudando nao custa nada aumentar a reputacao, isso incentiva grande abracao

  8. #8
    Suporte em Mikrotik Avatar de Genis
    Ingresso
    Nov 2006
    Localização
    INTERIOR-SP
    Posts
    1.591

    Padrão Re: Script Mikrotik copiar arquivo. Essa é Complicada

    porque não usa o cobian, é gratuito e não precisa fazer nat.



  9. #9
    Lucas Costa
    Visitante

    Padrão Re: Script Mikrotik copiar arquivo. Essa é Complicada

    Olá amigo!!

    Sua brigde não precisa ter acesso à toda a internet, tampouco de NAT para enviar emails.

    Sugiro que crie na Bridge uma rota para o ip do servidor de email. Você indicará à bridge que para acessar o servidor de email ela deve usar a RB 1100, que por sua vez tem acesso à internet.

    Acesse IP>routes>"+"
    Em "Dst. Address" adicione o IP do seu servidor de email.
    Em "Gateway" adicione o IP da sua RB1100.

    Apply>OK



    O mesmo procedimento pode ser usado para configurar o cliente NTP para estas Bridges sem acesso à internet.

    Espero ter ajudado!

  10. #10

    Padrão Re: Script Mikrotik copiar arquivo. Essa é Complicada

    Citação Postado originalmente por Lucas Costa Ver Post
    Olá amigo!!

    Sua brigde não precisa ter acesso à toda a internet, tampouco de NAT para enviar emails.

    Sugiro que crie na Bridge uma rota para o ip do servidor de email. Você indicará à bridge que para acessar o servidor de email ela deve usar a RB 1100, que por sua vez tem acesso à internet.

    Acesse IP>routes>"+"
    Em "Dst. Address" adicione o IP do seu servidor de email.
    Em "Gateway" adicione o IP da sua RB1100.

    Apply>OK



    O mesmo procedimento pode ser usado para configurar o cliente NTP para estas Bridges sem acesso à internet.

    Espero ter ajudado!
    Concordo com o amigo, é a solução mais simples e inteligente.



  11. #11

    Cool Re: Script Mikrotik copiar arquivo. Essa é Complicada

    Citação Postado originalmente por ManoDW Ver Post
    Boa tarde, to com um projeto e preciso de ajuda dos dinossauros ai do mkt.

    tenho uma rb1100 (10.10.0.1) que gerencia o provedor, o restante das torres estao todas em bridge

    essa rb1100 faz bkp e manda por e-mail. As outras como nao tem net conf, nao pode mandar.

    Kero que a rb1100 (10.10.0.1) acesse a (10.10.0.2) e copie o bkp e salve na rb1100.

    Ai a rb1100 envia o bkp por e-mail,

    Ou seria melhor conf, net em todas as torres? tem como fazer isso em bridge??

    agradeco toda ajuda
    Salva o backup no 10.10.0.2
    Código :
    /system backup save name="BACKUP-10.10.0.2"

    Cria um script no servidor: 10.10.0.1

    Código :
    /tool fetch address="10.10.0.2" src-path="BACKUP-10.10.0.2.backup"  user="USUÁRIO" mode=ftp password="SENHA" dst-path="BACKUP-10.10.0.2.backup" port=21 host="" keep-result=yes
     
    /tool e-mail set address="smtp.live.com" port="587" from="SEU_EMAIL" user="SEU_EMAIL" password="SUA_SENHA"
     
    :delay 2s
     
    /tool e-mail send to="SEU_EMAIL"  subject="BACKUP-10.10.0.2"  body="BACKUP-10.10.0.2" file="BACKUP-10.10.0.2.backup" tls="yes"