+ Responder ao Tópico



  1. #1

    Padrão Load balance pcc ip fixo 3 links 10 mega = alguns sites demorando abrir

    Tenho um load q depois que montei de acordo com um video do youtube ,, ele funcionou , porem percebo que em alguns momentos os sites demoram a abrir ,, a rb é a 750 ,, os links sao dedicados , entao nao adianta dizer que a variação é dos links, uso assim 3/0 , 3/1 e 3/2 peer conection ... o que pode ser pessoal ... e outra informação ,, geralmente o que fica lento ´e o banner dos sites...

  2. #2

    Padrão Re: Load balance pcc ip fixo 3 links 10 mega = alguns sites demorando abrir

    Cara to com mesmo problema que você so que aqui uso apenas 2 links de 10mb cada.



  3. #3

    Padrão Re: Load balance pcc ip fixo 3 links 10 mega = alguns sites demorando abrir

    O problema é na bendita da OI liguei la pra reclamar e me falaram que estão fazendo um reparo de uma rede que esta dando problemas por isso o download esta lento.

    Só que tenho outra dúvida tipo em um download com uma ADSL de 10MB de um arquivo quando ele estiver baixando no limite de 1mbps, a outra ADSL de 10MB vai mandar mas 1mbps para o download ou apenas para um outro download de outro arquivo.



  4. #4

    Padrão Re: Load balance pcc ip fixo 3 links 10 mega = alguns sites demorando abrir

    Olá, amigo esse dias ajudei um cara que tava com o mesmo problema no loadbalance dele percebi logo no acesso via Teamviewer ficava lento demais e quando um link caía o outro não assumia o trafego, a configuração que tava lá era do vídeo que tem no youtube ai joguei meu backup na RB450G dele e pronto ficou tudo 100% ele mesmo disse que melhorou e no caso meu links são tudo em bridge tenho dedicado mas coloquei uma RB750 e criei um servidor PPPoE, entende ?



  5. #5

    Padrão Re: Load balance pcc ip fixo 3 links 10 mega = alguns sites demorando abrir

    Entendi amanha farei teste em bridge pra ver se tenho melhoras.

  6. #6

    Padrão Re: Load balance pcc ip fixo 3 links 10 mega = alguns sites demorando abrir

    Coloquei em modo bridge e fiz os testes em cada modem de velocidade todos atingiram suas respectivas velocidades de acordo como foi contratado, ou seja, 10MB agora quando faço load balance e não consigo atingir nem 600Kbps de download. Usei o programa PCC 1.5 para gerar o script.
    Alguém tem ideia do que seja.



  7. #7

    Padrão Re: Load balance pcc ip fixo 3 links 10 mega = alguns sites demorando abrir

    Veja se seus links tem a mesma Network e posta o arquivo de configuração txt para darmos uma olhada.

    Pois um amigo tava com o mesmo problema e só jogando o backup da configuração do meu loadbalance na RB loadbalance dele que ficou tudo 100% internet com muito mais velocidade pois ele fez isso também só mudou os modens de roteado para bridge e não adiantou nada tinha ficado a mesma coisa, fica a dica.
    Última edição por freitascs; 19-03-2013 às 21:22.

  8. #8

    Padrão Re: Load balance pcc ip fixo 3 links 10 mega = alguns sites demorando abrir

    Sim tem a mesma network.

    usei esse script gerado pelo PCC 1.5

    # ip address --------------------------
    /ip address add address=192.168.88.1/29 interface=


    # interface pppoe-client ---------------
    /interface pppoe-client add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface= max-mru=1480 max-mtu=1480 mrru=disabled name=adsl_ password=xxxxxxxx profile=default service-name="" use-peer-dns=no user=ACOS25243974
    /interface pppoe-client add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface= max-mru=1480 max-mtu=1480 mrru=disabled name=adsl_ password=xxxxxxxx profile=default service-name="" use-peer-dns=no user=ACOS24789898


    # ip dns --------------------------------
    /ip dns set primary-dns=8.8.8.8
    /ip dns set secondary-dns=8.8.4.4
    /ip dns set allow-remote-requests=yes




    # ip firewall Filter------------------------
    /ip firewall filter add action=drop chain=forward comment="BLOQUEIO DE DNS REVERSO" content=velox.user.com.br disabled=no
    /ip firewall filter add action=drop chain=forward comment="BLOQUEIO DE DNS REVERSO" content=speed.user.com.br disabled=no


    # ip firewall nat--------------------------
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=adsl_
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=adsl_


    # ip firewall mangle------------------------


    # LoopBack por link-------------------------
    / ip firewall mangle add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no dst-address-list=LINK0 in-interface= new-connection-mark=Sites0 passthrough=yes
    / ip firewall mangle add action=mark-routing chain=prerouting comment="" connection-mark=Sites0 disabled=no in-interface= new-routing-mark=Rota0 passthrough=no
    / ip route add gateway=adsl_ routing-mark=Rota0
    / ip firewall mangle add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no dst-address-list=LINK1 in-interface= new-connection-mark=Sites1 passthrough=yes
    / ip firewall mangle add action=mark-routing chain=prerouting comment="" connection-mark=Sites1 disabled=no in-interface= new-routing-mark=Rota1 passthrough=no
    / ip route add gateway=adsl_ routing-mark=Rota1


    /ip firewall address-list add address=200.155.80.0-200.155.255.255 comment="BRADESCO" disabled=no list=LINK0
    /ip firewall address-list add address=200.220.186.0/24 comment="" disabled=no list=LINK0
    /ip firewall address-list add address=200.220.178.0/24 comment="" disabled=no list=LINK0
    /ip firewall address-list add address=64.38.29.0/24 comment="RapidShare" disabled=no list=LINK1
    /ip firewall address-list add address=208.69.32.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=208.67.217.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=201.7.178.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=201.7.176.0/24 comment="" disabled=no list=LINK1
    # Fim LoopBack por link----------------------


    /ip firewall mangle add action=accept chain=prerouting comment="HTTPS FORA DO LOADBALACED" disabled=no protocol=tcp dst-port=443 in-interface=
    /ip firewall mangle add action=accept chain=prerouting comment="FORA DO LOADBALACED" disabled=no dst-address-list=loopback in-interface=
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=adsl_ new-connection-mark=adsl__conn passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=adsl_ new-connection-mark=adsl__conn passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=adsl__conn disabled=no new-routing-mark=to_adsl_ passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=adsl__conn disabled=no new-routing-mark=to_adsl_ passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface= new-connection-mark=adsl__conn passthrough=yes per-connection-classifier=both-addresses-and-ports:2/0
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface= new-connection-mark=adsl__conn passthrough=yes per-connection-classifier=both-addresses-and-ports:2/1
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=adsl__conn disabled=no in-interface= new-routing-mark=to_adsl_ passthrough=yes
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=adsl__conn disabled=no in-interface= new-routing-mark=to_adsl_ passthrough=yes


    # ip route----------------------------------
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=adsl_ routing-mark=to_adsl_ comment="Link0"
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=adsl_ routing-mark=to_adsl_ comment="Link1"
    /ip route add comment="Link0" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=adsl_ scope=30 target-scope=10
    /ip route add comment="Link1" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=adsl_ scope=30 target-scope=10


    # ip firewall address-list-----------------------------
    /ip firewall address-list add address=200.155.80.0-200.155.255.255 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=200.220.186.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=200.220.178.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=64.38.29.0/24 comment=RapidShare disabled=no list=loopback
    /ip firewall address-list add address=208.69.32.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=208.67.217.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=201.7.178.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=201.7.176.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.159.128.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=201.7.176.0/20 comment="Vídeos - Globo" disabled=no list=loopback
    /ip firewall address-list add address=208.84.247.0/24 comment="Vídeos - terratv" disabled=no list=loopback
    /ip firewall address-list add address=200.154.56.0/24 comment="Vídeos - terratv" disabled=no list=loopback
    /ip firewall address-list add address=200.201.160.0/24 comment="Caixa Economica Federal" disabled=no list=loopback
    /ip firewall address-list add address=200.201.166.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.201.173.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.201.174.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.141.207.3 comment=Detran disabled=no list=loopback


    # /system script--------------------------------------
    /system script add name=Link0Dow policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link0\"] disabled=yes;\r\ \n/ip firewall nat set [find comment=\"Link0\"] disabled=yes;\r\ \n/ip firewall mangle set [find comment=\"Link0\"] disabled=yes;\r\ \n/ip route set [find comment=\"Link0\"] disabled=yes;"
    /system script add name=Link1Dow policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link1\"] disabled=yes;\r\ \n/ip firewall nat set [find comment=\"Link1\"] disabled=yes;\r\ \n/ip firewall mangle set [find comment=\"Link1\"] disabled=yes;\r\ \n/ip route set [find comment=\"Link1\"] disabled=yes;"
    /system script add name=Link0Up policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link0\"] disabled=no;\r\ \n/ip firewall nat set [find comment=\"Link0\"] disabled=no;\r\ \n/ip firewall mangle set [find comment=\"Link0\"] disabled=no;\r\ \n/ip route set [find comment=\"Link0\"] disabled=no;"
    /system script add name=Link1Up policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link1\"] disabled=no;\r\ \n/ip firewall nat set [find comment=\"Link1\"] disabled=no;\r\ \n/ip firewall mangle set [find comment=\"Link1\"] disabled=no;\r\ \n/ip route set [find comment=\"Link1\"] disabled=no;"



  9. #9

    Padrão Re: Load balance pcc ip fixo 3 links 10 mega = alguns sites demorando abrir

    Então amigo não vai balancear os links da forma certa eles vão ficar sempre assim um vai puxar mais e o outro vai ficar quase sem usar mas se um link cair o outro vai assumir todo o trafego ai esse link que tava quase sem usar ele vai ter um trafego grande, você vai ter que arrumar um jeito que mudar a porta do seu link no armário ou mudar de armário pra poder o balaceamento ficar 100% da uma olhada no meu balance nesse momento passando 26Mbs.
    Clique na imagem para uma versão maior

Nome:	         loadbalance.jpg
Visualizações:	256
Tamanho: 	95,7 KB
ID:      	43525

  10. #10

    Padrão Re: Load balance pcc ip fixo 3 links 10 mega = alguns sites demorando abrir

    Como assim mudar portas ?



  11. #11

    Padrão Re: Load balance pcc ip fixo 3 links 10 mega = alguns sites demorando abrir

    Só os caras da empresa vão te explicar, o que eu sei é que eles botaram suas linhas em um porta que sai o mesmo link de 10Megas por isso não da trafego nos outros links pois é o mesmo link.
    Última edição por freitascs; 27-08-2013 às 18:58.

  12. #12

    Padrão Re: Load balance pcc ip fixo 3 links 10 mega = alguns sites demorando abrir

    Citação Postado originalmente por freitascs Ver Post
    Só os caras da empresa vai te explicar, o que eu sei é que ele botaram suas linhas em um porta que sai o mesmo link de 10Megas por isso não da trafego nos outros links pois é o mesmo link.
    Amigo estou com o mesmo problema de consumir apenas 2 links por vez e o terceiro fica praticamente sem consumo, os links variam hora consome linkA e B, hora consome link C e A ou C e B mas nunca os três simultaneamente, mas no meu caso tirei da rede da operadora e simulei em outra rede a mesma configuração, se puder dar uma olhada na configuração ela segue abaixo:



    /interface ethernet
    set 0 arp=enabled auto-negotiation=yes cable-settings=default comment="" \
    disable-running-check=yes disabled=no full-duplex=yes mac-address=\
    08:00:27:80:1F:37 mtu=1500 name=wlan1 speed=100Mbps
    set 1 arp=enabled auto-negotiation=yes cable-settings=default comment="" \
    disable-running-check=yes disabled=no full-duplex=yes mac-address=\
    08:00:27:F8:61:8B mtu=1500 name=wlan2 speed=100Mbps
    set 2 arp=enabled auto-negotiation=yes cable-settings=default comment="" \
    disable-running-check=yes disabled=no full-duplex=yes mac-address=\
    08:00:27:61:9F:43 mtu=1500 name=wlan3 speed=100Mbps
    set 3 arp=enabled auto-negotiation=yes cable-settings=default comment="" \
    disable-running-check=yes disabled=no full-duplex=yes mac-address=\
    08:00:27:02:36:77 mtu=1500 name=saida speed=100Mbps


    /interface pppoe-client
    add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 comment=\
    "===== Disca Link01 =====" dial-on-demand=no disabled=no interface=wlan1 \
    max-mru=1480 max-mtu=1480 mrru=disabled name=pppoe-wlan1 password=gvt25 \
    profile=default service-name=service1 use-peer-dns=no user=\
    [email protected]
    add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 comment=\
    "===== Disca Link02 =====" dial-on-demand=no disabled=no interface=wlan2 \
    max-mru=1480 max-mtu=1480 mrru=disabled name=pppoe-wlan2 password=gvt25 \
    profile=default service-name=service2 use-peer-dns=no user=\
    [email protected]
    add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 comment=\
    "===== Disca Link03 =====" dial-on-demand=no disabled=no interface=wlan3 \
    max-mru=1480 max-mtu=1480 mrru=disabled name=pppoe-wlan3 password=gvt25 \
    profile=default service-name=service3 use-peer-dns=no user=\
    [email protected]
    /ip dns
    set allow-remote-requests=yes cache-max-ttl=1w cache-size=20240KiB max-udp-packet-size=512 servers=\
    8.8.8.8,8.8.4.4


    /ip firewall nat
    add action=masquerade chain=srcnat comment="===== Masquerade Interfaces =====" disabled=no out-interface=\
    pppoe-wlan1
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=pppoe-wlan2
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=pppoe-wlan3




    /ip firewall mangle
    add action=accept chain=prerouting comment="FORA DO LOADBALACED" disabled=no dst-address-list=loopback \
    in-interface=saida
    add action=mark-connection chain=input comment="===== Faz o pacote sair pela msm interface =====" disabled=no \
    in-interface=pppoe-wlan1 new-connection-mark=wlan1_conn passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=wlan1_conn disabled=no new-routing-mark=\
    to_wlan1 passthrough=yes
    add action=mark-connection chain=input comment="" disabled=no in-interface=pppoe-wlan2 new-connection-mark=\
    wlan2_conn passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=wlan2_conn disabled=no new-routing-mark=\
    to_wlan2 passthrough=yes
    add action=mark-connection chain=input comment="" disabled=no in-interface=pppoe-wlan3 new-connection-mark=\
    wlan3_conn passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=wlan3_conn disabled=no new-routing-mark=\
    to_wlan3 passthrough=yes
    add action=mark-connection chain=prerouting comment="===== Balance_PCC =====" disabled=no dst-address-type=\
    !local in-interface=saida new-connection-mark=wlan1_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:3/0
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=saida \
    new-connection-mark=wlan2_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:3/1
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=saida \
    new-connection-mark=wlan3_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:3/2
    add action=mark-routing chain=prerouting comment="===== Marcando todos os pacotes =====" connection-mark=\
    wlan1_conn disabled=no in-interface=saida new-routing-mark=to_wlan1 passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=wlan2_conn disabled=no in-interface=saida \
    new-routing-mark=to_wlan2 passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=wlan3_conn disabled=no in-interface=saida \
    new-routing-mark=to_wlan3 passthrough=yes


    /ip route
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-wlan1 \
    routing-mark=to_wlan1 scope=30 target-scope=10
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-wlan2 \
    routing-mark=to_wlan2 scope=30 target-scope=10
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-wlan3 \
    routing-mark=to_wlan3 scope=30 target-scope=10
    add check-gateway=ping comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=pppoe-wlan2 scope=30 \
    target-scope=10
    add check-gateway=ping comment="" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=pppoe-wlan3 scope=30 \
    target-scope=10
    add check-gateway=ping comment="" disabled=no distance=4 dst-address=0.0.0.0/0 gateway=pppoe-wlan1 scope=30 \
    target-scope=10

    Tanto na saindo pela rede da operadora quanto em meu laboratório o consumo se dá apenas em 2 links por vez, no meu Lab uso 3 links diferentes, que entram em 3 routerboards diferentes e dessas 3 saem os links para meu Load.


    Grato pela ajuda.



  13. #13

    Padrão Re: Load balance pcc ip fixo 3 links 10 mega = alguns sites demorando abrir

    Jacksonvieira tenho quase 100% de certeza que seu problema é que seus links tem a mesma network e por isso não ta balanceando, verifique ai e me diga se confere a minha suspeita.

  14. #14

    Padrão Re: Load balance pcc ip fixo 3 links 10 mega = alguns sites demorando abrir

    Citação Postado originalmente por freitascs Ver Post
    Jacksonvieira tenho quase 100% de certeza que seu problema é que seus links tem a mesma network e por isso não ta balanceando, verifique ai e me diga se confere a minha suspeita.
    Boa tarde meu caro. Hoje eu tentei fazer o ballance PCC e tive os mesmos problemas dos amigos. Só navegava em um link de cada vez. Observei que o gateway dos dois links é o mesmo.
    Para resolver isto eu teria que colocar dois routers para autenticar o pppoe? E claro mudar a faixa de ip para cada um deles? Neste caso, no MK o gateway de cada uma das interfaces seriam os routers (com diferentes IPs). Eu estava pesquisando agora sobre o meu caso e o seu comentário parece me esclarecer o problema.
    Outra dúvida. Tem alguma indicação de roteador ou modem/roteador? São ADSLs de 10 Mbits, as velocidades chegam certinho, não tenho oscilação de velocidade. Mas não tenho certeza se os roteadores TPlink 741 que tenho aqui, irão se comportar bem. Atualmente estou com 14 usuários na rede. Mas já tenho certeza de outros 40 clientes, que estão apenas aguardando que eu finalize as preparações. E o correto balanceamento destes links é um ponto chave desta preparação.
    Muito obrigado. Conto com as suas e as observações de todos. Quanto mais informações, melhor.