+ Responder ao Tópico



  1. #1
    Pronto Para Ajudar!!! Avatar de mjmmarcus2
    Ingresso
    Jun 2012
    Localização
    Paulista Pernambuco
    Posts
    428

    Padrão Melhore o Desempenho de seu Cache no Mikrotik

    Olá pessoal!

    Todos nós sabemos que o Thunder cache é a melhor opção, mas para quem não tem o thunder cache, pode continuar lendo.

    Observando o cache vi que dava para ele segurar mais arquivos e deixar a internet melhor e estabilizada.

    Criei essa regra para levar instruções para o Mikrotik segurar melhor os tipos de arquivos conhecidos como: jpg, png, js, gif, css... Em fim adicionei 89 Tipos de arquivos diferentes e populares para servir uma melhora na internet.

    Veja a imagem: (Mostra que a regra está funcionando!).

    Clique na imagem para uma versão maior

Nome:	         Sistema de cache melhorado.jpg
Visualizações:	1611
Tamanho: 	73,2 KB
ID:      	37791

    Adicionei tipos de arquivos importantes:
    1°) Atualizações de antivírus (Avira, Avast, Eset, Norton, Kapersky, e outros...)
    2°) Windows update
    3º) Complementos Firefox e Chome
    4°) Aplicativos para Tablet
    5°) Arquivos de Imagens, vídeo, áudio, de todos os tipos
    6º) Outras extensões de arquivos populares adicionados

    Agora vamos à regra:
    Regra para versão 5.xx: Melhore seu Cache Mikrotick 5.xx.txt
    Regra para versão 2.xx: Melhore seu Cache Mikrotick 2.xx.txt
    Última edição por mjmmarcus2; 05-06-2015 às 10:46. Razão: Links Atualizados

  2. #2

    Padrão re: Melhore o Desempenho de seu Cache no Mikrotik

    Cachear cacheia, o problema é devolver isso ao cliente, pois o cache do mikrotik não trata arquivos dinamicos!!



  3. #3
    Pronto Para Ajudar!!! Avatar de mjmmarcus2
    Ingresso
    Jun 2012
    Localização
    Paulista Pernambuco
    Posts
    428

    Padrão re: Melhore o Desempenho de seu Cache no Mikrotik

    Citação Postado originalmente por rogeriodj Ver Post
    Cachear cacheia, o problema é devolver isso ao cliente, pois o cache do mikrotik não trata arquivos dinamicos!!
    Não tenho problemas com isto, uso esta regra para ele não registrar arquivos dinâmicos, veja este tópico:
    https://under-linux.org/f211/cache-f...30/#post631916

    Lembrando que arquivos dinâmicos, é muito dificil ser baixado duas vezes pelos clientes, só perde para vídeos do youtube, mas trabalhamos como podemos, isto é para quem tem poucos clientes funciona beleza.
    Última edição por mjmmarcus2; 02-08-2012 às 23:38.

  4. #4

    Padrão Re: Melhore o Desempenho de seu Cache no Mikrotik

    Bom dia mjmmarcus2, tranquilo ?

    Cara, estava lendo seu topico e achei muito interessante, mas, estou na versão 5.4 do MK e não uso HotSpot, só PPPOE mesmo. Tenho balance em PCC funcionando 100%.

    Habilitei o cache aqui seguindo algumas dicas que encontrei na net. Em menos de 24hs o uso do meu HD no MK subiu mais de 10GB, ou seja, na minha opinião, estava armazenando "lixo" e lotando o HD.

    Por esse motivo, eu gostaria de trocar umas idéias c/ você, tipo, rever minhas regras, ver o que você acha do meu cenário aqui, essas coisas. "Uma mão lava a outra" kkkkkkkkkkkk...

    msn: [email protected]

    Bom, agradeço.



  5. #5
    Pronto Para Ajudar!!! Avatar de mjmmarcus2
    Ingresso
    Jun 2012
    Localização
    Paulista Pernambuco
    Posts
    428

    Padrão Re: Melhore o Desempenho de seu Cache no Mikrotik

    Citação Postado originalmente por FabianoMartins2 Ver Post
    Bom dia mjmmarcus2, tranquilo ?
    Cara, estava lendo seu topico e achei muito inter.....
    Veja este tópico
    https://under-linux.org/f211/cache-f...30/#post631916

  6. #6

    Padrão Re: Melhore o Desempenho de seu Cache no Mikrotik

    tem outro detalhe, essas regex ai, elevam o cpu da placa !!! e podem adicionar um pequeno delay nas requisições...



  7. #7

    Padrão Re: Melhore o Desempenho de seu Cache no Mikrotik

    meu caro "mjmmarcus2" não estou conseguindo fazer meu cache mikrotik funcionar, vou postar minhas regras pra alguem que puder me ajudar e me dizer o q tem de errado com elas: me digam tbm se tem que ter alguma regra no firewall/filter

    uso mikrotik versão 5.19 com hotspot.

    /ip proxy
    set always-from-cache=yes cache-administrator=webmaster cache-hit-dscp=4 cache-on-disk=yes enabled=yes max-cache-size=unlimited \
    max-client-connections=600 max-fresh-time=3d max-server-connections=600 parent-proxy=0.0.0.0 parent-proxy-port=0 port=\
    3128 serialize-connections=no src-address=0.0.0.0

    /ip proxy access
    add action=allow comment="Portas Para MSN" disabled=no dst-port=1025-65535
    add action=deny disabled=no path=*ADSAdClient31.dll* redirect-to=www.mkinfor.net/geronimo/msn.html
    add action=deny comment="allow CONNECT only to SSL ports 443 [https] and 563 [snews]" disabled=no dst-port=!443,563 \
    method=CONNECT
    add action=deny disabled=no path=*ork.user* redirect-to=www.mkinfor.net/geronimo/orkut.html
    add action=deny comment="block telnet & spam e-mail relaying" disabled=no dst-port=23-25

    /ip proxy cache
    add action=deny disabled=no dst-host=":cgi-bin \\\?"
    add action=deny disabled=no dst-host=https: path=/
    add action=allow disabled=no dst-host=http: path=/www.rjnet.com.br/2velocimetro.php
    add action=allow disabled=no dst-host=http: path=/www.terra.com.br
    add action=deny disabled=no dst-host=":cgi-bin \\\\\\\?"
    add action=deny disabled=no dst-host=https: path=/
    add action=allow disabled=no dst-host=http: path=/www.rapidus.com.br/velocidade/
    add action=allow disabled=no dst-host=http: path=/www.bol.com.br
    add action=allow disabled=no dst-host=http: path=/www.orkut.com
    add action=allow disabled=no dst-host=http: path=/www.autonoma.com.br/medidor/meter.php
    add action=allow disabled=no dst-host=http: path=/medidor.brisanet.com.br/
    add action=deny disabled=no dst-host=https: path=/portal.directv.com.br
    add action=deny disabled=no dst-host=http: path=/chat03.terra.com.br/
    add action=allow disabled=no dst-host=http*youtube*get_video*
    add action=allow disabled=no dst-host=http*youtube*video*
    add action=allow disabled=no dst-host="http*youtube*yva_get_video_inf o*"
    add action=allow disabled=no dst-host="\":\\\\\\\\.flv\$\""
    add action=allow disabled=no dst-host=http*globo*get_video*
    add action=allow disabled=no dst-host=http*globo*video*
    add action=allow disabled=no dst-host=http*googlevideo*get_video*
    add action=allow disabled=no dst-host=http*googlevideo*video*
    add action=allow disabled=no dst-host=http*video.google*get_video*
    add action=allow disabled=no dst-host=http*video.google*video*
    add action=allow disabled=no dst-host=http*videoplay*
    add action=allow disabled=no dst-host=http*74.125.15.83*get_video*
    add action=allow disabled=no dst-host=: path=:.swf*


    /ip firewall nat
    #REGRAS CRIADAS AUTOMATICAMENTO COM O HOTSPOT e abiaxo delas segue:
    add action=masquerade chain=srcnat comment="NAT - default configuration" disabled=no out-interface=INTERNET
    add action=redirect chain=dstnat comment="Proxy Transparente - Clientes" disabled=no dst-port=80 protocol=tcp \
    src-address=10.10.0.0/16 to-ports=3128

    /ip firewall mangle
    add action=mark-connection chain=output comment="2-PROXY FULL" disabled=no dscp=4 new-connection-mark=proxyfull \
    passthrough=yes protocol=tcp src-port=3128
    add action=mark-packet chain=output connection-mark=proxyfull disabled=no new-packet-mark=proxyfull passthrough=yes
    add action=return chain=output connection-mark=proxyfull disabled=no


    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=3M max-limit=3M name="2 - CACHE-FULL" \
    packet-mark=proxyfull parent=global-out priority=1 queue=default

    ***

  8. #8
    Pronto Para Ajudar!!! Avatar de mjmmarcus2
    Ingresso
    Jun 2012
    Localização
    Paulista Pernambuco
    Posts
    428

    Padrão Re: Melhore o Desempenho de seu Cache no Mikrotik

    Olá amigo, nosso companheiro alexandrecorrea criou um tópico especial para fazer o cache full rodar passo a passo.

    Veja o link:
    https://under-linux.org/f211/cache-f...emplos-102203/



  9. #9

    Padrão Re: Melhore o Desempenho de seu Cache no Mikrotik

    Citação Postado originalmente por eriksonricarte Ver Post
    meu caro "mjmmarcus2" não estou conseguindo fazer meu cache mikrotik funcionar, vou postar minhas regras pra alguem que puder me ajudar e me dizer o q tem de errado com elas: me digam tbm se tem que ter alguma regra no firewall/filter

    uso mikrotik versão 5.19 com hotspot.

    /ip proxy
    set always-from-cache=yes cache-administrator=webmaster cache-hit-dscp=4 cache-on-disk=yes enabled=yes max-cache-size=unlimited \
    max-client-connections=600 max-fresh-time=3d max-server-connections=600 parent-proxy=0.0.0.0 parent-proxy-port=0 port=\
    3128 serialize-connections=no src-address=0.0.0.0

    /ip proxy access
    add action=allow comment="Portas Para MSN" disabled=no dst-port=1025-65535
    add action=deny disabled=no path=*ADSAdClient31.dll* redirect-to=www.mkinfor.net/geronimo/msn.html
    add action=deny comment="allow CONNECT only to SSL ports 443 [https] and 563 [snews]" disabled=no dst-port=!443,563 \
    method=CONNECT
    add action=deny disabled=no path=*ork.user* redirect-to=www.mkinfor.net/geronimo/orkut.html
    add action=deny comment="block telnet & spam e-mail relaying" disabled=no dst-port=23-25

    /ip proxy cache
    add action=deny disabled=no dst-host=":cgi-bin \\\?"
    add action=deny disabled=no dst-host=https: path=/
    add action=allow disabled=no dst-host=http: path=/www.rjnet.com.br/2velocimetro.php
    add action=allow disabled=no dst-host=http: path=/www.terra.com.br
    add action=deny disabled=no dst-host=":cgi-bin \\\\\\\?"
    add action=deny disabled=no dst-host=https: path=/
    add action=allow disabled=no dst-host=http: path=/www.rapidus.com.br/velocidade/
    add action=allow disabled=no dst-host=http: path=/www.bol.com.br
    add action=allow disabled=no dst-host=http: path=/www.orkut.com
    add action=allow disabled=no dst-host=http: path=/www.autonoma.com.br/medidor/meter.php
    add action=allow disabled=no dst-host=http: path=/medidor.brisanet.com.br/
    add action=deny disabled=no dst-host=https: path=/portal.directv.com.br
    add action=deny disabled=no dst-host=http: path=/chat03.terra.com.br/
    add action=allow disabled=no dst-host=http*youtube*get_video*
    add action=allow disabled=no dst-host=http*youtube*video*
    add action=allow disabled=no dst-host="http*youtube*yva_get_video_inf o*"
    add action=allow disabled=no dst-host="\":\\\\\\\\.flv\$\""
    add action=allow disabled=no dst-host=http*globo*get_video*
    add action=allow disabled=no dst-host=http*globo*video*
    add action=allow disabled=no dst-host=http*googlevideo*get_video*
    add action=allow disabled=no dst-host=http*googlevideo*video*
    add action=allow disabled=no dst-host=http*video.google*get_video*
    add action=allow disabled=no dst-host=http*video.google*video*
    add action=allow disabled=no dst-host=http*videoplay*
    add action=allow disabled=no dst-host=http*74.125.15.83*get_video*
    add action=allow disabled=no dst-host=: path=:.swf*


    /ip firewall nat
    #REGRAS CRIADAS AUTOMATICAMENTO COM O HOTSPOT e abiaxo delas segue:
    add action=masquerade chain=srcnat comment="NAT - default configuration" disabled=no out-interface=INTERNET
    add action=redirect chain=dstnat comment="Proxy Transparente - Clientes" disabled=no dst-port=80 protocol=tcp \
    src-address=10.10.0.0/16 to-ports=3128

    /ip firewall mangle
    add action=mark-connection chain=output comment="2-PROXY FULL" disabled=no dscp=4 new-connection-mark=proxyfull \
    passthrough=yes protocol=tcp src-port=3128
    add action=mark-packet chain=output connection-mark=proxyfull disabled=no new-packet-mark=proxyfull passthrough=yes
    add action=return chain=output connection-mark=proxyfull disabled=no


    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=3M max-limit=3M name="2 - CACHE-FULL" \
    packet-mark=proxyfull parent=global-out priority=1 queue=default

    ***
    Amigo seu erro ta aki no que ta grifado em vermelho ok
    Vc ta marcando a conexão com um nome e informando outro nome na marcação do pacote ai realmente nao vai funcionar.
    Caso corriga e mesmo assim nao funcione adicione na marcação da conexão o
    "X-Cache: HIT" em content ok.
    Faça as correções e poste os resultados pra gente ok

  10. #10

    Padrão Re: Melhore o Desempenho de seu Cache no Mikrotik

    Amigao, me ajuda ae! vcs teriam regras para usar meu cache so pra paginas SUPER SIMPLES? sem video nem nada que passe de 5 megas!!!!!!!??????


    HELP ta meu POST
    https://under-linux.org/showthread.p...731#post667731



  11. #11

    Padrão Re: Melhore o Desempenho de seu Cache no Mikrotik

    ola mjmmarcus pode me ajudar também com essas regras?

    meu email é [email protected]


    Obrigado