Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Vejam bem, tudo que foi recomendado já foi testado, inclusive uso cabos da UBNT com conectores aterrados, com fonte original, com fonte alternativa.. e conclui que este problema é recorrente (com poucas incidências, mas existem). Com swcthi isso quase não existe mas ainda sim acontece.

    O script é apenas um alerta que me avisará quando interface entrar em modo 10Mbps, não é resolver o problema, é apenas para alarmar por email que o problema esta ocorrendo, e demandar um ajuste mais preciso...

    Até eletroduto de carbono eu já usei para se ter uma idéia. Mas vez ou outra o problema acontece. Já testei com PathPanel com cabo de 100 pares.

    Este é um problema e pronto. E o problema não é na iface do mikrotik, e sim na iface do Rocket. Pois só conectar e desconectar que volta a funcionar normalmente, continuo investigando as possíveis causas. Tanto em ambientes moderados como em ambientes hostis onde tenho torre.

    Mas no momento antes de encontrar uma solução eu preciso monitorar as interfaces... Alguém pode me ajudar ai?

  2. Segue uma dica:

    /tool netwatch

    add comment="Testa Comunicacao com Ubnt" disabled=no down-script="/interface e\
    thernet disable ether3-ubnt;\r\
    \n:log error \"INTERFACE UBNT PERDENDO PACOTE ESTA SENDO DESATIVADA\";\r\
    \n\r\
    \n/interface ethernet enable ether3-ubnt;\r\
    \n:log warning \"INTERFACE UBNT ATIVADA\";" host=3.3.3.3 interval=1m \
    timeout=1s up-script=""

    Instrução:
    host=3.3.3.3 ---> coloque o Ip do seu equipamento ligado ao mikrotik
    ether3-ubnt ---> Coloque o nome da interface mikrotik a ser testada

    Raciocinio:
    Quando a sua situação fica em estado critico. A latência aumenta. Nesta hora desabilitamos, jogamos uma mensagem no Log em vermelho.
    Apos, Habilitamos e jogamos outra mensagem no Log em azul.
    Manipule o Timeout conforme a sua necessidade.

    Atendendo essa sua necessidade, fazemos com que seja enviada por email.

    Espero que lhe ajude.



  3. Essa solução caro interhome não se aplica a minha necessidade. O que pretendo é identificar a velocidade da iface e não se ela esta ou não on-line.

  4. Começando a desvendar a coisa, até aqui conseguimos identificar qual o rate da interface, mas ainda não é oq eu desejo.. estamos chegando lá. No script abaixo tenho que setar individualmente cada interface que desejo monitorar, no entanto como vou usar o script em diversas rbs preciso que ele seja genérico, que identifica as ifaces, varra as mesmas e encontrando as com rate 10 mande um email.

    :global u
    /interface ethernet monitor ether1, ether2 once do={ :set u $rate }
    :if ($u = "10Mbps") do={
    :log error message="interface LAN esta em 10Mbits"
    /tool e-mail send subject="Interface em 10Mbis" to=suporte@zunet.com.br body="interface LAN esta em 10Mbits" tls=yes
    }



  5. Citação Postado originalmente por mauriciodelima Ver Post
    Essa solução caro interhome não se aplica a minha necessidade. O que pretendo é identificar a velocidade da iface e não se ela esta ou não on-line.
    Infelismente o Sr. não entendeu o raciocinio proposto.
    Conselho: Coloque na sua Rb que o mesmo funcionará como "anjo da guarda" fazendo com que haja uma nova negociação na interface que esta perdendo pacotes.
    De qualquer forma espero que no ao menos agradeça. Segue abaixo o seu serviço finalizado. Caso necessite de alguma melhoria, estou a disposição.
    #Script ETHERNET-Check v0.1
    #
    #Lista as ethernet que estao com velocidades negociadas igual u (10Mbps)
    #
    # Autor: Andre Andrade <dragaodragao@hotmail.com>
    # 15/08/2012 - 23:25pm
    #
    #Instrucoes de uso:
    # -- Adicionar o codigo completo em SYSTEM >> SCRIPTS
    # -- Por padrao o script nao vai derrubar nenhuma interface.
    # -- O script pode ser executado pelo botao "run script" ou via linha de comando.
    # "/ system script run <nome do script>
    # -- Testado nas versoes 5.13
    #
    #Informacoes:
    #
    #Variavel u -> valor que sera usado para rastreamento entre as interfaces ATIVAS.


    :global v
    :foreach i in=[ /interface ethernet find running] do={
    :local intname [ / interface ethernet get $i name ];
    :log warning (" Interface: " . $intname);
    /interface ethernet monitor $intname once do={ :set v $rate }
    :if ($v = "10Mbps") do={
    :log error message="interface LAN esta em 10Mbits";
    /tool e-mail send subject="Interface em 10Mbis" to=suporte@PROVEDOR.com.br body="interface LAN esta em 10Mbits" tls=yes
    };
    };






Tópicos Similares

  1. Respostas: 9
    Último Post: 26-08-2016, 11:20
  2. Respostas: 0
    Último Post: 15-12-2014, 13:01
  3. Respostas: 1
    Último Post: 02-12-2013, 16:53
  4. Respostas: 2
    Último Post: 19-08-2009, 08:47
  5. Respostas: 3
    Último Post: 03-07-2009, 07:35

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L