Primeiramente muito obrigado interhome, pelo empenho e no resultado do excelente trabalho. Abaixo dei uma pinceladinha no script para dar uma melhoramento estético e funcional na informação.

#Script ETHERNET-Check v0.2
#
#Lista as ethernet que estao com velocidades negociadas igual u (10Mbps)
#
# Autor: Andre Andrade <dragaodragao@hotmail.com>
# 15/08/2012 - 23:25pm
#Colaborador Maurício de lima <tiomol@hotmail.com>
#20/08/2012 - 10:52am
#
#Instrucoes de uso:
# -- Adicionar o codigo completo em SYSTEM >> SCRIPTS
# -- Por padrao o script nao vai derrubar nenhuma interface.
# -- O script pode ser executado pelo botao "run script" ou via linha de comando.
# "/ system script run <nome do script>
# -- Testado nas versoes 5.13
#
#Informacoes:
#
#Variável v -> valor que sera usado para rastreamento entre as interfaces ATIVAS.




:global v
:global data [/system clock get date]
:global hora [/system clock get time]
:global host [/system identity get name]
:foreach i in=[ /interface ethernet find running] do={
:local intname [ / interface ethernet get $i name ];
#:log warning (" Interface: " . $intname);




/interface ethernet monitor $intname once do={ :set v $rate }
:if ($v = "10Mbps") do={
:log error message="interface $intname esta em 10Mbps";
/tool e-mail send subject="Interface em 10Mbps em $host em $data ($hora)" to=suporte@PROVEDOR.com.br body="Corrigir interface LAN ($intname) que esta em 10Mbits" tls=yes
};
};
O email esta chegando beleza, porém chega 1 email para cada interface listada com 10 mbps, e talvez fosse mais interessante se colocássemos para enviar um único email e no body listasse todas as iterfaces com problema, mas isso é o de menos. No resto ficou show de bola demais.