+ Responder ao Tópico



  1. #1

    Lightbulb Duas entradas e duas saidas com RouterBoard 750

    Acabei de comprar um RouterBOARD 750 para fazer balanceamento de carga. Agora me surgiu uma outra demanda para o produto.
    Preciso fazer o seguinte:

    / Link 1 - 200.200.200.200
    Entrada:
    \ Link 2 - 200.200.200.190

    / Link 1 - 192.168.0.1
    Saida:
    \ Link 2 - 192.168.1.0

    Pegar tudo que entra no link 1 e jogar para a saida do link 1
    Pegar tudo que entra no link 2 e jogar para a saida do link 2

    Eu consigo fazer isso usando este aparelho?

    Grato por qualquer ajuda...

  2. #2
    Analista de Suporte em TI Avatar de demattos
    Ingresso
    Jul 2011
    Localização
    Criciuma/SC
    Posts
    1.923
    Posts de Blog
    3

    Padrão Re: Duas entradas e duas saidas com RouterBoard 750

    Seria uma rota para cada link com dois gateway diferentes, vc pode estar usando este tutorial http://mikrotikfacilnet.blogspot.com...-gateways.html , neste caso balancendo pela origem



  3. #3

    Padrão Re: Duas entradas e duas saidas com RouterBoard 750

    amigo nao tenho esperiencia nao, mas acho que assim nao funciona.

    vc tem q usar assim

    LINK1
    LINK2

    entram na RB750 e sai em determinada porta. vc pode colocar link entrando nas portas 1,2,3,4 e saindo a porta 5

    e vc joga em outra RB p/ administrar pois nao entra 2 links em uma RB, e nela mesma sai esses 2 link, isso nao da.

    da p/ vc ligar a saida em um rotiador comum mas ai a rb nao fara nada alem de balancear os links.

    me corrijam se nao for isso rs pos é isso que tenho em mente.

  4. #4
    Analista de Suporte em TI Avatar de demattos
    Ingresso
    Jul 2011
    Localização
    Criciuma/SC
    Posts
    1.923
    Posts de Blog
    3

    Padrão Re: Duas entradas e duas saidas com RouterBoard 750

    Citação Postado originalmente por medeiros64 Ver Post
    amigo nao tenho esperiencia nao, mas acho que assim nao funciona.

    vc tem q usar assim

    LINK1
    LINK2

    entram na RB750 e sai em determinada porta. vc pode colocar link entrando nas portas 1,2,3,4 e saindo a porta 5

    e vc joga em outra RB p/ administrar pois nao entra 2 links em uma RB, e nela mesma sai esses 2 link, isso nao da.

    da p/ vc ligar a saida em um rotiador comum mas ai a rb nao fara nada alem de balancear os links.

    me corrijam se nao for isso rs pos é isso que tenho em mente.

    Claro que da amigo, o tutorial que foi passado esta explicando isto, dois gateway um para cada link, assim vc faz balanceamento pela origem, usando a tabela de roteamento, eu acho o balanceamento mais eficiente que existe por que vc elege a rota que vc quer e vc pode determinar por qual rota um servico especifico pode sair.



  5. #5
    Avatar de Djaldair
    Ingresso
    Mar 2012
    Localização
    Matupá - MT
    Posts
    637
    Posts de Blog
    2

    Padrão Re: Duas entradas e duas saidas com RouterBoard 750

    Parece que do jeito que ele pediu não é balance, é só criar duas bridge com dois gateway diferentes.

  6. #6

    Padrão Re: Duas entradas e duas saidas com RouterBoard 750

    Citação Postado originalmente por marcioerli Ver Post
    Acabei de comprar um RouterBOARD 750 para fazer balanceamento de carga. Agora me surgiu uma outra demanda para o produto.
    Preciso fazer o seguinte:

    / Link 1 - 200.200.200.200
    Entrada:
    \ Link 2 - 200.200.200.190

    / Link 1 - 192.168.0.1
    Saida:
    \ Link 2 - 192.168.1.0

    Pegar tudo que entra no link 1 e jogar para a saida do link 1
    Pegar tudo que entra no link 2 e jogar para a saida do link 2

    Eu consigo fazer isso usando este aparelho?

    Grato por qualquer ajuda...
    Exemplo:


    Interface


    Rede ip - 192.168.0.1/24
    Link1 ip - 10.10.10.1/24
    Link2 ip - 20.20.20.1/24


    regras:


    Aonde está os xxx você coloca a faixa de ip que você esta usando, funciona mais ou menos assim, os pedidos que virem dos ips 192.168.2.1 até o ip 192.168.2.254
    vão sé rederecioando para o gateway que você escoler.




    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="GrupA" disabled=no new-routing-mark=GrupA passthrough=no src-address=xxx.xxx.xxx.xxx-xxx.xxx.xxx.xxx




    add action=mark-routing chain=prerouting comment="GrupB" disabled=no new-routing-mark=GrupB passthrough=no src-address=xxx.xxx.xxx.xxx-xxx.xxx.xxx.xxx






    /ip route
    add comment=GrupA disabled=no dst-address=0.0.0.0/0 gateway=xxx.xxx.xx.129 routing-mark=GrupA scope=255 target-scope=10


    add comment=GrupB disabled=no dst-address=0.0.0.0/0 gateway=xxx.xxx.xx.137 routing-mark=GrupoB scope=255 target-scope=10






    /system script
    add name=link1-on policy=ftp,reboot,read,write,policy,test,winbox,password,sniff source="/ip route {set [find comment=GrupA] gateway=xxx.xxx.xx.129 }"


    add name=link1-off policy=ftp,reboot,read,write,policy,test,winbox,password,sniff source="/ip route {set [find comment=GrupA] gateway=xxx.xxx.xx.137 }"


    add name=link2-on policy=ftp,reboot,read,write,policy,test,winbox,password,sniff source="/ip route {set [find comment=GrupB] gateway=xxx.xxx.xx.137 }"


    add name=link2-off policy=ftp,reboot,read,write,policy,test,winbox,password,sniff source="/ip route {set [find comment=GrupB] gateway=xxx.xxx.xx.129 }"



    /tool netwatch
    add comment="Rota - Grupo A" disabled=no down-script=link1-off host=xxx.xxx.xx.129 interval=5m timeout=1s up-script=link1-on


    add comment="Rota - Grupo B" disabled=no down-script=link2-off host=xxx.xxx.xx.137 interval=5m timeout=1s up-script=link2-on