+ Responder ao Tópico



  1. #1

    Padrão VPN Matriz Filial usando 2 RB MK + PPTP

    Olá pessoal

    Fiz uma ligação entre a Matriz e a filial da empresa utilizando 1 rb em cada ponta.
    A empresa possui IP Profissional, o que facilitou muito.
    A conexão se estabelece, consigo pingar as maquinas por IP, acessar documentos (pelo compartilhamento do windows).
    Só que a rede não resolve o hostname de uma maquina que se encontra na outra ponta.
    Nem mesmo de dentro de uma RB, pingando o Hostname de uma maquina que se encontra na outra ponta, atras da outra, consigo que ele resolva.
    Segue topologia.

    Matriz

    IP Interno - 192.168.1.0/24 (fazendo DHCP localmente)
    IP VPN - 10.1.1.1


    Filial

    IP Interno - 192.168.2.0/24 (fazendo DHCP localmente)
    IP VPN - 10.1.1.2
    Route / Dst Address - 192.168.1.0/24 Gateway - 10.1.1.1


    Alguem pode ajudar ?
    Desde já agradeço qualquer ajuda.

    Abraços

  2. #2
    tecnico chefe Avatar de naldo864
    Ingresso
    May 2010
    Localização
    Carapicuíba, Brazil, Brazil
    Posts
    3.104
    Posts de Blog
    1

    Padrão Re: VPN Matriz Filial usando 2 RB MK + PPTP

    as redes das filiais são redes em faixas diferentes uma não vai enchergar a outra e normal.



  3. #3

    Padrão Re: VPN Matriz Filial usando 2 RB MK + PPTP

    Ok, até ai eu entendi Naldo.
    Mais a duvida ficou, assim como eu direciono rota de requisição, tem como fazer o direcionamento para um servidor dns apenas da minha rede local ?
    Ou, tem alguma outra forma de fazer o dns da rede local funcionar enxergando todas as filiais e vice versa ?

    Eu pesquisei aqui no forum e em outros materiais na internet e vi varias referencias sobre direcionar wins, dns, criar bridge e uma interface em ppp.
    Mais nenhuma das soluções, pelo menos as que encontrei, se mostraram acertadas.
    Última edição por Dimas; 06-11-2012 às 22:49.

  4. #4
    tecnico chefe Avatar de naldo864
    Ingresso
    May 2010
    Localização
    Carapicuíba, Brazil, Brazil
    Posts
    3.104
    Posts de Blog
    1

    Padrão Re: VPN Matriz Filial usando 2 RB MK + PPTP

    se todas as maquinas estiverem na mesma rede e so configurar elas para o dns .
    voce pode configuarar o dns manualmente maquina por maquina ou atraves de dhcp.



  5. #5
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: VPN Matriz Filial usando 2 RB MK + PPTP

    Citação Postado originalmente por Dimas Ver Post
    Olá pessoal

    Fiz uma ligação entre a Matriz e a filial da empresa utilizando 1 rb em cada ponta.
    A empresa possui IP Profissional, o que facilitou muito.
    A conexão se estabelece, consigo pingar as maquinas por IP, acessar documentos (pelo compartilhamento do windows).
    Só que a rede não resolve o hostname de uma maquina que se encontra na outra ponta.
    Nem mesmo de dentro de uma RB, pingando o Hostname de uma maquina que se encontra na outra ponta, atras da outra, consigo que ele resolva.
    Segue topologia.

    Matriz

    IP Interno - 192.168.1.0/24 (fazendo DHCP localmente)
    IP VPN - 10.1.1.1


    Filial

    IP Interno - 192.168.2.0/24 (fazendo DHCP localmente)
    IP VPN - 10.1.1.2
    Route / Dst Address - 192.168.1.0/24 Gateway - 10.1.1.1


    Alguem pode ajudar ?
    Desde já agradeço qualquer ajuda.

    Abraços
    Bom dia,

    A internet da filial sai pela Matriz também?

    Configure no DHCP da filial para entregar o DNS da Matriz. Isso vai fazer com que as máquinas da filial resolvam os nomes da Matriz. Para que a matriz resolva também, a solução mais simples pode ser o cadastro manual dos computadores da filial, no servidor DNS da Matriz.

    Abraço

  6. #6

    Padrão Re: VPN Matriz Filial usando 2 RB MK + PPTP

    se todas as maquinas estiverem na mesma rede e so configurar elas para o dns .
    voce pode configuarar o dns manualmente maquina por maquina ou atraves de dhcp.
    Bom dai Naldo,
    Também pensei nessa possibilidade, de segmentar uma faixa de IP, mais ai vem a questão, como são lojas distantes geograficamente, se eu segmentar a faixa por mascara e atribuir a RB para que ela distribua a faixa localmente, eu terei o mesmo problema de utilizar faixas distintas.

    Se eu configurar o DNS manualmente nas rb, vou ter que travar os IP's tbm perdendo a funcionalidade do DHCP o que me seria muito util no dia-a-dia.


    A internet da filial sai pela Matriz também?

    Configure no DHCP da filial para entregar o DNS da Matriz. Isso vai fazer com que as máquinas da filial resolvam os nomes da Matriz. Para que a matriz resolva também, a solução mais simples pode ser o cadastro manual dos computadores da filial, no servidor DNS da Matriz.
    Bom dia Gamineiro,

    Cada loja possui sua internet, utilizando apenas a VPN para acesso a um modulo do sistema de ERP que se faz necessario para emissão da NFE.
    Até ai tudo OK.
    O problema é que o sistema aponta para a impressora nas filiais e utiliza algumas pastas, atraves da VPN.
    E tem limitações quanto a utilização de IP's, se faz necessário o Hostname.



    Fazendo alguns testes hoje, notei que mesmo a rb local, não pinga as maquinas que ela mesma atribuiu IP por DHCP.
    Dai veio o estranho, o Traceroute, encontra e a alcança pelo hostname, mais pelo terminal, não consigo pingar a mesma pelo hostname.

    Desde já agradeço pela colaboração.

    Att.

    Dimas



  7. #7
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: VPN Matriz Filial usando 2 RB MK + PPTP

    Mande-nos a saída do comando:

    Código :
    /ip dhcp-server export

  8. #8

    Padrão Re: VPN Matriz Filial usando 2 RB MK + PPTP

    Matriz

    Código :
    # nov/07/2012 09:27:08 by RouterOS 5.19
    # software id = XXXX-XXXX
    #
    /ip dhcp-server
    add address-pool=dhcp_pool1 authoritative=after-2sec-delay bootp-support=\
        static disabled=no interface=Switch lease-time=3d name=dhcp1
    /ip dhcp-server config
    set store-leases-disk=5m
    /ip dhcp-server lease
    add address=192.168.1.95 client-id=1:0:e0:52:bd:74:9f disabled=no mac-address=\
        00:E0:52:BD:74:9F server=dhcp1
        ntp-server="" wins-server=""
    add address=192.168.1.0/24 dhcp-option="" dns-server="" gateway=192.168.1.101 \
        ntp-server="" wins-server=""


    Filial

    Código :
    # jan/02/1970 00:19:48 by RouterOS 5.16
    # software id = XXXX-XXXX
    #
    /ip dhcp-server
    add address-pool=dhcp_pool1 authoritative=after-2sec-delay bootp-support=\
        static disabled=no interface=Switch lease-time=3d name=dhcp1
    add address-pool=dhcp_pool2 authoritative=after-2sec-delay bootp-support=\
        static disabled=no interface=ether1 lease-time=3d name=dhcp2
    /ip dhcp-server config
    set store-leases-disk=5m
    /ip dhcp-server network
    add address=192.168.2.0/24 dhcp-option="" dns-server="" gateway=192.168.2.101 \
        ntp-server="" wins-server=""
    Última edição por Dimas; 07-11-2012 às 12:25. Razão: mascaramento de software id



  9. #9
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: VPN Matriz Filial usando 2 RB MK + PPTP

    Você não está setando o dns-server na configuração do DHCP. Se existe algum DNS interno, adicione o IP dele ali, caso não possua, tente utilizar o IP do próprio servidor DHCP.

  10. #10

    Padrão Re: VPN Matriz Filial usando 2 RB MK + PPTP

    Setando o IP para o meu dns interno ou para o DHCP local ou para o DHCP da outra RB, o problema persiste.

    Estou estranhando porque esta permitindo ao traceroute resolver e o ping não.
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         traceroute.jpg
Visualizações:	100
Tamanho: 	66,5 KB
ID:      	40350  



  11. #11

    Padrão Re: VPN Matriz Filial usando 2 RB MK + PPTP

    Bom dia a todos, aproveitando o topico, estou c/ uma situação semelhante aqui. A diferença é que aqui são duas lojas ligas por uma VPN dentro da rede do provedor.

    Vou explicar melhor, quando digo "dentro da rede do provedor", quero dizer que as duas lojas usam internet do provedor, são clientes do nosso provedor. Aí no concentrador principal do provedor, habilitei o PPTP e criei os usuários no Secrets e tambem fiz as rotas p/ as duas lojas se enxergarem.

    Aí em cada uma das loja, coloquei um RB c/ mikrotik p/ conectar a vpn e tambem fornecer ip p/ as maquinas por DHCP. Até aí tudo bem, tá funcionando blzinha, unico detalhe é que só consigo acessar um PC de uma loja pra outra, pelo IP da maquina, não consigo pelo nome do host e nem pelo grupo de trabalho.

    Segue config DHCP da RB Loja1:
    /ip dhcp-server
    add address-pool=dhcp_loja1 authoritative=after-2sec-delay bootp-support=static \
    disabled=no interface=bridge1 lease-time=3d name=server1_loja1
    /ip dhcp-server config
    set store-leases-disk=5m
    /ip dhcp-server network
    add address=192.168.0.0/24 dhcp-option="" dns-server=192.168.0.1 gateway=\
    192.168.0.1 netmask=24 ntp-server="" wins-server=""
    [[email protected]_Roteamento_Loja1] /ip dhcp-server>

    Config DHCP Loja2:
    /ip dhcp-server
    add address-pool=dhcp_loja1 authoritative=after-2sec-delay bootp-support=static \
    disabled=no interface=bridge1 lease-time=3d name=server1_loja1
    /ip dhcp-server config
    set store-leases-disk=5m
    /ip dhcp-server network
    add address=192.168.2.0/24 dhcp-option="" dns-server=192.168.2.1 gateway=\
    192.168.2.1 netmask=24 ntp-server="" wins-server=""
    [[email protected]_Roteamento_Loja2] /ip dhcp-server>


    Desde já agradeço.

  12. #12
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: VPN Matriz Filial usando 2 RB MK + PPTP

    Normalmente esse tipo de necessidade é unilateral. Os computadores das filiais precisam acessar servidores da Matriz pelo nome. Isso é facilmente resolvido com um servidor DNS na Matriz com o DHCP integrado. Na filial você atribui o DNS das máquinas com o IP do servidor DNS da Matriz.

    Caso necessite acessar algo na filial por nome, crie uma entrada manual no servidor DNS da matriz. Um exemplo seria uma impressora de rede na filial, onde usuários da matriz precisam imprimir nela. Crie um nome qualquer com o IP da impressora. No momento de criar a fila de impressão, pode usar o nome DNS.

    O DHCP do RouterOS não é tão maduro ao ponto de fazer uma integração com o DNS. Mas existe um script[1] que pode te ajudar muito.

    Abraço


    [1] http://wiki.mikrotik.com/wiki/Settin...ach_DHCP_lease



  13. #13

    Padrão Re: VPN Matriz Filial usando 2 RB MK + PPTP

    Obrigado por responde amigão.

    Quer dizer que, por exemplo, como tenho um concentrador principal que gerencia todo o provedor, posso cetar o IP dele nas configurações DNS dos PC's da filial, + ou - isso ?

    Abraço...

  14. #14
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: VPN Matriz Filial usando 2 RB MK + PPTP

    Citação Postado originalmente por FabianoMartins2 Ver Post
    Obrigado por responde amigão.

    Quer dizer que, por exemplo, como tenho um concentrador principal que gerencia todo o provedor, posso cetar o IP dele nas configurações DNS dos PC's da filial, + ou - isso ?

    Abraço...
    Nesse caso você vai misturar a rede do provedor com a rede do cliente. Eu te sugiro que crie a VPN entre os roteadores do cliente, usando a rede do provedor apenas para prover a interconexão entre os dois sites. Então você seta o DNS da filial com o IP do DNS da matriz.

    Você até pode usar o IP do seu roteador, já que ele está fazendo a VPN, mas não é uma prática aconselhável.

    Abraço



  15. #15

    Padrão Re: VPN Matriz Filial usando 2 RB MK + PPTP

    Entendi. É que nesse caso, o cliente que é a Loja 2 tambem usa internet do provedor, como um cliente mesmo, por isso achei que podia usar o concentrador principal p/ resolver o DNS das duas lojas, como ambas estão na rede do provedor.

    Mas sua dica já me ajudou amigão, agradeço pela força.