Página 3 de 4 PrimeiroPrimeiro 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #41

    Padrão Re: Controle de Download

    Me dê ai uma luz, vi que as suas regras são de grande valia, mais me dê uma ajuda.
    Gostaria que os meus clientes navegassem livre, mais somente quando fossem fazer downloads ficassem com 300kbps, poderia me indicar uma regra para tal necessidade.

    Desde já agradeço !

  2. #42

    Padrão Re: Controle de Download

    Citação Postado originalmente por armim Ver Post
    Me dê ai uma luz, vi que as suas regras são de grande valia, mais me dê uma ajuda.
    Gostaria que os meus clientes navegassem livre, mais somente quando fossem fazer downloads ficassem com 300kbps, poderia me indicar uma regra para tal necessidade.

    Desde já agradeço !
    Nesse caso, com uma unica RB você consegue fazer isso.

    - Não crie controle de banda individual para cada cliente.
    - Apenas aplique as regras que postei, modifique-as conforme a necessidade.



  3. #43

    Padrão Re: Controle de Download

    Boa Noite AndrioPJ, a algum tempo utilizava esse QoS perfeitamente porque usava uma RB pra balance e outra para concentrador, só que decidi colocar cliente e balance na mesma RB, como e como não tem mais como colocar a QoS entre balance e concentrador coloquei depois do concentrador, mas não está funcionando. Você pode me ajudar?

  4. #44

    Padrão Re: Controle de Download

    Citação Postado originalmente por AndrioPJ Ver Post
    Os Clientes de diversas Operadoras, mesmo tendo 2, 3, 5 ou 10 Megas... algumas vezes não conseguem fazer download na velocidade máxima dele.
    Sendo necessário abrir 2, 3 ou mais downloads e somar a taxa de transferência para se ter a velocidade máxima.

    Hoje vou ensinar como implementar um controle de Download igual a esses que as Operadoras fazem.

    ### CENÁRIO:
    Esse controle de banda avançado é um QoS, sendo assim, não podemos aplica-lo no mesmo servidor que faz controle de banda dos clientes.
    Logo, essa regra somente irá funcionar na rede daqueles que tem um servidor central, mas fazem a autenticação (e controle de banda) dos clientes na RB mais próxima.
    Anexo 42314

    ### REGRAS (Firewall, Queue):
    Essa Regra deve ser adicionada no ROUTER 1

    /ip firewall mangle
    add action=mark-packet chain=forward comment=ControleDownloadAPJ connection-bytes=3000000-0 disabled=no new-packet-mark=3mb-0-conn passthrough=yes protocol=tcp
    add action=mark-packet chain=forward connection-bytes=3000000-0 disabled=no new-packet-mark=3mb-0-conn passthrough=yes protocol=udp

    /queue type
    add kind=pcq name=ControleDownloadAPJ pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=src-address,dst-address pcq-dst-address-mask=32 pcq-dst-address6-mask=64 pcq-limit=50 pcq-rate=512k pcq-src-address-mask=32 pcq-src-address6-mask=64 pcq-total-limit=5000

    /queue simple
    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both disabled=yes interface=all limit-at=0/0 max-limit=0/0 name=ControleDownloadAPJ packet-marks=3mb-0-conn parent=none priority=8 queue=default-small/ControleDownloadAPJ target-addresses=1xx.xx.xxx.0/24 time=17h-23h59m59s,sun,mon,tue,wed,thu,fri,sat total-queue=default-small

    ### COMO FUNCIONA:
    Com as regras acima, um cliente que possua 3 Mega de velocidade, se fizer um teste de velocidade, irá ter a velocidade máxima dele (3 Mega).

    Mas, quando esse cliente fizer um ou mais download, após ter baixado 3mb (connection-bytes). Cada download dele irá entrar no controle de banda avançado do ROUTER1 e sua velocidade de download vai baixar para 512k (pcq-rate).
    Sendo o limite máximo da banda dele o que estiver no Router2, que no caso desse cliente seria de 3 Mega.

    Em outras palavras.
    Um cliente que possua 3 megas de Velocidade, sem essas regras, precisaria fazer 1 ÚNICO download para usar 100% de sua banda.
    Já com essas Regras, o cliente precisaria fazer 6 downloads para usar 100% de sua banda.

    Exemplo:
    Download SEM a Regra - 1 Único download é suficiente para o cliente utilizar 100% de sua banda.
    Anexo 42315

    Download COM a Regra - Mesmo realizando 2 download, não foi o suficiente para o cliente utilizar 100% de sua banda.
    Anexo 42316

    ### ADAPTAÇÃO
    - Podemos fazer com que apenas alguns Clientes passem por essa regra.
    - Podemos fazer com que somente o download de alguns sites específicos passe por essa regra.
    - Podemos fazer com que esse controle funcione em determinado dia da semana ou hora.
    - Podemos fazer com que Diferentes tipos de Planos seja necessário fazer quantidades diferentes de download para atingir 100% da velocidade.

    connection-bytes - Tamanho do download que o Cliente poderá fazer antes de entrar no Controle (default da regra 3mb).
    pcq-rate - velocidade máxima (default da regra 512k) atingida após o cliente ter feito download acima.
    target-addresses - Faixa de IP que será controlada.
    time - Horário de funcionamento da regra

    Enfim, podemos adaptar essas regras para os mais variados tipos.
    Amigo gostei muito dessas regras gostaria que vc as configurassem para mim. ...me passe seu contato para combinarmos. Meu email [email protected]



  5. #45

    Padrão Re: Controle de Download

    Ola cara essa sua regra é muito top sou novo na área, começando estudar mikrotik agora eu tenho uma RB750 - configurei a faixa de IP: 192.168.2.1/24 na ether3 em PPOE, depois coloquei uma antena da ubiquiti em Bridge e nela só coloquei o IP: 192.168.2.3 - depois conectei a outra via PPOE com login e senha.

    minha duvida é se coloquei a bridge do modo correto, a outra antena se conectou, la no active connection quando o cara se conectar consigo ver que ele ta logado, espero que eu tenha feito tudo certo, achei estranho pq só coloquei o ip na bridge o ppoe serve só para os clientes se conectarem é isso para um melhor controle ? ou minha bridge esta correta.



    sobre sua regra o meu controle de banda é no queue, eu posso retirar todos os IP e setar somente sua regra em minha RB750?

  6. #46

    Padrão Re: Controle de Download

    Olá @AndrioPJ e @agatangelos ! tudo bem?
    Sei que faz tempo que ninguém movimenta o tópico, mas gostaria de saber se você @agatangelos conseguiu fazer funcionar as regras apresentadas no tópico em bridge e se vocês ainda usam estas regras, claro que adaptadas aos dias de hoje que exigem muito mais banda!

    Obrigado!

    Atenciosamente

    Juliano



  7. #47

    Padrão Re: Controle de Download

    Caro Colega infelizmente nunca consegui fazer elas funcionarem 100% por falta de tempo, de conhecimento e até por falta de dinheiro, pois na época não conseguia comprar uma outra rb para fazer de laboratório e não tinha como testa-las na minha rede ativa, pois os clientes não são cobaias, descobri na pela que não tem como se implantar uma novidade sem testa-las antes, nosso amigo Andrio rodava ela e outros colegas conseguiram mas no meu atua cenário não tenho mais como usa-las pois meus clientes são muito exigentes e consomem 100% da banda contratada, clientes que jogam, com acesso remoto, programadores, engenheiros técnicos em ti, tenho clientes de netflix que assistem filmes em 4k e exigem o melhor da conexão então hoje não faço qualquer tipo de controle ou limite a não ser a contratada no plano, faço assim pois hoje em dia os valores são bem mais acessíveis para mim em relação a link e para ser um diferencial entre as empresas da cidade ... Um grande abraço ... Rodrigo

  8. #48

    Padrão Re: Controle de Download

    Reacendendo o tópico que é muito interessante e de grande aprendizado.
    De fato para muitos esse controle não é viável dependendo do ponto de vista, mas ainda assim é uma forma engenhosa de oferecer valores altos de link, e mante qualidade.
    Falo assim porque a dias venho estudando este post e junto a ele comparando serviços de algumas operadoras como a net e live tim que vendem altos valores em megas para seus assinantes, mas que mantem diferentes tipos de controle para não existir uma saturação.

    Então amigo Andrio, se possível atenda o meu pedido e mostre como configurar o Mikrotik de Nº 1 para que deixe passar alguns users fora do controle já que estarão cadastrados somente no Mikrotik de Nº 2 , talvez vc já tenha mostrado e eu não tenha entendido, mas já fiz de tudo e não consigo fazer essa divisão.

    Obrigado



  9. #49

    Padrão Re: Controle de Download

    Hehe... Deixa o pessoal começar a usar a firmware do simet ou até mesmo o roteador do simet e abrir um chamado na anatel explicando o caso... Quero só ver!

    Gente o marco civil estabelece a neutralidade da rede, isto é, sem intervenção do ISP. Fazer isso é crime, quem diz isso não sou eu, claro se usado no provedor, para usar dentro de rede do cliente como objetivo de dividir melhor a banda do cliente eu até acho válido.

    Fica a dica.

    Enviado via XT1563 usando UnderLinux App

  10. #50

    Padrão Re: Controle de Download

    Citação Postado originalmente por claro se usado no provedor, para usar dentro de rede do cliente como objetivo de dividir melhor a banda do cliente eu até acho válido.

    Fica a dica.

    Enviado via XT1563 usando [URL="http://r.tapatalk.com/byo?rid=88519"
    UnderLinux App[/URL]
    Ninguém aqui tá pensando em fazer diferente da proposta do tópico e essa parte do seu comentário, que se analisar por ai é justamente o que andam fazendo as grandes operadoras como a live Tim e outras (DIVIDIR MELHOR A BANDA DO CLIENTE) de modo que nem ele mesmo se afogue. Quanto ao resto que citou é dispensável e não acrescentou nada.

    Obrigado.



  11. #51

    Padrão Re: Controle de Download

    Citação Postado originalmente por sergiofsm Ver Post
    Ninguém aqui tá pensando em fazer diferente da proposta do tópico e essa parte do seu comentário, que se analisar por ai é justamente o que andam fazendo as grandes operadoras como a live Tim e outras (DIVIDIR MELHOR A BANDA DO CLIENTE) de modo que nem ele mesmo se afogue. Quanto ao resto que citou é dispensável e não acrescentou nada.

    Obrigado.
    Vamos lá meu irmão, quem decide como a internet tem que funciona não são os usuários do under-linux.

    Segundo se outros fazem ou deixam de fazer não é argumento que dê o direito a alguém fazer TAMBÉM.

    Terceiro dispensável são os comentários que logo saem na defesa de gente que quer sacanear seus clientes, por favor, o cliente tem o direito de usar a internet como ele quiser, mesmo sem saber o que está fazendo de errado, se estiver pagando. O provedor do ten que se preocupar em entregar conectividade de boa qualidade, sem interferir como é distribuída a banda dentro das dependências dos seus clientes.

    É cada um que aparece aqui....

    Enviado via XT1563 usando UnderLinux App

  12. #52

    Padrão Re: Controle de Download

    Ok Amigo, bons pensamentos para vc, leia o tópico desde o inicio e tente entender melhor a proposta antes de criticar, Sobre aparecer aqui, reveja melhor seu tempo de inscrito e o meu, entenda que postar por postar quando não acrescentará nada não faz sentido e por isto não saio falando atoa para ganhar medalhas. Não pedi nada a vc, muito menos aula do que vc pensa ou deixa de pensar, então não seja pobre de espirito ao ponto de tentar incomodar se não for ajudar.



  13. #53

    Padrão Re: Controle de Download

    sergiofsm, boa tarde, tenho as regras funcionando em minha rede, adaptei as minhas necessidades pois tinha que funcionar em apenas uma rb, não vou postá-las aqui pois estou no trabalho neste momento, quando estiver em casa a noite te mando.

  14. #54

    Padrão Re: Controle de Download

    Citação Postado originalmente por makabeus Ver Post
    sergiofsm, boa tarde, tenho as regras funcionando em minha rede, adaptei as minhas necessidades pois tinha que funcionar em apenas uma rb, não vou postá-las aqui pois estou no trabalho neste momento, quando estiver em casa a noite te mando.
    Boa Tarde makabeus, fico grato se me ajudar nessa empreitada, Aguardo e lhe agradeço, como também agradeço ao autor do tópico pelo trabalho.



  15. #55

    Padrão Re: Controle de Download

    Pessoal, os dois parecem ter razão, dependendo de como se vê a coisa. Sob a ótica de recursos é válido, mas sob a ótica da legislação é arriscado.

    O tópico é do tempo que Marco Civil não existia... hoje a coisa mudou e precisamos rever nossos conceitos para se adaptar a nova realidade.
    Eu mesmo usava Burst e paramos para evitar problemas, apesar de que o burst não era para bitolar mas para dar algo a mais além do contratado. Mas vicia o cliente.

    É bom saber como fazer, mas daí a aplicar num provedor hoje tem que pensar muitas vezes. Que cada um corra um risco calculado.

  16. #56

    Padrão Re: Controle de Download

    Que bom ter novas opiniões quando elas não vem somente pelo lado negativo. Mas tbm pelo lado positivo.
    Seguinte, para deixar mais claro o que pretendo a principio e justamente testar.
    Usar dessa técnica o lado positivo, dar aos clientes um diferencial, exemplo clientes com 1M receber 2M mas ter somente sua banda contratada quando baixarem arquivos maiores e alem disso navegar sem problemas.



    Também fiz uso do Burst, mas a proposta aqui é outra, repartir a sobra entre os clientes. Justamente porque tenho link sobrando e pretendo fazer que meus usuários os receba para que essa sobra não seja pagos em vão.

    Agradeço cada opinião... mas s
    e me permitem, quero fazer este teste a favor dos clientes e não contra, porque se der certo de algum modo o retorno sempre virá.

    Dar o que nos sobra e mostrar qualidade nunca é de mais.

    Abraços



  17. #57

    Padrão Re: Controle de Download

    Já tentou mudar o tipo de fila de pacote para SFQ?

    esse tipo até onde sei, equaliza os pacotes de uma forma onde apenas uma aplicação ou cliente não ocupe sozinho a banda ( assim ocasionando a lentidão para os demais), assim se cliente fizer download e tentar navegar ao mesmo tempo, vai conseguir normal.

    Pode fazer na a partir do CPE do cliente, apenas para testar.

  18. #58

    Padrão Re: Controle de Download

    Citação Postado originalmente por 1929 Ver Post
    Pessoal, os dois parecem ter razão, dependendo de como se vê a coisa. Sob a ótica de recursos é válido, mas sob a ótica da legislação é arriscado.

    O tópico é do tempo que Marco Civil não existia... hoje a coisa mudou e precisamos rever nossos conceitos para se adaptar a nova realidade.
    Eu mesmo usava Burst e paramos para evitar problemas, apesar de que o burst não era para bitolar mas para dar algo a mais além do contratado. Mas vicia o cliente.

    É bom saber como fazer, mas daí a aplicar num provedor hoje tem que pensar muitas vezes. Que cada um corra um risco calculado.
    Quando eu crescer quero ser igual você mano! Quero ter principalmente seu talento para escolher as palavras!

    Mas sobre o assunto, é isso que estava me referindo, saber como fazer é importante, mas nem sempre pode ser a melhor escolha.

    Sobre as imposições que o marco civil nos trouxe, nada impede que a gente mime o cliente com banda a mais, só que é tudo uma questão de estratégia, vejam só, como eu uso accel-ppp nos meus clientes, tenho mais classes para gerenciar a banda contratada, e a gente combinou o seguinte, os cliente tem a banda contratada e 3x a mais de banda para tudo aquilo que for acessado dentro do domínio do provedor, isso gera algo excelente, quando o cliente acessa o DNS ele sempre tem mais banda, e quando usa isso não usa nada da banda contratada para qualquer acesso para fora dos domínios do provedor, a navegação fica extremamente rápida porque os pacotes UDP/53 sempre são recebido e devolvidos de forma rápida, e para o suporte descobrir falhas fica muito fácil, pois quando o cliente está estourando a banda o pessoal sempre consegue acessar o CPE, claro, de dentro da rede de suporte do provedor!



  19. #59

    Padrão Re: Controle de Download

    Sim, é justamente o que uso e confesso que funciona bem, Mas como estou em codomínio fechado sem ter mais a quem atender no local e ainda com link de sobra que ficaria mais caro diminui-los pela oferta que tenho do montante, decidi repassa-los a estes clientes sem mencionar aumento de velocidade, mas dando-lhes a sobra e controlando seus valores para não sobrecarregar a sim mesmos, como também me dando folgas quando as vezes um da casa usa toda a banda e o outro não consegue navegar.
    Creio desse modo não esta infringindo leis, nem contra os clientes, nem por desejar saber como fazer. Por isso a ideia é do tópico e bem vinda no meu ponto de vista e necessidades.

    Ainda assim lhe agradeço pela sugestão.

  20. #60

    Padrão Re: Controle de Download

    sergiofsm, como prometi tai as regras, só explicando de antemão que estou em um condominio com link dedicado de 15 MB, 30 usuários na rede interna. Estas regras foram feitas pra equalizar o uso entre os usuários dispondo de poucos recursos, está implementado em uma rb 450g versão 6.32

    /ip firewall mangle




    add action=mark-packet chain=forward connection-bytes=1000001-0 \
    dst-address-list=!allow-bit new-packet-mark=dpkt-u1 passthrough=no out-interface=ether1 \
    time=17h59m59s-23h59m59s,sun,mon,tue,wed,thu,fri,sat


    add action=mark-packet chain=forward connection-bytes=2000001-0 \
    dst-address-list=!allow-bit new-packet-mark=dpkt-u2 passthrough=no out-interface=ether1 \
    time=0s-17h59m58s,sun,mon,tue,wed,thu,fri,sat




    /ip firewall mangle


    add action=mark-packet chain=forward connection-bytes=6000001-20000000 \
    dst-address-list=!allow-bit in-interface=ether1 new-packet-mark=dpkt-d1 passthrough=no time=\
    0s-17h59m58s,sun,mon,tue,wed,thu,fri,sat


    add action=mark-packet chain=forward connection-bytes=20000001-40000000 \
    dst-address-list=!allow-bit in-interface=ether1 new-packet-mark=dpkt-d2 passthrough=no time=\
    0s-17h59m58s,sun,mon,tue,wed,thu,fri,sat


    add action=mark-packet chain=forward connection-bytes=40000001-0 \
    dst-address-list=!allow-bit in-interface=ether1 new-packet-mark=dpkt-d3 passthrough=no time=\
    0s-17h59m58s,sun,mon,tue,wed,thu,fri,sat




    /ip firewall mangle


    add action=mark-packet chain=forward connection-bytes=4000001-16000000 \
    dst-address-list=!allow-bit in-interface=ether1 new-packet-mark=dpkt-d1 passthrough=no time=\
    17h59m59s-23h59m59s,sun,mon,tue,wed,thu,fri,sat


    add action=mark-packet chain=forward connection-bytes=16000001-30000000 \
    dst-address-list=!allow-bit in-interface=ether1 new-packet-mark=dpkt-d2 passthrough=no time=\
    17h59m59s-23h59m59s,sun,mon,tue,wed,thu,fri,sat


    add action=mark-packet chain=forward connection-bytes=30000001-0 \
    dst-address-list=!allow-bit in-interface=ether1 new-packet-mark=dpkt-d3 passthrough=no time=\
    17h59m59s-23h59m59s,sun,mon,tue,wed,thu,fri,sat




    /queue simple
    add name=Down-3 packet-marks=dpkt-d3 priority=7/7 target=ether1 time=\
    0s-23h59m59s,sun,mon,tue,wed,thu,fri,sat total-queue=down-3
    add name=Down-2 packet-marks=dpkt-d2 priority=6/6 target=ether1 time=\
    0s-1d,sun,mon,tue,wed,thu,fri,sat total-queue=down-2
    add name=Down-1 packet-marks=dpkt-d1 priority=5/5 target=ether1 time=\
    0s-1d,sun,mon,tue,wed,thu,fri,sat total-queue=down-1
    add max-limit=2M/2M name=Up-1 packet-marks=dpkt-u1 priority=6/6 target=ether1 \
    time=0s-1d,sun,mon,tue,wed,thu,fri,sat total-queue=up-1
    add max-limit=2M/2M name=Up-2 packet-marks=dpkt-u2 priority=6/6 target=ether1 \
    total-queue=up-2


    /queue type
    set 2 sfq-allot=1500 sfq-perturb=10
    set 4 kind=pfifo
    add kind=pcq name=up-1 pcq-burst-time=1m35s pcq-classifier=src-address \
    pcq-rate=100k
    add kind=pcq name=down-2 pcq-burst-time=56s pcq-classifier=dst-address \
    pcq-limit=100 pcq-rate=500k
    add kind=pcq name=down-3 pcq-classifier=dst-address pcq-limit=100 pcq-rate=\
    400k
    add kind=pcq name=down-1 pcq-burst-time=56s pcq-classifier=dst-address \
    pcq-limit=100 pcq-rate=600k pcq-total-limit=4k
    add kind=pcq name=up-2 pcq-burst-time=1m35s pcq-classifier=src-address \
    pcq-rate=200k