Página 5 de 5 PrimeiroPrimeiro 12345
+ Responder ao Tópico



  1. Citação Postado originalmente por mascaraapj Ver Post
    Quando temos um balance, cada requisição de Entrada por alguma das WAN, acaba saindo pela Mesma WAN.
    O balanceamento de fato somente é feito em cima do trafego de saida (cliente > WAN).
    Cada requisição do "cliente" é balanceada entre os Links (WAN) Existentes.

    No Balance Peplink, quando você utiliza o modo drop-in... você consegue fazer com que cada cliente tenha um IP publico.
    Sendo que esse IP publico somente vai funcionar se durante o balanceamento de trafego, acabar saindo pela WAN1.
    Caso saia pelas demais WAN, então é feito um NAT.

    Acesse o link do site do Peplink e veja o funcionamento dele.
    Tem até um video mostrando...

    Perfeito isso que eu entendi.
    Acho que dá pra ser feito sim.

  2. Olá, amigo tenho uma duvida no caso aqui no provedor tenho mais uma RB antes do load que recebe o cabo do roteador do link dedicado e nela tenho um servidor pppoe que joga pro loadbalance que disca o link dedicado em pppoe e também alguns cliente que precisam de link dedicado e ip valido.

    No caso eu tenho que fazer essa regra também nessa RB antes do loadbalance ?


    disabled=no distance=1 dst-address=ip ou faixa desejada gateway=ip do route \
    scope=30 target-scope=10
    Ou se eu fosse usar essa outra regra no lugar da de cima.

    chain=srcnat action=netmap to-addresses=ip_publico protocol=tcp src-address=ip_do_router
    chain=dstnat action=netmap to-addresses=ip_do_router protocol=tcp dst-address=_ip_publico in-interface=ether_link



  3. Citação Postado originalmente por raus Ver Post
    Pessoal, boa noite! Andava meio sumido, ralando de mais chegava em casa acabava querendo apenas descansar.
    Há tempos venho cometendo erro, de nao estudar mais sobre o sistema. coisa que nem pode acontecer.
    Me deparei com uma situação meio complicada... alguem poderia me da uma luz, de como entregar ip valido depois do Load? andei dando uma pesquisada antes de postar aqui, mas nao algo para estudo. (posso ter cometido alguma falha mais...) grato a todos vcs, melhor do final de semana pra gente
    Apesar do tópico fazer um tempão é uma questão interessante para quem utiliza balance e têm ips válidos, pessoalmente utilizo assim:

    X Links ---->> Balance ------>>>> Concentrador

    No NAT do Link onde tenho os IPs válidos faço uma exceção para o bloco de ips válidos, crio uma address list com esses ips válidos, adiciono uma regra de markrouting especifica para o gateway de saída dos ips válidos, observando a ordem dessa regra que deve estar a cima das demais regras de markrouting.

    add action=mark-routing chain=prerouting comment=\
    "Marcadores de Rota - Excecao IPs Validos" in-interface=clientes \
    new-routing-mark=to_wlan1 passthrough=no src-address-list="Rota IPs Validos"

    Basicamente é isso, nunca tive problemas com essas regras, utilizo em todos meus clientes que têm esse cenário.

  4. Citação Postado originalmente por jacksonvieira Ver Post
    Apesar do tópico fazer um tempão é uma questão interessante para quem utiliza balance e têm ips válidos, pessoalmente utilizo assim:

    X Links ---->> Balance ------>>>> Concentrador

    No NAT do Link onde tenho os IPs válidos faço uma exceção para o bloco de ips válidos, crio uma address list com esses ips válidos, adiciono uma regra de markrouting especifica para o gateway de saída dos ips válidos, observando a ordem dessa regra que deve estar a cima das demais regras de markrouting.

    add action=mark-routing chain=prerouting comment=\
    "Marcadores de Rota - Excecao IPs Validos" in-interface=clientes \
    new-routing-mark=to_wlan1 passthrough=no src-address-list="Rota IPs Validos"

    Basicamente é isso, nunca tive problemas com essas regras, utilizo em todos meus clientes que têm esse cenário.

    Um colega aqui do forum me enviou uma msg com uma dúvida sobre como repassar ips válidos pelo balance, abaixo segue a forma que utilizo:

    /ip firewall nat
    add action=masquerade chain=srcnat comment=SERVIDOR dst-address=\
    out-interface=ether1 src-address=!189.126.x.x/27
    add action=masquerade chain=srcnat comment=SERVIDOR out-interface=\
    "Gvt - Invalido"
    add action=masquerade chain=srcnat comment=SERVIDOR out-interface=\
    "Gvt - Valido"


    Mangle


    /ip firewall mangle
    add chain=prerouting comment=Loopback dst-address-list=loopback in-interface=\
    clientes
    add action=mark-connection chain=input comment=wlan1_conn in-interface=ether1 \
    new-connection-mark=wlan1_conn
    add action=mark-connection chain=input comment=wlan2_conn in-interface=\
    "Gvt - Invalido" new-connection-mark=wlan2_conn
    add action=mark-connection chain=input comment=wlan2_conn in-interface=\
    "Gvt - Valido" new-connection-mark=wlan3_conn
    add action=mark-connection chain=output comment=to_wlan1 connection-mark=\
    wlan1_conn new-connection-mark=to_wlan1 passthrough=no
    add action=mark-connection chain=output comment=to_wlan2 connection-mark=\
    wlan2_conn new-connection-mark=to_wlan2 passthrough=no
    add action=mark-connection chain=output comment=to_wlan3 connection-mark=\
    wlan3_conn new-connection-mark=to_wlan3 passthrough=no
    add action=mark-connection chain=prerouting comment=Contadores \
    connection-state=new dst-address-type=!local in-interface=clientes \
    new-connection-mark=wlan1_conn per-connection-classifier=\
    both-addresses:3/0
    add action=mark-connection chain=prerouting connection-state=new \
    dst-address-type=!local in-interface=clientes new-connection-mark=\
    wlan2_conn per-connection-classifier=both-addresses:3/1
    add action=mark-connection chain=prerouting connection-state=new \
    dst-address-type=!local in-interface=clientes new-connection-mark=\
    wlan3_conn per-connection-classifier=both-addresses:3/2
    add action=mark-routing chain=prerouting comment=\
    "Marcadores de Rota - Excecao IPs Validos" in-interface=clientes \
    new-routing-mark=to_wlan1 passthrough=no src-address-list="Rota IP VALIDO"
    add action=mark-routing chain=prerouting comment=\
    "Marcadores de Rota - Rota GVT" in-interface=clientes new-routing-mark=\
    to_wlan2 passthrough=no src-address-list="Rota GVT"
    add action=mark-routing chain=prerouting comment="Marcadores de Rota " \
    connection-mark=wlan1_conn in-interface=clientes new-routing-mark=to_wlan1 \
    passthrough=no
    add action=mark-routing chain=prerouting connection-mark=wlan2_conn \
    in-interface=clientes new-routing-mark=to_wlan2 passthrough=no
    add action=mark-routing chain=prerouting connection-mark=wlan3_conn \
    in-interface=clientes new-routing-mark=to_wlan3 passthrough=no


    ip firewall address-list


    /ip firewall address-list
    add address=10.200.1.2 comment="Clientes que deverao sair pela gvt - para adici\
    onar novo apenas copie a regra e coloque o ip desejado" list="Rota GVT"
    add address=189.126.x.x/27 comment=\
    "Clientes que deverao sair pelo Dedicado" list="Rota IP Valido"
    add address=127.0.0.1 list=loopback
    add address=123.123.123.2 list=liberados
    add address=192.168.2.124 list=liberados
    add address=170.66.11.0/24 list=loopback




    ip route


    /ip route
    add distance=1 gateway=189.126.xx.y routing-mark=to_wlan1
    add distance=1 gateway="Gvt - Invalido" routing-mark=to_wlan2
    add distance=1 gateway="Gvt - Valido" routing-mark=to_wlan3
    add distance=1 gateway=189.126.xx.yy
    add distance=2 gateway="Gvt - Valido"
    add distance=3 gateway="Gvt - Invalido"
    add comment="Rota IPs Validos" distance=1 dst-address=189.126.99.yy/27 \
    gateway=10.200.1.1

    Nota: 189.126.99.yy/27 Bloco de IPs válidos.
    10.200.1.1 IP do Concentrador que distribui os ips para os clientes.






Tópicos Similares

  1. Entregar ip valido depois do Balance PCC
    Por freitascs no fórum Redes
    Respostas: 10
    Último Post: 24-01-2017, 14:25
  2. entregar ip valido para o cliente
    Por Sp4celan no fórum Redes
    Respostas: 7
    Último Post: 02-10-2013, 21:15
  3. Nat 1:1 ou entregar ip valido para cliente
    Por wnascimento no fórum Redes
    Respostas: 4
    Último Post: 14-07-2011, 23:38
  4. Ajuda com Ip Valido cliente e Balance
    Por gonso no fórum Redes
    Respostas: 1
    Último Post: 12-02-2009, 11:17
  5. ip valido responder dos 2 lados
    Por thenet no fórum Redes
    Respostas: 0
    Último Post: 23-05-2007, 10:33

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L