+ Responder ao Tópico



  1. #1

    Padrão Script para bloquear conexões Android (celulares / tablets)

    Amigos,

    gostaria de criar um script ou uma regra especifica no firewall para bloquear conexões de celulares e tablets com o hostname "android", a torre fica proximo a alguns predios e meu DHCP ocupa facilmente a range somente com essas conexões.
    Segue imagem em anexo.

    Clique na imagem para uma versão maior

Nome:	         android.jpg
Visualizações:	876
Tamanho: 	71,5 KB
ID:      	43298

    Fiz algumas pesquisas e achei esse script, porem não sei como padroniza-lo para minhas necessidade e também não tenho certeza se esses script me atenderia, segue link abaixo:
    http://forum.mikrotik.com/viewtopic....block+hostname

  2. #2

    Padrão Re: Script para bloquear conexões Android (celulares / tablets)

    não seria mais fácil colocar chave de segurança WPA na rede?
    terá uma melhora incrível no quesito segurança



  3. #3

    Padrão Re: Script para bloquear conexões Android (celulares / tablets)

    amigo não trata-se de uma rede particular e sim um provedor ter a rede com criptografia limitaria ate a questão de divulgação da rede, acredito que outros amigos também encontram esse tipo de dificuldade trabando em 2.4.
    saberiam me informar se existe algum script que possa bloquear hosts especificos na rede.

  4. #4

    Padrão Re: Script para bloquear conexões Android (celulares / tablets)

    Citação Postado originalmente por diogoaz Ver Post
    amigo não trata-se de uma rede particular e sim um provedor ter a rede com criptografia limitaria ate a questão de divulgação da rede, acredito que outros amigos também encontram esse tipo de dificuldade trabando em 2.4.
    saberiam me informar se existe algum script que possa bloquear hosts especificos na rede.
    Para divulgar não precisa ter rede aberta...

    Rede aberta apenas chama visitantes indesejáveis.
    Você teve sorte que o seu menor problema foi esgotar a classe /24.
    Os piores problemas poderia ser um ataque direto, um sniffer na rede, uma invasão, entre outros.

    Novamente, coloca senha e seja feliz.



  5. #5

    Padrão Re: Script para bloquear conexões Android (celulares / tablets)

    Vc indicaria entao WPA ou WPA2 para uso em provedor?

  6. #6

    Padrão Re: Script para bloquear conexões Android (celulares / tablets)

    Citação Postado originalmente por diogoaz Ver Post
    Vc indicaria entao WPA ou WPA2 para uso em provedor?
    WPA2 tem uma segurança mais forte, mas consome mais processamento.
    Então use WPA.

    Mas não se prenda a apenas um metodo de segurança.
    Ninguém e nenhuma rede é segura 100%, muito menos com 1 tipo de segurança apenas...



  7. #7

    Padrão Re: Script para bloquear conexões Android (celulares / tablets)

    Para hotspot
    Vê se isso serve pra você.
    Ele não bloqueia ele remove e limpa o DHCP
    Ficou meio bagunçado mais funcional, estou aprendendo ainda.
    remova os #
    Código :
     
    /ip dhcp-server lease
    :foreach MR in=[find dynamic=yes]  do={
        :global cmt [get $MR host-name];
        :global mac [get $MR mac-address];
        :global blk [:find $cmt "android"]; 
        :if ([:len $blk] != 0) do={
            :set blk [:pick $cmt ($blk) ($blk +6)];
            :put "$blk  $mac removido"
            #/ip hotspot host remove [/ip hotspot host find mac-address=$mac] 
            #/ip dhcp-server lease remove [/ip dhcp-server lease find mac-address=$mac]
        }
    }
    Última edição por mauquinhos; 14-08-2015 às 11:55.

  8. #8

    Padrão

    Citação Postado originalmente por mauquinhos Ver Post
    Para hotspot
    Vê se isso serve pra você.
    Ele não bloqueia ele remove e limpa o DHCP
    Ficou meio bagunçado mais funcional, estou aprendendo ainda.
    remova os #
    Código :
    /ip dhcp-server lease
    :foreach MR in=[find dynamic=yes]  do={
    :global cmt [get $MR host-name];
    :global mac [get $MR mac-address];
    :global blk [:find $cmt "android"]; 
    :if ([:len $blk] > 1) do={} else={
    :set blk [:pick $cmt ($blk) ($blk +17)];
    :put "$blk  $mac removido"
    #/ip hotspot host remove [/ip hotspot host find mac-address=$mac] 
    #/ip dhcp-server lease remove [/ip dhcp-server lease find mac-address=$mac]
    }}

    Amigo pegando uma carona neste post, esse script limpa os androides? na parte de scripts como ficaria na pratica teria como me da uma ajuda pois tem algumas opções no script que tem algumas caixinhas marcadas.
    segue na imagem

    Clique na imagem para uma versão maior

Nome:	         script.png
Visualizações:	79
Tamanho: 	21,2 KB
ID:      	59316

    E se teria que fazer mais alguma coisa para o script rodar?
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         script.png
Visualizações:	57
Tamanho: 	10,2 KB
ID:      	59315  



  9. #9

    Padrão Re: Script para bloquear conexões Android (celulares / tablets)

    Blz cara, bia noite. é simples, só retirar os #, comentar o put em seguida adicionar uma regra no scheruder não lembro como escreve mais ficaria mais ou menos assim
    /system script run script1
    chegando em casa dou uma revisada nesse script faz tempo que escrevi

  10. #10

    Talking

    Código UPDATE.
    Boa noite, espero que sua duvida seja sanada agora.
    Os 2 codigos se complementam, o primeiro faz o agendamento e o segundo executa a função de limpeza
    Modifique a gosto, boa sorte

    Código :
    /system scheduler add disabled=no interval=30m name=CleanTime30 on-event="/system script run clean" policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api start-date=may/27/2000 start-time=02:57:13

    Adicionar um script com o nome clean.
    clean
    Código :
    /system script add name=clean policy=\    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
        source="/ip dhcp-server lease \r\
        \n:foreach MR in=[find dynamic=yes]  do={\r\
        \n:local host1 [get \$MR host-name];\r\
        \n        :local mac [get \$MR mac-address];\r\
        \n        :local flag [:find \$host1 \"droid\"];\r\
        \n        :if (\$flag = 2) do={\r\
        \n         :log info \$host1;\r\
        \n        }\r\
        \n\t}\r\
        \n\t\r\
        \n"

    Após a linha :log info $host1; no script clean.
    Cole estes códigos:
    Código :
    /ip hotspot host remove [/ip hotspot host find mac-address=$mac] ;
    /ip dhcp-server lease remove [/ip dhcp-server lease find mac-address=$mac];
    O primeiro remove do hotspot e o segundo limpa o lease


    Qual utilidade disto?
    A principal utilidade disto é evitar a falta de ip's no pool e aqueles alertas chatos no log. Sei que podemos modificar a mascará para obter um range maior.
    Porém muitos aqui não são profissionais na área, e buscam aprender iguais a mim, comecei quebrando a cabeça e este script ajuda muito.
    Última edição por mauquinhos; 18-10-2015 às 15:00.



  11. #11

    Padrão Re: Script para bloquear conexões Android (celulares / tablets)

    Muito bom esse seu script mauquinhos

    testei aki e funcionou de boa!