+ Responder ao Tópico



  1. #1

    Padrão [RESOLVIDO] Acesso remoto não funciona corretamente

    Pessoal preciso da ajuda de vocês, usei o script abaixo que retirei do site wikimikrotik.com, justamente para modem roteado, funciona, porém caso haja uma queda no link, naturalmente o IP muda, e o script não atualiza no site changeip, aí não consigo mais acessar remotamente, até que manualmente eu faça a atualização. O que será que está errado?


    :local user "user"
    :local pass "pass"
    :local host "host"
    ##############
    ##############
    :global lastwanip;
    :if ([ :typeof $lastwanip ] = "nothing" ) do={ :global lastwanip 0.0.0.0 };
    :local wanip [:resolve $host];
    :if ( $wanip != $lastwanip ) do={
    /tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
    :local result [/file get dyndns.checkip.html contents]
    :local resultLen [:len $result]
    :local startLoc [:find $result ": " -1]
    :set startLoc ($startLoc + 2)
    :local endLoc [:find $result "" -1]
    :local currentIP [ick $result $startLoc $endLoc]
    :set lastwanip $currentIP;
    ut [/tool dns-update name=$host address=$currentIP key-name=$user key=$pass ]
    }

    * o primeiro ícone é ": pick" e o segundo é ": out" (sem as aspas e sem espaços)
    Última edição por Claudioanjos; 18-04-2013 às 16:18.

  2. #2
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: Acesso remoto não funciona corretamente

    Citação Postado originalmente por Claudioanjos Ver Post
    Pessoal preciso da ajuda de vocês, usei o script abaixo que retirei do site wikimikrotik.com, justamente para modem roteado, funciona, porém caso haja uma queda no link, naturalmente o IP muda, e o script não atualiza no site changeip, aí não consigo mais acessar remotamente, até que manualmente eu faça a atualização. O que será que está errado?


    :local user "user"
    :local pass "pass"
    :local host "host"
    ##############
    ##############
    :global lastwanip;
    :if ([ :typeof $lastwanip ] = "nothing" ) do={ :global lastwanip 0.0.0.0 };
    :local wanip [:resolve $host];
    :if ( $wanip != $lastwanip ) do={
    /tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
    :local result [/file get dyndns.checkip.html contents]
    :local resultLen [:len $result]
    :local startLoc [:find $result ": " -1]
    :set startLoc ($startLoc + 2)
    :local endLoc [:find $result "" -1]
    :local currentIP [ick $result $startLoc $endLoc]
    :set lastwanip $currentIP;
    ut [/tool dns-update name=$host address=$currentIP key-name=$user key=$pass ]
    }

    * o primeiro ícone é ": pick" e o segundo é ": out" (sem as aspas e sem espaços)



    Segue este aqui

    /tool dns-update name=seudominioddns address=127.0.0.255 key-name=seulogin changeip key=suasenha

    logo em seguida vá em

    /system/scheduler/ adicione

    /system script run dns

    coloque pra 5 minutos



  3. #3

    Padrão Re: Acesso remoto não funciona corretamente

    Citação Postado originalmente por Acronimo Ver Post
    Segue este aqui

    /tool dns-update name=seudominioddns address=127.0.0.255 key-name=seulogin changeip key=suasenha

    logo em seguida vá em

    /system/scheduler/ adicione

    /system script run dns

    coloque pra 5 minutos
    Faço dessa forma e funciona blz, só essas opções que nunca sei qual desmarcar, ja vi varios scripts diferentes.

    reboot read
    write policy
    test password
    sniff sensitive

  4. #4

    Padrão Re: Acesso remoto não funciona corretamente

    Citação Postado originalmente por Acronimo Ver Post
    Segue este aqui

    /tool dns-update name=seudominioddns address=127.0.0.255 key-name=seulogin changeip key=suasenha

    logo em seguida vá em

    /system/scheduler/ adicione

    /system script run dns

    coloque pra 5 minutos
    tenho uma RB750 e nela não tem essa opção dns-update, segue imagem
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         RB750.jpg
Visualizações:	90
Tamanho: 	33,1 KB
ID:      	44045  



  5. #5

    Padrão Re: Acesso remoto não funciona corretamente

    Citação Postado originalmente por Claudioanjos Ver Post
    tenho uma RB750 e nela não tem essa opção dns-update, segue imagem
    O dns-update em questão não é da rb750 e sim do script que foi colocada nela.

  6. #6

    Padrão Re: Acesso remoto não funciona corretamente

    Citação Postado originalmente por Acronimo Ver Post
    Segue este aqui

    /tool dns-update name=seudominioddns address=127.0.0.255 key-name=seulogin changeip key=suasenha

    logo em seguida vá em

    /system/scheduler/ adicione

    /system script run dns

    coloque pra 5 minutos

    Acronimo, muito obrigado, está funcionando bem agora.

    - - - Atualizado - - -

    Citação Postado originalmente por technodance Ver Post
    O dns-update em questão não é da rb750 e sim do script que foi colocada nela.
    Technodance, obrigado pelo toque!



  7. #7

    Unhappy Re: Acesso remoto não funciona corretamente

    Galera Boa tarde,
    Sou novato aqui no forum e tb estou começando agora com Mikrotik, antes usava Aprouter, adquirir uma RB751 já configurada com hotspot personalizado, fiz as alterações devidas e tdo funcionando tranquilo, tinha um link de 15M da GVT e solicitei alteração para 35M, recebi o novo modem da GVT PACE v5471, ai vem meus problemas: Não tem santo que ajude a colocar o acesso remoto no MK, o modem é todo travado e está funcionando como router, já configurei DMZ para um IP fixo na LAN (mesmo IP que atribuir a entrada que recebe sinal da NET no MK) redirecionei as portas TCP/UDP 8291 para o mesmo IP e nda.

    sequencia do que eu fiz:
    1- fiz uma conta no dyndns criei um dominio e atribui o IP da WAN do moden GVT
    2- No modem GVT lan 192.168.25.1 fiz um redirecionamento de porta TCP/UDP 8291 para o IP 192.168.25.3 ( ETHER 5 do MK751 onde recebo o sinal do modem GVT)
    3- Ativei DMZ no modem GVT para o IP 192.168.25.3

    como não é o MK que disca eu não alterei nada no MK, dai veio a duvida quando acesso o MK pelo winbox utilizo o IP da LAN do MK 192.168.88.1 não sei se a configuração do DMZ e das portas está correto.

    Duas alternativas:
    Ou conseguir colocar o modem em GVT em ponte (não achei ainda como fazer para este modelo)
    ou tentar novamente configurar DMZ (mas n funciona)

    Quem puder ajudar agradeço muito ......

    HELPPP

  8. #8

    Padrão Re: Acesso remoto não funciona corretamente

    Citação Postado originalmente por Acronimo Ver Post
    Segue este aqui

    /tool dns-update name=seudominioddns address=127.0.0.255 key-name=seulogin changeip key=suasenha

    logo em seguida vá em

    /system/scheduler/ adicione

    /system script run dns

    coloque pra 5 minutos
    Amigo, boa tarde, eu usei este script que vc citou acima, coloquei meu login, senha e dominio mais do NO-IP, aparentemente funcionou, minha duvida é: no script esta escrito "changeip" antes de "key=", esse "changeip" que esta escrito tem alguma coisa a ver com o site changeip.com ? Como eu disse, funcionou aqui na boa mais com os meus dados do no-ip ! Vim soh perguntar mesmo ! Abraços.



  9. #9

    Padrão Re: Acesso remoto não funciona corretamente

    Citação Postado originalmente por dsp_net Ver Post
    Galera Boa tarde,
    Sou novato aqui no forum e tb estou começando agora com Mikrotik, antes usava Aprouter, adquirir uma RB751 já configurada com hotspot personalizado, fiz as alterações devidas e tdo funcionando tranquilo, tinha um link de 15M da GVT e solicitei alteração para 35M, recebi o novo modem da GVT PACE v5471, ai vem meus problemas: Não tem santo que ajude a colocar o acesso remoto no MK, o modem é todo travado e está funcionando como router, já configurei DMZ para um IP fixo na LAN (mesmo IP que atribuir a entrada que recebe sinal da NET no MK) redirecionei as portas TCP/UDP 8291 para o mesmo IP e nda.

    sequencia do que eu fiz:
    1- fiz uma conta no dyndns criei um dominio e atribui o IP da WAN do moden GVT
    2- No modem GVT lan 192.168.25.1 fiz um redirecionamento de porta TCP/UDP 8291 para o IP 192.168.25.3 ( ETHER 5 do MK751 onde recebo o sinal do modem GVT)
    3- Ativei DMZ no modem GVT para o IP 192.168.25.3

    como não é o MK que disca eu não alterei nada no MK, dai veio a duvida quando acesso o MK pelo winbox utilizo o IP da LAN do MK 192.168.88.1 não sei se a configuração do DMZ e das portas está correto.

    Duas alternativas:
    Ou conseguir colocar o modem em GVT em ponte (não achei ainda como fazer para este modelo)
    ou tentar novamente configurar DMZ (mas n funciona)

    Quem puder ajudar agradeço muito ......

    HELPPP
    Cara, deixa seu modem em bridge que todo esse tormento acaba, se for aquele modem powerbox, tem varios tutoriais ai que ensina deixar ele em bridge ! Na moral, vai ser muito melhor para vc, deixa o mk fazer tudo e esquece esse modem ai discando. abraços.

  10. #10

    Padrão Re: Acesso remoto não funciona corretamente

    Ola amigos,

    Só uma dúvida, este provedor é a telefonica?

    Se for so há uma solução:

    Existe uma segurança implementada por eles que se os ips estiverem no mesmo roteador eles nao se enxergam por isso o acesso remoto falha,basta voce abrir um chamado, pela central de atendimento mesmo e informar o que ocorre , ai eles corrigem isso,

    Trabalhei lá um tempo, por isso sei dessa restrição

    Qualquer coisa to ai!!



  11. #11

    Padrão Re: Acesso remoto não funciona corretamente

    nao consigo fazer nenhum script funcionar com minha rb, uso a gvt com modem em bridge e uso o no-ip como ddns, por favor, alguem me da uma força ai, to perdendo a esperança, alguem tem um script funcional com o no-ip ? se tiver, tem como me mandar soh as linhas de comando aqui ? a unica forma que sei fazer eh criando o script e colando o texto lah dentro, nao sei fazer de outro jeito.

  12. #12

    Padrão Re: Acesso remoto não funciona corretamente

    Amigo, eu estava com o mesmo problema, a solução mais simples e pedir um ip fixo para seu provedor de internet.