+ Responder ao Tópico



  1. #1

    Unhappy DDNS para acesso Remoto

    Amigos, estou com um grave problema já rodei aqui o under-linux e ja tentei varios scripts mas não consegui...

    seguinte que acessar o uma rb450 fora da rede dela... tipo remoto

    eu tentei alguns tuto que tem aqui em criar o scritp e rodar ele em tempo a tempo mas quando eu tento no winbox com o endereço do changeip ele não acessa da um erro...

    1º pode acessar na mesma rede usando o endereço do changeip ? ou tem que ser fora da rede para testar ?

    2º se puder não consegui, não tentei fora da rede pois penso que pode entrar...

    não liberei nada e fora o scritp não criei mas nada em firewall pois não vi ninguem comentando sobre isso,

    meu modem é roteado....

    quando falo outra rede é = a testar usando outra internet que não seja a mesma da rb, tentei na mesma rede acessar a rb so pega por mac ou ip da rede...

    alguem tem como me ajudar ?

    agradeço desde já!

  2. #2

    Padrão Re: DDNS para acesso Remoto

    Para testar tem que ser de fora da sua rede . Se o modem for roteado tem que ficar atento ao redirecionamento do modem para a rb.



  3. #3

    Padrão Re: DDNS para acesso Remoto

    amigo tem como me ajudar,

    como faço o redirecionamento do modem para RB?

    e poderia me passar algum script que seja adequado para minha situação ?

    estou usando esse script....
    ainda vou testar
    :local user "usuariodochangeip"
    :local pass "passchangeip"
    :local host "XXXdochageip.ddns.info"
    ##############
    ##############
    :global lastwanip;
    :if ([ :typeof $lastwanip ] = "nothing" ) do={ :global lastwanip 0.0.0.0 };
    :local wanip [:resolve $host];
    :if ( $wanip != $lastwanip ) do={
    /tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
    :local result [/file get dyndns.checkip.html contents]
    :local resultLen [:len $result]
    :local startLoc [:find $result ": " -1]
    :set startLoc ($startLoc + 2)
    :local endLoc [:find $result "</body>" -1]
    :local currentIP [ick $result $startLoc $endLoc]
    :set lastwanip $currentIP;
    ut [/tool dns-update name=$host address=$currentIP key-name=$user key=$pass ]
    }

  4. #4

    Padrão Re: DDNS para acesso Remoto

    Vc tem que acessar as configurações do modem. Geralmente tem as opções no firewall do modem.
    Mais facil seria vc deixar esse modem em bridge e colocar a sua rb para discar com pppoe cliente.



  5. #5

    Padrão Re: DDNS para acesso Remoto

    amigo já usei ele em brigde, tive uns problemas aqui... no momento esse servido se adequa mais em modo roteado, pois em brigde tinha uns pro ai tem q ir lá resolver... e esse MK não tem muito acesso a ele, por isso que quero ter acesso a ele fora da rede... No modem em Firewall o que mais ? versão do modem é um TG508... me ajude aí plis

  6. #6

    Padrão Re: DDNS para acesso Remoto

    Citação Postado originalmente por auriceliodejesus Ver Post
    amigo já usei ele em brigde, tive uns problemas aqui... no momento esse servido se adequa mais em modo roteado, pois em brigde tinha uns pro ai tem q ir lá resolver... e esse MK não tem muito acesso a ele, por isso que quero ter acesso a ele fora da rede... No modem em Firewall o que mais ? versão do modem é um TG508... me ajude aí plis
    procure o manual do seu modem, cada modem tem um nome diferente, sugiro que o problema que vc teve com o modem em bridge foi psicologico ou falta de conhecimento, pois todos sabem que o melhor que seja o modem, usando roteado o modem não tem performance alguma, que usando em bridge fica super estavel. Sugiro vc estudar mais e mais!!



  7. #7

    Lightbulb Re: DDNS para acesso Remoto

    Citação Postado originalmente por rogeriodj Ver Post
    procure o manual do seu modem, cada modem tem um nome diferente, sugiro que o problema que vc teve com o modem em bridge foi psicologico ou falta de conhecimento, pois todos sabem que o melhor que seja o modem, usando roteado o modem não tem performance alguma, que usando em bridge fica super estavel. Sugiro vc estudar mais e mais!!

    amigo, o problema não é o modem e nem o usuário que sou eu, problema é o serviço da internet no local do servidor que estava com problemas! Que usando ele em brigde fica um pouco inviável...

    mas o nosso amigo ali em cima o megabyte me ajudou dizendo que é no modem e eu consegui em outro servidor de MK fazer... com esse script que postei em modo Roteador o MODEM... agora tentar no servidor que eu quero...

    outra dúvida, posso usar a conta do changeip "criando outro free domínio para usar em outro MK ou tenho que fazer outra conta e fazer na conta nova o outro domínio" ?

  8. #8

    Padrão Re: DDNS para acesso Remoto

    consegui ter acesso, mas agora se reinicar o modem não pega sozinho tenho que dar RUN no Script para pode pegar:? NO Sheduler eu coloquei mas nao esta pegando o que pode ser ?



  9. #9

    Padrão Re: DDNS para acesso Remoto

    Como ja foi dito,modem em bridge é muito melhor e evita essa trabalheira toda de redirecionar portas.
    Aqui uso esse script e funciona bem em uma RB750 v5.24

    /tool dns-update name=NOME DO HOST NO CHANGEIP address=127.0.0.255 key-name=NOME DO USUARIO key="SENHA"



    /system scheduler
    add disabled=no interval=10m name=schedule1 on-event=\
    "/system script run dns-update" policy=\
    read,write,policy,test,password,sniff start-time=startup

  10. #10

    Padrão Re: DDNS para acesso Remoto

    Citação Postado originalmente por technodance Ver Post
    Como ja foi dito,modem em bridge é muito melhor e evita essa trabalheira toda de redirecionar portas.
    Aqui uso esse script e funciona bem em uma RB750 v5.24

    /tool dns-update name=NOME DO HOST NO CHANGEIP address=127.0.0.255 key-name=NOME DO USUARIO key="SENHA"

    /system scheduler
    add disabled=no interval=10m name=schedule1 on-event=\
    "/system script run dns-update" policy=\
    read,write,policy,test,password,sniff start-time=startup
    amigo pelo que vi a sua configuração do /system sheduler esta funcionando na versão do MK v5.11 vou testar direitinho mas pelo o log acho q vai funcionar, mas na versão do MK v4.11 nem no log tá aparecendo normal... no sheduler... mas vou testar para ver na versão v5.11 se funcionar é a versão mesmo, pois a configuração das duas são a mesma coisa só muda a versão...



  11. #11

    Padrão Re: DDNS para acesso Remoto

    Testei em minha RB 750GL e deu certo, eu estava em busca de um script simples e funcional, obrigado por compartilhar amigo, abraços.

  12. #12

    Padrão Re: DDNS para acesso Remoto

    Citação Postado originalmente por technodance Ver Post
    Como ja foi dito,modem em bridge é muito melhor e evita essa trabalheira toda de redirecionar portas.
    Aqui uso esse script e funciona bem em uma RB750 v5.24

    /tool dns-update name=NOME DO HOST NO CHANGEIP address=127.0.0.255 key-name=NOME DO USUARIO key="SENHA"



    /system scheduler
    add disabled=no interval=10m name=schedule1 on-event=\
    "/system script run dns-update" policy=\
    read,write,policy,test,password,sniff start-time=startup

    Olá. Peço desculpas por ressuscitar o tópico quase um ano depois, mas estou precisando configurar esse script aqui.

    Enfim, minha dúvida é se precisa modificar o campo onde tem 'address=127.0.0.255'

    Grato desde já pela ajuda.