+ Responder ao Tópico



  1. #1

    Question Balanceamento NET Virtua e Oi Velox Rotiado e DMZ - Desafio do dia dia.

    Pessoal,


    Estou em um cliente que tem o RB750
    ether1 - NET-VIRTUA-Internet - DHCP CLIENT - 200.xxx.xxx.xxx IP Real Dinamico
    ether2 - Oi-Velox-Internet - 10.1.1.2 Roteado - DMZ LIGADO no router velox.
    ether3 - Rede da Empresa 192.168.0.100 até 200

    Estou tentando ha dias fazer o balanceamento de carga nos dois links e não consigo. Eu gostaria muito de resolver isto.
    ============================================================
    ] /interface> print
    Flags: D - dynamic, X - disabled, R - running, S - slave
    # NAME TYPE MTU L2MTU MAX-L2MTU
    0 R Oi-Velox-Internet ether 1500 1600 4076
    1 R NET-Internet ether 1500 1598 2028
    2 R Rede-DigiOffice ether 1500 1598 2028
    3 X ether4 ether 1500 1598 2028
    4 X ether5 ether 1500 1598 2028

    5 pptp-in1
    ============================================================
    /ip firewall nat> print
    Flags: X - disabled, I - invalid, D - dynamic
    0 chain=srcnat action=masquerade out-interface=NET-Internet


    1 chain=srcnat action=masquerade out-interface=Oi-Velox-Internet
    ============================================================
    /ip route> print
    Flags: X - disabled, A - active, D - dynamic,
    C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
    B - blackhole, U - unreachable, P - prohibit
    # DST-ADDRESS PREF-SRC GATEWAY DISTANCE
    0 ADS 0.0.0.0/0 187.20.160.1 0
    1 S 0.0.0.0/0 NET-Internet 1
    Oi-Velox-Internet
    2 ADC 10.1.1.0/24 10.1.1.2 Oi-Velox-Internet 0
    3 ADC 187.20.160.0/21 187.20.161.29 NET-Internet 0
    4 ADC 192.168.0.0/24 192.168.0.1 Rede-DigiOffice 0
    ============================================================
    /ip dhcp-client> print
    Flags: X - disabled, I - invalid
    # INTERFACE USE-PEER-DNS ADD-DEFAULT-ROUTE STATUS ADDRESS
    0 NET-Internet yes yes bound 18x.2x.16x.29/21
    ============================================================
    /ip address> print
    Flags: X - disabled, I - invalid, D - dynamic
    # ADDRESS NETWORK INTERFACE
    0 192.168.0.1/24 192.168.0.0 Rede-DigiOffice
    1 10.1.1.2/24 10.1.1.0 Oi-Velox-Internet
    2 D 18x.2x.16x.2x/21 187.20.160.0 NET-Internet
    ============================================================



    Acho que postei as características da minha rede se alguém puder me da uma ajuda para resolver desde já estou grato a todos.

  2. #2

    Padrão Re: Balanceamento NET Virtua e Oi Velox Rotiado e DMZ - Desafio do dia dia.

    Citação Postado originalmente por leandro.miranda Ver Post
    Pessoal,


    Estou em um cliente que tem o RB750
    ether1 - NET-VIRTUA-Internet - DHCP CLIENT - 200.xxx.xxx.xxx IP Real Dinamico
    ether2 - Oi-Velox-Internet - 10.1.1.2 Roteado - DMZ LIGADO no router velox.
    ether3 - Rede da Empresa 192.168.0.100 até 200

    Estou tentando ha dias fazer o balanceamento de carga nos dois links e não consigo. Eu gostaria muito de resolver isto.
    ============================================================
    ] /interface> print
    Flags: D - dynamic, X - disabled, R - running, S - slave
    # NAME TYPE MTU L2MTU MAX-L2MTU
    0 R Oi-Velox-Internet ether 1500 1600 4076
    1 R NET-Internet ether 1500 1598 2028
    2 R Rede-DigiOffice ether 1500 1598 2028
    3 X ether4 ether 1500 1598 2028
    4 X ether5 ether 1500 1598 2028

    5 pptp-in1
    ============================================================
    /ip firewall nat> print
    Flags: X - disabled, I - invalid, D - dynamic
    0 chain=srcnat action=masquerade out-interface=NET-Internet


    1 chain=srcnat action=masquerade out-interface=Oi-Velox-Internet
    ============================================================
    /ip route> print
    Flags: X - disabled, A - active, D - dynamic,
    C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
    B - blackhole, U - unreachable, P - prohibit
    # DST-ADDRESS PREF-SRC GATEWAY DISTANCE
    0 ADS 0.0.0.0/0 187.20.160.1 0
    1 S 0.0.0.0/0 NET-Internet 1
    Oi-Velox-Internet
    2 ADC 10.1.1.0/24 10.1.1.2 Oi-Velox-Internet 0
    3 ADC 187.20.160.0/21 187.20.161.29 NET-Internet 0
    4 ADC 192.168.0.0/24 192.168.0.1 Rede-DigiOffice 0
    ============================================================
    /ip dhcp-client> print
    Flags: X - disabled, I - invalid
    # INTERFACE USE-PEER-DNS ADD-DEFAULT-ROUTE STATUS ADDRESS
    0 NET-Internet yes yes bound 18x.2x.16x.29/21
    ============================================================
    /ip address> print
    Flags: X - disabled, I - invalid, D - dynamic
    # ADDRESS NETWORK INTERFACE
    0 192.168.0.1/24 192.168.0.0 Rede-DigiOffice
    1 10.1.1.2/24 10.1.1.0 Oi-Velox-Internet
    2 D 18x.2x.16x.2x/21 187.20.160.0 NET-Internet
    ============================================================



    Acho que postei as características da minha rede se alguém puder me da uma ajuda para resolver desde já estou grato a todos.
    Pra usar esse net com ip valido dinamico, vc tera de colocar um outro roteado para receber o ip valido...



  3. #3

    Padrão Re: Balanceamento NET Virtua e Oi Velox Rotiado e DMZ - Desafio do dia dia.

    Não existe outro método de fazer sem ter que colocar mais um router?

  4. #4

    Padrão Re: Balanceamento NET Virtua e Oi Velox Rotiado e DMZ - Desafio do dia dia.

    Citação Postado originalmente por leandro.miranda Ver Post
    Não existe outro método de fazer sem ter que colocar mais um router?
    Pior que não amigo!!



  5. #5

    Padrão Re: Balanceamento NET Virtua e Oi Velox Rotiado e DMZ - Desafio do dia dia.

    Achei que dava pra criar sei la as portas em bridge ou fazer algum seletor para tratar isso. Se transformar o Oi Velox em PPPoE da pra fazer loadbalance? Ou mesmo assim não será possível?

  6. #6

    Padrão Re: Balanceamento NET Virtua e Oi Velox Rotiado e DMZ - Desafio do dia dia.

    Citação Postado originalmente por leandro.miranda Ver Post
    Achei que dava pra criar sei la as portas em bridge ou fazer algum seletor para tratar isso. Se transformar o Oi Velox em PPPoE da pra fazer loadbalance? Ou mesmo assim não será possível?
    O problema é seu net, pois entrega ip valido por DHCP...



  7. #7

    Unhappy Re: Balanceamento NET Virtua e Oi Velox Rotiado e DMZ - Desafio do dia dia.

    Citação Postado originalmente por rogeriodj Ver Post
    O problema é seu net, pois entrega ip valido por DHCP...

    fiquei triste com isso... Vou ter q procurar solução para este problema...

  8. #8

    Padrão Re: Balanceamento NET Virtua e Oi Velox Rotiado e DMZ - Desafio do dia dia.

    Citação Postado originalmente por leandro.miranda Ver Post
    fiquei triste com isso... Vou ter q procurar solução para este problema...
    Mete um roteador tplink ai nesse net, faz dmz para o mikrotik e pronto, se precisar de suporte para isso so dar um toq!!



  9. #9

    Padrão Re: Balanceamento NET Virtua e Oi Velox Rotiado e DMZ - Desafio do dia dia.

    Vou tentar fazer o cliente comprar isso. https://under-linux.org/showthread.php?t=159159 mas este post o carinha fala que fez...

  10. #10

    Padrão Re: Balanceamento NET Virtua e Oi Velox Rotiado e DMZ - Desafio do dia dia.

    Citação Postado originalmente por leandro.miranda Ver Post
    Vou tentar fazer o cliente comprar isso. https://under-linux.org/showthread.php?t=159159 mas este post o carinha fala que fez...
    Amigo compre uma solução ja pronta como essa aqui: http://produto.mercadolivre.com.br/M...-4wan-1lan-_JM
    Tenho aqui um link dedicado e um adsl como backup, funciona que é uma maravilha, vai resolver seu problema.



  11. #11

    Padrão Re: Balanceamento NET Virtua e Oi Velox Rotiado e DMZ - Desafio do dia dia.

    A questão que vamos usar mais recursos, VPN, redirecionamento de portas e serviços, bloqueio de sites e portas.. separar a porta de rede do wifi-zone para visitantes e clientes... o objetivo que originou a compra do mk foi esse. e tem como colocar funcionando. Eu vou da um jeito... existem outros foruns... tbm.. vou pesquisar até achar o jeito melhor de fazer.

  12. #12

    Padrão Re: Balanceamento NET Virtua e Oi Velox Rotiado e DMZ - Desafio do dia dia.

    aqui nesse link http://blog.lcmm.info/?p=91 explica como fazer balanceamento com ips dinamico



  13. #13

    Padrão Re: Balanceamento NET Virtua e Oi Velox Rotiado e DMZ - Desafio do dia dia.

    Citação Postado originalmente por hagahood Ver Post
    aqui nesse link http://blog.lcmm.info/?p=91 explica como fazer balanceamento com ips dinamico

    Boa !!! Adorei este link!

  14. #14

    Padrão Re: Balanceamento NET Virtua e Oi Velox Rotiado e DMZ - Desafio do dia dia.

    Código do blog.

    Código :
     
    /ip firewall mangle
    add action=accept chain=prerouting comment=”remove balanceamento das redes conectadas /16 para agregar rede 192.168.1.0 e 192.168.0.0!” disabled=no dst-address=192.168.0.0/16 in-interface=ether5-local
     
     
    add action=mark-connection chain=input comment=”Inicio Conf PCC, marca conexF5es entrantes!” disabled=no in-interface=pppoe-out1 new-connection-mark=ppoe1 passthrough=yes
     
     
    add action=mark-connection chain=input comment=”" disabled=no in-interface=pppoe-out2 new-connection-mark=ppoe2 passthrough=yes
     
     
    add action=mark-connection chain=input comment=”" disabled=no in-interface=pppoe-out3 new-connection-mark=ppoe3 passthrough=yes
     
     
    add action=accept chain=output comment=”Sem Load Balance” disabled=no dst-address-list=nobalance
     
     
    add action=mark-routing chain=output comment=”" connection-mark=ppoe1 disabled=no new-routing-mark=para-ppoe1 passthrough=yes
     
     
    add action=mark-routing chain=output comment=”" connection-mark=ppoe2 disabled=no new-routing-mark=para-ppoe2 passthrough=yes
     
     
    add action=mark-routing chain=output comment=”" connection-mark=ppoe3 disabled=no new-routing-mark=para-ppoe3 passthrough=yes
     
     
    add action=mark-connection chain=prerouting comment=”PCC em si, colocando um peso igual para todos os ppoe” disabled=no dst-address=!192.168.0.0/16 dst-address-type=!local new-connection-mark=ppoe1 passthrough=yes per-connection-classifier=both-addresses:3/0 src-address=192.168.0.0/16
     
     
    add action=mark-connection chain=prerouting comment=”" disabled=no dst-address=!192.168.0.0/16 dst-address-type=!local new-connection-mark=ppoe2 passthrough=yes per-connection-classifier=both-addresses:3/1 src-address=192.168.0.0/16
     
     
    add action=mark-connection chain=prerouting comment=”" disabled=no dst-address=!192.168.0.0/16 dst-address-type=!local new-connection-mark=ppoe3 passthrough=yes per-connection-classifier=both-addresses:3/2 src-address=192.168.0.0/16
     
     
    add action=mark-routing chain=prerouting comment=”Aponta as conexF5es do Load Balance para as suas respectivas tabelas de roteamento” connection-mark=ppoe1 disabled=no dst-address=!192.168.0.0/16 new-routing-mark=para-ppoe1 passthrough=yes src-address=192.168.0.0/16
     
     
    add action=mark-routing chain=prerouting comment=”" connection-mark=ppoe2 disabled=no dst-address=!192.168.0.0/16 new-routing-mark=para-ppoe2 passthrough=yes src-address=192.168.0.0/16
     
     
    add action=mark-routing chain=prerouting comment=”" connection-mark=ppoe3 disabled=no dst-address=!192.168.0.0/16 new-routing-mark=para-ppoe3 passthrough=yes src-address=192.168.0.0/16



  15. #15

    Padrão Re: Balanceamento NET Virtua e Oi Velox Rotiado e DMZ - Desafio do dia dia.

    e ai? testou? "fungou"?

  16. #16

    Padrão Re: Balanceamento NET Virtua e Oi Velox Rotiado e DMZ - Desafio do dia dia.

    Pessoal,

    Fiz aqui e vou testar:

    Código :
     
    /ip firewall mangle
    add chain=prerouting comment="Remove balanceamento das redes conectadas /16 pa\
        ra agregar rede 192.168.1.0 e 192.168.0.0!" disabled=yes dst-address=\
        192.168.0.0/16 in-interface=Rede-DigiOffice
    add action=mark-connection chain=input comment=\
        "Inicio da Configura\E7ao do PCC, marca conex\F5es entrantes!" disabled=\
        yes in-interface=NET-Internet new-connection-mark=NETADSL
    add action=mark-connection chain=input disabled=yes in-interface=\
        Oi-Velox-Internet new-connection-mark=OiADSL
    add chain=output comment="Sem Load Balance" disabled=yes dst-address-list=\
        nobalance
    add action=mark-routing chain=output connection-mark=NETADSL disabled=yes \
        new-routing-mark=para-NETADSL
    add action=mark-routing chain=output connection-mark=OiADSL disabled=yes \
        new-routing-mark=para-OiADSL
    add action=mark-connection chain=prerouting comment=\
        "PCC em si, colocando um peso igual para todas interfaces" disabled=yes \
        dst-address=!192.168.0.0/16 dst-address-type=!local new-connection-mark=\
        NETADSL per-connection-classifier=both-addresses:2/0 src-address=\
        192.168.0.0/16
    add action=mark-connection chain=prerouting disabled=yes dst-address=\
        !192.168.0.0/16 dst-address-type=!local new-connection-mark=OiADSL \
        per-connection-classifier=both-addresses:2/1 src-address=192.168.0.0/16
    add action=mark-routing chain=prerouting comment=" Aponta as conexes do Load B\
        alance para as suas respectivas tabelas de roteamento" connection-mark=\
        NETADSL disabled=yes dst-address=!192.168.0.0/16 new-routing-mark=\
        para-NETADSL src-address=192.168.0.0/16
    add action=mark-routing chain=prerouting connection-mark=OiADSL disabled=yes \
        dst-address=!192.168.0.0/16 new-routing-mark=para-OiADSL src-address=\
        192.168.0.0/16



  17. #17

    Padrão Re: Balanceamento NET Virtua e Oi Velox Rotiado e DMZ - Desafio do dia dia.

    Citação Postado originalmente por hagahood Ver Post
    e ai? testou? "fungou"?

    Não está funcionando no meu ver.

    Inclusive não consigo acessar os PCs via VNC pelo IP da Oi Velox e sim pelo NET VIrtua.

    As configurações estão em anexo.

    Já analisei linha por linha de forma cautelosa, e infelizmente não sei o que se passa.
    Arquivos Anexos Arquivos Anexos

  18. #18

    Padrão Re: Balanceamento NET Virtua e Oi Velox Rotiado e DMZ - Desafio do dia dia.

    olando assim por cima parece que esta tudo certo.
    vc consegue acessar o mk pelo winbox/web "de fora" pela conexão adsl



  19. #19

    Padrão Re: Balanceamento NET Virtua e Oi Velox Rotiado e DMZ - Desafio do dia dia.

    Citação Postado originalmente por hagahood Ver Post
    olando assim por cima parece que esta tudo certo.
    vc consegue acessar o mk pelo winbox/web "de fora" pela conexão adsl

    Sim,

    Inclusive estou em casa e o MK está na empresa.

    Pelo link NET VIRTUA eu navego acesso remotamente tudo normal. E como vc pode observar todas as regras NAT q tem pro NET tem identica para o Oi Velox PPPoe e sinceramente nao sei o q fazer. rsrs....

  20. #20

    Padrão Re: Balanceamento NET Virtua e Oi Velox Rotiado e DMZ - Desafio do dia dia.

    Citação Postado originalmente por FMANDU Ver Post
    Amigo compre uma solução ja pronta como essa aqui: http://produto.mercadolivre.com.br/M...-4wan-1lan-_JM
    Tenho aqui um link dedicado e um adsl como backup, funciona que é uma maravilha, vai resolver seu problema.
    Sabe se da para usar esse TP-Link Load Balance na minha rede? Minha rede esta assim: MK-auth autenticando os clientes e uma rb-1100-AH fazendo roteamento do link dedicado. Queria colocar um link da NET-VIRTUA ip dinamico junto com o dedicado ip FIXO.
    Minha operadora dedicado vive caindo rsrsr. Uso PPPoE nos clientes. Obrigado