+ Responder ao Tópico



  1. #1

    Padrão Duvidas em fechamento do OSPF

    Boa noite a todos..

    Fechei um OSPF em minha rede, mais nao foi no sistema em circulo e sim como na imagem de topologia, agora quero fechar o anel entre elas e nesse ponto eu estou com duvidas como fazer e configurar.
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         Topologia.jpg
Visualizações:	123
Tamanho: 	24,2 KB
ID:      	46746  

  2. #2

    Padrão Re: Duvidas em fechamento do OSPF




  3. #3

    Padrão Re: Duvidas em fechamento do OSPF

    Citação Postado originalmente por megabyte Ver Post
    Boa noite, ja vi sim a minha duvida é fechar o anel pelas pontas das rbs e conservando os pontos a pontos existentes.

  4. #4

    Padrão Re: Duvidas em fechamento do OSPF

    Citação Postado originalmente por jwjunior Ver Post
    Boa noite, ja vi sim a minha duvida é fechar o anel pelas pontas das rbs e conservando os pontos a pontos existentes.

    Não precisa se preocupar com nada, basta fechar os enlaces, e continuar o que você ja fez. O resto o ospf faz para você.
    Não muda nada de uma configuração para outra.



  5. #5

    Padrão Re: Duvidas em fechamento do OSPF

    não entendi como esta tua rede, mas acredito que seja assim:
    Clique na imagem para uma versão maior

Nome:	         antes.png
Visualizações:	165
Tamanho: 	48,3 KB
ID:      	46756

    se for mais ou menos isso
    vc vai ter que colocar mais radios ligando os outros RBs um apontando para o outro.( eu estou supondo que é tudo enlace wireless)
    assim como a imagem abaixo:


    Clique na imagem para uma versão maior

Nome:	         Network Mapr.jpg
Visualizações:	313
Tamanho: 	169,3 KB
ID:      	46757

    (o verde é o que tu ja tem e o cinza é o que tu tem que adicionar)
    cada link/conexão deve ser uma rede ou subrede diferente para o OSPF funcionar.

  6. #6

    Padrão Re: Duvidas em fechamento do OSPF

    Citação Postado originalmente por hagahood Ver Post
    não entendi como esta tua rede, mas acredito que seja assim:
    Clique na imagem para uma versão maior

Nome:	         antes.png
Visualizações:	165
Tamanho: 	48,3 KB
ID:      	46756

    se for mais ou menos isso
    vc vai ter que colocar mais radios ligando os outros RBs um apontando para o outro.( eu estou supondo que é tudo enlace wireless)
    assim como a imagem abaixo:


    Clique na imagem para uma versão maior

Nome:	         Network Mapr.jpg
Visualizações:	313
Tamanho: 	169,3 KB
ID:      	46757

    (o verde é o que tu ja tem e o cinza é o que tu tem que adicionar)
    cada link/conexão deve ser uma rede ou subrede diferente para o OSPF funcionar.
    Boa tarde obrigado a todos vou fazer um exemplo pelo dude para me explicar melhor.



  7. #7

    Padrão Re: Dúvidas em fechamento do OSPF

    Citação Postado originalmente por jwjunior Ver Post
    ...Fechei um OSPF em minha rede, mais nao foi no sistema em circulo e sim como na imagem de topologia, agora quero fechar o anel entre elas e nesse ponto eu estou com duvidas como fazer e configurar.
    O processo é bem simples, conforme o colega douglasesmeriz enfatizou[1].

    Citação Postado originalmente por douglasesmeriz Ver Post
    Não precisa se preocupar com nada, basta fechar os enlaces, e continuar o que você ja fez. O resto o ospf faz para você.
    Não muda nada de uma configuração para outra.
    Há disponível aqui no Under-Linux um post[2] bem detalhado, contendo exemplo[2] completo de circularidade de rotas. Em outro[3] exemplo, você pode manipular os custos das interfaces, modificando[3] o processo de decisão de caminhos.

    Tenha cuidado com alguns materiais, tutoriais e vídeos disponíveis, não só sobre OSPF, mas de qualquer área. Alguns são bons, já outros vários materiais são cheios de incertezas, como "eu acho", "funciona, mas não sei como", ferem RFCs, entre outros problemas. Tenho a certeza de que são materiais criados com as melhores das intenções, mas não consideram critérios técnicos, e resultam em tumulto e confusão ao espectador, em vez de proporcionar um aprendizado efetivo.

    Faça bastante teste em laboratórios, para evitar[4] erros em produção.

    Citação Postado originalmente por jwjunior Ver Post
    ...obrigado a todos vou fazer um exemplo pelo dude para me explicar melhor.
    Faço votos para que tenha êxito em seus laboratórios

    [1] https://under-linux.org/showthread.p...411#post675411
    [2] https://under-linux.org/showthread.p...154#post618154
    [3] https://under-linux.org/showthread.p...112#post649112
    [4] https://under-linux.org/showthread.p...420#post640420

    Saudações,

    Trober

  8. #8

    Padrão Re: Dúvidas em fechamento do OSPF

    Citação Postado originalmente por trober Ver Post
    O processo é bem simples, conforme o colega douglasesmeriz enfatizou[1].



    Há disponível aqui no Under-Linux um post[2] bem detalhado, contendo exemplo[2] completo de circularidade de rotas. Em outro[3] exemplo, você pode manipular os custos das interfaces, modificando[3] o processo de decisão de caminhos.

    Tenha cuidado com alguns materiais, tutoriais e vídeos disponíveis, não só sobre OSPF, mas de qualquer área. Alguns são bons, já outros vários materiais são cheios de incertezas, como "eu acho", "funciona, mas não sei como", ferem RFCs, entre outros problemas. Tenho a certeza de que são materiais criados com as melhores das intenções, mas não consideram critérios técnicos, e resultam em tumulto e confusão ao espectador, em vez de proporcionar um aprendizado efetivo.

    Faça bastante teste em laboratórios, para evitar[4] erros em produção.



    Faço votos para que tenha êxito em seus laboratórios

    [1] https://under-linux.org/showthread.p...411#post675411
    [2] https://under-linux.org/showthread.p...154#post618154
    [3] https://under-linux.org/showthread.p...112#post649112
    [4] https://under-linux.org/showthread.p...420#post640420

    Saudações,

    Trober

    Boa tarde Trober. Muito obrigado seguindo https://under-linux.org/showthread.p...112#post649112. Entao em posso fazer assim, os ponto a ponto em preto da imagem eu trabalho com rotas menores, que serao principais e os ponto a ponto em vermelho trabalho com uma rota maior que sera de BACKUP?
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         Topologia.JPG
Visualizações:	71
Tamanho: 	19,1 KB
ID:      	46768  



  9. #9

    Padrão Re: Dúvidas em fechamento do OSPF

    Citação Postado originalmente por jwjunior Ver Post
    Boa tarde Trober. Muito obrigado seguindo https://under-linux.org/showthread.p...112#post649112. Entao em posso fazer assim, os ponto a ponto em preto da imagem eu trabalho com rotas menores, que serao principais e os ponto a ponto em vermelho trabalho com uma rota maior que sera de BACKUP?
    Exatamente

    Reforçando o que o Douglas já informou, com base no diagrama compartilhado por você, não há necessidade de fazer qualquer intervenção manual nos custos das interfaces, considerando que seu objetivo é a saída para a internet

    Saudações,

    Trober

  10. #10

    Padrão Re: Dúvidas em fechamento do OSPF

    Boa noite, Trober. tenho em funcionamento essas tres RBS com OSPF sendo a primeira com a internet.
    Arquivos Anexos Arquivos Anexos
    • Tipo de Arquivo: txt OSPF.txt (11,4 KB, 167 visualizações)



  11. #11

    Padrão Re: Dúvidas em fechamento do OSPF

    Citação Postado originalmente por jwjunior Ver Post
    Boa noite, Trober. tenho em funcionamento essas tres RBS com OSPF sendo a primeira com a internet.
    Sugiro colar o código na mensagem, usando a marcação de formatação de código (TAG CODE), disponível na ferramenta WYSIWYG do Under-Linux.

    Use também o comando abaixo, para não exportar sobras desnecessárias da configuração do MikroTik RouterOS.

    Código :
    /export compact

    Saudações,

    Trober

  12. #12

    Padrão Re: Dúvidas em fechamento do OSPF

    Citação Postado originalmente por trober Ver Post
    Sugiro colar o código na mensagem, usando a marcação de formatação de código (TAG CODE), disponível na ferramenta WYSIWYG do Under-Linux.

    Use também o comando abaixo, para não exportar sobras desnecessárias da configuração do MikroTik RouterOS.

    Código :
    /export compact

    Saudações,

    Trober

    Obrigado..


    RB 01 Entrada do link e saida para todas as outras pela ether02-Cliente

    /routing ospf instance
    set [ find default=yes ] distribute-default=always-as-type-1 router-id=10.255.255.1
    /routing ospf interface
    add interface=Loopback network-type=broadcast passive=yes
    add interface=ether2-CLIENTES network-type=broadcast
    add interface=ether3-SPEEDR network-type=broadcast passive=yes
    /routing ospf network
    add area=backbone network=172.16.2.0/30
    add area=backbone network=172.16.1.0/30
    add area=backbone network=172.16.4.0/30
    add area=backbone network=172.16.5.0/30
    add area=backbone network=172.16.3.0/30
    add area=backbone network=10.255.255.1/32
    add area=backbone network=10.1.1.0/24
    add area=backbone network=192.10.1.0/24
    add area=backbone network=192.10.2.0/24


    RB 02

    /routing ospf instance
    set [ find default=yes ] router-id=10.255.255.2
    /routing ospf interface
    add interface=Loopback network-type=broadcast passive=yes
    add interface=ether1-Link network-type=broadcast
    add interface=bridge1 network-type=broadcast passive=yes
    add interface=ether3-Mkauth network-type=broadcast passive=yes
    /routing ospf network
    add area=backbone network=172.16.1.0/30
    add area=backbone network=10.255.255.2/32
    add area=backbone network=10.95.100.0/24
    add area=backbone network=192.168.10.0/24
    add area=backbone network=192.1.1.0/24
    add area=backbone network=192.1.5.0/24

    RB 03
    /routing ospf instance
    set [ find default=yes ] router-id=10.255.255.3
    /routing ospf interface
    add interface=bridge1-Clientes network-type=broadcast passive=yes
    add interface=Loopback network-type=broadcast passive=yes
    add interface=ether3 network-type=broadcast passive=yes
    add interface=ether1-Link network-type=broadcast
    /routing ospf network
    add area=backbone network=172.16.2.0/30
    add area=backbone network=10.255.255.3/32
    add area=backbone network=192.168.11.0/24
    add area=backbone network=192.1.2.0/24



  13. #13

    Padrão Re: Dúvidas em fechamento do OSPF

    Está parcial sua exportação, mas já possibilita alguns comentários.

    Atente para as citações abaixo:

    RB01
    Citação Postado originalmente por jwjunior Ver Post
    add area=backbone network=192.10.1.0/24
    add area=backbone network=192.10.2.0/24
    RB02
    Citação Postado originalmente por jwjunior Ver Post
    add area=backbone network=192.1.1.0/24
    add area=backbone network=192.1.5.0/24
    RB03
    Citação Postado originalmente por jwjunior Ver Post
    add area=backbone network=192.1.2.0/24
    CONTRAS:

    Falta do uso de comentários, para incrementar a documentação.

    Você fez uso de endereços públicos, dos quais você não detém direito de alocação, na sua rede. Os endereços privados estão previstos no RFC1918[1]. Há alguns tópicos[2][3], disponíveis aqui no Under-Linux, já abordando esse assunto.

    Qual o problema de usar os endereços públicos (que você usa como privado)? Além de violar normas, será também problema, a impossibilidade de algum cliente seu alcançar redes da BBN Communications (Cambridge, Massachusetts), detentora de um dos blocos usados equivocadamente.

    PROS:

    Declaração explícita de interfaces passivas, sem diálogo OSPF.
    Declaração explícita de interfaces ativas.
    Definição de identificação do roteador (router-id).
    Redistribuição de rota padrão somente no roteador de saída.
    Declaração explícita das redes a serem anunciadas.

    Resumindo: do pouco que vi, no export parcial informado, gostei muito

    Agora é só arrumar aquela violação ao RFC1918, e adicionar comentários nas entradas de configurações dos ativos.

    [1] http://tools.ietf.org/html/rfc1918
    [2] https://under-linux.org/showthread.p...212#post653212
    [3] https://under-linux.org/showthread.p...859#post624859

    Saudações,

    Trober
    Última edição por trober; 06-11-2013 às 10:19. Razão: Correção gramatical

  14. #14

    Padrão Re: Dúvidas em fechamento do OSPF

    Citação Postado originalmente por trober Ver Post
    Está parcial sua exportação, mas já possibilita alguns comentários.

    Atente para as citações abaixo:

    RB01

    RB02

    RB03


    CONTRAS:

    Falta do uso de comentários, para incrementar a documentação.

    Você fez uso de endereços públicos, dos quais você não detém direito de alocação, na sua rede. Os endereços privados estão previstos no RFC1918[1]. Há alguns tópicos[2][3], disponíveis aqui no Under-Linux, já abordando esse assunto.

    Qual o problema de usar os endereços públicos (que você usa como privado)? Além de violar normas, será problema, seu e de alguns clientes seu, a impossibilidade de alcançar redes da BBN Communications (Cambridge, Massachusetts), detentora de um dos blocos usados equivocadamente.

    PROS:

    Declaração explícita de interfaces passivas, sem diálogo OSPF.
    Declaração explícita de interfaces ativas.
    Definição de identificação do roteador (router-id).
    Redistribuição de rota padrão somente no roteador de saída.
    Declaração explícita das redes a serem anunciadas.

    Resumindo: do pouco que vi, no export parcial informado, gostei muito

    Agora é só arrumar aquela violação ao RFC1918, e adicionar comentários nas entradas de configurações dos ativos.

    [1] http://tools.ietf.org/html/rfc1918
    [2] https://under-linux.org/showthread.p...212#post653212
    [3] https://under-linux.org/showthread.p...859#post624859

    Saudações,

    Trober

    Boa noite obrigado, os ips não autorizados irei retirar pois os mesmos só fazer parte dos ips das antenas AP, e não são distribuídos a clientes



  15. #15

    Padrão Re: Dúvidas em fechamento do OSPF

    Citação Postado originalmente por trober Ver Post
    Está parcial sua exportação, mas já possibilita alguns comentários.

    Atente para as citações abaixo:

    RB01

    RB02

    RB03


    CONTRAS:

    Falta do uso de comentários, para incrementar a documentação.

    Você fez uso de endereços públicos, dos quais você não detém direito de alocação, na sua rede. Os endereços privados estão previstos no RFC1918[1]. Há alguns tópicos[2][3], disponíveis aqui no Under-Linux, já abordando esse assunto.

    Qual o problema de usar os endereços públicos (que você usa como privado)? Além de violar normas, será problema, seu e de alguns clientes seu, a impossibilidade de alcançar redes da BBN Communications (Cambridge, Massachusetts), detentora de um dos blocos usados equivocadamente.

    PROS:

    Declaração explícita de interfaces passivas, sem diálogo OSPF.
    Declaração explícita de interfaces ativas.
    Definição de identificação do roteador (router-id).
    Redistribuição de rota padrão somente no roteador de saída.
    Declaração explícita das redes a serem anunciadas.

    Resumindo: do pouco que vi, no export parcial informado, gostei muito

    Agora é só arrumar aquela violação ao RFC1918, e adicionar comentários nas entradas de configurações dos ativos.

    [1] http://tools.ietf.org/html/rfc1918
    [2] https://under-linux.org/showthread.p...212#post653212
    [3] https://under-linux.org/showthread.p...859#post624859

    Saudações,

    Trober

    Boa noite. Gostaria de saber se OSPF funciona em bridge e vlan?

  16. #16

    Padrão Re: Dúvidas em fechamento do OSPF

    Boa noite Trober, eu tenho que declarar com interface passiva as bridge, os pppoe discadores e pptp vlan como passiva ou nao precisa anunciar elas?



  17. #17

    Padrão Re: Dúvidas em fechamento do OSPF

    Citação Postado originalmente por jwjunior Ver Post
    Boa noite Trober, eu tenho que declarar com interface passiva as bridge, os pppoe discadores e pptp vlan como passiva ou nao precisa anunciar elas?
    Por padrão, quem "não conversa" OSPF com um roteador vizinho (adjacente), fica declarado como passivo. Logo, dependendo do cenário, terá situações de VLAN passiva (ou não).

    Na dúvida, uma regrinha simples: A interface X "conversa" com algum roteador, usando OSPF? Se sim, então não passiva, senão, se não conversa, então passiva