+ Responder ao Tópico



  1. #1

    Padrão Balance PCC Address-List (Dúvida)

    Gostaria de esclarecer uma dúvida.

    O address list seleciona a rota default conforme a marcação "Distance" do link para poder passar os determinados sites fora do balance. certo?

    Tipo:
    link1 "distance 1"
    link2 "distance 2"
    link3 "distance 3"
    .
    .
    .
    Por padrão nesse exemplo o address list redirecionará os sites para o "link1" e se o mesmo falhar ou desligar, o address list enviaria os sites para o "link2" e assim sucessivamente?

    Ou tudo isso é viagem da minha cabeça? Já configurei balance pcc conforme video-aulas e funcionou, mas essa parte eu tô boiando. Queria entender.

    e aê pessoal tô pelo menos perto?

  2. #2

    Padrão Re: Balance PCC Address-List (Dúvida)

    um, parece que vc entendeu um pouco errado as video aulas, ou eu não entendi bem o que vc quis dizer. tem o link dessas video aulas?



  3. #3

    Padrão Re: Balance PCC Address-List (Dúvida)

    Citação Postado originalmente por hagahood Ver Post
    um, parece que vc entendeu um pouco errado as video aulas, ou eu não entendi bem o que vc quis dizer. tem o link dessas video aulas?
    Então amigo. Deixa seu ver se consigo resumir...

    Eu queria entender como o address list direciona os sites para fora do balance.
    Ou seja:

    - Se ele por padrão já joga no 1º link;
    - ou se há como eu escolher qual link eu quero jogar os sites cadastrados no address list.

    Nas vídeo aulas não há nada falando sobre isso. Na internet só acha regras com sites de bancos, jogos, etc... para o address list, mas como ele escolhe determinado link para direcionar esses sites, não fala.

    abs

  4. #4

    Padrão Re: Balance PCC Address-List (Dúvida)

    Bem. no address-list(aba/menu) vc cria uma lista de endereços IP para uma mesma finalidade. Estas listas servem para auxilha-lo a criar as regras no mangle e firewall. Ex. bloquear/permitir acesso a P2P, ou bloquear/permitir acesso a serviços HTTP/SSH/FTP.

    para remover a lista "games" do balanceamento, em um exemplo mais pratico, vc deve criar uma regra mangle, antes das regras de balanceamento, marcando a rota para aquela lista de IP.
    Código :
    /ip firewall address-list add name="games" address=200.201.201.66
     
    /ip firewall mangle add action=mark-routing chain=prerouting src-address-list="games" new-routing-mark=link1


    lembre-se que as regras são executadas em ordem, sendo a que está com menor numero (na primeira coluna) tem prioridade.



  5. #5

    Padrão Re: Balance PCC Address-List (Dúvida)

    Citação Postado originalmente por hagahood Ver Post
    Bem. no address-list(aba/menu) vc cria uma lista de endereços IP para uma mesma finalidade. Estas listas servem para auxilha-lo a criar as regras no mangle e firewall. Ex. bloquear/permitir acesso a P2P, ou bloquear/permitir acesso a serviços HTTP/SSH/FTP.

    para remover a lista "games" do balanceamento, em um exemplo mais pratico, vc deve criar uma regra mangle, antes das regras de balanceamento, marcando a rota para aquela lista de IP.
    Código :
    /ip firewall address-list add name="games" address=200.201.201.66
     
    /ip firewall mangle add action=mark-routing chain=prerouting src-address-list="games" new-routing-mark=link1


    lembre-se que as regras são executadas em ordem, sendo a que está com menor numero (na primeira coluna) tem prioridade.
    ahh ta! vc está me explicando que o certo seria add um mangle para cada IP do address list. é isso?
    essa regra colocada no mangle está direcionando para o link1. Certo?
    E se esse link cair?

  6. #6

    Padrão Re: Balance PCC Address-List (Dúvida)

    ahh ta! vc está me explicando que o certo seria add um mangle para cada IP do address list. é isso?
    não. é justamente o contrario. o address-list serve para vc criar uma lista de diversos ip e criar uma regra so para toda a lista.(falha minha ter colocado so um ip). tipo uma lista de servidores de CS:
    Código :
    /ip firewall address-list add name="games" address=200.201.201.66 
    /ip firewall address-list add name="games" address=200.201.201.69
    /ip firewall address-list add name="games" address=15.201.211.6 
    /ip firewall mangle add action=mark-routing chain=prerouting dst-address-list="games" new-routing-mark=link1
    todos os IPs da lista games saem pela rota (definida em ip/routes) marcada com link1
    Código :
    add comment="rota dos games" distance=1 gateway=177.86.53.1 routing-mark=link1

    essa regra colocada no mangle está direcionando para o link1. Certo?
    sim

    E se esse link cair?
    bem isso varia como está config seu roteador. alguns admins configuram uma rota default (em ip/route), já eu prefiro utilizar um netwash para monitorar os links e direciona-los para o link que eu quero com scripts.



  7. #7

    Padrão Re: Balance PCC Address-List (Dúvida)

    Citação Postado originalmente por hagahood Ver Post
    não. é justamente o contrario. o address-list serve para vc criar uma lista de diversos ip e criar uma regra so para toda a lista.(falha minha ter colocado so um ip). tipo uma lista de servidores de CS:
    Código :
    /ip firewall address-list add name="games" address=200.201.201.66 
    /ip firewall address-list add name="games" address=200.201.201.69
    /ip firewall address-list add name="games" address=15.201.211.6 
    /ip firewall mangle add action=mark-routing chain=prerouting dst-address-list="games" new-routing-mark=link1
    todos os IPs da lista games saem pela rota (definida em ip/routes) marcada com link1
    Código :
    add comment="rota dos games" distance=1 gateway=177.86.53.1 routing-mark=link1


    sim


    bem isso varia como está config seu roteador. alguns admins configuram uma rota default (em ip/route), já eu prefiro utilizar um netwash para monitorar os links e direciona-los para o link que eu quero com scripts.
    Amigo, já estou caindo a ficha aqui. Só mais uma coisa por favor!

    Essa configuração de rotas default no route seria essa?
    Ex: /ip route

    add comment=”Rota Saida sem Load Balance” disabled=no distance=1 dst-address=0.0.0.0/0 gateway=222.222.222.222 scope=30

    target-scope=10

    add comment=”Rota saida sem Load Balance” disabled=no distance=2 dst-address=0.0.0.0/0 gateway=200.200.200.200 scope=30

    target-scope=10

    Daí se o link1 cair o trafego é jogado para o link2? Essa marcação numérica em "distance" seria a ordem a ser seguida caso um link caia. é isso?

    Pra fazer fail-over netwash é mais complicado? Dá pra fazer pra qualquer quantidade de link balanceado?

    abs
    Última edição por Carlosaps; 31-07-2013 às 11:43. Razão: complementação

  8. #8

    Padrão Re: Balance PCC Address-List (Dúvida)

    Citação Postado originalmente por Carlosaps Ver Post
    Amigo, já estou caindo a ficha aqui. Só mais uma coisa por favor!

    Essa configuração de rotas default no route seria essa?
    Ex: /ip route

    add comment=”Rota Saida sem Load Balance” disabled=no distance=1 dst-address=0.0.0.0/0 gateway=222.222.222.222 scope=30

    target-scope=10

    add comment=”Rota saida sem Load Balance” disabled=no distance=2 dst-address=0.0.0.0/0 gateway=200.200.200.200 scope=30

    target-scope=10

    Daí se o link1 cair o trafego é jogado para o link2? Essa marcação numérica em "distance" seria a ordem a ser seguida caso um link caia. é isso?

    Pra fazer fail-over netwash é mais complicado? Dá pra fazer pra qualquer quantidade de link balanceado?

    abs
    isso mesmo mas ele tem que ter a opção "check-gateway=ping"(ou algo assim) para ele saber quando um link está online.

    sim netwash é mais complicado, mas te da um controle maior do trafego. sim, da pra fazer qq quant de links, mas quanto mais links mais complicado é.



  9. #9

    Padrão Re: Balance PCC Address-List (Dúvida)

    Citação Postado originalmente por hagahood Ver Post
    isso mesmo mas ele tem que ter a opção "check-gateway=ping"(ou algo assim) para ele saber quando um link está online.

    sim netwash é mais complicado, mas te da um controle maior do trafego. sim, da pra fazer qq quant de links, mas quanto mais links mais complicado é.
    Então fechou. Muito obrigado hagahood pela ajuda e paciência. Destrinchei as regras aqui e com sua grande ajuda entendi a mágica do balance. hehehe!

    Muito grato!
    abs