+ Responder ao Tópico



  1. #1

    Padrão [ Ajuda ] Adicionar PPPoE numa rede (HOTSPOT com rotas dinamicas via OSPF)

    Boa Trade.
    Estamos tendo problema pra implementar uma rede PPPOE junto com outra rede que já esta funcionado: HOTSPOT+OSPF tudo via radius.
    Porem, quando o cliente pppoe autentica, e o OSPF divulga a rota, alguns minutos depois, o OSPF para de divulgar todas as rotas.
    Verificando no OSPF, vi que as interfaces do PPPOE estão sendo levantadas no OSPF como Point-to-Point.

    Clique na imagem para uma versão maior

Nome:	         2.jpg
Visualizações:	115
Tamanho: 	27,4 KB
ID:      	47264

    Clientes Hotspot 100% funcionando

    Clique na imagem para uma versão maior

Nome:	         3.jpg
Visualizações:	136
Tamanho: 	132,6 KB
ID:      	47266

    Rascunho da rede:
    Clique na imagem para uma versão maior

Nome:	         1.jpg
Visualizações:	158
Tamanho: 	68,3 KB
ID:      	47265

    • Minhas configurações

    PowerEdige
    Loopback: 10.0.0.1/32
    ether1: Link Internet
    ether6: Hotspot (todos os cliente com ip dinâmico /30)
    ether2: OSPF___para____Rb1100_A (via_NBMA)
    ether5: OSPF___para____Rb1100_B (via_NBMA)
    ether7: OSPF___para____Rb1100_C (via_NBMA)
    /routing ospf instance
    set [ find default=yes ] name=LIMO_1 redistribute-connected=as-type-1 router-id=10.0.0.1
    /routing ospf area range
    add area=backbone range=186.y.y.0/20
    add area=backbone range=177.y.y.0/20
    /routing ospf interface
    add interface=LOOPBACK network-type=broadcast
    add interface=ether2 network-type=nbma
    add interface=ether5 network-type=nbma
    add interface=ether7 network-type=nbma
    /routing ospf nbma-neighbor
    add address=10.x.x.22 comment="Rb_1100_A"
    add address=10.x.x.10 comment="Rb_1100_B"
    add address=10.x.x.30 comment="Rb_1100_C"
    /routing ospf network
    add area=backbone comment=Loopback disabled=yes network=10.0.0.1/32
    add area=backbone comment="Rb_1100_A" network=186.y.y.144/28
    add area=backbone comment="Rb_1100_B" network=186.y.y.96/28
    add area=backbone comment="Rb_1100_C" network=186.y.y.112/28


    Rb1100_A
    Loopback: 10.0.2.5
    ether1: 10.x.x.22/30----------- ( fechando OSPF) -------- PowerEdige
    ether3: Hotspot (todos os cliente com ip dinâmico /30)
    ether4: (pretendemos usar pppoe)
    Rb1100_B
    Loopback: 10.0.2.6
    ether1: 10.x.x.30/30----------- ( fechando OSPF) -------- PowerEdige
    ether3: Hotspot (todos os cliente com ip dinâmico /30)
    ether4: (pretendemos usar pppoe)
    Rb1100_C
    Loopback: 10.0.2.7
    ether1: 10.x.x.10/30----------- ( fechando OSPF) -------- PowerEdige
    ether3: Hotspot (todos os cliente com ip dinâmico /30)
    ether3_vlan1: (OSPF para Rb433AH)
    ether4: (pretendemos usar pppoe)
    Rb433AH
    Loopback: 10.0.3.7
    ether1_vlan1: ----------- ( fechando OSPF) -------- Rb1100_C
    ether2: Hotspot (todos os cliente com ip dinâmico /30)
    ether3: (pretendemos usar pppoe)

  2. #2
    tecnico chefe Avatar de naldo864
    Ingresso
    May 2010
    Localização
    Carapicuíba, Brazil, Brazil
    Posts
    3.104
    Posts de Blog
    1

    Padrão Re: [ Ajuda ] Adicionar PPPoE numa rede (HOTSPOT com rotas dinamicas via OSPF)

    verifiquei que sua rede ospf e tipo nbma ou seja uma rede não broadcast ,numa rede deste tipo os roteadores não anunciam suas rotas visto que ele ja se conhecem então se uma interface cai ai fu#@$% para uma parte da rede o grande barato do ospf e poder criar redes que se uma interface cair ela muda para uma outra rota backup assim da tempo de descobrir o que aconteceu sem parar a rede .notei tambem que sua interface pppoe esta em estado down ja e um começo para começar a investigar ok.



  3. #3

    Padrão Re: [ Ajuda ] Adicionar PPPoE numa rede (HOTSPOT com rotas dinamicas via OSPF)

    Citação Postado originalmente por fsoaress76 Ver Post
    Boa Trade.
    Estamos tendo problema pra implementar uma rede PPPOE junto com outra rede que já esta funcionado: HOTSPOT+OSPF tudo via radius.
    Porem, quando o cliente pppoe autentica, e o OSPF divulga a rota, alguns minutos depois, o OSPF para de divulgar todas as rotas.
    Verificando no OSPF, vi que as interfaces do PPPOE estão sendo levantadas no OSPF como Point-to-Point.

    Clique na imagem para uma versão maior

Nome:	         2.jpg
Visualizações:	115
Tamanho: 	27,4 KB
ID:      	47264

    Clientes Hotspot 100% funcionando

    Clique na imagem para uma versão maior

Nome:	         3.jpg
Visualizações:	136
Tamanho: 	132,6 KB
ID:      	47266

    Rascunho da rede:
    Clique na imagem para uma versão maior

Nome:	         1.jpg
Visualizações:	158
Tamanho: 	68,3 KB
ID:      	47265

    • Minhas configurações

    PowerEdige
    Loopback: 10.0.0.1/32
    ether1: Link Internet
    ether6: Hotspot (todos os cliente com ip dinâmico /30)
    ether2: OSPF___para____Rb1100_A (via_NBMA)
    ether5: OSPF___para____Rb1100_B (via_NBMA)
    ether7: OSPF___para____Rb1100_C (via_NBMA)
    /routing ospf instance
    set [ find default=yes ] name=LIMO_1 redistribute-connected=as-type-1 router-id=10.0.0.1
    /routing ospf area range
    add area=backbone range=186.y.y.0/20
    add area=backbone range=177.y.y.0/20
    /routing ospf interface
    add interface=LOOPBACK network-type=broadcast
    add interface=ether2 network-type=nbma
    add interface=ether5 network-type=nbma
    add interface=ether7 network-type=nbma
    /routing ospf nbma-neighbor
    add address=10.x.x.22 comment="Rb_1100_A"
    add address=10.x.x.10 comment="Rb_1100_B"
    add address=10.x.x.30 comment="Rb_1100_C"
    /routing ospf network
    add area=backbone comment=Loopback disabled=yes network=10.0.0.1/32
    add area=backbone comment="Rb_1100_A" network=186.y.y.144/28
    add area=backbone comment="Rb_1100_B" network=186.y.y.96/28
    add area=backbone comment="Rb_1100_C" network=186.y.y.112/28


    Rb1100_A
    Loopback: 10.0.2.5
    ether1: 10.x.x.22/30----------- ( fechando OSPF) -------- PowerEdige
    ether3: Hotspot (todos os cliente com ip dinâmico /30)
    ether4: (pretendemos usar pppoe)
    Rb1100_B
    Loopback: 10.0.2.6
    ether1: 10.x.x.30/30----------- ( fechando OSPF) -------- PowerEdige
    ether3: Hotspot (todos os cliente com ip dinâmico /30)
    ether4: (pretendemos usar pppoe)
    Rb1100_C
    Loopback: 10.0.2.7
    ether1: 10.x.x.10/30----------- ( fechando OSPF) -------- PowerEdige
    ether3: Hotspot (todos os cliente com ip dinâmico /30)
    ether3_vlan1: (OSPF para Rb433AH)
    ether4: (pretendemos usar pppoe)
    Rb433AH
    Loopback: 10.0.3.7
    ether1_vlan1: ----------- ( fechando OSPF) -------- Rb1100_C
    ether2: Hotspot (todos os cliente com ip dinâmico /30)
    ether3: (pretendemos usar pppoe)
    Boa tarde amigo,

    1º - Primeiro, levante os anúncios de loopback em ranges do OSPF (em todos os routers);
    2º - Não distribua rotas conectadas;
    3º - Sumarize as rotas dos clientes PPPoE e crie filtros para que os mesmos não sejam anunciados nas outras áreas de sua rede, deixando assim sua tabela de roteamento menos inflada e por consequência, mais ágil as consultas;
    4º - Não trabalhe com nbma, é desnecessário, lembre-se de fechar seus enlaces sempre em ap-wds + stations wds.

    Faça estas alterações e nos retorne o resultado obtido;

    O caso das interfaces PPPoE aparecerem no OSPF, é normal, o que vc tem que fazer e filtrá-los para que não saiam de seu roteador para os vizinhos, fazendo da forma que citei no 3º item.

    Espero ter ajudado.
    Abraço

  4. #4

    Padrão Re: [ Ajuda ] Adicionar PPPoE numa rede (HOTSPOT com rotas dinamicas via OSPF)

    Estou testando em laboratórios, e postarei os resultados...



  5. #5

    Padrão Re: [ Ajuda ] Adicionar PPPoE numa rede (HOTSPOT com rotas dinamicas via OSPF)

    Relatório de bancadas.


    • 3 notebook conectados em cada ponta com pppoe.
    • Não teve como testar junto, maquinas com hotspot e IP-staticos
    • Não aplicado filtro.
    • Area-A: CloudCore-1036
    • Areb-B: 2 Rbs 600


    Lembramos que em produção vai rodar junto com Hotspot+IP-staticos e tudo com IP-Publico.


    CloudCore-1036

    Clique na imagem para uma versão maior

Nome:	         2.jpg
Visualizações:	119
Tamanho: 	141,0 KB
ID:      	47290

    RB600_1

    Clique na imagem para uma versão maior

Nome:	         1.jpg
Visualizações:	104
Tamanho: 	37,2 KB
ID:      	47291

    RB600_2

    Clique na imagem para uma versão maior

Nome:	         3.jpg
Visualizações:	99
Tamanho: 	54,5 KB
ID:      	47292


    Aguardo comentários.

  6. #6

    Padrão Re: [ Ajuda ] Adicionar PPPoE numa rede (HOTSPOT com rotas dinamicas via OSPF)

    Você esta sumarizando ?
    Como estão seus filtros de rotas?
    Exporte suas regras aqui para que possamos avaliar.



  7. #7

    Padrão Re: [ Ajuda ] Adicionar PPPoE numa rede (HOTSPOT com rotas dinamicas via OSPF)

    Citação Postado originalmente por jilianocg Ver Post
    Você esta sumarizando ?
    Como estão seus filtros de rotas?
    Exporte suas regras aqui para que possamos avaliar.
    Esta vindo um consultor aqui esse dias. vamos esperar. dependo da situação. voltarei aqui para da continuidade.

  8. #8

    Padrão Re: [ Ajuda ] Adicionar PPPoE numa rede (HOTSPOT com rotas dinamicas via OSPF)

    Citação Postado originalmente por fsoaress76 Ver Post
    Esta vindo um consultor aqui esse dias. vamos esperar. dependo da situação. voltarei aqui para da continuidade.
    Certo, qualquer coisa nos reporte.
    Abraço



  9. #9

    Padrão Re: [ Ajuda ] Adicionar PPPoE numa rede (HOTSPOT com rotas dinamicas via OSPF)

    Refiz as configurações aqui (parei tudo na madrugada).

    As cidade que fechamos o LINK via rádio digital com VLAN, o OSPF não funciona via BLOADCAST. Apenas via NBMA.
    A cidade que fechamos via 5.8 funciona sem problema com BLOADCAST.


    Configurações do servidor principal
    ##############################################################################
    /routing ospf instance
    set [ find default=yes ] redistribute-connected=as-type-1 router-id=10.0.0.1

    /routing ospf area range
    add area=backbone comment=Limoeiro range=186.2xx.x0.0/20
    add area=backbone range=177.yyy.y76.0/20

    /routing ospf interface
    add interface=ether5 network-type=nbma
    add interface=ether4 network-type=nbma
    add interface=ether7 network-type=nbma
    add interface=ether2 network-type=broadcast

    /routing ospf nbma-neighbor
    add address=186.xxx.x1.22 comment="Cidade1"
    add address=186.xxx.x0.110 comment="cidade2"
    add address=186.xxx.x1.30 comment="cidade3"
    add address=186.xxx.x1.10 comment="cidade4"

    /routing ospf network
    add area=backbone comment=Loopback network=10.0.0.1/32
    add area=backbone comment="Cidade2" network=186.2xx.x0.96/28
    add area=backbone comment="Cidade1" network=186.2xx.x1.20/30
    add area=backbone comment="Cidade4"network=186.2xx.x1.8/30
    add area=backbone comment="Cidade3"network=186.2xx.x1.28/30
    ########################################################################

    [Cidade2] Configuração da cidade via 5.8 fechando com bloadcast
    /routing ospf instance
    set [ find default=yes ] redistribute-connected=as-type-1 router-id=10.0.2.5
    /routing ospf interface
    add interface=Wan_cidade2 network-type=broadcast
    /routing ospf nbma-neighbor
    add address=186.2xx.x0.97
    /routing ospf network
    add area=backbone network=10.0.2.5/32
    add area=backbone network=186.2xx.x0.96/28
    add area=backbone network=186.2xx.x0.0/20
    add area=backbone network=177.yyy.y76.0/20

    [Cidade1] Configuração da cidade via radio digital com VLAN fechando com nbma
    /routing ospf instance
    set [ find default=yes ] redistribute-connected=as-type-1 router-id=10.0.0.2
    /routing ospf interface
    add interface=Vlan505 network-type=nbma
    /routing ospf nbma-neighbor
    add address=186.2xx.x1.21
    /routing ospf network
    add area=backbone network=10.0.2.6/32
    add area=backbone network=186.2xx.x0.0/20
    add area=backbone network=177.yyy.y76.0/20
    add area=backbone network=186.2xx.x1.20/30

    [Cidade3] Configuração da cidade via radio digital com VLAN fechando com nbma
    /routing ospf instance
    set [ find default=yes ] redistribute-connected=as-type-1 router-id=10.0.0.3
    /routing ospf interface
    add interface=ospf network-type=broadcast
    add interface=LINK network-type=nbma
    /routing ospf nbma-neighbor
    add address=186.2xx.x1.29
    /routing ospf network
    add area=backbone network=10.0.2.7/32
    add area=backbone disabled=yes network=177.yyy.y76.0/20
    add area=backbone disabled=yes network=186.2xx.x0.0/20
    add area=backbone network=186.2xx.x1.28/30

  10. #10

    Padrão Re: [ Ajuda ] Adicionar PPPoE numa rede (HOTSPOT com rotas dinamicas via OSPF)

    Opa boa noite.

    1 - Redistribuição de rotas apenas no primeiro Roteador (Power Edge)

    redistribute-connected=as-type-1


    2 - Autenticação MD5 em todas as conexões OSPF





  11. #11

    Padrão Re: [ Ajuda ] Adicionar PPPoE numa rede (HOTSPOT com rotas dinamicas via OSPF)

    Citação Postado originalmente por caicarabruno Ver Post
    Opa boa noite.

    1 - Redistribuição de rotas apenas no primeiro Roteador (Power Edge)



    2 - Autenticação MD5 em todas as conexões OSPF


    [/COLOR]
    Obrigado pela dica Bruno. vou fazer as alterações aqui.
    Sera que desta forma mudando para broadcast vai subir? Ate o momento ainda estou usando nbma.

  12. #12

    Padrão Re: [ Ajuda ] Adicionar PPPoE numa rede (HOTSPOT com rotas dinamicas via OSPF)

    Citação Postado originalmente por fsoaress76 Ver Post
    Obrigado pela dica Bruno. vou fazer as alterações aqui.
    Sera que desta forma mudando para broadcast vai subir? Ate o momento ainda estou usando nbma.
    Boa tarde,

    Minha Rede esta com OSPF, MPLS + VPLS, em breve iBGP, Vlan e VRF, quando sumarizei minha rede, diminuiu drasticamente o Broadcast e desabilitando o "redistribute-connected=as-type-1" no roteadores que não saem diretamente para internet, sempre uso como exemplo as explicações do TROBER [1], lembrando que o OSPF utiliza multcast através do endereço 224.0.0.5 porta 89, cuidado para não bloquear la na regrinha de BOGONS.

    Interface loopback utilizo como passive, desta forma ela não será definida como DR(Designated Route) ou BDR
    (Backup Designated Route) e será utilizada para identificar os Neighbors.



    [1]
    https://under-linux.org/showthread.p...851#post618154