+ Responder ao Tópico



  1. Citação Postado originalmente por Mephisto Ver Post

    Eriberto..... quando falei aqui nesse topico que eu faço serviço de reparo...e que eu discordava que uma grid que pinga no TFTP nao pode estar com problema de LAN..quase me trucidaram aqui..pq eu devia passar a informação....e nao vender o serviço. passei a informação porem nao deu certo etc. Eu to aqui dando a cara a tapa....e continuo vendendo meu serviço...
    Exato e entendo. O Naglio nao foi muito feliz na escolha do título do tópico, pois nao relata o problema real, mas ele teve o objetivo alcancado, pois o tópico teve respostas e rendeu.

    O título correto seria: Airgrid sem acesso via web ou ssh revive com OpenWRT.

    O problema é o clássico: perda de acesso a interface Web ou ssh após qualquer evento (no meu caso foi uma atualizacao de firmware, desligar o equipamento - pasmem, desligar uma Nanobridge aqui para mim é perigo), etc.

    Você pega um equipamento desses, que as vezes acusa counterfeit e faz o procedimento para resetar e subir o firmware por tftp. Após esse reset e deixarmos o equipamento em modo de recuperacao, ele fica apto para receber o firmware por tftp e volta a responder a pings no ip padrao (192.168.1.20), mas nao permite acesso à interface web e ao ssh, mas recebe o firmware. Você sobe o firmware, faz todo os procedimentos, espera uns 20 minutos, 30 minutos (tempo mais do que suficiente) e o equipamento nao volta. Nao responde a pings, nao permite acesso a interface web e tampouco ao ssh.

    O que o Naglio fez, e que eu entendi, foi ao invés de subir o Airos, subiu o openwrt e sim, teve êxito. Como já chegamos a conclusao, o opernwrt nao acessa certas áreas do flash que o Airos acessa, e portanto o openwrt aceita trabalhar e o Airos nao.

    Fazendo um paralelo com computadores (e um radio nada mais é que um computador seguindo a arquitetura Von Neumann, só que especializado em comunicacao), eles iniciam quando recebem energia, fazem o procedimento do POST (Power On SelfTest), e comecam a inicializar os dispositivos, e só ai, fazem a carga do sistema operacional. Nesse caso, temos um BIOS apoiando e carregando o Airos. A questao que fica é: porque o openwrt consegue ser carregado e o Airos nao? Penso que a configuracao do flash nao é limpa adequadamente pelo programa de tftp. Algo semelhante acontecia com placas Asus, na qual ela só aceitava ter o Bios limpo e pronto para regravacao se usasse um programa próprio da Asus. Ela nao aceitava ser gravada com o gravador do fabricante do Bios por exemplo. Em uma verificacao, notaram que alguns enderecos de memória ficavam travados e por isso os outros flashers nao podiam acessar essas áreas e limpar a memória. Algo semelhante deve ocorrer com os equipamentos da UBNT.

    Nossa maior reclamacao, e já to fazendo disso um mantra, nem é tanto contra a UBNT e sim contra os revendedores, que nos deixam na mao quando tem problemas.

    @Mephisto, o que eu comentei, nao foi contra você ou contra você oferecer seu servico. De certa forma você ainda resolve um problema que o responsável por ele (distribuidor/importador) está fazendo caso omisso. Minha reclamacao sobre vendas foi contra as revendas, pois quando o tópico é para falar bem de um equipamento, eles vivem fazendo spam no tópico, mas se o tópico é para descer o sarrafo, eles passam longe.

    @Chady;, se o pessoal de engenharia inventar uma forma fácil de resetar esses equipamentos, permitindo uma subida eficiente do firmware, o rma de vocês vai cair ainda mais, pois pode notar que boa parte dos problemas se encontra no flash e nao necessariamente no equipamento.

    E reforcando o que o @Djaldair comentou, o rma do meu distribuidor aqui consiste em:
    * resetar o equipamento para ele entrar no modo de recuperacao;
    * subir o firmware por tftp (até aqui eu faco);
    * abrir o equipamento e limpar a porta ethernet (daqui para baixo eu já nao faco, pois envolve abrir o equipamento);
    * dar um "hard reset" (entendo que é para acessar algumas áreas de programacao ou forcar o reset da memória, o famoso reset 30/30/30);
    * tentar subir o firmware de novo;
    * fazer o relatório e dizer que sim, teu equipamento é caso de garantia e que entre em contato com o teu vendedor (espere no mínimo 1 mês de boa vontade).

    Deixo aqui duas sugestoes para a UBNT:
    1ra: tentar facilitar e tornar mais eficiente o processo de recuperacao de equipamentos (Chady já disse ter encaminhado a engenharia da empresa, nos resta aguardar). Isso vai diminuir as reclamacoes e casos de rma.
    2do: garantir a troca facilitada do equipamento. Deu problema? Leva onde você comprou, aguarda um pouco (entre minutos, horas e poucos dias) e ganha um equipamento 0 Km.

    Garanto que com esses dois procedimentos vocês salvam os clientes que ainda ficaram. Tp-Link aqui faz isso. Deu problema? Eles tem uma rede de suporte exclusiva, criada pelo importador para atender os casos de rma. Equipamento está com falha? Ganha um novo.

  2. Achei que isso só acontecesse comigo! Mais não é skynet, pois aqui acontece sempre depois de temporais, não identifica a rede, se tu bota pingar e reseta em determinado momento comessa a responder mais não assessa.



  3. Estou com alguns AirGrid com o mesmo problema apresentado.
    (Respondem ao PING, ás vezes acessa, ás vezes não, ás vezes funciona normal mas qndo desliga/liga novamente para de vez)

    Fiz o seguinte:
    1 - Liguei o rádio já pressionando o botão de reset.
    2 - (respondeu ao ping normal) Enviei via tFtp o fw da OpenWRT (demorou uns 20min)
    3 - Após o fim o rádio reboot e qndo voltou a ficou com a luz POWER acesa, LAN acesa, e o último LED aceso tmb, porém não responde mais.
    Tentei pelos IP's 192.168.1.20, 192.168.1.1, 192.168.1.254..
    Não sei se após o procedimento muda o IP do rádio ou talvez pq não tenha dado certo mesmo.
    Caso algum possa me ajudar.
    Grato!

  4. 20 min.......poxa....pra um arquivo que pode ter no maximo 8 megas.....demoradinho neh
    essse radio provavelmente tem mais problemas...
    nem tudo é FW gente.
    Airgrids...assim como outros equipamentos tem uma vasta gama de possibilidades de problemas...
    desde problemas de alimentação....solda fria..queima de componentes passivos....queima de componentes ativos....problemas de lan...problemas de wireless....enfim....um FW pra sobrepujar todos essas possibilidades beira a magia.



  5. Pois é cara. Sinistro!
    O fw tem 3mb, estranho que qndo up o original da Ubiquiti vai rápido e normal, mas ai o rádio fica com aqueles problemas citados.
    Mas enfim, o IP muda? é normal o último LED acender?






Tópicos Similares

  1. Air Grid M5-HP trabalhando junto com tecnologia AC
    Por Guilhermealonso1 no fórum Redes
    Respostas: 6
    Último Post: 29-12-2014, 12:20
  2. Respostas: 9
    Último Post: 01-06-2014, 12:15
  3. Respostas: 6
    Último Post: 02-01-2014, 22:12
  4. Air Grid com Ponto a Ponto
    Por agnaldos no fórum Redes
    Respostas: 3
    Último Post: 29-05-2012, 14:04
  5. Respostas: 10
    Último Post: 05-01-2007, 14:58

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L