+ Responder ao Tópico



  1. #1

    Padrão Balanceamento de carga

    pessoal queria fazer rota pra sair determinado site por essa rota como faco isso ???

  2. #2

    Padrão Re: Balanceamento de carga

    Citação Postado originalmente por robertopc95 Ver Post
    pessoal queria fazer rota pra sair determinado site por essa rota como faco isso ???
    Tem muito material sobre balanceamento no site, dê uma pesquisada.

    Comece por aqui:
    https://under-linux.org/showthread.p...+balanceamento
    https://under-linux.org/showthread.p...+balanceamento



  3. #3

    Padrão Re: Balanceamento de carga

    Citação Postado originalmente por RickBrito Ver Post
    Tem muito material sobre balanceamento no site, dê uma pesquisada.

    Comece por aqui:
    https://under-linux.org/showthread.p...+balanceamento
    https://under-linux.org/showthread.p...+balanceamento
    brigado pela informacao mais eu queira tipo assim
    tenho dois link, um dedicado(30mb) e o outro é DSL(GVT 50MB). um link dedicado ja esta funcionado beleza agora eu queria colocar a DSL para sair algun site pra descarregar o link dedicado q ta muito carregado.
    observacao nesta mesma RB ja tem thunder junto mesmo assim não ta dano conta no horario de pico.

  4. #4

    Padrão Re: Balanceamento de carga

    o que vc quer fazer da pra fazer sim amigo usando o mikrotik mesmo ou c nao usando o squid....
    vc pode com o squid colocar determinada extanção saindo por determinada rota por exemplo

    .exe
    .avi
    eh tambem determinado site

    Abraço



  5. #5

    Padrão Re: Balanceamento de carga

    Citação Postado originalmente por Pupa Ver Post
    o que vc quer fazer da pra fazer sim amigo usando o mikrotik mesmo ou c nao usando o squid....
    vc pode com o squid colocar determinada extanção saindo por determinada rota por exemplo

    .exe
    .avi
    eh tambem determinado site

    Abraço
    mais ja uso mikotik com thunder o problema q meu link dedicado na esta suportado a carga e eu nao quero usar load balance
    eu só quero desviar alguns site q pessoal pra essa DSL

  6. #6

    Padrão Re: Balanceamento de carga

    da pra fazer sim amigo
    da pra desviar os site pra essa adsl sem problema ...
    qualquer site que vc quizer



  7. #7

    Padrão Re: Balanceamento de carga

    Citação Postado originalmente por Pupa Ver Post
    da pra fazer sim amigo
    da pra desviar os site pra essa adsl sem problema ...
    qualquer site que vc quizer

    como faco isso ??

  8. #8

    Padrão Re: Balanceamento de carga

    Esta ai.

    Mas antes de aplicar faça laboratório,

    [1] Aqui é a marcação de Rotas, pois primeiramente você precisará marcar o que você quer.

    /ip firewall mangle
    add chain=prerouting action=mark-routing new-routing-mark=LINK_ADSL passthrough=no protocol=tcp dst-address-list=ADSL_GVT
    [2] Como não sei quais sites você gostaria de mandar para lá você precisará adicionar o IP dos sites que deseja enviar para o ADSL

    /ip firewall addre-list
    add name=ADSL_GVT address="ip do site"
    [3] E aqui finalmente você vai indicar para qual link a marcação que você fez, deverá sair.
    /ip route
    add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe_gvt routing-mark=ADSL_GVT scope=30 target-scope=10
    [4] Existem várias formas de você fazer isto, por porta, protocolo, etc. Na Wiki da Mikrotik existe uma infinidade de receitas de bolo

    Abraços



  9. #9

    Padrão Re: Balanceamento de carga

    fiz isso nao funcionou amigao

  10. #10

    Padrão Re: Balanceamento de carga

    Posta as regras.


    /ip route export

    /ip firewall mangle export

    /ip firewall address0list export



    OBS.: Apenas as regras aplicadas para o fim desejado.



  11. #11

    Padrão Re: Balanceamento de carga

    /ip firewall mangle
    add action=mark-routing chain=prerouting comment=MARCK.GVT disabled=yes \
    dst-address-list=Link-GVT in-interface=ether4-Saida-Enlace \
    new-routing-mark=GVT passthrough=yes
    add action=mark-routing chain=prerouting comment=PC.THUNDER7.1 disabled=no \
    dst-address-list=!No_Cache dst-port=80 in-interface=!ether3-Thunder \
    new-routing-mark=thunder-rota passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting disabled=no dst-port=80 \
    in-interface=ether3-Thunder new-connection-mark=Thunder_Out passthrough=\
    yes protocol=tcp
    add action=mark-routing chain=prerouting connection-mark=Thunder_Out \
    disabled=no in-interface=!ether3-Thunder new-routing-mark=thunder-rota \
    passthrough=yes protocol=tcp src-port=80
    add action=mark-packet chain=postrouting comment=DSCP.THUNDER disabled=no \
    dscp=18 new-packet-mark=Thunder_Pacot passthrough=yes
    add action=add-dst-to-address-list address-list=Link-GVT \
    address-list-timeout=1d chain=prerouting comment=\
    "Site Direcionado para GVT" content=youtube.com disabled=yes \
    in-interface=ether2-Saida-Base protocol=tcp


    /ip route
    add comment="Link- GVT - DSL" disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=192.168.25.1 routing-mark=GVT scope=30 \
    target-scope=10
    add comment="Thunder Cache" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.200.10.2 routing-mark=thunder-rota \
    scope=30 target-scope=10
    add comment="Link Dedicado" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=187.17.50.xx scope=30 target-scope=10


    /ip firewall address-list
    add address=74.125.0.0/16 comment=youtube disabled=yes list=Link-GVT


    /ip address
    add address=172.16.1.1/30 comment=">>> CLIENTE01<<<" disabled=yes interface=ether2-Saida-Base network=172.16.1.0
    add address=172.16.2.1/30 comment=>>>RB450g-CLIENTE02<<< disabled=no interface=ether4-Saida-Enlace network=172.16.2.0
    add address=172.16.3.1/30 comment=>>>MICRO-CLIENTE03<<< disabled=no interface=ether2-Saida-Base network=172.16.3.0
    add address=192.200.10.1/24 comment=Thunder-Cache disabled=no interface=ether3-Thunder network=192.200.10.0
    add address=192.168.25.152/24 comment="Link - GVT - DSL" disabled=no interface=ether4-Saida-Enlace network=192.168.25.0
    add address=10.100.10.1/24 comment=ether2-Mk-auth disabled=no interface=ether5-Mk-Auth network=10.100.10.0
    add address=187.17.50.xx/30 comment="Link Dedicado" disabled=no interface=ether1-Link network=187.17.50.48

  12. #12

    Padrão Re: Balanceamento de carga

    Opa,

    Esta ai a regra,


    /ip firewall mangle
    add action=mark-routing chain=prerouting protocol=tcp dst-port=80 comment=MARCK.GVT disabled=yes dst-address-list=Link-GVT in-interface=ether4-Saida-Enlace new-routing-mark=GVT passthrough=yes

    add action=mark-routing chain=prerouting protocol=tcp dst-port=443 disabled=yes dst-address-list=Link-GVT in-interface=ether4-Saida-Enlace new-routing-mark=GVT passthrough=yes

    /ip firewall address-list
    add name=Link-GVT address="74.125.228.0/25" comment="RANGE IP YOUTUBE"

    /ip route
    add comment="Link- GVT - DSL" disabled=yes distance=3 dst-address=0.0.0.0/0 gateway=192.168.25.1 routing-mark=GVT scope=30 target-scope=10

    Testa sem o thunder, coloca o ip de um site que não tenha um range tão grande de IPS, como disse no post anterior faça laboratório antes de colocar em prod, no meu ambiente funciona.



  13. #13

    Padrão Re: Balanceamento de carga

    fiz nada

    Citação Postado originalmente por caicarabruno Ver Post
    Opa,

    Esta ai a regra,





    Testa sem o thunder, coloca o ip de um site que não tenha um range tão grande de IPS, como disse no post anterior faça laboratório antes de colocar em prod, no meu ambiente funciona.

  14. #14

    Padrão Re: Balanceamento de carga

    Citação Postado originalmente por robertopc95 Ver Post
    fiz nada
    Amigo vi que ninguém te deu uma solução gratuita ainda, porem existe algumas pagas que posso indicar:

    1 - Curso de load ballance do David Marcony - https://www.facebook.com/events/249600908497808/?ref=2

    2 - O amigo "Pirigoso" aqui do Under e consultor de TC poderia te ajudar - Skype: adcd_comprasonline

    OBS: Caso não consiga ajuda, poderá recorrer a soluções pagas citadas acima.



  15. #15

    Padrão Re: Balanceamento de carga

    qualquer coisa posso dar essa consultoria pra vc podemos combinar um horario ...
    faço as regras eh te dou a explicação para vc mesmo ir fazendo os proximo que vc quizer colocar

    Ah seu Thunder roda encima do que ?


    abraço

  16. #16

    Padrão Re: Balanceamento de carga

    Citação Postado originalmente por Pupa Ver Post
    qualquer coisa posso dar essa consultoria pra vc podemos combinar um horario ...
    faço as regras eh te dou a explicação para vc mesmo ir fazendo os proximo que vc quizer colocar

    Ah seu Thunder roda encima do que ?


    abraço
    das 8 ate 22 horas to disponível



  17. #17

    Padrão Re: Balanceamento de carga

    eh ai amigo jah consequio fazer o seu balanciamento ?

    qualquer coisa podemos combinar um horario

    abraço

  18. #18

    Padrão Re: Balanceamento de carga

    Roberto ainda não tive tempo para montar um laboratório conforme a sua estrutura.

    Mas ainda não desisti de fazer funcionar.

    Assim que tiver algo posto para você testar, isso se você quiser.

    abraços