+ Responder ao Tópico



  1. #1

    Padrão Change Ip script mudado de ip

    Olá amigos do underlinux, venho aqui pedir a ajudar de vcs.
    Tenho 3 LoadBalance na minha rede
    1 Load Balance: 3 ADSL RB750g
    2 Load Balance: 4 ADSL RB1100
    3 Load Balance: É a entradas dos 2 link RB750g, RB1100

    Bem coloco o script pra rodar no 1 load balance, roda perfeito, porem quando ele muda de ip ele ja pega o ip da rede 2 Load Balance, sendo q quando ele muda de ip nao consigo mais acessar o load balance 1 e sim o load balance 2 e assim vice verso.
    Como posso fazer para que o script rodando em apenas um load balance, pode me dar acesso a toda rede tanto um como o outro mesmo mudando o ip.

    # Dynamic DNS Update / Simple Edition
    # Written by Sam Norris, ChangeIP.com
    # Copyright ChangeIP.com 2009-2010
    # For support send mail to [email protected]
    #
    # 2009-06-22 RouterOS 3.25 Tested
    # 2009-10-05 RouterOS 4.01rc1 Tested
    #
    # OVERVIEW: %
    # This script will update a ChangeIP.com dynamic dns hostname
    # with an ip address located directly on an interface.
    # %
    # NOTES: %
    # IF THIS SCRIPT DOES NOT PRODUCE ANY OUTPUT PLEASE COPY AND PASTE IT
    # AGAIN. THERE PROBABLY IS A LINE BREAK IN THE WRONG PLACE! Once you
    # have created this script and tested that it works by running it
    # manually you can schedule it to run every few minutes.
    # %
    # CONFIGURATION FIELD DEFINITIONS:
    # ddnsuser: Enter your ChangeIP.com user id.
    # ddnspass: Enter your ChangeIP.com password.
    # ddnshost: Enter the hostname (www.example.com) to update.
    # ddnsinterface: Enter an interface name - case sensative.
    # %
    # %
    # %
    # %
    # % % %
    # % % %
    # % % %
    # %
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    # EDIT YOUR DETAILS / CONFIGURATION HERE
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    :global ddnsuser ""
    :global ddnspass ""
    :global ddnshost ""
    :global ddnsinterface "pppoe-out1"
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    # END OF USER DEFINED CONFIGURATION
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    :global ddnssystem ("mt-" . [/system package get [/system package find name=system] version] )
    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
    :global ddnslastip

    :if ([:len [/interface find name=$ddnsinterface]] = 0 ) do={ :log info "DDNS: No interface named $ddnsinterface, please check configuration." }

    :if ([ :typeof $ddnslastip ] = "nothing" ) do={ :global ddnslastip 0.0.0.0/0 }

    :if ([ :typeof $ddnsip ] = "nothing" ) do={

    :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")

    } else={

    :if ($ddnsip != $ddnslastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ ut [/tool dns-update name=$ddnshost address=[ick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip

    } else={

    :log info "DDNS: No changes necessary."

    }

    }

    # END OF SCRIPT

  2. #2

    Padrão Re: Change Ip script mudado de ip

    Código :
    /system script
    add name=DDNSC policy=\
        ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
        source="/tool dns-update name=SEU HOST address=127.0.0.255 key-\
        name=LOGIN key=\"SENHA\""

    Coloque na RB que disca o pppoe e depois faça o redirecionamento de porta, apenas alterando as portas do winbox, assim com apenas 1 DNS você acessa sua rede toda, uso aqui assim e funciona de boas.

    OBS: Não esqueça do scheduler.



  3. #3

    Padrão Re: Change Ip script mudado de ip

    coloquei os dois porem só da user e senha errada no logo e antes funcionava será q é pq o site atualizou?

  4. #4

    Padrão Re: Change Ip script mudado de ip

    aqui ja esta funcionando normal, acho q era apenas atualizaçao deles!



  5. #5

    Padrão Re: Change Ip script mudado de ip

    Sim, o script já voltou a funcionar.

    Porem uma coisa impressionante é o suporte deles, você envia um ticket e em menos de 5hrs eles já responde, muito bacana, quando vencer minha licença do DynDNS, irei migrar para o plano PRO do ChangeIP.

  6. #6

    Padrão Re: Change Ip script mudado de ip

    Citação Postado originalmente por RickBrito Ver Post
    Sim, o script já voltou a funcionar.

    Porem uma coisa impressionante é o suporte deles, você envia um ticket e em menos de 5hrs eles já responde, muito bacana, quando vencer minha licença do DynDNS, irei migrar para o plano PRO do ChangeIP.

    O meu ainda não poderia me ajuda
    atualiza no site
    mais dentro do Mk não atualiza
    no caso não consigo acesssa
    xxxxx.ddns.info
    ai vou no site e la tem o histórico
    pego o ip e vai normal, aguem ai um help



  7. #7

    Padrão Re: Change Ip script mudado de ip

    Citação Postado originalmente por gelsonteo Ver Post
    O meu ainda não poderia me ajuda
    atualiza no site
    mais dentro do Mk não atualiza
    no caso não consigo acesssa
    xxxxx.ddns.info
    ai vou no site e la tem o histórico
    pego o ip e vai normal, aguem ai um help
    Amigo use esse script que não tem erro:
    http://wiki.mikrotik.com/wiki/Dynami...r_ChangeIP.com

  8. #8

    Padrão Re: Change Ip script mudado de ip

    Citação Postado originalmente por RickBrito Ver Post
    Amigo use esse script que não tem erro:
    http://wiki.mikrotik.com/wiki/Dynami...r_ChangeIP.com
    estou usando este ai e está funcionando vamos ver até quando né se o pessoal do changeip não altera novamente nada.



  9. #9

    Padrão Re: Change Ip script mudado de ip

    Eu acessei o link acima, tem 3 scripts na pagina, qual devo escolher ? Depois de eu mudar os dados da minha conta e etc, como eu adiciono esse script na minha rb ? Uma vez eu fiz, soh que manual, fui em script e adicionei, depois eu fui em schedule e tbm criei uma regra lah e etc, alguem pode me ajudar ? Abraços !