+ Responder ao Tópico



  1. Passei as últimas 2 horas testando o script abaixo, funcionou perfeitamente inclusive rodando de um load balance com diversos links, nele é possível escolher qual link irá acessar o changeip.com, funcionou perfeitamente após alguns ajustes então amigo a sua conta pode estar inativa ou você pode ter outro problema que não seja o changeip.com.

    EthLinkA é a interface que tiver o ip público.
    As rotas estáticas serão alteradas de acordo com a interface para fazer o seu balance acessar o changeip sempre pelo link que estiver enviando o ip, assim não vai haver erro na detecção do ip pelo site.

    # New ChangeIP Dynamic DNS Update 04/10/2013 - Mikrotik 2 3 4 5 6
    # Compliado por Luciano Rampanelli, m4d3@homail.com - pcram.com.br
    #
    #Adicione manualmente as rotas abaixo para utilização em loadbalance:
    #/ip route add comment=CHANGEIP disabled=no distance=1 dst-address=204.16.170.0/24 gateway=EthLinkA scope=30 target-scope=10
    #/ip route add comment=CHANGEIP disabled=no distance=1 dst-address=209.208.4.0/24 gateway=EthLinkA scope=30 target-scope=10


    :global ddnsuser "seuuser"
    :global ddnspass "suasenha"
    :global ddnshost "seudominio.ddns.us"
    :global ifaceddns "EthLinkA"
    :global lastddnsip
    :global lastgat


    ##################################################################################


    :if ([:len [/interface find name=$ifaceddns]] = 0 ) do={ :log info "DDNS: Interface $ifaceddns nao encontrada, verifique."} else={


    :global ifaceip [/ip address get [find interface=$ifaceddns] address]
    :global ddnsip $ifaceip


    :if ([ :typeof $ddnsip ] = "nothing" ) do={
    :log info ("DDNS: Sem IP na interface " . $ifaceddns . ", verifique.")
    } else={
    :if ($ddnsip != $lastddnsip) do={
    :log info "DDNS: Setando gateway para $ifaceddns"
    :put [/ip route set [ find comment="CHANGEIP" ] gateway=$ifaceddns]
    :log info "DDNS: Atualizando, aguarde..."
    :log info [ :put [/tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global lastddnsip $ddnsip
    } else={
    :log info "DDNS: Sem modificacao."
    }
    }


    }


    Segue logs:
    Date Stamp Affected Result URL Query String Detected IP SSL User Agent
    10/04/2013 12:46:16 PM D:1 R:1 S:1 200 /nic/update?ip=187.x.x.115&hostname=x.ddns.us 187.x.x.115 1 Mikrotik/5.x
    10/04/2013 12:45:59 PM D:1 R:1 S:1 200 /nic/update?ip=187.x.x.61&hostname=x.ddns.us 187.x.x.61 1 Mikrotik/5.x
    10/04/2013 12:45:44 PM D:1 R:1 S:1 200 /nic/update?ip=200.x.x.176&hostname=x.ddns.us 200.x.x.176 1 Mikrotik/5.x


    Mais scripts em:
    http://wiki.mikrotik.com/wiki/Scripts

  2. vou testar aki pra ver o antigo tbm ta funcionando porem o ip parece que não atualiza vou ver com este obrigado.



  3. Citação Postado originalmente por m4d3 Ver Post
    Passei as últimas 2 horas testando o script abaixo, funcionou perfeitamente inclusive rodando de um load balance com diversos links, nele é possível escolher qual link irá acessar o changeip.com, funcionou perfeitamente após alguns ajustes então amigo a sua conta pode estar inativa ou você pode ter outro problema que não seja o changeip.com.

    EthLinkA é a interface que tiver o ip público.
    As rotas estáticas serão alteradas de acordo com a interface para fazer o seu balance acessar o changeip sempre pelo link que estiver enviando o ip, assim não vai haver erro na detecção do ip pelo site.




    Segue logs:
    Date Stamp Affected Result URL Query String Detected IP SSL User Agent
    10/04/2013 12:46:16 PM D:1 R:1 S:1 200 /nic/update?ip=187.x.x.115&hostname=x.ddns.us 187.x.x.115 1 Mikrotik/5.x
    10/04/2013 12:45:59 PM D:1 R:1 S:1 200 /nic/update?ip=187.x.x.61&hostname=x.ddns.us 187.x.x.61 1 Mikrotik/5.x
    10/04/2013 12:45:44 PM D:1 R:1 S:1 200 /nic/update?ip=200.x.x.176&hostname=x.ddns.us 200.x.x.176 1 Mikrotik/5.x


    Mais scripts em:
    http://wiki.mikrotik.com/wiki/Scripts

    Amigo me diga uma coisa seu ip é fixo

  4. Citação Postado originalmente por m4d3 Ver Post
    Passei as últimas 2 horas testando o script abaixo, funcionou perfeitamente inclusive rodando de um load balance com diversos links, nele é possível escolher qual link irá acessar o changeip.com, funcionou perfeitamente após alguns ajustes então amigo a sua conta pode estar inativa ou você pode ter outro problema que não seja o changeip.com.
    o script ta ok estada dando dns com sucesso porem pelo ddns não conecta só na hora que eu crio passado alguns minutos cai e não vai mais.



  5. aqui voltou a funcionar normalmente, acho que eles arrumaram o servidor novamente, estou usando o mesmo script de antes e esta OK






Tópicos Similares

  1. acesso remoto GEOVISON por wabcam ou multicast(redirecionar portas)
    Por linikersoares no fórum Servidores de Rede
    Respostas: 17
    Último Post: 19-07-2012, 23:02
  2. Problemas com netbios e acesso remoto mikrotik!!!
    Por RicardoMoura no fórum Redes
    Respostas: 4
    Último Post: 20-01-2011, 17:47
  3. não acesso remotamente mikrotik por ip fixo
    Por williamterencio no fórum Redes
    Respostas: 9
    Último Post: 27-12-2010, 14:37
  4. Acesso ao Mikrotik por FTP
    Por EdilsonLSouza no fórum Redes
    Respostas: 1
    Último Post: 13-12-2008, 09:09
  5. Acesso ao Mikrotik por mac address
    Por Good_speed no fórum Redes
    Respostas: 10
    Último Post: 05-05-2007, 01:22

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L