Página 2 de 4 PrimeiroPrimeiro 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #21

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    Citação Postado originalmente por ruanserver Ver Post
    poxa pessoal até coloquei o script la no mikrotik,

    porém aonde mudar exatamente pois estou com dúvidas em relação a isso.

    :local IpCurrent [/ip address get [find interface=$WANInter] address];:for i from=( [:len $IpCurrent] - 1) to=0 do={
    :if ( [ick $IpCurrent $i] = "/") do={
    :local NewIP [ick $IpCurrent 0 $i];
    :if ([:resolve $NOIPDomain] != $NewIP) do={
    /tool fetch mode=http user=$NOIPUser password=$NOIPPass url="http://dynupdate.no-ip.com/nic/update\3Fhostname=$NOIPDomain&myip=$NewIP" keep-result=no
    :log info "NO-IP Update: $NOIPDomain - $NewIP"
    }
    }
    }
    Amigo eu to esperando uma solução do chamgeip , mais se eu entendi vc não copiou todo o codigo , onde esta em negrito é onde muda eu só não sei o que é esse interface do link

    :local NOIPUser "[email protected]"
    :local NOIPPass "SENHA"
    :local WANInter "INTERFACE_DO_LINK"


    ###############################################


    :local NOIPDomain "SEUDOMINIO.no-ip.xxx"


    :local IpCurrent [/ip address get [find interface=$WANInter] address];
    :for i from=( [:len $IpCurrent] - 1) to=0 do={
    :if ( [ick $IpCurrent $i] = "/") do={
    :local NewIP [ick $IpCurrent 0 $i];
    :if ([:resolve $NOIPDomain] != $NewIP) do={
    /tool fetch mode=http user=$NOIPUser password=$NOIPPass url="http://dynupdate.no-ip.com/nic/update\3Fhostname=$NOIPDomain&myip=$NewIP" keep-result=no
    :log info "NO-IP Update: $NOIPDomain - $NewIP"
    }
    }
    }



    se ajudei agradecer é sempre bom

  2. #22

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    só uma duvida amigo fagtinti com esse script o ddns se atualiza sozinho em caso de mudança de ip?



  3. #23

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    aproveitando o topico o scritp para atualizar o ddns

    /system scheduler
    add disabled=no interval=5m name=InstallAPP on-event=\
    "/ system script run MeuDDNS" policy=\
    reboot,read,write,policy,test,password,sniff,sensitive start-date=\
    jan/01/1970 start-time=00:00:00

  4. #24

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    Citação Postado originalmente por Rodriguinhow Ver Post
    só uma duvida amigo fagtinti com esse script o ddns se atualiza sozinho em caso de mudança de ip?

    Amigo Rodriguinhow eu só tentei ajudar o amigo que tinha duvida eu na verdade nunca usei , eu to no mesmo barco que todos aqui estou esperando um script que funcione no chamge-ip novo



  5. #25

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    galera estou no mesmo problema, sera que não seria um novo script, ja que o site mudou, caso algum tenha poste ai , vlw.

  6. #26

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    consegui rodar o script para o no ip, tb utilizei o antigo script para fazer atualizar o ip só falta saber se realmente está funcionando, hj a noite eu poso a resposta para os amigos!, abraço.



  7. #27

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    caro amigo rodriguinnow, caso vc tenha conseguido, por favor passe pra gente, mas se possivel passe o passo a passo, pois existe uma grande galera que tem dificuldades em fazer, entao quanto mais detalhado melhor, se possivel o script e o passo a passo la no site do no ip, e diga tambem se la é gratuito, abraços...

  8. #28

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    está complicado mesmo,,

    ja coloquei o script, la certinho porém sei que estou errando em alguma coisa,

    dar uma ajuda ai pessoal



  9. #29

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    amigos acabei de chegar em casa já estou providenciando o script pra você com um passo a passo bem simples e detalhado ( direto ao assunto ), abraços.

  10. #30

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    esperando...

    acho que estou errando aonde alterar os dados corretamente.



  11. #31

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    Lá vai!!

    DDNS PARA O NO-IP ( TESTADO NA VERTÃO 6.X )



    /system script
    add name=ddns policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
    source=":local IpCurrent [/ip address get [find interface=\$WANInter] addr\
    ess];\r\
    \n:for i from=( [:len \$IpCurrent] - 1) to=0 do={ \r\
    \n:if ( [ick \$IpCurrent \$i] = \"/\") do={ \r\
    \n:local NewIP [ick \$IpCurrent 0 \$i];\r\
    \n:if ([:resolve \$NOIPDomain] != \$NewIP) do={\r\
    \n/tool fetch mode=http user=EMAIL.NO-IP password=SUA SENHA\
    url=\"http://dynupdate.no-ip.com/nic/update\\3Fhostname=SEU HOST.NO-IP\
    \" keep-result=no\r\
    \n:log info \"NO-IP Update: \$NOIPDomain - \$NewIP\"\r\
    \n}\r\
    \n} \r\
    \n}"


    =========================================================================================

    ATUALIZAR O DDNS ( ELE ATUALIZA MÁS MEU LINK AINDA NÃO CAIU PRA RENOVAR O IP ENTÃO TESTEM AI )



    /system scheduler
    add interval=2m name=InstallAPP on-event="/ system script run ddns" policy=\
    reboot,read,write,policy,test,password,sniff,sensitive start-date=\
    jan/01/1970 start-time=00:00:00



    ===========================================================================================

    Testem ai se ajudei clica ai na estrelinha por favor.

  12. #32

    Lightbulb Re: Acesso remoto mikrotik por chamge-ip

    Basta revalidar o seu login e utilizar normalmente o changeip.com com o script abaixo:

    :global ddnsuser "seuusuario"
    :global ddnspass "suasenha"
    :global ddnshost "seudominioddns.changeip.com"
    :global ddnsinterface "InterfaceParaPegarIP"
    #=======================================#


    :global ddnssystem ("mt-" . [/system package get [/system package find name=system] version] )
    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
    :global ddnslastip


    :if ([:len [/interface find name=$ddnsinterface]] = 0 ) do={ :log info "DDNS: Interface nao existe $ddnsinterface, verifique." }


    :if ([ :typeof $ddnslastip ] = "nothing" ) do={ :global ddnslastip 0.0.0.0/0 }


    :if ([ :typeof $ddnsip ] = "nothing" ) do={


    :log info ("DDNS: Nenhum IP presente na interface " . $ddnsinterface . ", verifique.")


    } else={


    :if ($ddnsip != $ddnslastip) do={


    :log info "DDNS: Enviando atualizacao!"
    :log info [ ut [/tool dns-update name=$ddnshost address=[ick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip


    } else={


    :log info "DDNS: Atualizacao desnecessaria."


    }


    }

    Procedimento testado e em pleno funcionamento mesmo após a mudança ocorrida no site, apenas é necessário revalidar o seu cadastro clicando em reenviar senha, depois no e-mail clique no link e informe a nova senha (que pode ser a mesma antiga).

    Abraço a todos...



  13. #33

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    mais rodriguinho, meu modem está em bridge,,,,

    nao tem que alterar tambem o nome da interface?

  14. #34

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    É verdade, desculpe



  15. #35

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    amigo m4d3 veja se minhas alterações estão corretas pois está dando erro na v 6.x


    :global ddnssystem ("mt-" . [/system package get [/system package find name=system] version] )
    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
    :global ddnslastip


    :if ([:len [/interface find name=$ddnsinterface]] = 0 ) do={ :log info "DDNS: Interface nao existe $ddnsinterface, verifique." }


    :if ([ :typeof $ddnslastip ] = "nothing" ) do={ :global ddnslastip 0.0.0.0/0 }


    :if ([ :typeof $ddnsip ] = "nothing" ) do={


    :log info ("DDNS: Nenhum IP presente na interface " . $ddnsinterface . ", verifique.")


    } else={


    :if ($ddnsip != $ddnslastip) do={


    :log info "DDNS: Enviando atualizacao!"
    :log info [ ut [/tool dns-update name=HOST address=[ick $ddnsip 0 [:find $ddnsip "/"] ] key-name=USUÁRIO key=SENHA ] ]
    :global ddnslastip $ddnsip


    } else={


    :log info "DDNS: Atualizacao desnecessaria."


    }



    Se eu estiver errado por favor me corriga, pois está dando erro, obrigado.

  16. #36

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    onde alterar corretamente o nome da interface??? pois estou vendo aqui waninterface, porém tem que alterar corretamente para nao ter erros.



  17. #37

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    Bom dia pessoal

    Hoje o meu router conectou no changeip e atualizou o ip, estou usando a os 2.9 mikrotik

    :log info "DDNS Begin"
    :global ddns-user "*******"
    :global ddns-pass "*******"
    :global ddns-interface "******"
    :global ddns-host "host.changeIP.com"
    :global ddns-ip [/ip address get [/ip address find interface=$ddns-interface] address]
    :if {[ :typeof $ddns-lastip] = nil } do={ :global ddns-lastip 0.0.0.0/0 }
    :if {[ :typeof $ddns-ip] = nil} do={
    :log info "DDNS: No addres present on your interface, plesae check."
    } else={
    # :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending update!"
    :log info [/tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    # :global ddns-lastip $ddns-ip
    # } else={
    # :log info ("DDNS: No change.")
    # }
    }
    :log info ("DDNS: End.")

  18. #38

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    opa vou testar :f



  19. #39

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    ESSE AQUI FUNFOU NO CHANGE IP NO MK V6.X JÁ NA 5.X NÃO RODOU TESTEM!!!

    :global ddnsuser "USUÁRIO"
    :global ddnspass "SENHA"
    :global ddnshost "HOST CHANGE IP"
    :global ddnsinterface "INTERFACE DE ENTRADA DO LINK"
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    # END OF USER DEFINED CONFIGURATION
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~


    :global ddnssystem ("mt-" . [/system package get [/system package find name=system] version] )
    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
    :global ddnslastip


    :if ([:len [/interface find name=$ddnsinterface]] = 0 ) do={ :log info "DDNS: No interface named $ddnsinterface, please check configuration." }


    :if ([ :typeof $ddnslastip ] = "nothing" ) do={ :global ddnslastip 0.0.0.0/0 }


    :if ([ :typeof $ddnsip ] = "nothing" ) do={


    :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")


    } else={


    :if ($ddnsip != $ddnslastip) do={


    :log info "DDNS atualizado com sucesso"
    :log info [ ut [/tool dns-update name=$ddnshost address=[ick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip


    } else={


    :log info "não foi necessário atializar o ddns"


    }


    }


    # END OF SCRIPT


    Obs: Preciso de um script que rode na versão 5.x no change ip quem tiver por favor manda detalhado!!

  20. #40

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    Citação Postado originalmente por m4d3 Ver Post
    Basta revalidar o seu login e utilizar normalmente o changeip.com com o script abaixo:



    Procedimento testado e em pleno funcionamento mesmo após a mudança ocorrida no site, apenas é necessário revalidar o seu cadastro clicando em reenviar senha, depois no e-mail clique no link e informe a nova senha (que pode ser a mesma antiga).

    Abraço a todos...


    Amigo fiz isso mais para mim não funcionou