Página 4 de 4 PrimeiroPrimeiro 1234
+ Responder ao Tópico



  1. #61

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    Basta usar esse script, ele voltou a funcionar normalmente.

    *TESTADO

    http://wiki.mikrotik.com/wiki/Dynami...r_ChangeIP.com

  2. #62

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    Bom Amigos do forum ,com esse script funcionou finalmente .


    Esse é o script

    Crie o script com nome de DDNS

    :global ddnsuser "Usuario"
    :global ddnspass "Senha"
    :global ddnshost "endereço de dominio"
    :global ifaceddns "interface do ip exemplo pppoe-out2"
    # daqui para baixo não precisa alterarnada
    :global lastddnsip
    :global lastgat




    ##################################################################################




    :if ([:len [/interface find name=$ifaceddns]] = 0 ) do={ :log info "DDNS: Interface $ifaceddns nao encontrada, verifique."} else={




    :global ifaceip [/ip address get [find interface=$ifaceddns] address]
    :global ddnsip $ifaceip




    :if ([ :typeof $ddnsip ] = "nothing" ) do={
    :log info ("DDNS: Sem IP na interface " . $ifaceddns . ", verifique.")
    } else={
    :if ($ddnsip != $lastddnsip) do={
    :log info "DDNS: Setando gateway para $ifaceddns"
    ut [/ip route set [ find comment="CHANGEIP" ] gateway=$ifaceddns]
    :log info "DDNS: Atualizando, aguarde..."
    :log info [ ut [/tool dns-update name=$ddnshost address=[ick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global lastddnsip $ddnsip
    } else={
    :log info "DDNS: Sem modificacao."
    }
    }




    }



    Depois do script

    criar o scherduler com o nome update
    colocar irtervalo de 5 ou 10 min do jeito que quiser
    e execute o script

    / system script run DDNS

    Pronto só testar



  3. #63

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    Nao entendi sera que vc pode ser mais claro de como fazer o passo a asso , por favor.
    Se possivel m add no skype: alessandro.rodrigues30
    fico no aguarde, abraços.

  4. #64

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    Citação Postado originalmente por RickBrito Ver Post
    Basta usar esse script, ele voltou a funcionar normalmente.

    *TESTADO

    http://wiki.mikrotik.com/wiki/Dynami...r_ChangeIP.com
    Coloquei aqui no MK, e Voilà !!

    100% OK.



  5. #65

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    Aqui ainda nao deu, continua o mesmo erro.

  6. #66

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    Citação Postado originalmente por RickBrito Ver Post
    Basta usar esse script, ele voltou a funcionar normalmente.

    *TESTADO

    http://wiki.mikrotik.com/wiki/Dynami...r_ChangeIP.com
    Com esse script aqui funcionou na hora.



  7. #67

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    Citação Postado originalmente por isacloko Ver Post
    aqui voltou a funcionar normalmente, acho que eles arrumaram o servidor novamente, estou usando o mesmo script de antes e esta OK
    altera a sua senha que volta ao normal

  8. #68

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    Só aproveitando o tópico...
    Estou com um problema no acesso remoto. Ele está parando no balance e as vezes passa para o MK servidor.
    Mas é muito raro de dar certo o acesso ao servidor MK.

    uso essa config no nat do balance para direcionar ao ip e porta do MK servidor.

    chain=dstnat action=dst-nat to-addresses=192.168.1.2 to-ports=1010
    protocol=tcp dst-port=1010


    Já aconteceu isso com algum de vocês?

    valeww



  9. #69

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    Citação Postado originalmente por Carlosaps Ver Post
    Só aproveitando o tópico...
    Estou com um problema no acesso remoto. Ele está parando no balance e as vezes passa para o MK servidor.
    Mas é muito raro de dar certo o acesso ao servidor MK.

    uso essa config no nat do balance para direcionar ao ip e porta do MK servidor.

    chain=dstnat action=dst-nat to-addresses=192.168.1.2 to-ports=1010
    protocol=tcp dst-port=1010


    Já aconteceu isso com algum de vocês?

    valeww
    o certo e assim amigo:

    chain=dstnat action=dst-nat to-addresses=192.168.1.2 to-ports=8291
    protocol=tcp dst-port=8294
    lembrando vai funcionar assim se vc não tiver alterado a porta do winbox na rb dos clientes. se não tiver alterado, basta fazer esta alteração e ir no seu winbox com o ip de internet exemplo 200.12.111.214:8294 e vai conectar de boa, se vc tiver altera a porta do winbox da rb dos clientes ai vc tem que colocar ela na regra ai no lugar de "8291" e ira funcionar perfeitamente.

  10. #70

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    Citação Postado originalmente por claudinhohw Ver Post
    o certo e assim amigo:



    lembrando vai funcionar assim se vc não tiver alterado a porta do winbox na rb dos clientes. se não tiver alterado, basta fazer esta alteração e ir no seu winbox com o ip de internet exemplo 200.12.111.214:8294 e vai conectar de boa, se vc tiver altera a porta do winbox da rb dos clientes ai vc tem que colocar ela na regra ai no lugar de "8291" e ira funcionar perfeitamente.
    Pois é amigo, a porta que estou direcionando é a 1010. A porta 8291 é a do meu balance e nele eu tenho acesso normal. Já na 1010 as vezes acontece de passar e dar acesso. Agora queria saber porque tem momento eu consigo acessar e a maior parte não?

    valew



  11. #71

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    Citação Postado originalmente por Carlosaps Ver Post
    Pois é amigo, a porta que estou direcionando é a 1010. A porta 8291 é a do meu balance e nele eu tenho acesso normal. Já na 1010 as vezes acontece de passar e dar acesso. Agora queria saber porque tem momento eu consigo acessar e a maior parte não?

    valew
    em in.interface escolha um dos pppoe ai vc vai sair só por ele.

  12. #72

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    Citação Postado originalmente por claudinhohw Ver Post
    em in.interface escolha um dos pppoe ai vc vai sair só por ele.

    Nada amigo... Cara, isso é estranho d+. No MK não tem nada barrando acesso, pois funcionava com o ddns. A única coisa que mudou foi que coloquei ip fixo.

    Obrigado!



  13. #73

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    Citação Postado originalmente por Carlosaps Ver Post
    Nada amigo... Cara, isso é estranho d+. No MK não tem nada barrando acesso, pois funcionava com o ddns. A única coisa que mudou foi que coloquei ip fixo.

    Obrigado!
    vc tem que mudar o ddns para o ip fixo então e se vc tem ip fixo não precisa usar ddns.

  14. #74

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    Citação Postado originalmente por claudinhohw Ver Post
    vc tem que mudar o ddns para o ip fixo então e se vc tem ip fixo não precisa usar ddns.
    Opa!! desculpa ai amigo expliquei errado.

    Eu tinha o ddns rodando blz, daí coloquei um link dedicado e passei a usar o ip fixo. O que tinha do ddns eu tirei tudo. Não há nada
    de ddns no meu servidor.
    daí estou com esse bendito problema de não estar passando do balance o acesso remoto. Só falta meu server mK esta com fumo, pois as regras de redirecionamento estão certas, tanto é que algumas vezes eu consegui o acesso.

    abraço



  15. #75

    Padrão Re: Acesso remoto mikrotik por chamge-ip

    Citação Postado originalmente por isacloko Ver Post
    aqui voltou a funcionar normalmente, acho que eles arrumaram o servidor novamente, estou usando o mesmo script de antes e esta OK

    Usei o script esta funcionando normal, porém quando coloco meu usuário e senha do winbox

    ele informa que esta errado, porém eu sei que estar certo !!