+ Responder ao Tópico



  1. #1

    Thumbs up bgp loopback

    Boa tarde...
    Se eu usar a loopback para fechar uma sessao bgp é obrigatorio eu habilitar a opçao "multihop" no peer? E nao opçao advanced do peer eu tenho que colocar a interface ou o ip da interface em update source nos dois lados ou em um lado somente ja basta?

    Desde ja agradeço

  2. #2
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.969
    Posts de Blog
    44

    Padrão Re: bgp loopback

    Olá

    multihop só é necessario em caso de conexao com outros peers ou seja asn local e asn remoto diferentes o que nós chamamos de eBGP. Em caso de iBGP asn local e remoto iguais você não necessita usar multihop.

    Este fato não tem relação com usar uma interface loopback para bgp.



  3. #3

    Padrão Re: bgp loopback

    Citação Postado originalmente por MarcusMaciel Ver Post
    Olá

    multihop só é necessario em caso de conexao com outros peers ou seja asn local e asn remoto diferentes o que nós chamamos de eBGP. Em caso de iBGP asn local e remoto iguais você não necessita usar multihop.

    Este fato não tem relação com usar uma interface loopback para bgp.
    Desde ja lhe agradeço pela disponibilidade....
    Talvez me expressei mal mas seriam duas as minhas duvidas, uma em relaçao ao multihop e a outra em relaçao ao update-source

    1ª Se eu usar a loopback para fechar uma sessao bgp é obrigatorio eu habilitar a opçao "multihop" no peer?
    multihop só é necessario em caso de conexao com outros peers ou seja asn local e asn remoto diferentes o que nós chamamos de eBGP. Em caso de iBGP asn local e remoto iguais você não necessita usar multihop.
    Este fato não tem relação com usar uma interface loopback para bgp.


    2ª E nao opçao advanced do peer quando fecho BGP com loopback eu tenho que colocar a interface loopback ou o ip da loopback em update source nos dois lados ou em um lado somente ja basta?

  4. #4
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.969
    Posts de Blog
    44

    Padrão Re: bgp loopback

    Citação Postado originalmente por elmikrotik Ver Post
    Desde ja lhe agradeço pela disponibilidade....
    Talvez me expressei mal mas seriam duas as minhas duvidas, uma em relaçao ao multihop e a outra em relaçao ao update-source

    1ª Se eu usar a loopback para fechar uma sessao bgp é obrigatorio eu habilitar a opçao "multihop" no peer?
    multihop só é necessario em caso de conexao com outros peers ou seja asn local e asn remoto diferentes o que nós chamamos de eBGP. Em caso de iBGP asn local e remoto iguais você não necessita usar multihop.
    Este fato não tem relação com usar uma interface loopback para bgp.


    2ª E nao opçao advanced do peer quando fecho BGP com loopback eu tenho que colocar a interface loopback ou o ip da loopback em update source nos dois lados ou em um lado somente ja basta?

    1- Não é obrigatorio usar opcao multihop se você estiver usando ibgp (ASN de origem e ASN remoto iguais)
    2- no meu entendimento se voce colocar a interface ou ip da loopback daria na mesma pois o source é o mesmo. Sobre sua pergunta de nos dois lados ou um lado só não entendi. você poderia ser mais especifico ? detalhar melhor o que esta chamando de dois lados ?



  5. #5

    Padrão Re: bgp loopback

    Citação Postado originalmente por MarcusMaciel Ver Post
    1- Não é obrigatorio usar opcao multihop se você estiver usando ibgp (ASN de origem e ASN remoto iguais)
    2- no meu entendimento se voce colocar a interface ou ip da loopback daria na mesma pois o source é o mesmo. Sobre sua pergunta de nos dois lados ou um lado só não entendi. você poderia ser mais especifico ? detalhar melhor o que esta chamando de dois lados ?
    Me refiro na configuraçao local do peer e na configuraçao do peer remoto, o que vc chama de "ASN de origem e ASN remoto", tenho que especificar no update source como vc disse tanto faz a interface ou o ip, mas a duvida é se tenho que colocar no ASN de origem e ASN remoto ou em um lado somente bastaria.....
    Desde ja lhe agradeço pela disponibilidade....

  6. #6
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.969
    Posts de Blog
    44

    Padrão Re: bgp loopback

    Citação Postado originalmente por elmikrotik Ver Post
    Me refiro na configuraçao local do peer e na configuraçao do peer remoto, o que vc chama de "ASN de origem e ASN remoto", tenho que especificar no update source como vc disse tanto faz a interface ou o ip, mas a duvida é se tenho que colocar no ASN de origem e ASN remoto ou em um lado somente bastaria.....
    Desde ja lhe agradeço pela disponibilidade....
    Bom creio que o exemplo abaixo irá responder sua pergunta

    Exemplo com IBGP

    Nome:      Ibgp_load_bal.png
Visitas:     206
Tamanho:  13,3 KB

    Roteador A
    Código :
    # loopback interface
    /interface bridge add name=lobridge
     
     
    # addresses
    /ip address add address=1.1.1.1/24 interface=ether1
    /ip address add address=2.2.2.1/24 interface=ether2
    /ip address add address=9.9.9.1/32 interface=lobridge
     
     
    # ECMP route to peer's loopback
    /ip route add dst-address=9.9.9.2/32 gateway=1.1.1.2,2.2.2.2
     
     
    # BGP
    /routing bgp instance set default as=65000
    /routing bgp add name=peer1 remote-address=9.9.9.2 remote-as=65000 update-source=lobridge

    Roteador B

    Código :
    # loopback interface
    /interface bridge add name=lobridge
     
     
    # addresses
    /ip address add address=1.1.1.2/24 interface=ether1
    /ip address add address=2.2.2.2/24 interface=ether2
    /ip address add address=9.9.9.2/32 interface=lobridge
     
     
    # ECMP route to peer's loopback
    /ip route add dst-address=9.9.9.1/32 gateway=1.1.1.1,2.2.2.1
     
     
    # BGP
    /routing bgp instance set default as=65000
    /routing bgp add name=peer1 remote-address=9.9.9.1 remote-as=65000 update-source=lobridge
     
     
    # a route to advertise
    /routing bgp network add network=4.4.4.0/24


    Exemplo com EBGP

    Nome:      Ebgp_load_bal.png
Visitas:     202
Tamanho:  11,3 KB

    Roteador A
    Código :
    /routing bgp instance set default as=65000
    /routing bgp set peer1 remote-address=9.9.9.2 remote-as=65001 update-source=lobridge multihop=yes

    Roteador B
    Código :
    /routing bgp instance set default as=65001
    /routing bgp set peer1 remote-address=9.9.9.1 remote-as=65000 update-source=lobridge multihop=yes

    Conteúdo de http://wiki.mikrotik.com/wiki/Manual...two_interfaces



  7. #7

    Padrão Re: bgp loopback

    multihop voce utiliza quando seu router bgp nao esta diretamente conectado ao outro AS..


    por ex:

    BGP01 <---> BGP02 -> nao precisa multihop

    BGP01 <--> GW <--> BGP02 -> Multihop = 1 ou ativado (cisco voce informa quantos 'hops' serao permitidos).

    BGP01 <--> GW <--> GW <--> BGP02 = Multihop = 2 ou ativado ..

  8. #8

    Padrão Re: bgp loopback

    sempre feche BGP com o ip da WAN ... se fechar com loopback, a outra parte precisa ter uma rota para ele...



  9. #9

    Padrão Re: bgp loopback

    Citação Postado originalmente por alexandrecorrea Ver Post
    multihop voce utiliza quando seu router bgp nao esta diretamente conectado ao outro AS..


    por ex:

    BGP01 <---> BGP02 -> nao precisa multihop

    BGP01 <--> GW <--> BGP02 -> Multihop = 1 ou ativado (cisco voce informa quantos 'hops' serao permitidos).

    BGP01 <--> GW <--> GW <--> BGP02 = Multihop = 2 ou ativado ..
    Multihop voce utiliza quando seu router bgp nao esta diretamente conectado ao outro AS.... usando loopback nao estaria diretamente conectado(seria tipo um gw no meio do BGP01 e do BGP02), estou certo, entao precisaria do multihop habilitado?

    É que fiquei meio confuso pq teve um amigo no inicio do topico deu explicou diferente no meu entendimento, dai a minha duvida qual das duas estaria correta....
    multihop só é necessario em caso de conexao com outros peers ou seja asn local e asn remoto diferentes o que nós chamamos de eBGP. Em caso de iBGP asn local e remoto iguais você não necessita usar multihop.

  10. #10

    Padrão Re: bgp loopback

    mas mesmo assim.. da interface loopback ate a outra ponta... seria direto.... !! neste caso nao precisa de multihop !!



  11. #11

    Padrão Re: bgp loopback

    Citação Postado originalmente por alexandrecorrea Ver Post
    mas mesmo assim.. da interface loopback ate a outra ponta... seria direto.... !! neste caso nao precisa de multihop !!


    E quanto ao update-souce nas opçoes avançadas do peer quando posso deixar "none" e quando tenho que usar "interface loopback"?

  12. #12

    Padrão Re: bgp loopback

    se usar loopback.. vc seta loopback .. se usar o ip da interface, seta a interface .. se tiver mais de um ip da interface.. coloca o ip que fechou a wan..

    esse parametro é pra definir com QUAL ip o router vai fazer a conexão.. em eBGP (vc e a operadora) o recomendado eh usar o IP da WAN ( do /30 que eles te fornecem) ..

    loopback vc usa no iBGP ... e usa o ipdate-source !



  13. #13

    Padrão Re: bgp loopback

    Citação Postado originalmente por MarcusMaciel Ver Post
    Olá

    multihop só é necessario em caso de conexao com outros peers ou seja asn local e asn remoto diferentes o que nós chamamos de eBGP. Em caso de iBGP asn local e remoto iguais você não necessita usar multihop.

    Este fato não tem relação com usar uma interface loopback para bgp.
    No caso de fechar uma sessão iBGP eu uso o meu AS mesmo ou aqueles numeros de AS reservados (65xxx) ??

  14. #14
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.969
    Posts de Blog
    44

    Padrão Re: bgp loopback

    Depende do seu objetivo.



  15. #15

    Padrão Re: bgp loopback

    A ideia é esta, na imagem:
    Clique na imagem para uma versão maior

Nome:	         BGP.jpeg
Visualizações:	10
Tamanho: 	34,1 KB
ID:      	68424

  16. #16
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.969
    Posts de Blog
    44

    Padrão Re: bgp loopback

    Olha no exemplo acima no meu entender tanto faz.

    Pois se você quer compartilhar as rotas dentro do seu AS em ambos roteadores no final de contas so vai depender de como você utiliza as rotas dentro do roteador.

    Mas creio que usando seu próprio ASN para o iBGP iria facilitar sua vida.

    Aproveitando, no futuro crie um novo tópico para suas dúvidas para evitar confusões neste tópico.



  17. #17