Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão routerOS v6.0 E Agora que Regras Usar?

    Ola a todos, alguém sabe me dizer como que ficaram as configurações de controle de banda no mikrotik v6.xx, pois não tem mais controle global-in e global-out somente global e como tenho que configurar exemplo: Facebook , P2P,Medidores de Velocidade e You tube etc.

    E Agora o que fazer?
    já procurei pela net nos principais fóruns e nada ninguém diz nada só manda fazer o dowgrade para a versão 5.xx ai estar o
    problema a minha rb ccr1016-12g só aceita a versão 6.xx.
    então pensei eu não estou sozinho neste barco também deve ter amigos passando por esse mesmo problemas,vamos
    galera do under linux ajuda ai posta algo que nos tire deste mato sem cachorro rsrsrs.

    exemplos de regras que não pega na versão 6.xx:

    REGRAS DO FACEBOOK:

    /ip firewall mangle> add action=mark-connection chain=output
    comment="Marca Facebook" content=facebook disabled=no new-connection-mark=Facebook passthrough=yes

    /ip firewall mangle> add action=mark-packet chain=output comment="Marca pkt Facebook" connection-mark=Facebook disabled=no new-packet-mark=facebook-pkt passthrough=yes

    /queue tree> add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=3m name=Facebook packemark=facebook-pkt parent=global-out priority=8 queue=default


    REGRAS DO P2P:


    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="CONTROLE P2P" disabled=\
    no new-connection-mark=p2p_conn p2p=all-p2p passthrough=yes
    add action=mark-packet chain=prerouting comment="" connection-mark=p2p_conn \
    disabled=no new-packet-mark=p2p passthrough=yes

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=1k name=P2P_IN packet-mark=p2p parent=global-in priority=8 \
    queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=1k name=P2P_OUT packet-mark=p2p parent=global-out priority=8 \
    queue=default

  2. #2

    Padrão Re: routerOS v6.0 E Agora que Regras Usar?

    da uma olhada nesse tópico, acho que pode te ajudar

    https://under-linux.org/showthread.php?t=163951



  3. #3

    Padrão Re: routerOS v6.0 E Agora que Regras Usar?

    Citação Postado originalmente por AndrioPJ Ver Post
    da uma olhada nesse tópico, acho que pode te ajudar

    https://under-linux.org/showthread.php?t=163951
    não sei se vc não viu mais no final desse tópico fiz uma pergunta que ninguém respondeu.
    moderador da uma luz por favor.

  4. #4

    Padrão Re: routerOS v6.0 E Agora que Regras Usar?

    tem muitas formas.
    em firewall escolha o chain input ou output.
    e em queue tree, no lugar de global-in ou global-out, voce seleciona as interfaces RedeInterna

    Firewall chain input,
    Queue tree interface RedeInterna
    Voce esta controlando o upload.

    Chain output
    Queue tree interface RedeInterna
    Voce esta controlando o download


    Ou, cria apenas uma regra no firewall, chain forward.
    Ai em queue tree escolha as respectivas interfaces RedeInterna e outra para Internet
    Última edição por AndrioPJ; 13-03-2014 às 21:39.



  5. #5

    Padrão Re: routerOS v6.0 E Agora que Regras Usar?

    Citação Postado originalmente por AndrioPJ Ver Post
    tem muitas formas.
    em firewall escolha o chain input ou output.
    e em queue tree, no lugar de global-in ou global-out, voce seleciona as interfaces RedeInterna

    Firewall chain input,
    Queue tree interface RedeInterna
    Voce esta controlando o upload.

    Chain output
    Queue tree interface RedeInterna
    Voce esta controlando o download


    Ou, cria apenas uma regra no firewall, chain forward.
    Ai em queue tree escolha as respectivas interfaces RedeInterna e outra para Internet
    Andriopj desculpa a burrice mais eu não tenho nem noção de como fazer essa regras (e eu tenho certeza que muitos também tem essa mesma dúvida mais eu fui o único corajoso pra perguntar rsrsrs) tem como explicar melhor pois tenho uma rb com essa versão também.
    eu uso hotsopt .
    e uma pergunta por que tiraram o global in e global out já que tem varias regras que usar.

  6. #6

    Padrão Re: routerOS v6.0 E Agora que Regras Usar?

    Socorro eu pago preciso dessas regras urgente.



  7. #7

    Padrão Re: routerOS v6.0 E Agora que Regras Usar?

    Citação Postado originalmente por Arthur Bernardes Ver Post
    Estou usando o RouterOS 5.x e nessa versão nunca consegui usar o controle do P2P, mas com a ajuda de um amigo no Facebook consegui fazer funcionar e vi que faltava marcação dos pacotes na cadeia "postrouting" do "mangle" e agora dropou alguns pacotes aqui num curto espaço de teste que fiz!
    Arthur como fico as regras do queue tree vc usou global out e global in o problema aqui é que na versão do RouterOS 6.x só tem
    global, ai estou a ver navio e ninguem que usar essa versão dar uma luz.

  8. #8

    Padrão Re: routerOS v6.0 E Agora que Regras Usar?

    Citação Postado originalmente por Arthur Bernardes Ver Post
    Sim, usei o "global-out" e "global-in", vi que aqui tem a opção "global", vou testar aqui para ver como fica!

    A opção "global" já trata a "input" e a "output" ou não?

    Aqui para poder tratar as duas cadeias, tive que marcar no "mangle" as cadeias "prerouting" e "postrouting" (antes e depois), como ficaria na versão 6.x? Vou instalar a versão 6.10 para fazer esse tipo de teste!
    Boa Tarde Arthur Bernardes desculpa o incomodo vc já testou ,deu certo?



  9. #9

    Padrão Re: routerOS v6.0 E Agora que Regras Usar?

    Citação Postado originalmente por Arthur Bernardes Ver Post
    Andei lendo um tópico sobre "cache-full" no RouterOS 6.x e me deparei com isso:

    "Para entendimento, a mudança principal no Cache Full da versão 6x ocorre porque o Packet Flow é diferente. As Queue Tree são processadas antes da Queue Type, mesmo que se configure um parâmetro para Cache Full na Queue Tree, quando a Queue Type for carregada após a Queue Tree, os valores reais serão da Queue Type."

    Vi que o limite é carregado na Queue Type agora, usando o PCQ, segue um exemplo.

    Anexo 50921

    Código :
    /queue type
    add kind=pcq name=CacheFull pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=3M pcq-src-address6-mask=64

    E então criar uma "Simple Queue", exemplo:

    Anexo 50922 Anexo 50923

    Código :
    /queue simple
    add name=CacheFull packet-marks=CacheFull_Mikrotik_6x queue=CacheFull/CacheFull target=""

    Marque os pacotes no "mangle" normalmente, agora quanto a cadeia "prerouting" ou "postrouting" ainda não sei, no entanto vamos testar!

    Link do tópico de referência: http://www.overnix.com/showthread.ph...rotik-Router0S

    Juntando essas informações acima com isso abaixo:



    Ainda vou continuar as pesquisas aqui!
    Nesse seu exemplo, foi criado um único PCQ, com o parâmetro dst-address.
    Depois você criou um Simple Queue e atribuiu esse PCQ tanto em upload como em download.

    Está errado!!!
    o Upload tem como ponto de referencia o src
    E o Download tem como ponto de referencia o dst

    Então, aconselho a criar 2 PCQ, um para Down e outro para UP

    Quanto a regra de Firewall, estou com uma pequena duvida, mas acredito que bastaria uma unica regra:
    chain forward
    p2p= all-p2p
    Mark Conection

  10. #10

    Padrão Re: routerOS v6.0 E Agora que Regras Usar?

    Citação Postado originalmente por Arthur Bernardes Ver Post
    Jasper, não uso a versão 6.x, o que fiz foi uma simples pesquisa para poder ajudar os amigos a reunir informações para poder fazer, e também quero tentar; agora se está errado ou não eu não sei dizer, de qualquer forma, obrigado pela "correção"!
    ^^ da nada nao uehsuhesuess



  11. #11

    Padrão Re: routerOS v6.0 E Agora que Regras Usar?

    aqui utilizo esse, pega udp, tem regra pra p2p mais n esta funcionando, se alguem conseguir corrigir
    so executar no new terminal.
    coloquei no txt pq passou da quantidade de character permitido

    na imagem mostra o codigo funcionando, ele esta limitando os downloads tranquilos, utilizei o utorrent para testes

    Clique na imagem para uma versão maior

Nome:	         queue.jpg
Visualizações:	387
Tamanho: 	51,3 KB
ID:      	50930
    Clique na imagem para uma versão maior

Nome:	         queuetorrent.jpg
Visualizações:	292
Tamanho: 	45,4 KB
ID:      	50932
    queue.txt

  12. #12

    Red face Re: routerOS v6.0 E Agora que Regras Usar?

    Acompanhado...
    esse fórum estar de parabéns.
    vou agora fazer as pesquisas de Arthur Bernardes.
    e Bruno belas valeu a ajuda!!!!



  13. #13

    Padrão Re: routerOS v6.0 E Agora que Regras Usar?

    so falta alguem da uma olhada nos códigos, para ver pq nao esta marcando os p2p...

  14. #14

    Smile Re: routerOS v6.0 E Agora que Regras Usar?

    Citação Postado originalmente por Arthur Bernardes Ver Post
    Estive conversando com um colega consultor no Facebook e ele me disse que para QoS a versão 6.x está um lixo (na opinião dele), e quem quer manter um QoS 100% que volte para a versão 5.x!

    Logo pensei em vocês com esse pepino, e o problema também é a CCR não suportar versões anteriores à 6.x!
    Valeu Arthur Bernardes pela Força,por favor não deixe a galera com esse pepino rsrsrsr



  15. #15

    Padrão Re: routerOS v6.0 E Agora que Regras Usar?

    alguem ja deu uma olhada na nova versao, a 6.10, se mudou muita coisa sobre os queue ou nada de animador

  16. #16

    Padrão Re: routerOS v6.0 E Agora que Regras Usar?

    o jeito é se virar como der, ateeee vim uma versao com QoS bom, acredito q teve ter uma maneira de configurar corretamente... so falta descobrir como xD



  17. #17

    Padrão Re: routerOS v6.0 E Agora que Regras Usar?

    até aqui nada de novo como todos podem ver , achei essas regras para cachefull na internet funcionar no mikrotik 6.xx mas pode existir algum problema assim agradeço se o pessoal mais experiente puder analisar para mim.

    /ip firewall mangle
    add action=mark-packet chain=CACHE_FULL_DOWN comment=\
    \"dscp->12 => [packetspeedrHIT]\" dscp=12 new-packet-mark=packetspeedrHIT \
    passthrough=no
    add action=mark-packet chain=CACHE_FULL_DOWN comment=\
    \"dscp->10 => [packetspeedrHIT]\" dscp=10 new-packet-mark=packetspeedrHIT \
    passthrough=no
    add action=mark-packet chain=CACHE_FULL_DOWN comment=\
    \"dscp->48 => [packetspeedrHIT]\" disabled=yes dscp=48 new-packet-mark=\
    packetspeedrHIT passthrough=no
    add action=jump chain=prerouting jump-target=CACHE_FULL_DOWN

    /queue tree
    add limit-at=10M max-limit=10M name=\"webcache HIT\" packet-mark=\
    packetspeedrHIT parent=global queue=default

    /queue simple
    add limit-at=8M/8M max-limit=8M/8M name=\"webcache HIT II\" packet-marks=\
    packetspeedrHIT queue=default/default target=\
    X.X.X.X/X total-queue=default

    se alguém quiser testar ou se tiver alguma ideia para outras regras como o P2P , FACEBOOK ou MEDIDORES DE VELOCIDADE e só postar os resultados fico grato.

  18. #18

    Unhappy Re: routerOS v6.0 E Agora que Regras Usar?

    Por Favor Ajuda nestas regras tem muita gente precisando mesmo.




  19. #19

    Padrão Re: routerOS v6.0 E Agora que Regras Usar?

    A lógica séria aplicada em cima dessas regras que o Arthur passou http://paste.ubuntu.com/7148980/

    Com isso dar para vc marcar HTTP e HTTPS correto? Sim está correto rsrs.

    Prerouting= O que vem da net com destino ao cliente. Postrouting o que sai do PC do Cliente em destino a NET= UPLOAD

    Mudou algumas coisas nas versões 6x uma delas é a leitura no Queues que lê da esquerda para direita.

    Séria interessante setar a interface onde entra o link em In-Interface.

    Depois disso era só partir para o Queues-Tree usando o esquema HTB tem uns conceitos importantes do David Marcony só está um pouco antigo a lógica do mesmo aplicado no Queues Tree pois foi feito em versões anteriores.


  20. #20

    Padrão Re: routerOS v6.0 E Agora que Regras Usar?

    Sem contar que vc teria o controle melhor do que entra e do que sai do seu core e load ou seja se vc tiver balance e core vc tem que fazer o QoS em ambos no caso do core a interface de entrada que vc seta é onde chega o link.