Consegui resolver isso hj.
Fiz o seguinte:

Desativei essas duas regras:

Código :
/ ip firewall nat 
add chain=srcnat protocol=udp src-port=123 action=src-nat to-addresses=191.167.100.254 to-ports=0-65535 comment="====================================================================NTP" disabled=no
 
add chain=dstnat in-interface=CLIENTES src-address=!172.16.1.1 protocol=udp dst-port=!53 action=dst-nat to-addresses=172.16.1.1 to-ports=53 comment="====================================================================CACHE_ACELERADOR_DE_DNS" disabled=no

em seguida dei um "flush" no DNS e tudo ficou beleza graças a Deus!

vlw a todos pela atenção!