Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Citação Postado originalmente por Carlosaps Ver Post
    Amigos, estou querendo usar meu mk-auth apenas para mostrar página de corte.

    Estou tentando fazer o redirecionamento.
    /ip firewall nat
    add action=dst-nat dst-address=!172.31.255.2 chain=dstnat comment="PG CORTE" disabled=no protocol=tcp src-address=10.3.0.2-10.3.3.254 to-addresses=172.31.255.2 to-ports=85

    Criei o pool com a range 10.3.0.2-10.3.3.254 e um profile pppoe "corte" para os clientes inadimplentes e estou direcionando para o ip e porta da página de corte (172.31.255.2:85). só que não direciona, na regra há envio de pacotes, mas não mostra a página de corte. Já se eu jogar esse ip e porta no browser, abre blz a página de corte.

    Alguém tem funcionando dessa maneira?
    Desde já agradeço!
    Amigão, observando a regra que você postou aqui, está faltando a Src. Address List = pgcorte, veja minha regra abaixo:

    add action=dst-nat chain=dstnat comment="Redireciona para a pagina de bloqueio\
    \_(MANTER ESSA REGRA SEMPRE ACIMA DAS OUTRAS)" dst-address=!172.31.255.2 \
    dst-port=80 protocol=tcp src-address-list=pgcorte to-addresses=\
    172.31.255.2 to-ports=85

  2. Citação Postado originalmente por FabianoMartins2 Ver Post
    Amigão, observando a regra que você postou aqui, está faltando a Src. Address List = pgcorte, veja minha regra abaixo:

    add action=dst-nat chain=dstnat comment="Redireciona para a pagina de bloqueio\
    \_(MANTER ESSA REGRA SEMPRE ACIMA DAS OUTRAS)" dst-address=!172.31.255.2 \
    dst-port=80 protocol=tcp src-address-list=pgcorte to-addresses=\
    172.31.255.2 to-ports=85
    editei igual essa regra, mas não deu certo. Com ela, o cliente mesmo bloqueado dá navegação. Antes bloqueava, mas não mostrava a página de corte.

    Mesmo assim obrigado!



  3. Amigo já passe por esta mesma situação, não sei o que era, se algum bug na instalação ou alguma coisa assim, mas tente o seguinte, faça um backup para você não ter que reconfigurar nada e reinstale o sistema, aqui fiz isto e deu certo, só não sei se foi a reinstalação ou atualização ao certo pois após reinstalar eu atualizei para a última versão, quando conclui ficou tudo 100%, não esqueça de atualizar a hora, deixe automática via ntp.

    Abraço.

    Citação Postado originalmente por Carlosaps Ver Post
    editei igual essa regra, mas não deu certo. Com ela, o cliente mesmo bloqueado dá navegação. Antes bloqueava, mas não mostrava a página de corte.

    Mesmo assim obrigado!

  4. Citação Postado originalmente por Carlosaps Ver Post
    editei igual essa regra, mas não deu certo. Com ela, o cliente mesmo bloqueado dá navegação. Antes bloqueava, mas não mostrava a página de corte.

    Mesmo assim obrigado!
    A diferença da minha regra p/ a sua, é que você usa uma range de IP's diferente p/ os clientes bloqueados. Eu já não uso. Meus clientes que são bloqueados pegam o mesmo IP, porem são adicionados a address-list "pgcorte" e não navegam, nem em HTTPS.

    E tem outra coisa faltando na sua regra, a porta destino "80". Editei aqui e fiz uma regra adequando p/ a sua situação aí, veja:
    add action=dst-nat chain=dstnat comment="PG CORTE" disabled=no dst-address=\
    !172.31.255.2 dst-port=80 protocol=tcp src-address=10.3.0.2-10.3.3.254 \
    src-address-list=pgcorte to-addresses=172.31.255.2 to-ports=85


    Veja se vai rolar agora.

    Abraço.



  5. Citação Postado originalmente por danilopereira Ver Post
    Amigo já passe por esta mesma situação, não sei o que era, se algum bug na instalação ou alguma coisa assim, mas tente o seguinte, faça um backup para você não ter que reconfigurar nada e reinstale o sistema, aqui fiz isto e deu certo, só não sei se foi a reinstalação ou atualização ao certo pois após reinstalar eu atualizei para a última versão, quando conclui ficou tudo 100%, não esqueça de atualizar a hora, deixe automática via ntp.

    Abraço.

    Citação Postado originalmente por FabianoMartins2 Ver Post
    A diferença da minha regra p/ a sua, é que você usa uma range de IP's diferente p/ os clientes bloqueados. Eu já não uso. Meus clientes que são bloqueados pegam o mesmo IP, porem são adicionados a address-list "pgcorte" e não navegam, nem em HTTPS.

    E tem outra coisa faltando na sua regra, a porta destino "80". Editei aqui e fiz uma regra adequando p/ a sua situação aí, veja:
    add action=dst-nat chain=dstnat comment="PG CORTE" disabled=no dst-address=\
    !172.31.255.2 dst-port=80 protocol=tcp src-address=10.3.0.2-10.3.3.254 \
    src-address-list=pgcorte to-addresses=172.31.255.2 to-ports=85


    Veja se vai rolar agora.

    Abraço.

    Amigos obrigado pelas dicas. Vou fazer tudo do zero novamente. Vou formatar e instalar o MK-auth e reconfigurar tudo.
    depois posto os resultados.

    Abraço!






Tópicos Similares

  1. Não aparece pagina de bloqueio do mk-auth
    Por orelhared no fórum Servidores de Rede
    Respostas: 1
    Último Post: 25-10-2015, 14:26
  2. Respostas: 2
    Último Post: 25-04-2015, 14:59
  3. Backup para envio de E-mail de meu MK-Auth
    Por amjservicos no fórum Redes
    Respostas: 3
    Último Post: 12-12-2013, 18:51
  4. Como mandar pagina de corte
    Por Yasawa no fórum Redes
    Respostas: 9
    Último Post: 22-07-2009, 19:44
  5. como enviar uma pagina de corte
    Por wescleybueno1 no fórum Redes
    Respostas: 2
    Último Post: 31-03-2009, 06:11

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L