+ Responder ao Tópico



  1. #1

    Padrão Página de corte MK-auth

    Amigos, estou querendo usar meu mk-auth apenas para mostrar página de corte.

    Estou tentando fazer o redirecionamento.
    /ip firewall nat
    add action=dst-nat dst-address=!172.31.255.2 chain=dstnat comment="PG CORTE" disabled=no protocol=tcp src-address=10.3.0.2-10.3.3.254 to-addresses=172.31.255.2 to-ports=85

    Criei o pool com a range 10.3.0.2-10.3.3.254 e um profile pppoe "corte" para os clientes inadimplentes e estou direcionando para o ip e porta da página de corte (172.31.255.2:85). só que não direciona, na regra há envio de pacotes, mas não mostra a página de corte. Já se eu jogar esse ip e porta no browser, abre blz a página de corte.

    Alguém tem funcionando dessa maneira?
    Desde já agradeço!

  2. #2



  3. #3

    Padrão

    Uso aqui e funciona de boa. No webadmin do mk-auth, em opções>configurar recursos

    Tem algumas opções lá referente a pagina de corte. Veja lá.

    Abraço.

  4. #4

    Padrão

    bom dia Carlosaps,

    Tchê veja como o amigo colocou a acima se nas opções do MK-Auth está marcado para exibir página de corte, caso não resolva atualize seu MK-Auth, aqui eu quebrei a cabeça de todas as formas e eu não conseguia fazer funcionar, foi que um dia tive que atualizar e funcionou, e a versão que estava antes funcionava com várias pessoas mas eu não consegui, inclusive o próprio Pedro tentou ver o que era e também não encontrou o problema, pois aparentemente estava tudo certo e não aparecia a PGCorte. Tente atulizar e depois poste ai.

    Abraço.

    Citação Postado originalmente por Carlosaps Ver Post
    Amigos, estou querendo usar meu mk-auth apenas para mostrar página de corte.

    Estou tentando fazer o redirecionamento.
    /ip firewall nat
    add action=dst-nat dst-address=!172.31.255.2 chain=dstnat comment="PG CORTE" disabled=no protocol=tcp src-address=10.3.0.2-10.3.3.254 to-addresses=172.31.255.2 to-ports=85

    Criei o pool com a range 10.3.0.2-10.3.3.254 e um profile pppoe "corte" para os clientes inadimplentes e estou direcionando para o ip e porta da página de corte (172.31.255.2:85). só que não direciona, na regra há envio de pacotes, mas não mostra a página de corte. Já se eu jogar esse ip e porta no browser, abre blz a página de corte.

    Alguém tem funcionando dessa maneira?
    Desde já agradeço!



  5. #5

    Padrão

    Citação Postado originalmente por danilopereira Ver Post
    bom dia Carlosaps,

    Tchê veja como o amigo colocou a acima se nas opções do MK-Auth está marcado para exibir página de corte, caso não resolva atualize seu MK-Auth, aqui eu quebrei a cabeça de todas as formas e eu não conseguia fazer funcionar, foi que um dia tive que atualizar e funcionou, e a versão que estava antes funcionava com várias pessoas mas eu não consegui, inclusive o próprio Pedro tentou ver o que era e também não encontrou o problema, pois aparentemente estava tudo certo e não aparecia a PGCorte. Tente atulizar e depois poste ai.

    Abraço.
    Olhei aqui e atualizei, mas não deu não. Vou tentando aqui, qualquer coisa se funcionar eu posto.

    obrigado!

  6. #6

    Padrão

    Citação Postado originalmente por Carlosaps Ver Post
    Amigos, estou querendo usar meu mk-auth apenas para mostrar página de corte.

    Estou tentando fazer o redirecionamento.
    /ip firewall nat
    add action=dst-nat dst-address=!172.31.255.2 chain=dstnat comment="PG CORTE" disabled=no protocol=tcp src-address=10.3.0.2-10.3.3.254 to-addresses=172.31.255.2 to-ports=85

    Criei o pool com a range 10.3.0.2-10.3.3.254 e um profile pppoe "corte" para os clientes inadimplentes e estou direcionando para o ip e porta da página de corte (172.31.255.2:85). só que não direciona, na regra há envio de pacotes, mas não mostra a página de corte. Já se eu jogar esse ip e porta no browser, abre blz a página de corte.

    Alguém tem funcionando dessa maneira?
    Desde já agradeço!
    Amigão, observando a regra que você postou aqui, está faltando a Src. Address List = pgcorte, veja minha regra abaixo:

    add action=dst-nat chain=dstnat comment="Redireciona para a pagina de bloqueio\
    \_(MANTER ESSA REGRA SEMPRE ACIMA DAS OUTRAS)" dst-address=!172.31.255.2 \
    dst-port=80 protocol=tcp src-address-list=pgcorte to-addresses=\
    172.31.255.2 to-ports=85



  7. #7

    Padrão

    Citação Postado originalmente por FabianoMartins2 Ver Post
    Amigão, observando a regra que você postou aqui, está faltando a Src. Address List = pgcorte, veja minha regra abaixo:

    add action=dst-nat chain=dstnat comment="Redireciona para a pagina de bloqueio\
    \_(MANTER ESSA REGRA SEMPRE ACIMA DAS OUTRAS)" dst-address=!172.31.255.2 \
    dst-port=80 protocol=tcp src-address-list=pgcorte to-addresses=\
    172.31.255.2 to-ports=85
    editei igual essa regra, mas não deu certo. Com ela, o cliente mesmo bloqueado dá navegação. Antes bloqueava, mas não mostrava a página de corte.

    Mesmo assim obrigado!

  8. #8

    Padrão

    Amigo já passe por esta mesma situação, não sei o que era, se algum bug na instalação ou alguma coisa assim, mas tente o seguinte, faça um backup para você não ter que reconfigurar nada e reinstale o sistema, aqui fiz isto e deu certo, só não sei se foi a reinstalação ou atualização ao certo pois após reinstalar eu atualizei para a última versão, quando conclui ficou tudo 100%, não esqueça de atualizar a hora, deixe automática via ntp.

    Abraço.

    Citação Postado originalmente por Carlosaps Ver Post
    editei igual essa regra, mas não deu certo. Com ela, o cliente mesmo bloqueado dá navegação. Antes bloqueava, mas não mostrava a página de corte.

    Mesmo assim obrigado!



  9. #9

    Padrão

    Citação Postado originalmente por Carlosaps Ver Post
    editei igual essa regra, mas não deu certo. Com ela, o cliente mesmo bloqueado dá navegação. Antes bloqueava, mas não mostrava a página de corte.

    Mesmo assim obrigado!
    A diferença da minha regra p/ a sua, é que você usa uma range de IP's diferente p/ os clientes bloqueados. Eu já não uso. Meus clientes que são bloqueados pegam o mesmo IP, porem são adicionados a address-list "pgcorte" e não navegam, nem em HTTPS.

    E tem outra coisa faltando na sua regra, a porta destino "80". Editei aqui e fiz uma regra adequando p/ a sua situação aí, veja:
    add action=dst-nat chain=dstnat comment="PG CORTE" disabled=no dst-address=\
    !172.31.255.2 dst-port=80 protocol=tcp src-address=10.3.0.2-10.3.3.254 \
    src-address-list=pgcorte to-addresses=172.31.255.2 to-ports=85


    Veja se vai rolar agora.

    Abraço.

  10. #10

    Padrão

    Citação Postado originalmente por danilopereira Ver Post
    Amigo já passe por esta mesma situação, não sei o que era, se algum bug na instalação ou alguma coisa assim, mas tente o seguinte, faça um backup para você não ter que reconfigurar nada e reinstale o sistema, aqui fiz isto e deu certo, só não sei se foi a reinstalação ou atualização ao certo pois após reinstalar eu atualizei para a última versão, quando conclui ficou tudo 100%, não esqueça de atualizar a hora, deixe automática via ntp.

    Abraço.

    Citação Postado originalmente por FabianoMartins2 Ver Post
    A diferença da minha regra p/ a sua, é que você usa uma range de IP's diferente p/ os clientes bloqueados. Eu já não uso. Meus clientes que são bloqueados pegam o mesmo IP, porem são adicionados a address-list "pgcorte" e não navegam, nem em HTTPS.

    E tem outra coisa faltando na sua regra, a porta destino "80". Editei aqui e fiz uma regra adequando p/ a sua situação aí, veja:
    add action=dst-nat chain=dstnat comment="PG CORTE" disabled=no dst-address=\
    !172.31.255.2 dst-port=80 protocol=tcp src-address=10.3.0.2-10.3.3.254 \
    src-address-list=pgcorte to-addresses=172.31.255.2 to-ports=85


    Veja se vai rolar agora.

    Abraço.

    Amigos obrigado pelas dicas. Vou fazer tudo do zero novamente. Vou formatar e instalar o MK-auth e reconfigurar tudo.
    depois posto os resultados.

    Abraço!



  11. #11

    Padrão

    Citação Postado originalmente por Carlosaps Ver Post
    Amigos obrigado pelas dicas. Vou fazer tudo do zero novamente. Vou formatar e instalar o MK-auth e reconfigurar tudo.
    depois posto os resultados.

    Abraço!
    Blz brother, mas não tem erro não viu. Pra mim fiz de primeira toda a configuração e nunca precisei mexer. E tenho amigos que também usam o mk-auth e fiz a configuração pra eles, tudo rodando de boa até hoje.

    Abraço.

  12. #12

    Padrão Re: Página de corte MK-auth

    bem gente sou novo em mikrotik e estou com este mesmo problema creio que eu e ele estamos configurando as range de ip de forma errada e por isso o mkauth nao corta os clientes bloqueados.

    esse range de ip para pgcorte: eu crio uma qualquer ou coloca a mas range de ip criada para o ppoe



  13. #13

    Padrão Re: Página de corte MK-auth

    Citação Postado originalmente por amaurybrito Ver Post
    bem gente sou novo em mikrotik e estou com este mesmo problema creio que eu e ele estamos configurando as range de ip de forma errada e por isso o mkauth nao corta os clientes bloqueados.

    esse range de ip para pgcorte: eu crio uma qualquer ou coloca a mas range de ip criada para o ppoe
    Eu não uso uma range especifica p/ os clientes bloqueados. Aqui quem está bloqueado pega o mesmo ip sempre, e o corte funciona perfeitamente.

    Dê mais detalhes de como está configurando, vamos ver se resolvemos.

  14. #14

    Padrão

    Citação Postado originalmente por FabianoMartins2 Ver Post
    Blz brother, mas não tem erro não viu. Pra mim fiz de primeira toda a configuração e nunca precisei mexer. E tenho amigos que também usam o mk-auth e fiz a configuração pra eles, tudo rodando de boa até hoje.

    Abraço.

    cara to sofrendo sem ter ajuda, faz 3 meses que uso o mk-auth e não algo ta errado, bloqueia, vai para address list, mais não aparece a pagina de corte, nem aviso de boletos em atraso, teria como ajudar não, add no zap, 83 99945-6222, tem como?



  15. #15

    Padrão Re: Página de corte MK-auth

    Eu estou desistindo do MkAuth, cada dia pior. Hahaha

  16. #16

    Padrão

    Citação Postado originalmente por avatar52 Ver Post
    Eu estou desistindo do MkAuth, cada dia pior. Hahaha

    amigo, não teria como me ajudar?



  17. #17

    Padrão

    Bom dia vamos lá, as regras são:

    /ip firewall filter
    add action=drop chain=forward comment=CORTE dst-port=!53 protocol=udp src-address-list=pgcorte (permite consultas DNS porta 53)
    add action=drop chain=forward comment=CORTE dst-port=!80,85,443,445 protocol=tcp src-address-list=pgcorte (Permite as portas 80,85,443,445 para clientes no pool de pgcorte)

    /ip firewall nat
    add action=dst-nat chain=dstnat comment=CORTE_HTTPS dst-address=!172.31.255.2 dst-port=443 protocol=tcp src-address-list=pgcorte to-addresses=172.31.255.2 to-ports=445 (regra para redirecionar acessos https para pagina de corte)
    add action=dst-nat chain=dstnat comment=CORTE_HTTP dst-address=!172.31.255.2 dst-port=80 protocol=tcp src-address-list=pgcorte to-addresses=172.31.255.2 to-ports=85 (regra para redirecionar acessos http para pagina de corte)

    Exibir pagina de corte usando Radius Pool:

    /ip pool
    add name=pgcorte ranges=10.3.0.2-10.3.3.254 (POOL CORTE - OS CLIENTES BLOQUEADOS TEEM QUE CAIR NESTE RANGE SE NÃO AS REGRAS ACIMA NÃO FUNCIONARÃO)

    /ip address
    add address=10.3.0.1/22 broadcast=10.3.3.255 network=10.3.0.0 comment=CORTE interface=porte (GW DA REDE DE CORTE DEVE ESTAR NA PLACA POR ONDE OS CLIENTES AUTENTICAM)

    /ip firewall filter
    add action=drop chain=forward comment=CORTE dst-port=!53 protocol=udp src-address=10.3.0.2-10.3.3.254 (CASO NÃO QUEIRA USAR UMA ADDRESS LIST UTILIZE ESTA REGRA, INSERINDO A CLASSE DE BLOQUEIO NO SRC ADDRESS)
    add action=drop chain=forward comment=CORTE dst-port=!80,85,443,445 protocol=tcp src-address=10.3.0.2-10.3.3.254(CASO NÃO QUEIRA USAR UMA ADDRESS LIST UTILIZE ESTA REGRA, INSERINDO A CLASSE DE BLOQUEIO NO SRC ADDRESS)

    /ip firewall nat
    add action=dst-nat chain=dstnat comment=CORTE_HTTPS dst-address=!172.31.255.2 dst-port=443 protocol=tcp src-address=10.3.0.2-10.3.3.254 to-addresses=172.31.255.2 to-ports=445 (NAT PERMITINDO ACESSO APENAS AO IP DO MK AUTH HTTPS)
    add action=dst-nat chain=dstnat comment=CORTE_HTTP dst-address=!172.31.255.2 dst-port=80 protocol=tcp src-address=10.3.0.2-10.3.3.254 to-addresses=172.31.255.2 to-ports=85 (NAT PERMITINDO ACESSO APENAS AO IP DO MK AUTH HTTP)

    CASO USE RADIUS, VERIFIQUE SE ELE ESTÁ ENVIANDO O CLIENTE PARA O POOL CORRETO. CASO O CLIENTE BLOQUEADO PEGUE OUTRO IP A REGRA NÃO IRÁ FUNCIONAR


    Atenciosamente:
    Dzyan Mendes
    http://consultortik.com.br
    T: (35) 9.9853-4244
    E:[email protected]
    S: dzyan.mendes

  18. #18

    Padrão Re: Página de corte MK-auth

    Como tmb não aparece a página. Aparece o cliente no address list normal com PGCORTE. Pelo que vi essa regra foi a mesma que usei. Farei outro teste...