+ Responder ao Tópico



  1. #1

    Question Servidor OpenVPN em Mikrotik, com clientes windows, alguem sabe fazer sem usar linux?

    Alguem ae sabe fazer um servidor mikrotik pra servir Ovpn
    pra maquinas windows como cliente?

    de preferencia com usario e senha cadastrado nos secrets,
    pra melhor gerencia, mas nao é obrifatorio..

  2. #2

    Padrão

    Citação Postado originalmente por mpsnet Ver Post
    Alguem ae sabe fazer um servidor mikrotik pra servir Ovpn
    pra maquinas windows como cliente?

    de preferencia com usario e senha cadastrado nos secrets,
    pra melhor gerencia, mas nao é obrifatorio..

    qualquer rb faz isso marciano



  3. #3

    Padrão

    O setup é bem simples, confira no link. Dúvidas só postar...

    http://wiki.mikrotik.com/wiki/OpenVP...n_Step_by_Step

  4. #4

    Padrão

    Citação Postado originalmente por felipeandrade55 Ver Post
    O setup é bem simples, confira no link. Dúvidas só postar...

    http://wiki.mikrotik.com/wiki/OpenVP...n_Step_by_Step
    pois é... durante a semana eu tentei fazer baseado neste turorial e encontrei duas dificuldades...
    gerar os certificados via cacert.org, uma vez q nao tenho nenhum dominio publicado na nic.br
    e como nao tenho nem sei usar linux, mesmo q desse pra fazero certificado no cacert no formato
    q a mikrotik aceita... entao gerei as chaves via easy-rsa, porem.. acho q nao estou sabendo talvez
    configurar o openvpn no cliente windows;...


    veja meus logs, no windows... cliente..

    Código :
    Sun May 25 01:55:26 2014 OpenVPN 2.0.9 Win32-MinGW [SSL] [LZO] built on Oct  1 2006Sun May 25 01:55:26 2014 IMPORTANT: OpenVPN's default port number is now 1194, based on an official port number assignment by IANA.  OpenVPN 2.0-beta16 and earlier used 5000 as the default port.
    Sun May 25 01:55:26 2014 WARNING: No server certificate verification method has been enabled.  See http://openvpn.net/howto.html#mitm for more info.
    Sun May 25 01:55:26 2014 Control Channel MTU parms [ L:1543 D:140 EF:40 EB:0 ET:0 EL:0 ]
    Sun May 25 01:55:26 2014 Data Channel MTU parms [ L:1543 D:1450 EF:43 EB:4 ET:0 EL:0 ]
    Sun May 25 01:55:26 2014 Local Options hash (VER=V4): 'db02a8f8'
    Sun May 25 01:55:26 2014 Expected Remote Options hash (VER=V4): '7e068940'
    Sun May 25 01:55:26 2014 Attempting to establish TCP connection with 201.22.212.74:1194
    Sun May 25 01:55:26 2014 TCP connection established with 201.22.212.74:1194
    Sun May 25 01:55:26 2014 TCPv4_CLIENT link local: [undef]
    Sun May 25 01:55:26 2014 TCPv4_CLIENT link remote: 201.22.212.74:1194
    Sun May 25 01:55:27 2014 TLS: Initial packet from 201.22.212.74:1194, sid=1609bdad b5ab8a69
    Sun May 25 01:55:27 2014 VERIFY OK: depth=1, /C=BR/ST=RS/L=Brochier/O=Bar/[email protected]
    Sun May 25 01:55:27 2014 VERIFY OK: depth=0, /C=BR/ST=RS/O=Bar/CN=201.22.212.74/emailAddres[email protected]
    Sun May 25 01:56:26 2014 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
    Sun May 25 01:56:26 2014 TLS Error: TLS handshake failed
    Sun May 25 01:56:26 2014 Fatal TLS error (check_tls_errors_co), restarting
    Sun May 25 01:56:26 2014 TCP/UDP: Closing socket
    Sun May 25 01:56:26 2014 SIGUSR1[soft,tls-error] received, process restarting
    Sun May 25 01:56:26 2014 Restart pause, 5 second(s)

    agora veja meu log na mikrotik ovpnserver na outra cidade...
    Código :
    01:57:36 ovpn,info TCP connection established from 186.251.59.50 01:57:38 ovpn,info : using encoding - BF-128-CBC/SHA1 
    01:58:41 ovpn,info TCP connection established from 186.251.59.50 
    01:58:43 ovpn,info : using encoding - BF-128-CBC/SHA1 
    01:59:46 ovpn,info TCP connection established from 186.251.59.50 
    01:59:48 ovpn,info : using encoding - BF-128-CBC/SHA1


    abraço galeraaa!



  5. #5

    Padrão Re: Servidor OpenVPN em Mikrotik, com clientes windows, alguem sabe fazer sem usar linux?

    Uma coisa muito importante quando se usa Openvpn, o servidor e os clientes precisam estar com o fuso-horário configurados. Caso não estejam configurados vai dar erro nos certificados pois não é possivel checar a validade do certificado ( no caso o certificado é considerado expirado ).

    Para configurar o ntp ( atualizacao de hora/data via internet ) no mikrotik:
    /system clock
    set time-zone-name=America/Brasilia
    /system ntp client
    set enabled=yes mode=unicast primary-ntp=200.192.232.8 secondary-ntp=200.160.0.8

  6. #6

    Padrão

    Citação Postado originalmente por amaia Ver Post
    Uma coisa muito importante quando se usa Openvpn, o servidor e os clientes precisam estar com o fuso-horário configurados. Caso não estejam configurados vai dar erro nos certificados pois não é possivel checar a validade do certificado ( no caso o certificado é considerado expirado ).

    ambas pontas com relógios sincronizado via sntp
    e nada...



  7. #7

    Padrão Re: Servidor OpenVPN em Mikrotik, com clientes windows, alguem sabe fazer sem usar linux?

    Olha, segundo este link:
    http://wiki.mikrotik.com/wiki/OpenVPN#Windows

    Para ter um cliente Windows, o openvpn no mikrotik tem que estar configurado no modo bridge.



    Este tutorial:
    http://wiki.mikrotik.com/wiki/OpenVP...n_Step_by_Step
    Está no modo roteado, então acho que não vai conectar.

  8. #8

    Padrão Re: Servidor OpenVPN em Mikrotik, com clientes windows, alguem sabe fazer sem usar linux?

    seguinte galera, achei o fiu da miada... vejam, o discador da open vpn vem ppré configurado com algumas coisas q o mikrotik nao aceita...

    Currently unsupported OVPN feature:

    • UDP mode
    • LZO compression
    • TLS authentication
    • authentication without username/password


    bom.,.. o primeiro e segundo problema eu matei, falta o terceiro e quarto...


    desativar o tls... e fazer pedir usuario e senha,,,



  9. #9

    Padrão Re: Servidor OpenVPN em Mikrotik, com clientes windows, alguem sabe fazer sem usar linux?

    caraca meu povo.. nao consigo fazer o open vpn pedir senha!!!

  10. #10

    Padrão OpenVPN cliente windows, como pedir senha

    alguem sabe como fazer a maquina windows pedir usuario e senha do open vpn ?



  11. #11

    Padrão Re: OpenVPN cliente windows, como pedir senha

    Olha, segundo este link:
    http://wiki.mikrotik.com/wiki/OpenVPN#Windows
    Se existir no arquivo de configuracao da vpn a linha:

    auth-user-pass auth.cfg

    O usuario e a senha devem constar neste arquivo no formato:
    usuario
    senha

    Se nao existir a linha, o cliente deve pedir o usuario e a senha.

  12. #12

    Padrão Re: OpenVPN cliente windows, como pedir senha

    só q nao tem nem a linha. ai eu criava a linha e o arquivo no endereço... e mesmo assim nao conseguia ler o arquivo
    ai agora q vc me falou, me surgio a ideia de nao citar o arquivo, ai passo a pedir a senha certinho;; valeu! vo da uma reputaçao pra vc