+ Responder ao Tópico



  1. #1

    Padrão Ajuda com Load Balance PCC

    Esta é minha configuração do meu loadbalance, funcionando com wan roteadas, mas preciso que uma das interface disque uma conexão pppoe, mas confesso que me perdi.
    O load é por rotas por ser mais simplificado, não nescecitando de muitas regras e não ter problemas com sites de bancos etc..
    A wan que preciso que disque está em vermelho.

    IPS Mikrotik:
    LAN: 172.16.0.1
    WAN1:10.0.30.2
    WAN2: 10.0.40.2
    WAN3: 10.0.50.2

    IPS Routers = Gateway
    WAN1: 10.0.30.1 -----------Dedicado 10Mb
    WAN2: 10.0.40.1 -----------Dedicado 3Mb
    WAN3: 10.0.50.1 -----------Adsl 10Mb

    /ip address
    add address=172.16.0.1/24 broadcast=172.16.0.255 comment=”LAN” disabled=no \
    interface=ether1 network=172.16.0.0
    add address=10.0.30.2/24 broadcast=10.0.30.255 comment=”WAN1″ disabled=no \
    interface=ether2 network=10.0.30.0

    add address=10.0.40.2/24 broadcast=10.0.40.255 comment=”WAN2″ disabled=no \
    interface=ether3 network=10.0.40.0
    add address=10.0.50.2/24 broadcast=10.0.50.255 comment=”WAN3″ disabled=no \
    interface=ether4 network=10.0.50.0


    Aqui tenho 3 conexões para 10Mb dedicado 1 para 3Mb dedicado e 1 para adsl mesmo sendo 10Mb tô considerando 3Mb pela qualidade da adsl.
    E aqui tá minha dificuldade como coloco as conexôes do 10Mb dedicado discando PPPOE?
    / ip route
    add dst-address=0.0.0.0/0 gateway=10.0.30.1,10.0.30.1,10.0.30.1,10.0.40.1,10.0.50.1 check-gateway=ping

    / ip firewall nat
    add chain=srcnat out-interface=WAN1 action=masquerade
    add chain=srcnat out-interface=WAN2 action=masquerade
    add chain=srcnat out-interface=WAN3 action=masquerade

    / ip firewall mangle
    add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=wan1_conn
    add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=wan2_conn
    add chain=input in-interface=WAN3 action=mark-connection new-connection-mark=wan2_conn

    add chain=output connection-mark=wan1_conn action=mark-routing new-routing-mark=to_wan1
    add chain=output connection-mark=wan2_conn action=mark-routing new-routing-mark=to_wan2
    add chain=output connection-mark=wan3_conn action=mark-routing new-routing-mark=to_wan2

    / ip route
    add dst-address=0.0.0.0/0 gateway=10.0.30.1.1 routing-mark=to_wan1
    add dst-address=0.0.0.0/0 gateway=10.0.40.1.1 routing-mark=to_wan2
    add dst-address=0.0.0.0/0 gateway=10.0.50.1.1 routing-mark=to_wan3

    É possível alterar as configs ou terei que modificar o PCC?

    Desde já agradeço a ajuda.
    JMayer

  2. #2

    Padrão Re: Ajuda com Load Balance PCC

    Alguém tem uma dica? tenho que colocar em produção na 1ª hora amanhã.
    JMayer.



  3. #3

    Padrão Re: Ajuda com Load Balance PCC

    Isso, voce consegue fazer apenas se tiver link dedicado com BGP

  4. #4

    Padrão Re: Ajuda com Load Balance PCC

    ola amigo, aki uso conexoes discando trankilo, vc tenke fazer um discador, e criar as regras de rotas, funfa legal



  5. #5

    Padrão Re: Ajuda com Load Balance PCC

    Sim o discador eu configuro tranquilo, mas como ficaria as regras nas rotas? É aí que me perdi. Como ficaria as regras?
    Grato.
    JMayer

  6. #6

    Padrão Re: Ajuda com Load Balance PCC

    aki uso 2 link com discador ficam assim:

    /ip route
    add comment="Rota Link1" disabled=no distance=1 dst-address=0.0.0.0/0 \
    gateway=link1 routing-mark=LINK1-ROUTE scope=30 target-scope=10
    add comment="Rota Link2" disabled=no distance=1 dst-address=0.0.0.0/0 \
    gateway=LINK2 routing-mark=LINK2-ROUTE scope=30 target-scope=10
    add disabled=no distance=2 dst-address=0.0.0.0/0 gateway=LINK1 scope=30 \
    target-scope=10
    add comment="Rota Link2" disabled=no distance=3 dst-address=0.0.0.0/0 \
    gateway=LINK2 scope=30 target-scope=10