+ Responder ao Tópico



  1. #1

    Padrão Interface GSM não faz ligações

    Gostaria de pedir ajuda a alguém que já tenha tido experiencia com a interface de celular gsm MIDCOM INTELYSWITCH 3G, adquiri duas unidades da mesma para inserir chips de celular e poder através dela liga-los a um spa3102 e transportar assim as linhas de celular para áreas distantes, porem para minha surpresa a interface faz e recebe chamadas telefônicas normalmente quando insiro o meu chip de celular vivo bastante antigo, mais quando coloco um desses chips novos, a interface recebe chamadas normalmente porem não as realiza, não faço a menor ideia do que pode estar causando isso, existe diferenças físicas nas conexões dos chips porem não creio ser este o motivo pois a interface e nova, e apesar de não realizar ligações ela recebe normalmente, agradeço a quem possa ajudar.

  2. #2

    Padrão Re: Interface GSM não faz ligações

    Tem por aí um celular velho pra colocar esse SIM por uns minutos?

    Quando coloca um chip num celular que ainda não teve chip dessa operadora chega aquela config. de conexão, "antigamente" (2007, digamos) você tinha que aceitar manualmente e tal, nos smartphones atuais é automatico, se plugar um chip num celular antigo chega SMS falando que em instante receberá uma msg. essa config. e etc mas ou não chega nada ou chega SMS ilegivel pro aparelho velho.

    Chip é coisa barata, US$ 0,3 pra fabricar, não são produtos de qualidade alta, por isso as vezes se embananam na hora de armazenar as coisas, corrompem dado armazenado, e pra reescrever algumas coisas é só plugar num celular muito diferente, que eu saiba só faz efeito em celulares bem antigos sem acesso a web e tal (Nokia 1100, 1200, etc).

    Mas também tem diferenças internas nos chips, tem umas mudanças pra armazenar dados de redes 3G ou 4G que a 10 anos não tinha, se tiver acesso a muitos chips (Revenda de celulares) daria pra testar chips de 64 e 128KB pra ver se algum tamanho tem problemas, mas duvido que resolva assim, cada fabricante de chip tem pequenas mudanças na arquitetura, e pode ter um chip com dados corrompidos, ou com alguma função (comando) inoperante, os aparelhos usam comandos levemente diferentes.

    Ah, veja nível de sinal, modulo usa antena com conector não muito firme, com nível de sinal baixo o aparelho pode dar aquela rajada de pacotes pra iniciar a conexão com a torre e a conexão falhar, mas recepção é uma atividade passiva, o modulo recebe uns pacotes e responde depois, se não responder talvez a torre reenvie, enquanto que ao realizar chamada não ocorre a repetição de pacotes perdidos logo no começo (E conexão de celular começa com banda tipo 32kbps, conforme baixa o sinal o datarate pra 11 ou 8Kbps pra aproveitar maior sensibilidade e potencia dos aparelhos onde o sinal está ruim, sinal ruim no meio de chamada talvez esse modulo aceite, mas na realização de chamadas não).

    A 10 anos usava uns modulos da Sagem, depois uns laranjados que esqueci a marca, e eles eram péééééssimos de sinal, um nokia classico do lado mostrava sinal tipo 40% ("2 pauzinhos" de 5) mas o modulo não fazia nem recebia ligação devido a sinal baixo, tinhamos que colocar antenas de 5dB de cabo curto e com conector caprichado, porque aquelas anteninhas automotivas pretas com imã em baixo eram péssimas (Até em celular de mesa perdem sinal as vezes).



  3. #3
    Avatar de Nilton Nakao
    Ingresso
    Sep 2013
    Localização
    Carlos Chagas, Minas Gerais
    Posts
    906

    Padrão Re: Interface GSM não faz ligações

    Tenho um a interface da Huawei, 3G dotado de saída para telefone, cabo de rede, roteador wireless e com antena externa para sinal de celular quadri-band. Neste caso(o meu) tenho de entrar via navegador, configurar roteador, numero de discagem da web, operadora, senha de acesso etc, precisa também selecionar o modo de frequência para operação, recomendo deixar no automático. Algumas operadoras requerem um chip específico para 2G, 3G ou 4G. Contate a sua operadora de preferencia ou se tiver um celular ou smart com acesso a web você consegue as informações na tela, a maioria dos novos chips não vem com numero pré-ativado e as operadoras exigem o cadastro completo para usar web(nome completo, endereço, cpf etc).

  4. #4

    Padrão Re: Interface GSM não faz ligações

    Amigo estou com o mesmo problema, coloquei o chip do meu celular e depois o que era para permanecer na interface, o primeiro funciona perfeitamente e qualquer outro que eu coloque não funciona, inclusive chips antigos de mais de 10 anos de uso.
    Acredito que haja alguma "configuração que tenha que ser efetuada por um aparelho telefonico conectado mas não encontro informação nenhuma em lugar algum.
    Conseguiste resolver?



  5. #5

    Padrão

    Citação Postado originalmente por jralencar Ver Post
    Gostaria de pedir ajuda a alguém que já tenha tido experiencia com a interface de celular gsm MIDCOM INTELYSWITCH 3G, adquiri duas unidades da mesma para inserir chips de celular e poder através dela liga-los a um spa3102 e transportar assim as linhas de celular para áreas distantes, porem para minha surpresa a interface faz e recebe chamadas telefônicas normalmente quando insiro o meu chip de celular vivo bastante antigo, mais quando coloco um desses chips novos, a interface recebe chamadas normalmente porem não as realiza, não faço a menor ideia do que pode estar causando isso, existe diferenças físicas nas conexões dos chips porem não creio ser este o motivo pois a interface e nova, e apesar de não realizar ligações ela recebe normalmente, agradeço a quem possa ajudar.
    Citação Postado originalmente por marcosps Ver Post
    Amigo estou com o mesmo problema, coloquei o chip do meu celular e depois o que era para permanecer na interface, o primeiro funciona perfeitamente e qualquer outro que eu coloque não funciona, inclusive chips antigos de mais de 10 anos de uso.
    Acredito que haja alguma "configuração que tenha que ser efetuada por um aparelho telefonico conectado mas não encontro informação nenhuma em lugar algum.
    Conseguiste resolver?
    Também adquiri essa mesma interface e também estou com o mesmo problema! Com meu chip da vivo, já antigo, que utilizo já há um tempo, o aparelho funciona perfeitamente. Porém, ao adquirir um chip novo, também da Vivo, ela só recebe ligações. Lendo no manual, aprendi uma maneira de conseguir fazer ligações: antes de digitar o número, tem que "forçar" a chamada colocando o código #66835#, aí funciona. Fica assim: #66835# +0 + 15 (cód área) + (número). Gostaria de saber se conseguiriam resolver o problema de outra forma, pois não é nada prático ficar digitando esses códigos sempre antes de ligar rsrs.

  6. #6

    Padrão Re: Interface GSM não faz ligações

    O tópico é velho, mas acabei de comprar essa $*#@& de aparelho também. A fábrica parece que não existe mais. Já que não tem mesmo "galantia", abri o bicho e aprendi algumas coisas:
    1. A CPU é a NUC100 de 48 pinos da Nuvoton (um ARM Cortex).
    2. Usa um módulo GSM "normal"
    3. Usa um módulo SLIC FSX/FXO baseado SI3217
    4. Comunica-se com o módulo GSM pela UART0, exposta no J10.
    5. Usa a UART1 (no J3) como saída de log/debug.
    6. Permite restaurar as configurações de fábrica pelo SW2.

    Olhando o log gerado, aparentemente ele usa 3 tabelas de configuração: uma para as configurações "gerais" da aplicação, outra para as regras de discagem e uma outra "on hold" com data para entrar em vigor. Durante a inicialização do dispositivo, se o SW2 estiver fechado, ele reescreve as 3 tabelas (que provavelmente estão na data flash) com cópias "hard-coded".

    Uma outra coisa interessante é que, assim que é ligado, um SMS é enviado para a VIVO.

    Acho que se for possível reescrever as regras do dialplan que estão na data flash, podería ser possível reprogramar o bicho para que ele usasse sempre o GSM para qualquer ligação, ou mesmo usar algo menos ridículo do que #66835# como prefixo.

    O problema é que usando a UART1 só consegui "ler" as mensagens, não consegui fazer com que ele aceitasse nenhum comando. Talvez tenha uma sequência especial, uma senha, ou algum dos jumpers faça com que ele entre em modo de configuração. Tentei fechar todos os jumpers abertos, sem sucesso. Outra possibilidade é que uma mensagem SMS faça isso, pode ser que um novo "dialplan" possa ser enviado via SMS.

    Uma possibilidade mais radical seria remover o chip e regravar.

    Alguém tem alguma sugestão?