+ Responder ao Tópico



  1. #1

    Padrão Hora nos Logs errada.

    Bom dia senhores, estou com o seguinte problema, gostaria de pedir a ajuda de vcs para solucionar.
    Segue imagem abaixo onde podemos ver que o horario no servidor está correto mas nos logs está aparecendo cerca de aproximadamente 4 horas a mais.
    Clique na imagem para uma versão maior

Nome:	         erro na hora dos log.png
Visualizações:	117
Tamanho: 	209,6 KB
ID:      	52945

  2. #2
    Avatar de Nilton Nakao
    Ingresso
    Sep 2013
    Localização
    Carlos Chagas, Minas Gerais
    Posts
    906

    Padrão Re: Hora nos Logs errada.

    Alguns equipamentos costumam configurar automaticamente e outras não. Aqueles que configuram costuma marcar hora oficial de Brasilia(DF) e outras GMT. São poucos os que costumam configurar a hora local, vai depender do seu servidor local.



  3. #3

    Padrão

    Citação Postado originalmente por eberty Ver Post
    Segue imagem abaixo onde podemos ver que o horario no servidor está correto mas nos logs está aparecendo cerca de aproximadamente 4 horas a mais.
    Sugiro executar o script abaixo. A primeira linha definirá sua zona de tempo (supondo que você está em UTC -0300 / Horário de Brasília). A segunda linha define quais serão seus servidores de tempo.

    Código :
    /system clock set time-zone-name=America/Sao_Paulo
    /system ntp client set enabled=yes primary-ntp=a.ntp.br secondary-ntp=b.ntp.br

    Uso desta forma, e não tenho problemas com diferenças de horário nos logs.

    Saudações,

  4. #4

    Padrão Re: Hora nos Logs errada.

    Fiz o que vc falou mas ainda continua errado.
    e no New terminal aparece a seguinte mensagem:
    invalid value for argument primary-ntp:
    invalid value for argument ip-address
    invalid value for argument ipv6-address




  5. #5

    Padrão

    Citação Postado originalmente por eberty Ver Post
    Fiz o que vc falou mas ainda continua errado.
    e no New terminal aparece a seguinte mensagem:
    Experimente o seguinte comando, já com nomes resolvidos para números, e testados no MikroTik RouterOS 6.15.

    Código :
     /system clock set time-zone-name=America/Sao_Paulo
    /system ntp client set enabled=yes primary-ntp=200.160.0.8 secondary-ntp=200.189.40.8

  6. #6

    Padrão Re: Hora nos Logs errada.

    Nada ainda. Assim tbm não alterou o horario nos logs.

    Citação Postado originalmente por trober Ver Post
    Experimente o seguinte comando, já com nomes resolvidos para números, e testados no MikroTik RouterOS 6.15.

    Código :
     /system clock set time-zone-name=America/Sao_Paulo
    /system ntp client set enabled=yes primary-ntp=200.160.0.8 secondary-ntp=200.189.40.8



  7. #7

    Padrão

    Citação Postado originalmente por eberty Ver Post
    Nada ainda. Assim tbm não alterou o horario nos logs.
    Eberty, por favor, informe a saída dos três comandos abaixo. Vamos resolver este problema

    Código :
    /system clock export compact
    Código :
    /system ntp export compact
    Código :
    /system logging export compact

  8. #8

    Padrão Re: Hora nos Logs errada.

    [[email protected]] > /system clock export compact
    # jul/11/2014 17:11:16 by RouterOS 6.15
    # software id = 61TH-X2Y0
    #
    /system clock
    set time-zone-name=America/Campo_Grande
    [[email protected]] > /system ntp export compact
    # jul/11/2014 17:11:27 by RouterOS 6.15
    # software id = 61TH-X2Y0
    #
    /system ntp client
    set enabled=yes primary-ntp=200.160.0.8 secondary-ntp=200.189.40.8
    [[email protected]] > /system logging export compact
    # jul/11/2014 17:11:35 by RouterOS 6.15
    # software id = 61TH-X2Y0
    #
    /system logging action
    set 1 disk-lines-per-file=10
    set 3 remote=10.111.111.111



    Citação Postado originalmente por trober Ver Post
    Eberty, por favor, informe a saída dos três comandos abaixo. Vamos resolver este problema

    Código :
    /system clock export compact
    Código :
    /system ntp export compact
    Código :
    /system logging export compact



  9. #9

    Padrão

    Grato Eberty

    Até aqui tudo Ok. Agora preciso do resultado da saída dos comandos abaixo. Precisarei que você informe o horário local, e horário de Brasília que você executou os comandos:

    Código :
    /system ntp client print
    Código :
    /system clock print

  10. #10

    Padrão Re: Hora nos Logs errada.

    [[email protected]] > /system ntp client print
    enabled: yes
    primary-ntp: 200.160.0.8
    secondary-ntp: 200.189.40.8
    mode: unicast
    poll-interval: 15m
    active-server: 200.160.0.8
    last-update-from: 200.160.0.8
    last-update-before: 14m40s400ms
    last-adjustment: 1ms375us
    [[email protected]] > /system clock print
    time: 19:41:33
    date: jul/12/2014
    time-zone-name: America/Campo_Grande
    gmt-offset: -04:00
    dst-active: no
    [[email protected]] >



    Citação Postado originalmente por trober Ver Post
    Grato Eberty

    Até aqui tudo Ok. Agora preciso do resultado da saída dos comandos abaixo. Precisarei que você informe o horário local, e horário de Brasília que você executou os comandos:

    Código :
    /system ntp client print
    Código :
    /system clock print



  11. #11

    Padrão Re: Hora nos Logs errada.

    Estava com o mesmo problema, bug do OS (travado o Time Zone).
    O que fiz para resolver: System/clock/Manual Time Zone/ em Time Zone -03:00 coloque uma hora a menos, no log já vai ficar correto ai volte para o time zone correto.
    O meu voltou a funcionar assim, espero ter ajudado.