+ Responder ao Tópico



  1. #1

    Padrão Load Balance parou de funcionar

    Bom tarde a todos.

    Venho mais uma vez ao forum para tentar solucionar um problema.

    Apos efetuar a troca de uma RB750GL e por no lugar uma RB450G o balance parou de funcionar.

    Segue codigo.
    Código :
    /ip address
    add address=192.168.88.1/24 network=192.168.88.0 broadcast=192.168.88.255 interface=Local
    add address=10.1.1.2/24 network=10.1.1.0 broadcast=10.1.1.255 interface=WAN1
    add address=10.1.2.2/24 network=10.1.2.0 broadcast=10.1.2.255 interface=WAN2
    add address=10.1.3.2/24 network=10.1.3.0 broadcast=10.1.3.255 interface=WAN3
     
    /ip firewall mangle
    add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
    add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn
    add chain=input in-interface=WAN3 action=mark-connection new-connection-mark=WAN3_conn
     
    add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
    add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2
    add chain=output connection-mark=WAN3_conn action=mark-routing new-routing-mark=to_WAN3
     
    add chain=prerouting dst-address=192.168.1.0/24 action=accept in-interface=Local
    add chain=prerouting dst-address=192.168.2.0/24 action=accept in-interface=Local
    add chain=prerouting dst-address=192.168.3.0/24 action=accept in-interface=Local
     
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:3/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:3/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:3/2 action=mark-connection new-connection-mark=WAN3_conn passthrough=yes
    add chain=prerouting connection-mark=WAN1_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN1
    add chain=prerouting connection-mark=WAN2_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN2
    add chain=prerouting connection-mark=WAN3_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN3
     
     
    /ip route
    add dst-address=0.0.0.0/0 gateway=10.1.1.1 routing-mark=to_WAN1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.1.2.1 routing-mark=to_WAN2 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.1.3.1 routing-mark=to_WAN3 check-gateway=ping
     
    add dst-address=0.0.0.0/0 gateway=10.1.1.1 distance=1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.1.2.1 distance=2 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.1.3.1 distance=3 check-gateway=ping
     
    /ip firewall nat
    add chain=srcnat out-interface=WAN1 action=masquerade
    add chain=srcnat out-interface=WAN2 action=masquerade
    add chain=srcnat out-interface=WAN3 action=masquerade
     
    #Servidor DNS
    8.8.8.8,8.8.4.4

    Tudo sai apenas pela wan1 ele não divide mais entre os link.
    Porem se eu for em IP - Firewall - Connections, ele requisita para wan2 e wan3.
    Há, testei os link separadamente ambos estão funcionamento normalmente.
    Versão da 750GL era 5.24 e da 450G e 5.26, será que e esse o motivo? ( 750GL queimou )

    Ficaria grato se pudesem me ajudar novamente

    E desde já um muito obrigado.

  2. #2

    Padrão Re: Load Balance parou de funcionar

    Amigo, coloca distance=1 nessas rotas e teste.

    /ip route add dst-address=0.0.0.0/0 gateway=10.1.1.1 distance=1 routing-mark=to_WAN1 check-gateway=ping add dst-address=0.0.0.0/0 gateway=10.1.2.1 distance=1 routing-mark=to_WAN2 check-gateway=ping add dst-address=0.0.0.0/0 gateway=10.1.3.1 distance=1 routing-mark=to_WAN3 check-gateway=ping

    vlw



  3. #3

    Padrão Re: Load Balance parou de funcionar

    Como voce restaurou o backup?
    Exportou e importou ou fez backup e importou?

  4. #4

    Padrão Re: Load Balance parou de funcionar

    Carlosaps, não adiantou trocar as distances.

    RobsonCostta, Eu refiz ela na mão comando por comando, não importei backup.

    Porem o problema parece estar na outra RB em modo cliente, ela não esta pegando o IP correto.

    O IP correto seria 172.17.0.4 ela esta pegando 0.30 no dhcp-client.

    Teria alguma forma de setar o IP do dhcp-client manualmente (SXT 5nd r2 modo cliente), eu troquei essa sxt junto porem agora que notei que ela não estava pegando o IP que deveria



  5. #5

    Padrão Re: Load Balance parou de funcionar

    O IP de saída não seria 192.168.88.x, segundo sua configuração?

  6. #6

    Padrão Re: Load Balance parou de funcionar

    Então amigo essa faixa 10.1.2.x ela recebe link de uma sxt que deveria pegar o IP 172.17.0.4 e repassar com a faixa 10.1.2.x porem ela pega como 172.17.0.30 onde não navega ai fica como se não tive-se internet nela.

    O Link1 e Link3 esta funcionando normal agora, apenas o link2 que está parado e foi onde fui verificar isso e constatei que o dhcp-client pega um IP diferente do que deveria, e não consegui fazer ele pegar o IP 172.17.0.4.

    E após futricar muito no SXT não encontrei uma forma de setar o IP do wireless (modo cliente) para 172.17.0.4 (Acostumado com Ubiquiti. )


    (Se eu clonar o mac+ip e fazer um repasse eu consigo me conectar normal no netbook, agora no SXT não consegui setar o IP correto.)



  7. #7

    Padrão

    Adiciona um lease estático no servidor DHCP de onde a SXT pega IP, ex:
    Código :
    /ip dhcp-server lease add address=172.17.0.4 mac-address=<MAC DA INTERFACE DA SXT>

  8. #8

    Padrão Re: Load Balance parou de funcionar

    Muito obrigado TsouzaR, funcionou, e muito obrigado aos amigos Carlosaps e RobsonCostta que tentaram ajudar também.