+ Responder ao Tópico



  1. #1

    Padrão Regras para cache full hyper taghos

    Ola amigos, estou com um grande problema, uso a versao 6.18 Mikrotik com controle de hotspot, meu problema é o seguinte, como faço para rodar o cache full no hotspot hyper taghos, tenho clientes com 512k, e nao consiguo usar o cache full, alguem poderia me ajudar com algum passo a passo, desde já fico grato.

    Abraços...

  2. #2
    tecnico chefe Avatar de naldo864
    Ingresso
    May 2010
    Localização
    Carapicuíba, Brazil, Brazil
    Posts
    3.104
    Posts de Blog
    1

    Padrão Re: Regras para cache full hyper taghos

    Tenho este mesmo problema ainda bem que uso myauth foi mas fácil ,mas com MikroTik sem chance já cheguei ate a discutir com eles varias vezes sobre isto não existe um manual para isto só te dão uns scripts e um dane-se .
    Se eu ultiiza_se somente mikroti já tinha devolvido ele para a Taghos junto com um dane se também.



  3. #3

    Padrão Re: Regras para cache full hyper taghos

    eles tmb me deram uns script, mas nao funcionou,

  4. #4

    Padrão Re: Regras para cache full hyper taghos

    Camarada, tenta estas regras:


    /ip firewall mangle
    add action=mark-packet chain=postrouting comment="Regras CACHE FULL HYPER" dscp=3 \
    new-packet-mark=CacheFull_Mikrotik_6x passthrough=no
    add action=mark-connection chain=forward comment=\


    /queue type
    add kind=pcq name=CacheFull pcq-classifier=dst-address pcq-dst-address6-mask=\
    64 pcq-rate=5M pcq-src-address6-mask=64


    /queue simple
    add name=CacheFull packet-marks=CacheFull_Mikrotik_6x queue=\
    CacheFull/CacheFull target=""


    Seguinte na queue simples na regra do cache full em target coloque 0.0.0.0/0 esta queue tem que esta acima de todas as queues, e para conseguir que esta regra fique acima das outras usando hotspot vai ter que agendar um script para esta função:
    (no caso de pppoe não precisa do scrip as regras terminam aqui)

    /system script
    add name=CacheFull policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
    source=\
    "\"/queue simple move [find name=\"CacheFull\"] [ick [find] 0] \""

    agora só agendar o script para rodar a cada 10s:

    /system scheduler
    add interval=10s name=ag-cachefull on-event="/system script run CacheFull" \
    policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
    start-date=aug/15/2014 start-time=10:00:00


    Dando tudo certo responde ai!



  5. #5

    Padrão Re: Regras para cache full hyper taghos

    Aguem testou a regra do amigo acima, deu certo ?

  6. #6

    Padrão Re: Regras para cache full hyper taghos

    Leandro Oliveira, fiz algo parecido com essa configuração, na verdade é o mesmo script de liberação de banda em horários determinados só que a diferença é que marquei os pacotes da porta 80 e na simple queue o acesso é liberado apenas para tal porta 80. Mas não é 100% eficiente já que quando o conteúdo existe no cache ele é acessado full (até ai beleza), mas quando não tem em cache essa regra libera para o cliente usar a navegação sem controle. Portanto estaca zero novamente