tenta atualizar para 6.28, é uma das versões mais estáveis do mk