+ Responder ao Tópico



  1. #1

    Padrão Watchdog por porta - MikroTik

    Bom dia,

    Possuímos algumas câmeras IP que travam com constância, e não conseguimos identificar o motivo. Observamos que apenas tirando o cabo de rede do switch e o reconectando imediatamente, essas câmeras voltam a funcionar.

    Observando essa situação, penso que se posse possível criar um sistema do tipo Watchdog por porta, resolveríamos o problema.

    Penso em um script que fique pingando nos IPs desses dispositivos, e caso não obtenha resposta que desabilitasse a respectiva porta do dispositivo, e a habilitasse novamente alguns segundos depois.


    Saberiam de alguma solução, ou algum script que fizessem isso?


    Obrigado!

  2. #2

    Padrão Re: Watchdog por porta - MikroTik

    Citação Postado originalmente por wiband Ver Post
    Bom dia,

    Possuímos algumas câmeras IP que travam com constância, e não conseguimos identificar o motivo. Observamos que apenas tirando o cabo de rede do switch e o reconectando imediatamente, essas câmeras voltam a funcionar.

    Observando essa situação, penso que se posse possível criar um sistema do tipo Watchdog por porta, resolveríamos o problema.

    Penso em um script que fique pingando nos IPs desses dispositivos, e caso não obtenha resposta que desabilitasse a respectiva porta do dispositivo, e a habilitasse novamente alguns segundos depois.


    Saberiam de alguma solução, ou algum script que fizessem isso?


    Obrigado!
    Esse equipamento faz isso amigo.
    http://www.powernetwork.com.br/produtos.php?i=330

    Tem opção de 5 e 10 portas.



  3. #3
    Alex Rock Avatar de alexrock
    Ingresso
    Jan 2006
    Localização
    S. J. do Rio Preto-SP
    Posts
    828

    Padrão Re: Watchdog por porta - MikroTik

    Quanta câmeras seriam? É possível desativar o POE das portas da RB750UP através de script, e com a ferramenta Netwatch da mesma RB, rodar um script caso um ping falhe.

  4. #4

    Padrão Re: Watchdog por porta - MikroTik

    Olá Alex.


    É exatamente isso a proposta. Consegui com o script abaixo:


    :if ([/ping xxx.xxx.xxx.xxx count=5] = 0) do={
    /interface disable [find name=wan3]
    :delay 5s
    /interface enable [find name=wan3]
    }



  5. #5

    Padrão Re: Watchdog por porta - MikroTik

    Assim, utilizando o Netwatch eh melhor, nao ?

    Código :
    /tool netwatch
    add down-script=":log error \"**** Host Down ***\"\r\
        \n/ interface ethernet disable ether3\r\
        \n:delay 5\r\
        \n/ interface ethernet enable ether3\r\
        \n" host=x.y.z.z interval=30s up-script=\
        ":log warning \"**** Host UP ****\""

    ali no x.y.z.z é o host q precisa monitorar.. 30 em 30 segundos ele monitora.. pode alterar o intervalo para menosou mais..

  6. #6
    Alex Rock Avatar de alexrock
    Ingresso
    Jan 2006
    Localização
    S. J. do Rio Preto-SP
    Posts
    828

    Padrão Re: Watchdog por porta - MikroTik

    Use netwatch, é um Daemon dedicado, não tem risco de travar o script...