+ Responder ao Tópico



  1. #1

    Lightbulb Trocar PCC por VLAN - Ajuda

    Estou tendo problemas com o PCC que não equaliza as cargas, sempre explora mais o link 1 mesmo calibrando não fica bom principalmente no UPload.


    Gostaria de trocar o PCC por VLANs desde os Rockets até a saída em cada link, determinado uma quantidade de clientes para cada link e um failover geral. Ou melhorar o PCC

    Esquema a baixo.

    Ideias ???
    Clique na imagem para uma versão maior

Nome:	         esquema1.jpg
Visualizações:	83
Tamanho: 	34,7 KB
ID:      	55776Clique na imagem para uma versão maior

Nome:	         esquema2.jpg
Visualizações:	71
Tamanho: 	39,0 KB
ID:      	55777

  2. #2

    Padrão Re: Trocar PCC por VLAN - Ajuda

    Citação Postado originalmente por Arthur Bernardes Ver Post
    Você quer levar os links em cada concentrador por VLAN? Perfeitamente possível.

    Estou explorando um cenário para levar 30 links ADSL (10 em cada RB1100AHx2) para uma CCR usando VLAN ou VPLS.
    Boa noite amigo voce poderia me dar mas detalhes de como voce ira fazer este esquema, a dias venho um esta ideia de fazer isto.



  3. #3

    Padrão Re: Trocar PCC por VLAN - Ajuda

    Citação Postado originalmente por Arthur Bernardes Ver Post
    Segunda-feira posto aqui as ideias, é interessante.
    Ok vamos aguardar

  4. #4

    Padrão Re: Trocar PCC por VLAN - Ajuda

    Interessante Arthur



  5. #5
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: Trocar PCC por VLAN - Ajuda

    pode se colocar todos em um tunel, se nao esta equilibrado é problema no mangle

  6. #6

    Padrão

    Citação Postado originalmente por Acronimo Ver Post
    pode se colocar todos em um tunel, se nao esta equilibrado é problema no mangle
    Se eu colocar as regras aqui, você pode pode verificar?



  7. #7

    Padrão Re: Trocar PCC por VLAN - Ajuda

    Citação Postado originalmente por Arthur Bernardes Ver Post
    Claro, coloque sim Marcelo!

    Coloquei 16 BOTHs e a carga ficou mais ou menos balanceada, mas sempre se nota que o link1 é mais explorado principalmente no upload mesmo tendo apenas 1 both e os 3 links tendo cargas iguais


    MikroTik RouterOS 5.16




    /ip firewall mangle
    add action=mark-connection chain=prerouting connection-state=new disabled=no \
    dst-address-list=LINK0 in-interface=ether5 new-connection-mark=Sites0 \
    passthrough=yes
    add action=mark-routing chain=prerouting connection-mark=Sites0 disabled=no \
    in-interface=ether5 new-routing-mark=Rota0 passthrough=no
    add action=mark-connection chain=prerouting connection-state=new disabled=no \
    dst-address-list=LINK1 in-interface=ether5 new-connection-mark=Sites1 \
    passthrough=yes
    add action=mark-routing chain=prerouting connection-mark=Sites1 disabled=no \
    in-interface=ether5 new-routing-mark=Rota1 passthrough=no
    add action=mark-connection chain=prerouting connection-state=new disabled=no \
    dst-address-list=LINK2 in-interface=ether5 new-connection-mark=Sites2 \
    passthrough=yes


    =================================================
    add action=mark-routing chain=prerouting connection-mark=Sites2 disabled=no \
    in-interface=ether5 new-routing-mark=Rota2 passthrough=no
    add action=accept chain=prerouting comment="HTTPS FORA DO LOADBALACED" \
    disabled=no dst-port=443 in-interface=ether5 protocol=tcp
    add action=accept chain=prerouting comment="FORA DO LOADBALACED" disabled=no \
    dst-address-list=loopback in-interface=ether5
    add action=change-ttl chain=forward comment="Filtro Tracert / Traceroute" \
    disabled=no new-ttl=set:30 passthrough=yes protocol=icmp

    =================================================
    add action=mark-connection chain=prerouting connection-state=new disabled=no \
    in-interface=link_ether1 new-connection-mark=link_ether1_conn passthrough=\
    yes
    add action=mark-connection chain=prerouting connection-state=new disabled=no \
    in-interface=link_ether2 new-connection-mark=link_ether2_conn passthrough=\
    yes
    add action=mark-connection chain=prerouting connection-state=new disabled=no \
    in-interface=link_ether3 new-connection-mark=link_ether3_conn passthrough=\
    yes


    =================================================
    add action=mark-routing chain=output connection-mark=link_ether1_conn disabled=\
    no new-routing-mark=to_link_ether1 passthrough=yes
    add action=mark-routing chain=output connection-mark=link_ether2_conn disabled=\
    no new-routing-mark=to_link_ether2 passthrough=yes
    add action=mark-routing chain=output connection-mark=link_ether3_conn disabled=\
    no new-routing-mark=to_link_ether3 passthrough=yes


    =================================================
    add action=mark-connection chain=prerouting connection-state=new disabled=no \
    dst-address-type=!local in-interface=ether5 new-connection-mark=\
    link_ether1_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:16/0


    =================================================
    add action=mark-connection chain=prerouting connection-state=new disabled=no \
    dst-address-type=!local in-interface=ether5 new-connection-mark=\
    link_ether2_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:16/1
    add action=mark-connection chain=prerouting connection-state=new disabled=no \
    dst-address-type=!local in-interface=ether5 new-connection-mark=\
    link_ether2_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:16/2
    add action=mark-connection chain=prerouting connection-state=new disabled=no \
    dst-address-type=!local in-interface=ether5 new-connection-mark=\
    link_ether2_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:16/3
    add action=mark-connection chain=prerouting connection-state=new disabled=no \
    dst-address-type=!local in-interface=ether5 new-connection-mark=\
    link_ether2_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:16/4
    add action=mark-connection chain=prerouting connection-state=new disabled=no \
    dst-address-type=!local in-interface=ether5 new-connection-mark=\
    link_ether2_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:16/5
    add action=mark-connection chain=prerouting connection-state=new disabled=no \
    dst-address-type=!local in-interface=ether5 new-connection-mark=\
    link_ether2_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:16/6
    add action=mark-connection chain=prerouting connection-state=new disabled=no \
    dst-address-type=!local in-interface=ether5 new-connection-mark=\
    link_ether2_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:16/7


    =================================================
    add action=mark-connection chain=prerouting connection-state=new disabled=no \
    dst-address-type=!local in-interface=ether5 new-connection-mark=\
    link_ether3_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:16/8
    add action=mark-connection chain=prerouting connection-state=new disabled=no \
    dst-address-type=!local in-interface=ether5 new-connection-mark=\
    link_ether3_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:16/9
    add action=mark-connection chain=prerouting connection-state=new disabled=no \
    dst-address-type=!local in-interface=ether5 new-connection-mark=\
    link_ether3_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:16/10
    add action=mark-connection chain=prerouting connection-state=new disabled=no \
    dst-address-type=!local in-interface=ether5 new-connection-mark=\
    link_ether3_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:16/11
    add action=mark-connection chain=prerouting connection-state=new disabled=no \
    dst-address-type=!local in-interface=ether5 new-connection-mark=\
    link_ether3_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:16/12
    add action=mark-connection chain=prerouting connection-state=new disabled=no \
    dst-address-type=!local in-interface=ether5 new-connection-mark=\
    link_ether3_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:16/13
    add action=mark-connection chain=prerouting connection-state=new disabled=no \
    dst-address-type=!local in-interface=ether5 new-connection-mark=\
    link_ether3_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:16/14
    add action=mark-connection chain=prerouting connection-state=new disabled=no \
    dst-address-type=!local in-interface=ether5 new-connection-mark=\
    link_ether3_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:16/15




    =================================================
    add action=mark-routing chain=prerouting connection-mark=link_ether1_conn \
    disabled=no in-interface=ether5 new-routing-mark=to_link_ether1 \
    passthrough=yes
    add action=mark-routing chain=prerouting connection-mark=link_ether2_conn \
    disabled=no in-interface=ether5 new-routing-mark=to_link_ether2 \
    passthrough=yes
    add action=mark-routing chain=prerouting connection-mark=link_ether3_conn \
    disabled=no in-interface=ether5 new-routing-mark=to_link_ether3 \
    passthrough=yes

  8. #8

    Padrão Re: Trocar PCC por VLAN - Ajuda

    Porque vc colocou 16?Existe um calculo para isso.

    Eu tenho 10 links de 35MB e to passando por o mesmo problema no 1 link



  9. #9

    Padrão Re: Trocar PCC por VLAN - Ajuda

    Usem balanceamento por rotas, garanto que não vai sofrer com isso, tem que saber fazer... mais fica muito bom.
    Procurem né um tópico aqui mesmo que já postei.
    Ou busquem fazer o "pcc 2020", retirando o nat do concentrador, para o balance ter "capacidade" de explorar todos os links em https.

  10. #10

    Padrão Re: Trocar PCC por VLAN - Ajuda

    Citação Postado originalmente por fabinhonsouza Ver Post
    Porque vc colocou 16?Existe um calculo para isso.

    Eu tenho 10 links de 35MB e to passando por o mesmo problema no 1 link
    Pelo que foi falado aqui, é porque as conexões para páginas https saem pelo link 1, vou procurar alguma regra que faça balanceamento em todos os links para o HTTPS sem dar problema nos bancos.

    Se alguém souber de um tutorial para o problema gentileza deixar o caminho aqui para os UNDERs