+ Responder ao Tópico



  1. #1

    Padrão Mikrotik 5.26 nao atualiza ddns

    Amigos tenho um rb951g-2hnd e não esta atualizando o ddns no no-ip oi changeip,
    a configuração fiz do jeito que encontrei em foruns, video tutoriais e que e igual ao site do
    wiki Mikrotik.
    Toda vez que o rb reinicia ou cai a energia ele não atualiza o servidor ddns.

  2. #2

    Padrão Re: Mikrotik 5.26 nao atualiza ddns

    Citação Postado originalmente por Claudinei Ver Post
    Amigos tenho um rb951g-2hnd e não esta atualizando o ddns no no-ip oi changeip,
    a configuração fiz do jeito que encontrei em foruns, video tutoriais e que e igual ao site do
    wiki Mikrotik.
    Toda vez que o rb reinicia ou cai a energia ele não atualiza o servidor ddns.
    Talvez você não tenha inserido no scheduler o script para chamar o DDNS caso reinicie o servidor. Verifique isso.



  3. #3

    Padrão Re: Mikrotik 5.26 nao atualiza ddns

    acredito que esta tudo certo a configuração que coloquei foi para o no-ip e changeip. no no-ip esta assim o script:

    Nome do script
    ddns no-ip

    script

    # No-IP Dynamic DNS atualização automática


    # --------------- Alterar os valores nesta seção para corresponder à sua configuração ------------------


    # No-IP informações da conta do usuário
    :local noipuser "meu_user_no-ip"
    :local noippass "minha_senha_no-ip"




    # Configure o nome do host ou o rótulo de rede a ser atualizado.
    # Hostnames com espaços não são suportados. Substitua o valor nas citações abaixo com seus nomes de host.
    # Para especificar vários hosts, separe-os com vírgulas.
    :local noiphost "host_no-ip"




    # Mude para o nome da interface que obtém o endereço IP dinâmico
    :local inetinterface "Speedy"

    #Porta de entrada do link PPPoE da vivo


    #------------------------------------------------------------------------------------
    # No more changes need


    :global previousIP


    :if ([/interface get $inetinterface value-name=running]) do={
    # Get the current IP on the interface
    :local currentIP [/ip address get [find interface="$inetinterface" disabled=no] address]


    # Strip the net mask off the IP address
    :for i from=( [:len $currentIP] - 1) to=0 do={
    :if ( [ick $currentIP $i] = "/") do={
    :set currentIP [ick $currentIP 0 $i]
    }
    }


    :if ($currentIP != $previousIP) do={
    :log info "No-IP: Current IP $currentIP is not equal to previous IP, update needed"
    :set previousIP $currentIP


    # The update URL. Note the "\3F" is hex for question mark (?). Required since ? is a special character in commands.
    :local url "http://dynupdate.no-ip.com/nic/update\3Fmyip=$currentIP"
    :local noiphostarray
    :set noiphostarray [:toarray $noiphost]
    :foreach host in=$noiphostarray do={
    :log info "No-IP: Sending update for $host"
    /tool fetch url=($url . "&hostname=$host") user=$noipuser password=$noippass mode=http dst-path=("no-ip_ddns_update-" . $host . ".txt")
    :log info "No-IP: Host $host updated on No-IP with IP $currentIP"
    }
    } else={
    :log info "No-IP: Previous IP $previousIP is equal to current IP, no update needed"
    }
    } else={
    :log info "No-IP: $inetinterface is not currently running, so therefore will not update."
    }

    ##################################################

    no scheduler

    Atualização do ddns - No-IP
    startup
    00:00:50
    ddns no-ip

  4. #4

    Padrão Re: Mikrotik 5.26 nao atualiza ddns

    o ddns só funciona qdo vou no site no-ip ou changeip e coloco meu ip manualmente..



  5. #5

    Padrão Re: Mikrotik 5.26 nao atualiza ddns

    Amigo,esses dias também estava sofrendo com este problema.Mas no meu caso era com sistema de câmeras stand alone.No caso coloquei o modem p discar(ddns) e nada,coloquei o roteador p discar(ddns) e nada,também coloquei o stande alone e nada.Eu tinha q manualmente colocar meu ip no server dydnddns.
    Toda vez q o modem reiniciava o ddns(dynddns) não conectava.
    Até hoje não sei o porque deste problema.

  6. #6

    Padrão Re: Mikrotik 5.26 nao atualiza ddns

    parceiro quando você aciona o script verifique no log de registro se aparace DNS NO CHANGE.

    Se isto ocorrer, favor verificar seguintes itens.

    modem com nat ?
    algum router após modem?



  7. #7

    Padrão Re: Mikrotik 5.26 nao atualiza ddns

    Substitua estas linhas:
    :if ([/interface get $inetinterface value-name=running]) do={
    # Get the current IP on the interface
    :local currentIP [/ip address get [find interface="$inetinterface" disabled=no] address]


    # Strip the net mask off the IP address
    :for i from=( [:len $currentIP] - 1) to=0 do={
    :if ( [pick $currentIP $i] = "/") do={
    :set currentIP [pick $currentIP 0 $i]
    }
    }


    Por estas:
    # get the current IP address from the internet (in case of double-nat)
    /tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
    :local result [/file get dyndns.checkip.html contents]

    # parse the current IP result
    :local resultLen [:len $result]
    :local startLoc [:find $result ": " -1]
    :set startLoc ($startLoc + 2)
    :local endLoc [:find $result "</body>" -1]
    :local currentIP [pick $result $startLoc $endLoc]
    # :log info "UpdateDynDNS: currentIP = $currentIP"


    No seu script, está checando o ip da Speedy, que se estiver atras de um modem roteado nao vai mudar. So funcionaria se o modem estivesse em bridge.

    Neste outro caso, funciona de qualquer jeito, pois utiliza um site externo para pegar o ip da conexao.

    Se quiser ver seu ip atual, basta colocar no navegador:
    http://checkip.dyndns.org/