+ Responder ao Tópico



  1. #1

    Padrão MK-Auth sem comunicação com outras RBs via Radius

    Olá pessoal,
    Já quebrei bastante a cabeça aqui mas não consegui configurar de modo que meu MK-Auth se comunique com minhas RBs para que eu possa utilizar os recursos de cadastrar os clientes somente no MK-Auth e libera-los em todas as RBs, o MK-Auth está se comunicando apenas com a RB1100AHx2 que é o "servidor" da rede para autenticação, link e etc. O que preciso é comunicação com as RBs que possui os cartões, as transmissoras apenas.
    Hoje minha rede é o seguinte:
    MK-Auth - Autenticando os clientes via HotSpot e PPPoE - IP 172.31.255.2
    RB 1100AHX2:
    > Recebe o link via eth1 - cliente PPPoE, ela disca a conexão, modem em bridge;
    > eth2 sai para o MK-Auth - IP 172.31.255.1
    > eth3 sai para os clientes, faixa de IP 10.3.0.0 para os HotSpot e IP 10.2.0.0 para os clientes PPPoE.
    Os clientes, tanto PPPoE e HotSpot estão autenticando normalmente, mas tenho que cadastrar no Access List manual, minhas RBs estão com IPs 10.3.3.254, 10.3.3.253, 10.3.3.252...
    Quando eu estou via HotSpot acesso tudo, mas via PPPoE não consigo, acesso apenas a 10.3.0.1 que é a RB 1100AHX2, o restante não e o MK-Auth só acessa via chave SSH e Radius a RB 1100AHX2 também. O que posso fazer?

  2. #2

    Padrão Re: MK-Auth sem comunicação com outras RBs via Radius

    Nas rbs AP's, você setou a autenticação no cartão como sendo via radius?



  3. #3

    Padrão Re: MK-Auth sem comunicação com outras RBs via Radius

    amigo, isso é configuração na RB para comunicar no mk-auth.
    verifique todas configurações passo-a-passo que tem no proprio forum do mk-auth e testa novamente.
    faça o teste de SSH, onde ele cria uma regra de filtro desativado no mikrotik, funcionando esse teste é muito provavel o funcionamento do mk-auth com seus mikrotik.

  4. #4

    Padrão

    Citação Postado originalmente por felipeandrade55 Ver Post
    Nas rbs AP's, você setou a autenticação no cartão como sendo via radius?
    Olá Felipe, setei sim, está via radius.

    Citação Postado originalmente por EvertonLuigi Ver Post
    amigo, isso é configuração na RB para comunicar no mk-auth.
    verifique todas configurações passo-a-passo que tem no proprio forum do mk-auth e testa novamente.
    faça o teste de SSH, onde ele cria uma regra de filtro desativado no mikrotik, funcionando esse teste é muito provavel o funcionamento do mk-auth com seus mikrotik.
    Everton eu configurei e já fiz e refiz o tutorial do Pedro, o seguinte, o teste de SSH funciona somente na RB que está diretamente conectada com o MK-Auth, na interface do MK-Auth na RB o IP é 172.31.255.1 e no MK-Auth é 172.31.255.2, e nas demais RBs estão com IP 10.3.3.245 até 254, esses IPs estão na Bridge delas, não estão com IP setado na interface específica da eth, já testei colocar um IP na mesma faixa de 172.31.255.x mas também não adiantou.
    Estou utilizando PPPoE (10.2.0.0) e HotSpot (10.3.0.0). Eu acredito que seja alguma configuração de rota pelo seguinte, quando estou logado via HotSpot tenho acesso a todas as RBs e quando estou conectado via PPPoE só tenho acesso a RB 1100 que tem o IP 10.3.0.1 também em gateway.



  5. #5

    Padrão Re: MK-Auth sem comunicação com outras RBs via Radius

    Nas rbs ap, vc ja importou a chave ssh?

  6. #6

    Padrão Re: MK-Auth sem comunicação com outras RBs via Radius

    ai tem que adicionar todas RB no mk-auth
    e tem que fazer a configuração em todas RB ai funciona normal.



  7. #7

    Padrão Re: MK-Auth sem comunicação com outras RBs via Radius

    Sim, importei as chaves, criei o usuário mkauth, tudo conforme o tutorial do Pedro, mas não funcionou. A estrutura é a seguinte:

    RB1100AHx2
    ether6 - MK-Auth
    ether9 - Clientes - PPPoE e HotSpot
    ether10 - Lan com o Link
    pppoe-out1 - autentica pela ether10

    Address List
    172.31.255.1/24 - Network: 172.31.255.0 - ether6

    Nesta RB os clientes estão autenticando tudo certo e sem problemas, mas nas RBs que estão apenas em Bridge para fazer a conexão wireless é que não tenho comunicação com o MK-Auth, além do PPPoE ou HotSpot, eu utilizo a rede criptografada em WPA2 e Access List para evitar não-clientes conectados e tentando navegar ou outra coisa na rede, então a cada cliente, eu tenho que conectar manual na rede, colocar a chave e adicioná-lo no Access List, o que eu gostaria de fazer diretamente pelo MK-Auth.

  8. #8

    Padrão

    Foi adicionado no mk-auth.



  9. #9

    Padrão Re: MK-Auth sem comunicação com outras RBs via Radius

    Gente, um detalhe, tenho dois Nanos da rede, nestes consigo pingar partindo do MK-Auth, mas nas RBs, só consigo pingar na que está conectada diretamente ao MK-Auth, nas outras não.

  10. #10

    Padrão Re: MK-Auth sem comunicação com outras RBs via Radius

    Amigo acho q o problema é configuração em sua rede.
    POP 1;senário rb1100,porta 1 link internet,porta 2 mk-auth,porta 3 clientes.Porta 3 para os APS em bridge,clientes se conectam aos APS,bloqueio e etc,tudo funcionando certinho.
    Ai queremos montar um outro POP,no caso POP 2.Usando o mesmo mk-auth,BLZ.Mas temos que pensar em como fazer este novo POP vai se comunicar com o mk-auth.Eu usava aqui tudo em bridge,ou seja,puxava um ptp e montava um novo POP em bridge sem uma nova RB,funciona mas é errado.Então para cada POP o certo é por uma nova RB e "isolar cada POP".
    POP 2;senário rb2011,porta 1 link,porta 2 clientes.Porta 2 para os APS em bridge,clientes se conectam aos APS...
    POP 3;senário rb433ah,porta 1 link,porta 2 clientes.Porta 2 para os APS em bridge,clientes se conectam aos APS...
    Para fazer as rbs se comunicarem com o mk-auth de forma correta tem q ter regras no POP 1 que basicamente vai ser seu "SERVER" principal.
    As regras você encontra no fórum do mk-auth mesmo.



  11. #11

    Padrão Re: MK-Auth sem comunicação com outras RBs via Radius

    Citação Postado originalmente por brunocemeru Ver Post
    Amigo acho q o problema é configuração em sua rede.
    POP 1;senário rb1100,porta 1 link internet,porta 2 mk-auth,porta 3 clientes.Porta 3 para os APS em bridge,clientes se conectam aos APS,bloqueio e etc,tudo funcionando certinho.
    Ai queremos montar um outro POP,no caso POP 2.Usando o mesmo mk-auth,BLZ.Mas temos que pensar em como fazer este novo POP vai se comunicar com o mk-auth.Eu usava aqui tudo em bridge,ou seja,puxava um ptp e montava um novo POP em bridge sem uma nova RB,funciona mas é errado.Então para cada POP o certo é por uma nova RB e "isolar cada POP".
    POP 2;senário rb2011,porta 1 link,porta 2 clientes.Porta 2 para os APS em bridge,clientes se conectam aos APS...
    POP 3;senário rb433ah,porta 1 link,porta 2 clientes.Porta 2 para os APS em bridge,clientes se conectam aos APS...
    Para fazer as rbs se comunicarem com o mk-auth de forma correta tem q ter regras no POP 1 que basicamente vai ser seu "SERVER" principal.
    As regras você encontra no fórum do mk-auth mesmo.
    Olá Bruno,

    A cada novo POP aqui eu monto da seguinte maneira:
    Nova RB com cartão e sotorial em modo AP-Bridge para os clientes e cartão e antena ou uma antena como SXT para o enlace. Não isolei cada POP idependente, mas estou pensando em fazê-lo antes de termos muitos clientes e ficar mais difícil depois. Seria como ter "ramais" pela configuração do MK-Auth, correto?

  12. #12

    Padrão

    [RESOLVIDO]

    Obrigado aos que deram um minuto de atenção em me ajudar, de certa forma ajudou muito, as vezes o pessoal quer a receita do bolo e não percebem que em uma resposta errada ou sugestão pode estar o caminho certo de forma oculta.

    Solução: nas RBs que estavam apenas em AP-BRIDGE setei DNS e GATEWAY, funcionou normalmente. Coloquei o DNS 10.3.0.1 e o Gateway o mesmo valor. Estou com todo o controle agora via MK-Auth.

    Obrigado novamente.