+ Responder ao Tópico



  1. #1

    Thumbs up [ Tutorial ] - FailOver eficiente modem roteado

    Aqui é um simples tutorial para quem tem 2 links e deseja colocar 1 link como backup, e caso queira utilizar em seu failover que está somente com check gateway, pode também é só adaptar a regra e reconfigurar de acordo com seu cenário, segue abaixo regras e explicações.

    CENÁRIO
    eth1 - ISP1
    eth2 - ISP2
    eth3 - REDE LOCAL


    Primero vamos adicionar as 2 rotas default com distance diferente para deixar somente o ISP2 como backup, somente irá sair tráfego pelo ISP2 se o ISP1 cair a internet. E também criamos 1 rota para o IP 208.67.222.222 para forçar o ping sair somente pelo ISP1 e fazer verificação de queda de link.
    Código :
    /ip route 
    add dst-address=0.0.0.0/0 gateway=ISP1 check-gateway=ping distance=1 comment=ISP1
    add dst-address=0.0.0.0/0 gateway=ISP2 check-gateway=ping distance=2 comment=ISP2
    add dst-address=208.67.222.222 gateway=ISP1 check-gateway=ping distance=1

    Agora vamos adicionar o netwatch para fazer ping no ip 208.67.222.222 a cada 15 segundos e ativar os script de acordo se ele está ativo ou inativo, segue a criação do netwatch.
    Código :
    /tool netwatch
    add host=208.67.222.222 interval=00:00:15 timeout=1000ms up-script=ativar-isp1 down-script=ativar-isp2

    Feito o netwatch vamos criar 2 script, 1 que vai ser ativo quando o link estiver ON e outro que será ativado quado o link ficar OFF.
    Código :
    /system script
    add name=ativar-isp1 policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive source="/ip route set [/ip route find comment=ISP1] distance=1\r\n\r/ip route set [/ip route find comment=ISP2] distance=2"
    add name=ativar-isp2 policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive source="/ip route set [/ip route find comment=ISP1] distance=2\r\n\r/ip route set [/ip route find comment=ISP2] distance=1"


    Resumindo todo funcionamento.
    O que as regras faz é testar via PING pela ISP1 se está funcionando a internet, se o IP DESTINO responder o PING, ele irá ativar o script ativar-isp1 que ele muda a distancia da rota default para menor valor e fica saindo tráfego por ela, caso ele não responde ele irá ativar o isp2 e alterar a distancia do ISP2 para menor valor e sair o tráfego pelo ISP2.


    Tutorial feito por: Everton Luigi

  2. #2

    Padrão Re: [ Tutorial ] - FailOver eficiente modem roteado

    parabéns mais uma vez pela iniciativa!!! @EvertonLuigi, estrelinha pra vc!



  3. #3

    Padrão Re: [ Tutorial ] - FailOver eficiente modem roteado

    Citação Postado originalmente por faelldantas Ver Post
    parabéns mais uma vez pela iniciativa!!! @EvertonLuigi, estrelinha pra vc!
    Obrigado Fael...

  4. #4

    Padrão Re: [ Tutorial ] - FailOver eficiente modem roteado

    para modens roteados, você pode usar o proprio /ip route para testar e desativar o link, sem precisar de script



  5. #5

    Padrão Re: [ Tutorial ] - FailOver eficiente modem roteado

    Citação Postado originalmente por AndrioPJ Ver Post
    para modens roteados, você pode usar o proprio /ip route para testar e desativar o link, sem precisar de script
    Não intendi... como fazer Andrio ?
    nunca fiz dessa forma...

  6. #6

    Padrão Re: [ Tutorial ] - FailOver eficiente modem roteado

    Citação Postado originalmente por EvertonLuigi Ver Post
    Não intendi... como fazer Andrio ?
    nunca fiz dessa forma...
    aqui tem um exemplo:
    https://under-linux.org/showthread.php?t=177732



  7. #7

    Padrão Re: [ Tutorial ] - FailOver eficiente modem roteado

    Citação Postado originalmente por AndrioPJ Ver Post
    Ah ta.. setando o gateway e check ping pelo ip de teste... legal, no final todos ficam iguais... eu gosto mesmo é de usar o netwatch pra desabilitar porta... assim independente da quantidade de link no balance eu consigo fazer 1 failover eficiente e muito funcional....
    configurei essa semana balance com 4 LINKS e failover, desabilitando a rota por netwatch e script... muito funcional, modem roteados.

  8. #8

    Padrão Re: [ Tutorial ] - FailOver eficiente modem roteado

    Citação Postado originalmente por EvertonLuigi Ver Post
    Ah ta.. setando o gateway e check ping pelo ip de teste... legal, no final todos ficam iguais... eu gosto mesmo é de usar o netwatch pra desabilitar porta... assim independente da quantidade de link no balance eu consigo fazer 1 failover eficiente e muito funcional....
    configurei essa semana balance com 4 LINKS e failover, desabilitando a rota por netwatch e script... muito funcional, modem roteados.
    não exatamente
    o check gateway está em cima do "gateway falso", que por sua vez está apontado para o IP de teste, que por sua vez está direcionado para sair por determinado link.



  9. #9

    Padrão Re: [ Tutorial ] - FailOver eficiente modem roteado

    Muito bom.Testado e aprovado.
    Estrelinha....